[i810] Broken Intel Video i810, upgrade from 8.04 to 8.10 Beta unless Option "NoDRI" used

Bug #279835 reported by Vladimir Hidalgo on 2008-10-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg

Hi!, after upgrading from Ubuntu 8.04 to (today) Ubuntu 8.10 Beta, via update_manager I got an useless Desktop, because GDM stops from appear, instead the screen just flickers when it has too appear (GDM).

The culprit, I think, is xserver-xorg. I had configured my driver in xorg.conf as "i810" but new 7.4 Xorg rejects it, it will give a lot of errors complaining about it.

Problem is partially solved doing a dpkg-reconfigure xserver-xorg, but I lose my Monitor modelines, needed to get 1024x768 (otherwise, from Xorg autodetection, I only get 800x600).

If I use displayconfig-gtk, I can choose my monitor (AOC Spectrum 4V), my video chipset (i180), and my desired resolution (1024x768). Problem is that xorg.conf generated by it (displayconfig-gtk) is not accepted by Xorg 7.4, because the keyboad, mouse and even the i810 driver specified...

To sort my problem I have to copy the modelines generated by displayconfig-gtk, then run dpkg-reconfigure xserver-xorg, copy the modelines in the new xorg.conf and I got a useful Desktop again.

I mean, this is a big incompatibility problem between old xorg.conf and new 7.4 Xorg. Because that, GDM didn't load in my case (just after the upgrade) because it was using a 1024x768 that Xorg did not accepted at the moment, instead of GDM it showed garbage and freezes.

I had to change to TTY1, stop GDM, kill X, and run "startx" to get my Gnome Desktop (at 800x600), thing which was not so easy to figure it out at first time...

Please, if you can improve Xorg support for i810 (which was extra fine in Hardy), it would be greatly appreciated :)

Thank you!

:~$ apt-cache policy xserver-xorg
xserver-xorg:
  Instalados: 1:7.4~2ubuntu5
  Candidato: 1:7.4~2ubuntu5
  Tabla de versión:
 *** 1:7.4~2ubuntu5 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

:~$ apt-cache policy gdm
gdm:
  Instalados: 2.20.8-0ubuntu1
  Candidato: 2.20.8-0ubuntu1
  Tabla de versión:
 *** 2.20.8-0ubuntu1 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Timo Aaltonen (tjaalton) wrote :

i810 was dropped from the archive because the driver is not supported anymore. Please attach your /var/log/Xorg.0.log with the new xorg.conf.

Changed in xorg:
status: New → Incomplete
Vladimir Hidalgo (vlad88sv) wrote :

umm that's why, I had specified i810 in xorg.conf before the upgrade, and so that's why Xorg was refusing to start, after running "dpkg-reconfigure xserver-xorg", "Intel" driver is being used (although not explicitly specified on xorg.conf, but I shows up on Xorg.0.log as being used).

My new (working) xorg.conf produces the attached Xorg.0.log.

Vladimir Hidalgo (vlad88sv) wrote :

This is the xorg.conf with the modelines needed to get 1024x768

Vladimir Hidalgo (vlad88sv) wrote :

I updated xorg today, and the problem is worse. GDM won't start even with the modelines.

:~$ apt-cache policy xserver-xorg
xserver-xorg:
  Instalados: 1:7.4~2ubuntu7
  Candidato: 1:7.4~2ubuntu7
  Tabla de versión:
 *** 1:7.4~2ubuntu7 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
:~$ apt-cache policy xorg
xorg:
  Instalados: 1:7.4~2ubuntu7
  Candidato: 1:7.4~2ubuntu7
  Tabla de versión:
 *** 1:7.4~2ubuntu7 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
--------

I've to kill X, stop GDM and do startx to get a 800x600 Dekstop.

Vladimir Hidalgo (vlad88sv) wrote :

Using Intel driver I found that if xorg.conf has the following lines:

Section "Device"
       Option "XaaNoPixmapCache"
EndSection

...

Section "Module"
       Load "v4l"
EndSection

------------------

GDM won't load, commenting both of them makes GDM happy.

If I kill GDM & X, and then start the desktop with "startx", everything is fine, with "v4l" and "XaaNoPixmapCache" enabled or not, so it must be something in GDM that is triggering a failure in X.

In brief, the problem is: "intel" driver + "XaaNoPixmapCache" + "v4l"

Vladimir Hidalgo (vlad88sv) wrote :

If i810 driver is dropped, why there's still active updates for xserver-xorg-video-i810 ?

By the way, it's just my imagination or i810 driver gave better fps than Intel does?. I would like to try it out but setting "i810" driver in xorg.conf does not seems to work.

Vladimir Hidalgo (vlad88sv) wrote :

http://packages.ubuntu.com/intrepid/xserver-xorg-video-i810

X.Org X server -- Intel i8xx, i9xx display driver

This is a transitional package providing the Xorg video driver for the Intel i8xx and i9xx family of chipsets, and can be safely removed.

------------------------------

Ok, I got the point about deprecated and removed...

The key point in this bug report is that now, Intrepid is just not working by default with i810 chipsets. I have a Compaq Presario 5000LA (which is dated I know, but it's still useful..) and it won't load gdm because this xserver-xorg problem :( which for a (even more than me) beginner will be a total frustration.

Actual problems with Intel driver for i810 chipset are:

-GDM becomes crazy and crashes by default.
-If I kill GDM/X and get to my desktop using "startx", the display settings window won't let me choose above 800x600 by default.
-dri is only activated @ 16bpp, I found it while reading the Xorg.0.log, otherwise @ 24bpp I get 30fps in glxgears, in 16bpp I get ~200fps :)

Bottom line is that intel driver is not that bad, but it's default configuration just does not work!.

Please, Intrepid is only 9 days from now, and just God knows how many users will be disappointed when they see theirs GDM crashing with no obvious reason :(

Timo Aaltonen (tjaalton) wrote :

(no need to keep open for xorg too)

Changed in xorg:
status: New → Invalid
Vladimir Hidalgo (vlad88sv) wrote :

Testing with:
:~$ apt-cache policy xserver-xorg xorg xserver-video-intel
xserver-xorg:
  Instalados: 1:7.4~5ubuntu2
  Candidato: 1:7.4~5ubuntu2
  Tabla de versión:
 *** 1:7.4~5ubuntu2 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
xorg:
  Instalados: 1:7.4~5ubuntu2
  Candidato: 1:7.4~5ubuntu2
  Tabla de versión:
 *** 1:7.4~5ubuntu2 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
W: No se ha podido localizar el paquete xserver-video-intel
vlad@AuroX:~$ apt-cache policy xserver-xorg xorg xserver-xorg-video-intel
xserver-xorg:
  Instalados: 1:7.4~5ubuntu2
  Candidato: 1:7.4~5ubuntu2
  Tabla de versión:
 *** 1:7.4~5ubuntu2 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
xorg:
  Instalados: 1:7.4~5ubuntu2
  Candidato: 1:7.4~5ubuntu2
  Tabla de versión:
 *** 1:7.4~5ubuntu2 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status
xserver-xorg-video-intel:
  Instalados: 2:2.4.1-1ubuntu9
  Candidato: 2:2.4.1-1ubuntu9
  Tabla de versión:
 *** 2:2.4.1-1ubuntu9 0
        500 http://sv.archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

Vladimir Hidalgo (vlad88sv) wrote :
Vladimir Hidalgo (vlad88sv) wrote :
Vladimir Hidalgo (vlad88sv) wrote :
Vladimir Hidalgo (vlad88sv) wrote :

5 days... I presume that we're going to have Intrepid not working for computers with i810 video chipsets :(

I updated to:
xserver-xorg:
  Instalados: 1:7.4~5ubuntu3
  Candidato: 1:7.4~5ubuntu3
xorg:
  Instalados: 1:7.4~5ubuntu3
  Candidato: 1:7.4~5ubuntu3
xserver-xorg-video-intel:
  Instalados: 2:2.4.1-1ubuntu10
  Candidato: 2:2.4.1-1ubuntu10

Rebooted and still the same issue (well, worse because now I can't find a way to start GDM).

BTW. While GDM is crashed, I can switch to TTY1 and start htop, where I can see Zenity running with a message which says something like "You're running at low resolution..." -- that's all what I can read.

Vladimir Hidalgo (vlad88sv) wrote :

umm I figured out how to get some debug information form GDM, even if I do not know if it's even useful.

I got the attached log with "sudo gdm --nodaemon --debug 2> debug_gdm.txt"

Vladimir Hidalgo (vlad88sv) wrote :

umm ~01:00a.m, finally found the problem.

Intel driver + DRI + GDM is not working, adding option to not use DRI in xorg.conf (Option "NoDRI") solves the problem and GDM start nicely -- for the first time in several days :)

It's more important to me GDM than DRI support (common, I don't expect to play on a Presario 5000LA), so I can live with it. FPS in glxgears dropped from 200fps to 40fps, but it's ok.

Weird that only GDM trigger this bug on the intel driver.

Changed in xorg:
status: Invalid → New
Changed in xserver-xorg-video-intel:
status: Incomplete → New
Bryce Harrington (bryce) wrote :

[Don't need to have this open against both -intel and xorg; the former should suffice.]

Changed in xorg:
status: New → Invalid
Bryce Harrington (bryce) wrote :

The i810 chipset is so old that upstream no longer provides support for it. So other than your workaround it's unlikely we'll see a real fix to this issue. But leaving the bug report open for now.

Changed in xserver-xorg-video-intel:
importance: Undecided → Low
status: New → Confirmed
Vladimir Hidalgo (vlad88sv) wrote :

I guess you're right :(

By the way, I'd found that I can use DRI if I boot with acpi=off (weird eh?), GDM starts after showing garbage and restarting X 2 times.

I discovered it because on Intrepid I can't get my IC Plus 1000A to work without using "acpi=off" as a boot parameter.

Anyway, DRI + i810 is so unstable that my Firefox crashes very often when displaying embedded videos.

I suggest to use "NoDRI" as default for i810 chipsets, but I think that will be more a job to upstream than to Ubuntu.

Bryce Harrington (bryce) wrote :

Yeah I've been wondering about that. Compiz is disabled on at least a couple 8xx chips already. But removing DRI drops a lot of useful stuff so I want to avoid doing it if any other workarounds are available.

Bryce Harrington (bryce) wrote :

Hmm, on second thought, maybe I can put in the NoDRI on i810 by just extending the i865 patch. I'll take a look into this later.

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → bryceharrington
importance: Low → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.6.3-0ubuntu8

---------------
xserver-xorg-video-intel (2:2.6.3-0ubuntu8) jaunty; urgency=low

  * Expand patch 116 and rename to 116_8xx_disable_dri.patch to
    fix freezing issue on i810 as well.
    (LP: #279835)

 -- Bryce Harrington <email address hidden> Mon, 06 Apr 2009 18:18:46 -0700

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers