X hangs, corrupts/blanks vt sessions preventing installation [Mobile GM965 8086:2a02]

Bug #267945 reported by Bryce Harrington on 2008-09-08
22
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Undecided
Bryce Harrington
Hardy
High
Unassigned
Intrepid
Undecided
Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

The -intel driver does not appear to work on the Dell Studio Hybrid (Mobile GM965 8086:2a02 / 1028:0279). On booting the Intrepid Alpha-4 cd and selecting either the Live CD option or the Install ubuntu option, the screen blanks and never comes back. I'm not certain if it is hanging at that point or waiting for input. Vt switching *sort of* works; about half the time if I ctrl-alt-f1/f2 several times, I'll see either a corrupted text screen or get an uncorrupted text screen, that I can log into and use; the other half of the time the console just remains blank.

I was able to successfully boot an old Gutsy Tribe 2 LiveCD using Safe Graphics mode (regular LiveCD hung as above). In this case, X seemed okay but I had trouble getting the wired network to connect to the network (kernel device driver problem?)

Next, I went back to the Intrepid Alpha-4 CD and switched it to the vesa driver. Unfortunately, I couldn't get it to start up via startx (see the log file attached, which displays the error message).

[StableReleaseUpdate]
Impact: The bug prevents Ubuntu from being installed using the Desktop LiveCD, and makes X display nothing when the -intel graphics driver is used if installing some other way.

Addressed: The root cause of the problem is known upstream, and they've provided a quirking mechanism to deal with this class of problem. Adding the quirk solves this bug. This has already been uploaded to Intrepid.

Patch: See attached. In addition to this quirk, it also syncs 3 quirks from upstream; one for the same bug on another hardware platform, and two for the very common hang-on-lid-close pipe-a problem.

Reproducing: The LVDS bug can be reproduced by attempting to boot a LiveCD. After usplash the screen will blank, including vt's. The hang-on-lid-close bug is reproduced by closing the laptop lid or putting the machine into sleep mode.

Regression Potential: Quirks are targeted to specific PCI ID's and thus the scope of any regression is extremely small. Additionally, quirks are just changes in a data table, so the worst possibility is mistyping the PCI ID.

Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :

An error message I saw once on the console when attempting to do Install Ubuntu on Alpha4, vt1 showed" Can't get mode info (vm86 failure).

Also, I misspoke about the hang with Tribe2's LiveCD and -intel; it did not hang quite like on Intrepid, but rather hung after X had started up, while GNOME was initializing (it hung right after displaying the gnome-volume-manager splash screen). Switching to vt consoles produced corruption and blank screens.

Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
Bryce Harrington (bryce) wrote :

Actually the -vesa issue was just a typo in the xorg.conf.

Bryce Harrington (bryce) wrote :

Aha, looks like LVDS just needs quirked on this.

Changed in xserver-xorg-video-intel:
status: New → In Progress
Bryce Harrington (bryce) wrote :
Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: New → In Progress
Bryce Harrington (bryce) on 2008-09-10
description: updated
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.4.1-1ubuntu4

---------------
xserver-xorg-video-intel (2:2.4.1-1ubuntu4) intrepid; urgency=low

  * 23_quirks_studiohybrid_eeepc_and_w251u.patch:
    - Fix blank screen on startup on Asus Eee PC due to LVDS
      misconfiguration (LP: #233787)
    - Fix blank screen on startup on Dell Studio Hybrid due to LVDS
      misconfiguration (LP: #267945)
    - Fix crash on lid close on Gigabyte W251U - pipeA quirk (LP: #244242)

 -- Bryce Harrington <email address hidden> Fri, 12 Sep 2008 00:53:01 +0000

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Any testers?

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Changed in dell:
status: New → Fix Released
Changed in somerville:
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305574

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments