Comment 414 for bug 252094

Figured I'd make an update.

Mesa git fixed some issues for me.
unreal tournament isn't hoping around anymore.
Actually is pretty smooth now.

Blender's latest available build still renders outside the container
window but some of the glitches were fixed. You still can't see the
selection window.

L ate r

On 8/4/09, Jerry McCarthy <email address hidden> wrote:
> http://anholt.livejournal.com/41306.html
> ()_- [ We do use ut2004. It does stutter with 2.6.31rc (unstable code)
> due to a performance improvement that requires a Mesa fix to avoid the
> stuttering. The Mesa fix has been undergoing review.]-_()
> }-._
> He never mentions the fix. I haven't had time to look through the
> intel forums to find the thread with the discussion.
>
>
> Observations-_
> Use of the rc kernels is a bad idea. You risk loosing functionality.
> Best practice would be to use 2.6.29 and back-port all the GEM revisions.
> ( compare the two kernels and copy source files from one to the other )
> I used to do this a lot. To me 2.6.24 was the best so I'd port back
> all the junk I liked in the newer kernels. It's time consuming but
> worth it if you want to keep everything going. Think Red Hat here.
>
>
>
> Below is what I have:
> 1.mesa-git/glew-git
> 2.linux-2.6.31rc5
> 3.xf86-video-intel-2.8.0
>
> Not much of an improvement.
>
> -- "it's worst than that he's dead jim, dead jim dead jim." Bones
> looking at the intel driver.
>
> On 8/4/09, Tom Chiverton <email address hidden> wrote:
>> Quote from Storm's URL : " within Mesa there are regressions where we
>> could not even complete OpenGL tests with the current Karmic stack that
>> had run fine under Ubuntu 9.04". Although it says the stack has less
>> glitches, which is at least some improvement.
>>
>> --
>> MASTER: Poor graphics performance on Intel
>> https://bugs.launchpad.net/bugs/252094
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>> Status in X.org xf86-video-intel: Invalid
>> Status in “linux” package in Ubuntu: Fix Released
>> Status in “xserver-xorg-video-intel” package in Ubuntu: Fix Released
>> Status in linux in Ubuntu Karmic: Fix Released
>> Status in xserver-xorg-video-intel in Ubuntu Karmic: Fix Released
>>
>> Bug description:
>> I experience significant performance loss with ubuntu 8.10 alpha 3 with
>> my
>> Intel DG965WH based system and SVDO/ADD2 video card. Actually, the
>> performance loss started with ubuntu 8.04.1; I upgraded to see if there
>> was
>> any performance gain with the new version. While "glxgears" produced
>> values
>> between 1580 fps and 1496 fps with ubuntu 7.04 and 7.10, respectively, now
>> I
>> can only achieve something like 445 fps with ubuntu 8.10 alpha 3. I get
>> an
>> error message when starting glxgears that "TTM" was not available and
>> classic mode would be used. Similary, the flight simulator "flightgear"
>> achieves frames rates of 1-2 fps only.
>> My suspicion is that some of the hardware acceleration features of the
>> X3000
>> system are not being used, and I don't know how to activate them with the
>> new xorg.conf structure and the underlying automatic configuration
>> approach.
>> I would like to see the graphics performance go back to the values
>> achieved
>> in ubuntu 7.04 and 7.10.
>> Your help / comment is greatly appreciated.
>> Bingo
>>
>> [Update]
>> Intel upstream has been in a multi-year effort to rearchitect X and the
>> Intel 2D and 3D driver to provide better performance. While this work is
>> underway, people are seeing variations in performance levels from version
>> to
>> version, for a variety of reasons. There are probably multiple unrelated
>> bugs being reported in the comments here.
>>
>> It is important to note and remember that glxgears is *not* a benchmark
>> tool. It simply measures how fast the driver writes images to the
>> screen,
>> whereas most 3D applications are limited by render speed, not merely blit
>> speed. Instead use a 3D game (flightgear, tremulous, etc.) that has a
>> real
>> rendering workload to make comparisons.
>>
>> If you're definitely seeing performance problems and are able to narrow
>> it
>> to a specific cause, please do not comment onto this bug report - it's
>> too
>> lengthy and rambling already, and your issue will just be lost in the
>> noise.
>> Instead, make a new report and please be as specific as possible with
>> exact
>> steps to reproduce and as much detail and logs as you can. See
>> http://wiki.ubuntu.com/X/Reporting for tips on making a good X bug
>> report.
>>
>> A troubleshooting guide, with additional background about performance
>> issues
>> on Intel is available at:
>>
>> https://wiki.ubuntu.com/X/Troubleshooting/IntelPerformance
>>
>
>
> --
> You will be required to do wrong no matter where you go. It is the
> basic condition of life, to be required to violate your own identity.
> At some time, every creature which lives must do so. It is the
> ultimate shadow, the defeat of creation; this is the curse at work,
> the curse that feeds on all life. Everywhere in the universe. Philip
> K. Dick
>

--
You will be required to do wrong no matter where you go. It is the
basic condition of life, to be required to violate your own identity.
At some time, every creature which lives must do so. It is the
ultimate shadow, the defeat of creation; this is the curse at work,
the curse that feeds on all life. Everywhere in the universe. Philip
K. Dick