[Lenovo ThinkPad T440s] Laptop sometimes doesn't detect external monitor

Bug #1552040 reported by Kai Mast on 2016-03-02
80
This bug affects 14 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

Usually a reboot fixes the problem. I see stuff like this in dmesg.

[15294.887642] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15295.568309] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15295.587193] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15296.267547] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15296.286426] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15296.886015] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15296.886264] [drm:intel_dp_link_training_channel_equalization [i915]] *ERROR* failed to train DP, aborting
[15296.898472] [drm:intel_dp_link_training_channel_equalization [i915]] *ERROR* Timed out waiting for DP idle patterns
[15296.899688] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15297.579305] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15297.598328] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15298.279238] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15298.298275] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15298.965500] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15298.984539] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15299.665619] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15299.684522] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15300.367119] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15300.386173] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15301.067203] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15301.086097] [drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit
[15301.768998] [drm:intel_dp_link_training_clock_recovery [i915]] *ERROR* too many voltage retries, give up
[15301.769703] [drm:intel_dp_link_training_channel_equalization [i915]] *ERROR* failed to train DP, aborting
[15301.781947] [drm:intel_dp_link_training_channel_equalization [i915]] *ERROR* Timed out waiting for DP idle patterns

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xserver-xorg-video-intel 2:2.99.917+git20160218-1ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.20-0ubuntu3
Architecture: amd64
BootLog: [ OK ] Started LSB: Speech Dispatcher.
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Mar 1 20:58:27 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Haswell-ULT Integrated Graphics Controller [17aa:220c]
InstallationDate: Installed on 2016-02-26 (5 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160224)
MachineType: LENOVO 20AQS00500
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-8-generic root=UUID=bb8da1f1-8970-435e-aeaf-d7e1d9aa8a4e ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/21/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: GJET85WW (2.35 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20AQS00500
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrGJET85WW(2.35):bd09/21/2015:svnLENOVO:pn20AQS00500:pvrThinkPadT440s:rvnLENOVO:rn20AQS00500:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 20AQS00500
dmi.product.version: ThinkPad T440s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.2+16.04.20160209-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.1.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.1.2-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.17.3-2ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.6.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160218-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1
xserver.bootTime: Tue Mar 1 12:11:39 2016
xserver.configfile: default
xserver.errors: systemd-logind: failed to get session: PID 832 does not belong to any known session
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12350
 vendor AUO
xserver.version: 2:1.17.3-2ubuntu4

Kai Mast (kai-mast) wrote :

Kai Mast, thank you for reporting this and helping make Ubuntu better.

As per http://support.lenovo.com/us/en/products/Laptops-and-netbooks/ThinkPad-T-Series-laptops/ThinkPad-T440s?linkTrack=GPS:Body_Search%20Products&beta=false an update to your computer's buggy, insecure, and outdated BIOS is available (2.37). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it change anything?

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note, your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

Also, you don't have to create a new bug report.

Once the BIOS is updated, if the problem is still reproducible:
1) Please provide the output of the following terminal command (not perform an apport-collect):
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
2) Please make a comment specifically advising on if there was an improvement or not.
3) Please mark this report Status New.

If it's not reproducible, please mark this as Invalid.

Thank you for your understanding.

tags: added: bios-outdated-2.37
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Kai Mast (kai-mast) wrote :

I don't see anything in the changelogs that affects dockstations. But yeah I can go through the process of updating BIOS again...

Kai Mast (kai-mast) wrote :

kai@kai-thinkpad:~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
GJET86WW (2.36 )
12/04/2015

So this is weird. I applied the latest updated and it says 2.36 not 2.37. The releasenotes also don't mention 2.37...

Unfortunately the problem still occurs with this BIOS version. I am 99% certain this problem is caused by a the kernel module and not a faulty bios.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
vik (askvictor) wrote :

I'm getting the same error on a Thinkpad Yoga S1 when I connect to a dock. I've only started experiencing this as a major problem since upgrading to 16.04. I'm on the latest BIOS for this device (1.28).

vik (askvictor) wrote :

Here is the same/similar issue at RedHat: https://bugzilla.redhat.com/show_bug.cgi?id=1321296

vik, it will help immensely if you filed a new report with Ubuntu by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
knut (mr-knut) wrote :

Same problem here with a Dell Latitude E5440:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
 Subsystem: Dell Haswell-ULT DRAM Controller
 Flags: bus master, fast devsel, latency 0
 Capabilities: [e0] Vendor Specific Information: Len=0c <?>
 Kernel driver in use: hsw_uncore

The external monitor is sometimes not found after wake up from suspend. It seems this happens if I have used the laptop without monitor before suspend.

The external monitor is not recognized on DisplayPort nor at VGA connector.

Kai Mast (kai-mast) wrote :

I have the same problem on a T460s (skylake CPU).

tags: added: bios-outdated-2.41
removed: bios-outdated-2.37
T (mightyowl) wrote :

I have a Dell XPS 15 and connect over USB C to a display port hub to a HDMI external monitor.

Sometime in the past few months I ran into this issue. When I would lock my screen (xflock4) or go into standby the computer would lock up on resume and I had plenty of the following in the logs.

drm:intel_wait_ddi_buf_idle [i915_bpo]] *ERROR* Timeout waiting for DDI BUF B idle bit

It was fine on startup, as long as it didn't lock the screen.

I had been running kernel 4.4.0 on Xubuntu 16.04

I upgraded to kernel to 4.10.0 and my issue is now fixed.

Sergey Menshikov (sergem) wrote :

Ubuntu 17.10 Gnome/Xorg Lenovo 4th gen X1 20FBxxx Skylake i7 Intel built-in video
Kernel 4.13.0-32-generic #35-Ubuntu SMP

When connecting Thinkpad Dock with 2 Dell monitors, screen locks up (mouse is moving though) and is not responding. Monitors are not recognized. Unlocks 20 sec after disconnect. Happens every time after first connection following a reboot (first connection after reboot is OK)

dmesg shows a lot of:
drm:intel_wait_ddi_buf_idle [i915_bpo]] *ERROR* ...

Workaround:

sudo vi /usr/share/X11/xorg.conf.d/20-intel.conf

paste:

Section "Device"
 Identifier "Intel Graphics"
 Driver "intel"
 Option "DRI" "3"
EndSection

reboot
The issue does not return, unless the above file it removed.

Hat tip to https://wiki.archlinux.org/index.php/intel_graphics#Skylake_support

ThinkPad T460p
Ubuntu 18.04 / Linux Mint 19
uname -a Linux deus-ex-machina 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Mate Desktop

Same problem.
If I boot with the dock, everything is fine.
If I unplug and plug it again, my external monitors are still black and my internal keyboad and the USB are not working.
But I get the message, that the ethernet cable is connected and that the laptop gets power.

I also tested https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1552040/comments/14 from Sergey Menshikov (sergem)
After adding /usr/share/X11/xorg.conf.d/20-intel.conf my computer was unusable, stopping at the bootscreen, with the message
PKCS#7 signature not signed with a trusted key
Secure Boot is deactivated.

tags: added: bios-outdated-2.49
removed: bios-outdated-2.41

Kai Mast:

1) As per the sticker of the monitor itself (not from the Bug Description, or the result of a terminal command), could you please provide the full monitor manufacturer and model?

2) Regarding how you have the monitor connected, is this straight into the computer's miniDP cable, mDP to something else adapter, etc.?

3) Did this issue start to happen after an update? If so, which and when precisely?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
summary: - Laptop sometimes doesn't detect external monitor
+ [Lenovo ThinkPad T440s] Laptop sometimes doesn't detect external monitor
Sergey Menshikov (sergem) wrote :

My workaround is to enable GuC firmware loading and boot without the dock attached.

Kernel 4.15.0.30 Ubuntu 18.04.1 Xorg/Gnome Lenovo 4th gen X1 20FBxxx Skylake i7 Intel built-in video

Looks like this is some kind of race condition related to DisplayPort Multi-Stream mode (DP-MST). This is why multi-monitor docking stations are affected. A race is happening, with system attempting modesetting upon disconnect of the mst dock, which leaves the connector enabled. Error messages upon disconnect:

[drm:intel_dp_start_link_train [i915]] *ERROR* failed to enable link training
[drm:intel_mst_pre_enable_dp [i915]] *ERROR* failed to allocate vcpi

Next connection leads to black screen. Multiple error messages upon connect:

[drm:intel_wait_ddi_buf_idle [i915]] *ERROR* Timeout waiting for DDI BUF C idle bit

Related cases I've found:

https://patchwork.kernel.org/patch/8603521/
https://bugzilla.redhat.com/show_bug.cgi?id=1470960
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1552040
https://bugs.freedesktop.org/show_bug.cgi?id=73705

Workaround:

sudo vi /etc/modprobe.d/i915.conf

options i915 enable_guc_loading=1 enable_guc_submission=1

sudo update-initramfs -u
sudo reboot

always reboot while disconnected from DP MST dock

Sergey Menshikov, it is most helpful if you use the computer the problem is reproducible with, and file a new report with Ubuntu via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Paulo (ptsneves) wrote :

I had the exact same problem but with a dell xps15 9550 with a thunderbolt to display port in MsT mode with 2 external screens. Afer Sergeys tips everything became stable and workable.

Strange though, I did not have this problem at all in 18.04. Only occurred now after upgrading to 18.10. What changed? The kernel patch linked to is from 2016, and a lot of the other bug reports are older as well. Is it a regression of a sort?

I have a Thinkpad X270 (latest BiOS - 1.33) and this is driving me nuts. Luckily I came across this bug report so I'll at least have a couple of workarounds to try out :)

Tried the first workaround, the X.org conf.d snippet, and this has helped a great deal. Although, sometimes the lock screen acts up and shows my windows, toolbars and is weirdly unresponsive after resuming from suspend. I suppose that could be a different bug, perhaps with Gnome or Gnome Shell?

tags: added: bios-outdated-2.50
removed: bios-outdated-2.49
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.