X starts with black screen / blue screen (i965G)

Bug #153188 reported by mek on 2007-10-16
14
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Bryce Harrington
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I tested my PC (running now with Ubuntu 7.04 Feisty) with 7.10 Gutsy release candidate Live CD(downloaded on Oct. 12th at Swedish site). Kernel starts ok, but just when the Gnome should start, the whole screen goes black and stays black, no matter what I try. I'd like to be sure that my display works with Gutsy, that's why I tested with live-CD.

Intel Dual Core E2140 processor, with integrated Intel® Graphics Media Accelerator X3000 (Intel® GMA X3000) and my screen is 15" Philips LCD-TV 15PF9936/12 (http://www.p4c.philips.com/cgi-bin/dcbint/cpindex.pl?ctn=15PF9936/12&scy=gb&slg=ENG&grp=TV_GR&cat=FLAT_TV_CA&sct=LCD_SMALL_10_20_SU). The resolution of screen is ordinary 1024x768, 60 hz. The screen just notices, that the input video signal cannot be shown.

Ricardo (guarnero) wrote :

I just loaded 7.10 and I've got a blue screen (kinda like the BSOD) and nothing else. No controls. No menu. Not sure where to go from here.

Hi mek, this sounds sort of like an issue mdz encountered that I've been trying to gain more info about so we can solve it.

Is it possible to get to a console via ctrl-alt-f1? If so, could you attach your /var/log/Xorg.0.log[.old] showing the failure, and the output of lscpi -vvnn?

Also, is the blue screen just a solid color blue, or is there any text or graphics artifacts on it? If it's possible to attach a photo of the screen, that could prove useful.

Changed in xorg:
assignee: nobody → bryceharrington
status: New → Incomplete
eiffebaer (norbert-herrmann) wrote :

Hi Bryse,

i have the same problem: after automatic updating and restarting: the X begins with start and ends with black screen. If I start as root X it will work fine.

Do you have an idea?

Norbert

Bryce Harrington (bryce) wrote :

eifflebear, it's likely your bug is not related to Ricardo's, however please attach your /var/log/Xorg.0.log[.old] showing the failure, and the output of lscpi -vvnn and we'll see.

Anthony Brock (anthony-brock) wrote :

I posted the following to bug #132716. However, "mek" referenced me to this bug as well. It appears that this bug could be more closely related to my issue.

I'm experiencing problems with dual-head setup and xrandr 1.2 on a recent upgrade to Ubuntu 7.10 on my Dell Latitude D810 laptop with docking station. Previously this worked with the ati driver and it still functions when I change over to the "fglrx" driver (which rules out bad hardware).

I have a striped down configuration xorg.conf with two identical Dell FP1905 monitors connected through a docking station, one via VGA-0 and the other via DVI-0. On startup the DVI-0 monitor functions as expected while the VGA-0 monitor displays "1: Analog Input Cannot Display This Video Mode". The "working" monitor shifts from DVI-0 to VGA-0 when I issue the following command:

xrandr --output DVI-0 --crtc 0 --output VGA-0 --crtc 1

At this point, my desktop is properly displayed on VGA-0 while DVI-0 displays "2: Digital Input Cannot Display This Video Mode". Is it possible that this bug is related to "crtc 0" on the ATI x600 (M24)?

The log file from this session is attached. I can provide my xorg.conf upon request.

Tony

Anthony Brock (anthony-brock) wrote :

Ubuntu Gutsy just released a new xorg-driver-fglrx (version 7.1.0-8.37.6+2.6.22.4-14.10). However, this new version does not change the behavior. Any ideas on this?

Tony

Bryce Harrington (bryce) wrote :

Anthony, your issue is certainly not related to mek's. The symptoms don't match, and you have ATI hardware rather than Intel like mek. Please report it separately.

Ricardo, since you get a blue screen instead of a black screen, I'm doubtful your issue is the same as mek's either. Please see http://wiki.ubuntu.com/X/Debugging for tips on how to analyze and report bugs, and file a new bug with a detailed description of the issue, log files, and a photo if possible.

eifflebear, I can't tell if your issue is the same as mek's without more info, so please attach your /var/log/Xorg.0.log[.old] showing the failure, and the output of lscpi -vvnn and we'll see.

mek, we put some fixes into Gutsy that *might* address this - can you verify that the problem still exists with Gutsy-final? Also, we'll be releasing Hardy Alpha 1 within the week, so if you could test that one once it's out, that could help too.

mek, also, please attach your /var/log/Xorg.0.log.

mek (marekda) wrote :

Attached xorg.0.log.old at first try on 2007-10-16. I'll test again with ubuntu-7.10-desktop-amd64.iso Downloaded from Finnish server on 2007-11-28 and will attach the xorg... log if it doesn't still work.

mek (marekda) wrote :

Attached xorg.0.log, when tried at 7.10 64 bit Live-CD version downloaded 2007-11-28 from Finnish location.

mek (marekda) wrote :

Attached xorg.0.log.old, when tried at 7.10 64 bit Live-CD version downloaded 2007-11-28 from Finnish location.

Bryce Harrington (bryce) on 2008-02-07
Changed in xserver-xorg-video-intel:
status: Incomplete → Triaged
Bryce Harrington (bryce) wrote :

mek, thanks for attaching the log files; there wasn't an obvious crash though. Would you mind testing against the Hardy alpha, to see if the issue is still present there?

Changed in xserver-xorg-video-intel:
importance: Undecided → High
protoman (protomank) wrote :

After a upgrade to driver package xserver-xorg-video-intel 2.1.1-ubuntu9.1 I've started to have this problem also :-(
Does anyone knows how I can downgrade to 9.0 easily?

mek (marekda) wrote :

Hi Bryce,

I tested also with Hardy Alpha 8.04 LTS Live-CD, downloaded Feb 14th at Finnish location. It worked ok, if I chose "start Ubuntu at safe graphics mode" and chose also display as VGA. See attached log. However, it didn't work, if I chose the first option "Start or install Ubuntu" and chose display as 1024x768 (there are just options for 16 or 32 hz, not for 60 hz, which my display is).

Finally, my present Ubuntu 7.04 started work with integrated card reader after the kernel update in January, so I'm now not in a hurry for updating 7.10 or 8.04. I think I'll wait untill the release of 8.04. The problem with card reader was the reason why I starter trying 7.10.

unggnu (unggnu) wrote :

Which Hardy LiveCD do you have tested? According to your log the vesa driver was used which makes sense because of the safed graphic mode so the Intel driver could still have this issue.
What happens if you just start the LiveCD with "start or install Ubuntu" without changing anything except the keyboard or language?

mek (marekda) wrote :

Hi Unggnu,

I downoaded hardy-desktop-amd64.iso Live-CD at Finnish location on 14th February. If I start Live-CD normally with "start or install Ubuntu" , the display doesn't work but goes black just before the Gnome should start (just after I see blinking cursor at top left). So, it behaves just like 7.10.

I can't attach the log of this start with the error, how to do it when the display is black?

-Markku-

My system is also displaying this fault. 50% of the time I can clear it by doing ctrl+alt+F1 followed by ctrl+alt+F7.

pampelmoose (sam-dept) wrote :

I'm not an ubuntu user, but I seem to have had a similar problem.

I have (at my office) a Dell Optiplex, with an Intel 965q chipset. I was using Sidux (which is mostly Debian unstable). When I upgraded xserver-xorg-video-intel to 2.1.1 (in Debian unstable), my computer would hang at boot-up, just when X was starting. It was a complete hard freeze : no keyboard shortcuts worked, and I had to shut off the computer using the on-off button. [If I booted in single-user mode, I usually could start X as root, but even that was iffy.]

And it turns out that there was a similar bug reported at Xorg, only occurring with the Intel 965 chipset, and only with versions 2.1.1 and 2.2.1 of xserver-xorg-video-intel.

Changing the driver in "xorg.conf" from "intel" to "vesa" stopped the problem, but the screen resolution didn't look that great.

But I think (knock wood) that it got fixed when I downloaded the latest xserver-xorg-video-intel package --- 2.3.0 -- from Debian experimental. I don't know if that would work on a Ubuntu system. But maybe you could get the Ubuntu maintainers to upgrade the xserver-xorg-video-intel package to 2.30 (I think 2.2.9* would also work) in the hardy heron release?

Bryce Harrington (bryce) wrote :

That is good news that the newer -intel from Debian experimental solved the issue. It's not likely that we'd be able to pull that driver in, however if we could identify particular patches we may be able to SRU them.

mek, can you also confirm that running Debian's 2.3.0 driver resolves your issue?

Also, would either of you mind trying out the 'rac763634' git driver at this page: http://people.ubuntu.com/~bryce/bisect/?

If that version works, please try some of the older ones to see where it switches from working to failing; this will help us in narrowing down at what point it started working.

Brodie Rao (brodie) wrote :

I'm having this exact same issue. When Xorg starts with the intel driver, it randomly crashes. If I keep rebooting, it eventually comes up without crashing, and works fine from then on.

There's nothing in any logs about the crash. The system sometimes completely freezes, sometimes I can get to a terminal. I should note though that with the intel driver, *displaying* terminals has never worked for me, it just gives a blank screen. However, I can still do things in those terminals, I just don't get any video.

I tried running Xorg in gdb with the loglevel set to 127 (I'm not sure what the highest value is), and with modeline debugging on and signal trapping off. Sometimes it would get to the point where it'd print the backtrace, and other times the log of gdb's output would just end abruptly.

I'll attach the log with the backtrace. Unfortunately it seems like it's crashing in random functions, so I think it could be an array bounds/memory corruption issue in the driver. I also have a core dump, but I'm not sure how to populate it with debug symbols, so I don't know how useful it would be. I can attach the core dump if you'd like.

When I get time I plan on running the plugin with Valgrind. I'll try those git builds when I get a chance as well.

Bryce Harrington (bryce) wrote :

Thanks Brodie, let us know how the testing turns out.

Brodie Rao (brodie) wrote :

The builds you have up at the moment all seem to be older than what's currently in Hardy, at least going by the version numbers. I've tested both ccac60bf and rac763634 - neither exhibit the crash.

I did end up running X with Valgrind, but unfortunately I don't remember what version of the driver I was using at the time. I believe it was whatever was in hardy or hardy-updates when I recorded the output (2008-05-28). I'm attaching the log anyway. There are some warnings specifically related to the Intel driver, but I don't know if they're relevant.

If you could provide newer builds, I can test them out when I get a chance.

Jan Pejša (jpejsa) wrote :

I'm having same problem - graphic card intel 965G in computer Optiplex 745 DELL.
With rac763634 (i386) package from http://people.ubuntu.com/~bryce/bisect/ it works fine for me.
Is planned add this fix into ubuntu-hardy oficial repository?

unggnu (unggnu) wrote :

There is an unofficial package http://people.ubuntu.com/~bryce/Testing/intel/hardy-i386/xserver-xorg-video-intel_2.3.1-1ubuntu1~bwh3_i386.deb (AMD64 http://people.ubuntu.com/~bryce/Testing/intel/hardy-md64/xserver-xorg-video-intel_2.3.1-1ubuntu1~bwh3_amd64.deb) of a newer -intel driver for Hardy.

To install it you have to remove the old i810 driver before.
sudo apt-get remove xserver-xorg-video-i810 xserver-xorg-video-all

If you want to reset everything do the follow commands.
sudo apt-get remove xserver-xorg-video-intel
sudo apt-get install xserver-xorg-video-all

It should work when rac763634 or the Debian sid packages worked for you. If so the issue is already fixed in Intrepid but for Hardy the patch/commit have to be found like described above.

Jan Pejša (jpejsa) wrote :

I had tried unofficial package xserver-xorg-video-intel_2.3.1-1ubuntu1~bwh3_i386.deb (see comment above), but this doesn't solve my problem - xserver crashes during start again.
I'm now working with xserver-xorg-video-intel_2.2.0+git20080318.ac763634-1_i386.deb package - it works for me as expected (no xserver crash).

unggnu (unggnu) wrote :

Please attach your files /var/logXorg.0.log and /var/log/Xorg.0.log.old directly after X has crashed with the unofficial driver.

Jan Pejša (jpejsa) wrote :

/var/log/Xorg.0.log.old file (when it crashes)

Jan Pejša (jpejsa) wrote :

/var/log/Xorg.0.log (when it is OK)

Wit Wilinski (wit-wilinski) wrote :

I get blank screen, too. Sometimes restarting the machine helps. Temporary solved (but not 100% if it helps) by disabling framebuffer (nofb kernel option)

kernel: Linux localhost 2.6.26-2-generic #1 SMP Thu Jun 19 15:51:43 UTC 2008 i686 GNU/Linux

video driver: various versions of ...video-intel (2.2.x, 2.3.x)

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
        Subsystem: Lenovo Device 383e
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fc000000 (64-bit, non-prefetchable) [size=1M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1800 [size=8]
        Capabilities: <access denied>
        Kernel modules: intelfb

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
        Subsystem: Lenovo Device 383e
        Flags: bus master, fast devsel, latency 0
        Memory at fc100000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>

Bryce Harrington (bryce) wrote :

Next step for this bug is to bisect between the working and broken versions, to find what change caused the breakage and to report it upstream.

Meanwhile, we have -intel 2.3.2 in Intrepid now - if folks could confirm whether or not the issue still exists there, it would help.

Bryce Harrington (bryce) wrote :

Since it sounds like the newer driver in Intrepid won't have this issue, I'm closing the bug report as fixed, but will open a task for hardy - if someone can identify what the fix was, we can SRU it.

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
Jan Pejša (jpejsa) wrote :

Where can I download intel video driver of version 2.3.2?
I want to test this version with hardy - last time I had no luck with version 2.3.1 - it doesn't work for me :(

Jan Pejša (jpejsa) wrote :

I had tried official package xserver-xorg-video-intel_2.3.2-2ubuntu3_i386.deb for ubuntu intrepid in hardy and it doesn't work for me! :(

With 2.3.2-2 intel video driver xserver doesn't crash, but it doesn't work.

downloaded from: http://packages.ubuntu.com/intrepid/xserver-xorg-video-intel
command to install into hardy: dpkg -i --ignore-depends=xserver-xorg-core Desktop/xserver-xorg-video-intel_2.3.2-2ubuntu3_i386.deb

in attachment is log of Xorg server when it doesn't work

Bryce Harrington (bryce) wrote :

Probably no surprise it doesn't work - that .deb of 2.3.2 was built against the intrepid X server, so wouldn't work properly with the hardy X server.

Amit Kucheria (amitk) wrote :

I have only updated my kernel to 2.6.25-5 from Intrepid. All the userspace is still Hardy and my X fails.

Booting back into the Hardy kernel brings X back up. Diff'ing the Xorg.log gives the following. I will attached both Xorg.logs

amit@k2 - (~) $ diff -u Xorg.0.log.old Xorg.0.log
--- Xorg.0.log.old 2008-08-03 01:28:40.000000000 +0300
+++ Xorg.0.log 2008-08-03 01:32:29.000000000 +0300
@@ -11,7 +11,7 @@
 Release Date: 5 September 2007
 X Protocol Version 11, Revision 0
 Build Operating System: Linux Ubuntu (xorg-server 2:1.4.1~git20080131-1ubuntu9.2)
-Current Operating System: Linux k2 2.6.26-5-generic #1 SMP Sat Jul 26 21:35:46 UTC 2008 i686
+Current Operating System: Linux k2 2.6.24-20-generic #1 SMP Mon Jul 28 13:49:52 UTC 2008 i686
 Build Date: 13 June 2008 01:08:21AM

  Before reporting problems, check http://wiki.x.org
@@ -20,7 +20,7 @@
 Markers: (--) probed, (**) from config file, (==) default setting,
  (++) from command line, (!!) notice, (II) informational,
  (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
-(==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 3 01:21:08 2008
+(==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 3 01:24:38 2008
 (==) Using config file: "/etc/X11/xorg.conf"
 (==) ServerLayout "Default Layout"
 (**) |-->Screen "Default Screen" (0)
@@ -531,9 +531,9 @@
 (II) Loading sub module "ramdac"
 (II) LoadModule: "ramdac"(II) Module "ramdac" already built-in
 (II) intel(0): Comparing regs from server start up to After PreInit
-(WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x00000202 to 0x00000242
-(WW) intel(0): PIPEBSTAT before: status: VSYNC_INT_STATUS VBLANK_INT_STATUS
-(WW) intel(0): PIPEBSTAT after: status: VSYNC_INT_STATUS LBLC_EVENT_STATUS VBLANK_INT_STATUS
+(WW) intel(0): Register 0x71024 (PIPEBSTAT) changed from 0x80000202 to 0x80000242
+(WW) intel(0): PIPEBSTAT before: status: FIFO_UNDERRUN VSYNC_INT_STATUS VBLANK_INT_STATUS
+(WW) intel(0): PIPEBSTAT after: status: FIFO_UNDERRUN VSYNC_INT_STATUS LBLC_EVENT_STATUS VBLANK_INT_STATUS
 (==) Depth 24 pixmap format is 32 bpp
 (II) do I need RAC? No, I don't.
 (II) resource ranges after preInit:
@@ -666,7 +666,7 @@
 (II) intel(0): Display plane B is now enabled and connected to pipe B.
 (II) intel(0): Output VGA is connected to pipe none
 (II) intel(0): Output LVDS is connected to pipe B
-(II) intel(0): [drm] dma control initialized, using IRQ 16
+(II) intel(0): [drm] dma control initialized, using IRQ 20
 (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
 (II) intel(0): DPMS enabled
 (II) intel(0): Set up overlay video

Amit Kucheria (amitk) wrote :

BTW, in case it wasn't clear, I get the same black screen symptoms as reported by others.

mek (marekda) wrote :

I think the Ubuntu version 8.04.1 64 bit solved my problem, but just after getting also a new screen with 1280 x 1024 resolution. I'm writing this by running 8.04.1 64 bit Live CD (downloaded at July 22nd) and finally it works fine.

mek (marekda) wrote :

Attached also Xorg.0.log of this working version of 8.04.1.

Amit Kucheria (amitk) wrote :

In my case (Intrepid kernel + Hardy userspace), it turned out to be related to usplash. Disabling usplash with the Intrepid kernel makes the blank screen problem go away.

pukyxd (pukyxd) wrote :

I have the same problem in Kubuntu Intrepid alpha4. But when I connect an external monitor and reboot it works fine.

pukyxd (pukyxd) wrote :

I make a mistake the black screen only is when I do a normal boot. When I choose the (Last Boot succeded) it works fine.

I am running standard Hardy 8.04 on a Intel GM965 chipset (X3100 intergrated graphics). On first boot, after usplash, with TV (SVideo) and VGA connected, both displays are black. Doing a CTRL+F1 then CTRL+F7 brings the X display onto the VGA, but nothing on TV. If I suspend the system to S3 then wake it up I get a display on the TV and nothing on VGA until I do a CTRL+F1 then CTRL+F7 which makes both the TV and VGA work perfectly.

If I disable usplash on boot, as suggested by Amit above, then I still get a black screen after first boot. However, doing a CTRL+F1 then CTRL+F7 brings an X display on both the TV and VGA (no need to suspend then wake up to get the TV working).

My usual configuration is just a TV connected via SVideo. The TV results with just a TV connected and no VGA are the same as above.

Andy Piper (andy-piper-gmail) wrote :

I've been seeing very similar behaviour as John at Canterbury in all desktop Ubuntu releases since 7.04, except the "black display" problem occurs randomly about 50% of the time on my system. The same "switch TTYs" workaround works for me too.

Since upgrading to 8.10 I've been presented with a dark red/brown screen (very) occasionally, but the vast majority of the time its black. Disabling usplash seems to have no effect.

My system is an Aopen Minipc MP965 with a similar spec to John's: an Intel GM965 chipset and X3100 integrated graphics, but I only have a single VGA monitor attached (an Acer P223W LCD running at 1680 x 1050)

I'll grab the Xorg logs next time I see this happen.

dino99 (9d9) on 2012-08-31
Changed in xserver-xorg-video-intel (Ubuntu Hardy):
status: New → Invalid
To post a comment you must log in.