Ubuntu

[i945] Second display not enabled with "intel" video driver

Reported by Vincenzo Ciancia on 2007-09-04
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
High
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I am using gutsy cd tribe 5, with the new "intel" driver for my video card. The second display (vga out) is not enabled and pressing the relevant "fn" key on my laptop does not enable it (may be a matter of frequencies). Using the i810 driver solves the problem, but lowers the range of available resolutions.

James Henstridge (jamesh) wrote :

You should be able to enable it by running the following command in the terminal:
    xrandr --output VGA --auto

If a monitor is attached, it should enable it. If one isn't attached, it should disable it again. I guess what is needed here is some daemon to perform the appropriate xrandr commands in response to the key presses.

Dan Gilliam (geocritter) wrote :

Is this what I am running into? When I install gutsy, either the alternate installer or the graphical installer, it gets to the point where it's installing the packages, and all of a sudden, goes into a "colored and gray blocks" mode. Switching between terminals, I can see it working, and it will install ok, but it's all in these blocks, showing that something is wrong with the video. You can kind of tell what's going on, based on experience (i.e., you can see that it's proceeding line by line), and by hitting enter when you think it should be at the finishing point, it ejects the cd, etc., and on reboot it's fine. Then later xserver crashes on logout (a different bug). Chipset is Intel 915GM...

Dan Gilliam (geocritter) wrote :

Oops, that must not be the right bug, sorry, missed that it was for a second terminal. I thought it meant when it switched to another terminal internally during install. Should this be a separate bug?

Vincenzo Ciancia (vincenzo-ml) wrote :

I had the same problem you are experiencing, I guess it was a bug in the console switching code, however it seems to me that it has been solved in recent updates. What version of gutsy are you using to install it?

Timo Aaltonen (tjaalton) wrote :

Dan: that has been fixed.

Vincenzo: do you still see the original issue with uptodate gutsy?

Changed in xserver-xorg-video-intel:
status: New → Incomplete
Vincenzo Ciancia (vincenzo-ml) wrote :

Unfortunately my power charger is broken and I am really busy, so I don't have the time to think about that. I am using another laptop in the meantime, so can't provide additional information. Please don't close the bug, just leave it in incomplete status, I will provide required info as soon as possible.

Bryce Harrington (bryce) wrote :

Hi Vincenzo, just checking back in - it's been 3 months, are you still interested in this bug?

Vincenzo Ciancia (vincenzo-ml) wrote :

Bryce, sorry for delayed reply. Yes, I am still interested. I completely forgot about the issue until a couple of weeks ago. With fully up-to-date gutsy, I had to do a presentation and my vga out didn't work at all. Then I found on the web to use

        Option "TVOutFormat" "SVIDEO" # "COMPOSITE"

in my "Screen" section in /etc/X11/xorg.conf

This worked on my two vga monitor (one analog and one digital) but DIDN'T work on the projector, even though I changed resolution to the usual 1024x768 and the frequency reported by the screen resolution properties was 50 hz (but let me doubt about that :-)) Hence, this bug is still present in gutsy and was a bad publicity for ubuntu at the meeting we had (my laptop always worked on that projector until feisty).

Regarding hardy, if I press the key for switching to VGA output on my laptop (with correct resolution) the only thing that happens is that I see gtk widgets getting back to the default gtk theme for a moment, and then to the "human" one. This is quite strange, seems like the gnome-settings-daemon has been restarted.

In any case, fiddling up with the new tools that were introduced in hardy, I succeded in having a vga out, but at some strange frequencies that my external monitor cannot handle... it keeps switching settings (I hear it clicking) and sometimes for a moment it displays garbled output.

I have now the power charger and the time to debug the issue a little more so feel free to ask more information. I am running hardy nowadays so my system is up-to-date for testing.

Bryce Harrington (bryce) on 2008-03-15
Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Hi Vincenzo,

Thanks for getting back to me - and sorry to have not replied sooner!

You may have noticed that there is a new Xrandr GUI, which can prove helpful in setting up projectors and secondary (cloned) monitors. I've been testing projector support on -intel the past month or two, and while there are still some glitches, it more or less works. I'd be very interested in hearing your findings of it.

I've also been pumping in a ton of bug fix patches to -intel, and while the issues you describe don't sound identical to ones we've addressed, it's possible yours got fixed in the process. So re-testing would be a big help.

Some of the test data that is worth attaching to this report would be your Xorg.0.log, the output of `xrandr`, and your /etc/X11/xorg.conf. A photo of the screen showing "garbling" can also be helpful - some of the screen corruption modes will be immediately recognizable by sight, but prove difficult to describe in words. What I've done in testing is just cycle through all listed resolutions and note down particular ones that have problems.

Vincenzo Ciancia (vincenzo-ml) wrote :

Thanks Bryce for your reply. For now a quick update, I will then report more tomorrow or on sunday, since I have a deadline tomorrow morning: I installed fresh hardy beta, it is up-to-date. The new gui for resolution is pretty cool. However, I personally found no way to set up the second display, it just keeps powering on and off (seems like it is protecting itself from damage). However, second monitor is autodetected correctly and that was a positive surprise to me.

I now have attached an LCD panel to my vga out. In the new resolution tool, after clicking on "detect displays", it does NOT show the second display, however when I click in the preview area showing the monitors layout, the new screen suddenly is drawn.

There, I enabled it selecting its native resolution (1280x1024) and clicked on "apply". The external monitor was not turned on, and the laptop lcd disappeared from the preview in the resolution tool. My panels have changed their position (they are reflecting a 1280x1024 display) but the desktop remained at its original resolution, 1400x1050. I attach a screenshot of the resolution applet after clicking "apply", and of my desktop (however, the top panel was not captured - I don't know why) after setting 1280x1024.

Then, I logged out and in, and tried to put my resolution back. I attach the result, which is a desktop with a rectangle (i suspect of the old size) working, and the rest black. However notice that the black area has been captured by the gnome screenshot tool.

If I press my vga-out switch, the panels resize and move to match the resolution of the second display. However, the desktop and the windows are NOT resized. If I press it again, everything comes back to normal. I attach a screenshot of this too.

 I also attach my xserver configuration, out-of-the-box with hardy, and my x server log. The external LCD was never turned on, and it does not turn on with xrandr --output --auto.

Vincenzo Ciancia (vincenzo-ml) wrote :

I forgot to add the output of Xrandr. Everything seems ok as you can see, but the CRT monitor reports that frequencies are out of range. I paste both sony crt and acer lcd output.

Sony CRT:
==========================

vincenzo@frattaglia:~$ xrandr
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1400 x 1400
VGA connected 1024x768+0+0 (normal left inverted right x axis y axis) 312mm x 234mm
   1024x768 85.0*+ 84.9 75.1 70.1 60.0 43.5
   1280x1024 74.9 75.0
   1280x960 74.9
   1152x864 84.8 75.0
   832x624 74.6
   800x600 84.9 72.2 75.0 60.3 56.2
   640x480 84.6 75.0 72.8 66.7 60.0
   720x400 87.8 70.1
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1400x1050 60.1*+ 85.3 74.8 70.0 60.0
   1280x1024 85.0 75.0 60.0
   1280x960 85.0 60.0
   1280x800 60.0
   1152x864 85.1 75.0
   1280x768 60.0
   1152x768 54.8
   1024x768 85.0 75.0 70.1 60.0
   832x624 74.6
   800x600 85.1 72.2 75.0 60.3 56.2
   640x480 85.0 72.8 75.0 59.9
   720x400 85.0
   640x400 85.1
   640x350 85.1
TMDS-1 disconnected (normal left inverted right x axis y axis)
TV disconnected (normal left inverted right x axis y axis)
vincenzo@frattaglia:~$

ACER LCD
========================

vincenzo@frattaglia:~$ xrandr
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1400 x 1400
VGA connected 1024x768+0+0 (normal left inverted right x axis y axis) 337mm x 270mm
   1280x1024 60.0 + 75.0 59.9
   1280x960 59.9
   1152x864 74.8
   1024x768 75.1 70.1 60.0
   832x624 74.6
   800x600 72.2 75.0 60.3 56.2
   640x480 75.0 72.8 66.7 60.0
   720x400 70.1
LVDS connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1400x1050 60.1*+ 85.3 74.8 70.0 60.0
   1280x1024 85.0 75.0 60.0
   1280x960 85.0 60.0
   1280x800 60.0
   1152x864 85.1 75.0
   1280x768 60.0
   1152x768 54.8
   1024x768 85.0 75.0 70.1 60.0
   832x624 74.6
   800x600 85.1 72.2 75.0 60.3 56.2
   640x480 85.0 72.8 75.0 59.9
   720x400 85.0
   640x400 85.1
   640x350 85.1
TMDS-1 disconnected (normal left inverted right x axis y axis)
TV disconnected (normal left inverted right x axis y axis)

Alfrenovsky (alfredo-fing) wrote :

Same thing happens to me.
With i810 drivers everything works. Even the fn-F5 key cycles between LCD, CRT, LCD+CRT...

with intel driver xrandr reports VGA monitor connected (When I connect it), and with the same resolution and position that the LCD one, but the external monitor doesn't wake up.
In the debugged logs I can see that the Samsung monitor or an external EPSON projector is detected and the EDID chat is done. But I have no signal.

I can turn off the LCD and it works. I can turn it on by typing blindly, and it works, but when I change any VGA output setting, even when xrandr reports the settings has been applied, nothing happens.

I think the problem could be the VGA power saving option that keeps enabled.
Anyone knows how can I interact directly with VGA card energy saving settings.

ea2973929 (nilsson-e) wrote :

I also have some stange problems with the intel driver and external output.

It all started the other day when I tried to make GDM show in a higher resolution. I tried doing "xrandr ---output LDMS --auto --output TDMS-1 --auto" in the end of /etc/gdm/Init/Default. This seemed to work fine, restarted, resolution was correct on both monitors, pulled out the external screen, restarted, everything seemed to work fine. Then came the choke - putting back the external screen and restarting resulted in picture on the laptop screen only. Since then I revoked the oneliner and tested again, but the problems now seem to be permanent, I can't get display on my external monitor back.

I ran xrandr and only got

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
   1280x800 59.9*+ 60.0
   1280x768 60.0
   1024x768 60.0
   800x600 60.3
   640x480 59.9
TV disconnected (normal left inverted right x axis y axis)

That is, no TDMS-1 detected at all!

I'm really at a blank here....

Oh by the way, If you think this i separate bug please feel free to open a new one.

Vincenzo Ciancia (vincenzo-ml) wrote :

Bryce: ping :)

Bryce Harrington (bryce) wrote :

@Vincenzo, initially this sounded like another bug, but looking at the logs and screenshots it's clearly something different.

The next step here will be to test against the upstream git-version driver and verify the problem still occurs there, and then report the issue upstream. If you can build the driver on your own and verify it occurs there too, then it can be forwarded upstream. If not, now that 8.04.1 is out I will be producing debs of the git-version of the driver within a week or so.

@ea2973929, what you describe sounds like it is unrelated to Vincenzo's. Please refer to http://wiki.ubuntu.com/X/Reporting and report a new bug.

Vincenzo Ciancia (vincenzo-ml) wrote :

Bryce: I finally found time to test.

I tested again with freshly installed, and upgraded, hardy, and with intrepid. The bug and the symptoms remain. In intrepid, the GUI configuration tool for screens is not working anymore and does not detects displays.

Now I built git version of the drivers, and installed it. The difference is that now the external CRT/LCD display is not even detected by xrandr (it says "VGA disconnected").

This is a bug forwarded from a Ubuntu user:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/137234

Issue: VGA out is disabled for this hardware (chip 8086,27a6 card 1179,0001 (Intel 945GM)), but when manually enabled the detected screen resolution is wrong, and when set manually results in panel bars displayed at the wrong lengths.

I notice we have a pipe-A quirk against this hardware, but it's targeted to 915GM - should this be 945GM?

    /* Toshiba Protege R-205, S-209 needs pipe A force quirk */
    { PCI_CHIP_I915_GM, 0x1179, 0x0001, quirk_pipea_force },

xorg.conf: http://launchpadlibrarian.net/16007302/xorg.conf
Xorg.0.log: http://launchpadlibrarian.net/16007327/Xorg.0.log
Screenshot: http://launchpadlibrarian.net/16007333/desktop_after_trying_to_enable_second_display.png

[Please attach files individually, not in tarballs, as it makes it harder to link to them when upstreaming bug reports.]

Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :

Hi Vincenzo, I've forwarded the bug upstream here: https://bugs.freedesktop.org/show_bug.cgi?id=16702

Please subscribe to the upstream bug there in case they need further info from you or have things for you to test.

Changed in xserver-xorg-video-intel:
status: Confirmed → Triaged
Changed in xorg-server:
status: Unknown → Confirmed

The behavior described by the user is pretty weird. I don't think the pipea force quirk is the problem though, that would just leave the output on but shouldn't break anything.

Moreover, the resolutions for the VGA connected displays seem to be detected properly, so I'm not sure why things aren't working for him.

The screen shot looks typical of what you'd expect a cloned configuration to look like where one head was running at a different resolution than the LCD (that's why the desktop is smaller).

Maybe you can try setting different modes by hand on the external displays by hand? E.g.
  $ xrandr --output VGA --mode 800x600 --right-of LVDS
or something. Also choosing a lower refresh rate might help.

The last comment in the launchpad entry is disturbing too, he says with the latest bits VGA isn't even detected properly, even when a display is plugged in? That sounds bad...

The logs actually look pretty normal; what you'd expect for a dual head config.

I had to send my laptop for assistance, as soon as it is back I will test more, however I have seen other -945 that behave the same (on sony vaio laptops).

Changed in xorg-server:
status: Confirmed → In Progress

(In reply to comment #2)
> however I have seen other -945 that behave the same (on sony vaio laptops).
>

any specific links where we can find details?

 Vincenzo Ciancia , have you got your machine back?

Unfortunately not yet. Also the persons owning the sony vaio laptops I mentioned are on vacation. I hope to have the laptop soon but I will leave on the 9th, if toshiba assistance will repair my laptop later, I will be back to italy at the end of august.

 Vincenzo Ciancia, What's the model of your sony vaio?

I don't have a sony vaio, but a toshiba M400 (tablet). The sony vaio I mentioned are from my colleagues but they are on vacations right now. My laptop has been repaired and they are about to send it back, I hope to have it at latest on monday.

Fixed my VGA problem upgrading to a backport 2.3.2-2ubuntu3
Just downloaded the deb src from intrepid, compiled and installed in hardy fixed my problem enabling VGA out on my Toshiba A10S100 notebook

I got my machine back. It is still half-broken (thanks, toshiba!) and I have to send it back for further repair. Before doing that, I just downloaded the sources for version 2.3.2 of the driver (from ubuntu intrepid) and tested those on ubuntu hardy but nothing changed. I also tested the whole intrepid but cant manage to log in (X hangs due to keyboard, dont know why).

I also tried xrandr --output VGA --mode 800x600, and tried the new ubuntu GUI for xrandr, but nope: the CRT is correctly detected, the resolution is changed, but nothing appears on the screen, as if was physically disconnected. I also tried the same screen with another intel laptop running ubuntu hardy, and everything works fine.

I tried the same: downloaded xserver-xorg-video-intel sources and rebuilt version 2.3.2 from a hardy live usb, but nothing changed, and the bug is still there.

(In reply to comment #8)
> I also
> tried the same screen with another intel laptop running ubuntu hardy, and
> everything works fine.
>

it sounds like maybe a HW problem of your laptop...Hmm.. Do you have another kind of monitor that you can connect to your toshiba to see if it works or not?

Under windows my vga out works fine and it also used to work fine with the i810 driver. I have other monitors and I tried an LCD panel. I reported the results in the following ubuntu bug:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/137234

(see the comments past 2008-04-14 for some screenshot and xrandr output using both monitors).

My laptop is now back to the toshiba service, I fear that I won't get it back until the end of august since they'll have their vacation now.

We recently fixed an issue with the pipe a force code; the SAREA for 3D apps wasn't getting updated which might have caused anything outside the initial configuration to not show up. Can you try git master and see if the issue is fixed for you?

Fwiw, I have an Aug 12 snapshot deb of -intel built for Intrepid built here; dunno if it's new enough tho:

http://people.ubuntu.com/~bryce/Testing/Gem/

At least some of the fixes made it in after that... do you have anything more recent?

Not at this time. The user will need to rebuild from the git source then.

ping Vincenzo for comments....

My laptop was back from warranty after more than two months. I have tested both the driver currently in ubuntu intrepid (2.4.1) and the git version (2.5.96) - the latter required me to install git libdrm.

Using both drivers, I don't get any output from secondary monitor. However, with 2.4.1 (the older version) if I connect the cable before system power on I get both outputs correctly, even tough the primary LCD panel of the laptop is much less bright than ordinary (don't know why). There are other bugs, but this is sufficient to give a talk if one remembers to boot with vga connected.

Using the latest git version of the driver, if I connect vga before boot, I only see the secondary monitor and there is no way to view the integrated LCD panel of the laptop.

I am going to attach the output from xrandr and the server log in the latter case (xrandr shows that the laptop LCD panel is not detected at all).

From what I can see (e.g. screen blinking sometimes) the problems with second display not enabled when the cable is NOT connected at boot time are related to wrong frequencies - maybe there is some number calculation error in the driver itself?

Changed in xorg-server:
status: In Progress → Confirmed
Bryce Harrington (bryce) on 2008-12-20
Changed in xserver-xorg-video-intel:
status: Triaged → Incomplete
Changed in xserver-xorg-video-intel:
status: Incomplete → In Progress
Changed in xorg-server:
status: Confirmed → In Progress
37 comments hidden view all 117 comments

(In reply to comment #50)
> Michael: I confirm that your summary is correct. However the following
> statement can be made a bit more precise (just to summarize):
>
> "Neither A1 nor A2 case make your LCD and external VGA work at the same time,
> while B case, LCD and VGA can both work at the same time."
>
> In fact, in A1 and A2 cases, my VGA output does not work at all, even with the
> LCD disabled. In B case, LCD and VGA work at the same time, but the LCD is set
> at minimum brightness and changing the setting using the hotkeys seems to do
> whatever it has to do, but does not do anything.
>

Let's not to mention the brighteness or hotekey.. those are not related with this bug... thanks.

Changed in xorg-server:
status: In Progress → Confirmed

hi Vincenzo Ciancia,

as we know A2 case is from pluging VGA after boot and run "$xrandr --output VGA --auto"

I find the register-dump difference between case A2 and case B is mode line.

for case A2 is
1024x768 (0x3e) 94.5MHz +HSync +VSync *current +preferred
        h: width 1024 start 1072 end 1168 total 1376 skew 0 clock 68.7KHz
        v: height 768 start 769 end 772 total 808 clock 85.0Hz

for case B is
1024x768 (0x5c) 65.0MHz -HSync -VSync *current
        h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
        v: height 768 start 771 end 777 total 806 clock 60.0Hz

So under A2 case, could you try to run "$xrandr --output VGA --mode 0x5c"

then run "$xrandr --verbose" to check whether VGA is using the same mode line with that of above case B ? (key *current shows the current mode line )

Thanks
Ma Ling

I hoped but nothing new happened, the monitor is still out of scan range:

$ xrandr --output VGA --mode 0x5c
$ xrandr --verbose|grep current
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1792 x 1792
  1024x768 (0x5c) 65.0MHz -HSync -VSync *current
  1024x768 (0x5c) 65.0MHz -HSync -VSync *current

(In reply to comment #53)
> I hoped but nothing new happened, the monitor is still out of scan range:
> $ xrandr --output VGA --mode 0x5c
> $ xrandr --verbose|grep current
> Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1792 x 1792
> 1024x768 (0x5c) 65.0MHz -HSync -VSync *current
> 1024x768 (0x5c) 65.0MHz -HSync -VSync *current

hi Vincenzo Ciancia,

please paste dump-register in comment #53 case.

Thanks
Ma Ling

(In reply to comment #54)
> (In reply to comment #53)
> > I hoped but nothing new happened, the monitor is still out of scan range:
> > $ xrandr --output VGA --mode 0x5c
> > $ xrandr --verbose|grep current
> > Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1792 x 1792
> > 1024x768 (0x5c) 65.0MHz -HSync -VSync *current
> > 1024x768 (0x5c) 65.0MHz -HSync -VSync *current
>
> hi Vincenzo Ciancia,
>
> please paste dump-register in comment #53 case.
>
> Thanks
> Ma Ling
>

ling, if I understand correctly, it's the reg_dump in comment# 23 you are asking for...

Changed in xorg-server:
status: Confirmed → In Progress

Created an attachment (id=22180)
register dump after setting mode to 0x5c

hi Vincenzo,

Please use $xrandr --output VGA --off before using $xrandr --output VGA --mode 0x5c under A2 case, after that try "$xrandr --output VGA --mode 0x5c" again.

Thanks
Ma Ling

(In reply to comment #49)
> (In reply to comment #48)
> > Created an attachment (id=22130) [details] [details]
> > Various tests on a sony vaio multiscan E200 monitor.
> >
>
> Vincenzo Ciancia,
>
> To confirm with you.
>
> A1 is after starting Xorg ,before connect VGA
> A2 is after connect VGA and runing "$xrandr --output VGA --auto"
>
> B is vga is pluged before boot
>
> Neither A1 nor A2 case make your LCD and external VGA work at the same time,
> while B case, LCD and VGA can both work at the same time.
>
> Is the above statement right?
>
> If that's true, one interesting thing is, the reg_dump in comment# 23 is
> identical with B case, while comment# 23 doesn't work while B works... This
> senario is identical with bug# 16777. It seems vbios did something we are not
> aware...
>

Vincenzo, I went through the bug comments and am not sure if you have tested this case, let's call it A3:

boot system up without VGA connected, but boot to console mode, connect VGA monitor, they run startx.

Will both your LCD and VGA work? please attach xorg.log with modedubug turns on. thanks!

ping for response... Vincenzo

As usual, very sorry for my delay, It seems that I am constantly either travelling, or under heavy overwork. Next week I will change the country where I work and live for 9 months (this includes changing monitor) and I am extremely busy for this reason. I will absolutely find some time later today to check what you requested, if something else that requires to use the same monitor comes to your mind let me know, otherwise I will have to redo all the tests with a new monitor in my next office.

I did the test you requested: boot in text mode, plug the VGA cable in, run startx. Gnome is started at a lower resolution than ordinary, indicating that the display has been correctly autodetected, and the monitor says "out of scan range". I attach the X server log, and the output from intel_reg_dumper and xrandr.

Created an attachment (id=23325)
X server log with modedebug on

Created an attachment (id=23326)
Dump

Created an attachment (id=23327)
output from xrandr

I forgot to reply to comment #57, I tried xrandr --output VGA --off, and then xrandr --output VGA --mode 0x5c, but the effect is exactly the same.

I believe I am also seeing this issue, I am only able to use an external monitor when the VGA adapter is plugged in at boot time.

I am running ubuntu jaunty
Module intel: vendor="X.Org Foundation"
        compiled for 1.5.99.902, module version = 2.6.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 5.0

My laptop is a Toshiba dynabook SS RX1/T7E, which is equivalent to the Portege R500 I believe.

I am able to perform some testing with an external monitor later this week if you are able to tell me what versions of code I should be running and what logs you wish to see.

Any news on this issue?

Andrew Ash (ash211) on 2009-05-08
tags: added: tv-out

Bryce, we are using high priority bug as blocking release. this bug is specific to the model of laptop, so won't be P1 to us. We are currently out of idea. will look at this after Q2 release. thanks.

If having access to the hardware would help to solve this bug and #16777 which appears to be related (very similar problem, same hardware), I'd be willing to mail you my M400 laptop and docking station. I'd wipe the drive before sending it to you, so you could install whatever tools were needed without having to worry about preserving the data.

Thanks,
Hugh

(In reply to comment #69)
> If having access to the hardware would help to solve this bug and #16777 which
> appears to be related (very similar problem, same hardware), I'd be willing to
> mail you my M400 laptop and docking station. I'd wipe the drive before sending
> it to you, so you could install whatever tools were needed without having to
> worry about preserving the data.
>
> Thanks,
> Hugh
>

thanks for your offering, Hugh. In fact, we have bought a M400 for this bug.. that's why I said we still remember this bug , but just out of idea for now. Given currently we are at the last minute of Q2 release, we will come back to this bug after the release is done.. sorry about the delay and really appreciated your report.

Changed in xorg-server:
status: In Progress → Confirmed
gerbalblaste (gerbalblaste) wrote :

I resolved this Issue was resolved by updating xserver-xorg-video-intel to latest from xorg-edgers starting a session in gnome-failsafe.

Changed in xorg-server:
status: Confirmed → In Progress
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] Second display not enabled with "intel" video driver
+ [i945] [i945] Second display not enabled with "intel" video driver
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945] Second display not enabled with "intel" video driver
+ [i945] Second display not enabled with "intel" video driver

On this M400 laptop I found another interesting scenario.
   >The VGA is attached before powering on. After the system is powered on, the system will select the VGA as the primary display device in BIOS phase. Then I use the hotkey of "Fn+F5" to switch the primary display device from VGA to LVDS panel. And after the system is booted, the VGA can't work well, neither.
    If it can display on both VGA and LVDS in BIOS phase, the VGA monitor can work well as expected.

Thanks.

On the M400 I also found another test case besides the case in comment #71. It is described in the following:
   No external monitor is attached when powering on. I press the hotkey of Fn+F5 before loading the kernel. Then after the system is booted, the external monitor can be detected correctly and work well.

   From the above test cases it seems that the system behaviour can be changed if the hotkey of "Fn + F5" is pressed before loading the linux kernel.

Thanks.
   Yakui

Michael, since you guys have the M400, can you find someone to work on this one? Maybe the DDC routing changes based on the BIOS boot setting or something?

Changed in xorg-server:
importance: Unknown → High
Changed in xorg-server:
importance: High → Unknown
Changed in xorg-server:
importance: Unknown → High

Please provide a update on the progress towards a fix on this issue, (If possible).

Have a blessed day,

Carl

2 comments hidden view all 117 comments

So, is this bug still active or it was fixed meanwhile?

reassign to Nanhai for triage.

Changed in xorg-server:
status: In Progress → Confirmed
2 comments hidden view all 117 comments
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu Hardy):
status: New → Confirmed

Also affects Ubuntu 12.04:

I have a Intel GM965 integrated video card and SVGA out is not working. It does work with 10.04, all subsequent versions it no longer works.

The TV is detected, I can see the screen flicker while it is being detected, and I can move the mouse to it, but the TV screen is black.

stefan@stefan-Extensa-5220:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [IDE mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
04:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
0f:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0f:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
0f:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0f:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller

stefan@stefan-Extensa-5220:~$ xrandr
Screen 0: minimum 320 x 200, current 2080 x 800, maximum 8192 x 8192
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
1280x800 60.0*+
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)
TV1 connected 800x600+1280+0 (normal left inverted right x axis y axis) 0mm x 0mm
848x480 30.0 +
640x480 30.0 +
1024x768 30.0
800x600 30.0*

Stefan

Changed in xserver-xorg-video-intel (Ubuntu):
status: In Progress → New
2 comments hidden view all 117 comments
Evan Peck (colors) wrote :

Since this bug is still an issue in Precis AND multiple people are affected,
I will marked confirmed.

Thank you!

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
5 comments hidden view all 117 comments

Marking as NEEDINFO to refresh the current status of this bug.

4 comments hidden view all 117 comments
Bryce Harrington (bryce) wrote :

If anyone is still reproducing this problem, please post a dmesg and /var/log/Xorg.0.log to the upstream bug report, and an explanation of what you're experiencing.

(Or, post it here to this bug in launchpad by just replying to this email, and a triager can copy the info up to the upstream bug.)

Issue still present in 12.04. Attached dmesg and xorg.0.log

Problem is that when I connect SVGA-out cable to laptop and TV, the screen stays black. I can see it flicker when it tries to detect it, the system can see the tv but there is no image on the TV.

(tv is detected as 848x480)

and xorg.0.log attached

3 comments hidden view all 117 comments

Timeout. Please do reopen if you can still reproduce the issue and help us diagnose the problem, thanks.

From reading the last several comments it looks like Intel was going to re-test on their M400 but so far there's no indications anyone has confirmed it fixed, so I think this got closed out too quickly. The downstream bug shows one user still reproducing the bug in precise as of June (dmesg and Xorg.0.log on that bug if interested).

3 comments hidden view all 117 comments
Bryce Harrington (bryce) wrote :

Hi Raylene, thanks for indicating you are reproducing this problem back in June. A few months have passed (and several kernel updates) since then; are you still seeing the bug in precise?

If at all possible, I'd encourage you to join the discussion on the upstream bug report for this issue:
https://bugs.freedesktop.org/show_bug.cgi?id=16702

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Changed in xserver-xorg-video-intel (Ubuntu Hardy):
status: Confirmed → Won't Fix
4 comments hidden view all 117 comments

Needinfo again, we need someone to actually test this on the latest kernels ...

3 comments hidden view all 117 comments

Hi Bryce,

In Precise the issue seems to be resolved, as well as in Quantal. I can
attach my TV through my S-Video cable, and it works excellent. I do not
have to reboot anymore, it works right away!

Best regards

On 12-10-22 03:06 PM, Bryce Harrington wrote:
> Hi Raylene, thanks for indicating you are reproducing this problem back
> in June. A few months have passed (and several kernel updates) since
> then; are you still seeing the bug in precise?
>
> If at all possible, I'd encourage you to join the discussion on the upstream bug report for this issue:
> https://bugs.freedesktop.org/show_bug.cgi?id=16702
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Confirmed => Incomplete
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu Hardy)
> Status: Confirmed => Won't Fix
>

Changed in xorg-server:
status: Confirmed → Incomplete
4 comments hidden view all 117 comments

Looks like at least one reporter said this was fixed in the LP bug.

Changed in xorg-server:
status: Incomplete → Fix Released
Bryce Harrington (bryce) on 2012-12-21
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
Displaying first 40 and last 40 comments. View all 117 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.