[XPS M1330] HDMI port being configured instead of LCD

Bug #135169 reported by Roger Noriega on 2007-08-27
36
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Dell XPS 1330 with Gutsy Tribe5: When X comes up the taskbars do not extend to the end of the display. I guess this is caused by the HDMI port, it appears Gutsy is configuring the HDMI port at 1024x768 instead of the LCD at 1280x800. Typing "xrandr --output TV --off" works around the issue on the fly no need to restart X.

dell@dell-laptop:~$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right)
LVDS connected 1280x800+0+0 (normal left inverted right) 287mm x 180mm
   1280x800 60.0*+ 60.0
   1280x768 60.0
   1024x768 60.0
   800x600 60.3
   640x480 59.9
TMDS-1 disconnected (normal left inverted right)
TV connected (normal left inverted right)
   1024x768 30.0
   800x600 30.0
   848x480 30.0

Roger Noriega (rnoriega) wrote :

See attached screenshot

Changed in dell:
importance: Undecided → Medium
status: New → Confirmed

Installing Gutsy 9/21 image displays taskbars extended to the end of the screen, but max resolution is 1024 x 768. Output of "xrandr":

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1280 x 1280
VGA disconnected (normal left inverted right)
LVDS connected 1024x768+0+0 (normal left inverted right) 287mm x 180mm
   1024x768 60.0*+
   1280x800 60.0 + 60.0
   1280x768 60.0
   800x600 60.3
   640x480 59.9
TMDS-1 disconnected (normal left inverted right)
TV connected 1024x768+0+0 (normal left inverted right) 0mm x 0mm
   1024x768 30.0*+
   800x600 30.0
   848x480 30.0
   640x480 30.0

Running "xrandr --output TV --off" allows me to change resolution to 1280x1024 (native resolution on XPS 1330).

Video card information:

$ lspci -vnnn -d 8086:2a02

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller [8086:2a02] (rev 0c) (prog-if 00 [VGA])
 Subsystem: Dell Unknown device [1028:0209]
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fea00000 (64-bit, non-prefetchable) [size=1M]
 Memory at e0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at eff8 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
 Capabilities: [d0] Power Management version 3

Gotta have this working without workaround.

Changed in dell:
importance: Medium → High
Bryce Harrington (bryce) wrote :

Perhaps try this?

Section "Monitor"
       Identifier "TV"
       Option "Ignore" "True"
EndSection

Section "Device"
       Identifier "MonitorTV"
       Option "monitor-TV" "TV"
EndSection

Bryce:

Your suggestion did not work. I get a black screen. Attaching /var/log/Xorg.0.log

Bryce Harrington (bryce) wrote :

Attach your xorg.conf and lspci -vvnn as well. (You should always include these when reporting bugs.)

Bryce:

Here's my xorg.conf

And here's the output of lspci -vvnn

Timo Aaltonen (tjaalton) wrote :

should this be taken upstream? It's marked as private though..

Timo Aaltonen (tjaalton) wrote :

also, this is the same as bug #136783, but it's with intel.

Kyle McMartin (kyle) wrote :

http://people.ubuntu.com/~kyle/xserver-xorg-video-intel_2.1.1-0ubuntu3_i386.deb

Hi Jose, can you please test this package for me? It should provide the fix you require.

The reason the panel is mis-sized, is, exactly as you point out, because the TV defaulted to cloning the primary display, and gnome-panel only grows to the size of the smallest display (so you can see the whole of it when it's cloned across several resolutions.)

Cheers,
  Kyle McMartin

Kyle,

This deb worked for me. I installed it and ran 'dpkg-reconfigure xserver-xorg', started gdm, and I got the native resolution 1280 x 800, which I had not been able to get before.

Kyle,

It appears that my HDMI port is disabled, not even recognized. How do I enable it in case I want to use it?

Here's the output from 'xrandr":

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right)
LVDS connected 1280x800+0+0 (normal left inverted right) 287mm x 180mm
   1280x800 60.0*+ 60.0
   1280x768 60.0
   1024x768 60.0
   800x600 60.3
   640x480 59.9
TMDS-1 disconnected (normal left inverted right)

Attached is my latest /etc/X11/xorg.conf

Tim Gardner (timg-tpi) wrote :

Kyle uploaded to archive and pushed upstream.

Changed in xorg:
assignee: nobody → timg-tpi
importance: Undecided → High
status: New → Fix Committed
Kyle McMartin (kyle) wrote :

Hi Jose,

Thanks for testing, I'm glad it fixed your panel sizing issues.

Two things -- "TV out" is a bit of a misnomer. It means the SVideo/analog style TVout connectors, which as I'm led to believe, the XPS 1330 doesn't have.

The HDMI protocol is very similar to DVI, and as such would be connected to the TMDS-1 transmitter, like any other DVI device would be. I'm not sure if it is actually expected to work in the intel driver at the moment, but you should be able to find out if you mess with the "TMDS-1" port with xrandr.

Sorry I can't be much more help, I don't have a laptop with a HDMI port to mess around with.

Regards,
  Kyle

Tim Gardner (timg-tpi) wrote :

xserver-xorg-video-intel_2.1.1-0ubuntu5

Changed in xserver-xorg-video-intel:
assignee: timg-tpi → nobody
status: Fix Committed → Fix Released
Changed in dell:
status: Confirmed → Fix Released
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305665

no longer affects: somerville

Hi Tim,

I think you may have the wrong notification email address? I haven't ever
had a Dell XPS machine and this bug is unfamiliar to me...

-Dave

On Thu, Apr 10, 2014 at 2:39 AM, Timothy R. Chavez <
<email address hidden>> wrote:

> The bug task for the somerville project has been removed by an automated
> script. This bug has been cloned on that project and is available here:
> https://bugs.launchpad.net/bugs/1305665
>
> ** No longer affects: somerville
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (136783).
> https://bugs.launchpad.net/bugs/135169
>
> Title:
> [XPS M1330] HDMI port being configured instead of LCD
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/135169/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers