not using whole widescreen

Bug #136783 reported by EspenG
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Bryce Harrington

Bug Description

I'm having problems with my widescreen. The resolution and refresh speed and everything works fine, but I can't get gnome to use the whole screen. If I don't do anything everything automatically uses this width: but i manage to "drag" some of the programs wider like this: but as you can see I'cant get the top menu bar as wide as i like. I also get the same problem when watching movies, there is a screenshot of totem: you can see that the image width is exactly as wide as the top menu bar.
If I create a new user I can't drag any window over the "magic border". Also the same problem appears in GDM where I can see a different color on the other side of the "magic line".

OS: Gutsy Gibbon tribe 5
xorg: 1:7.2-5ubuntu7
xserver-xorg: 1:7.2-5ubuntu7
xserver-xorg-core: 2:

Laptop: The new Dell XPS M1330 with the new santa rosa chipset, and a intel video card.
HAL Device Manager says that the product ID of the video card is 10754 or 10755

Hope you can fix this, and if you need any more info please tell me.
Espen Grindhaug

Revision history for this message
Reinhard Tartler (siretart) wrote :

I can confirm this bug on a dell xps m1330.

xrandr working properly and are reporting correct values. no idea why gnome has a different impression of the screen

Revision history for this message
Don Mullis (don.mullis) wrote :

KDE on Kubuntu may offer a clue.
`xrandr` output is:

Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right)
LVDS connected 1280x800+0+0 (normal left inverted right) 287mm x 180mm
   1280x800 60.0*+ 60.0
   1280x768 60.0
   1024x768 60.0
   800x600 60.3
   640x480 59.9
TMDS-1 disconnected (normal left inverted right)
TV connected 1024x768+0+0 (normal left inverted right) 0mm x 0mm
   1024x768 30.0*
   800x600 30.0
   848x480 30.0
   640x480 30.0

But KDE's System_Settings->Monitor&Display GUI offers a choice of sizes 640x480, 848x480, 800x600, or 1024x768.
So KDE is seeing the sizes for TV output, not for the laptop screen (LVDS).

Tried using xrandr to disable the TV output, without success. Anyone know how the TV-output-specific info is getting into

Revision history for this message
Reinhard Tartler (siretart) wrote :

Very good catch. Indeed, the problem is that the external TV device is detected as always being attached. This causes gdm, gnome, etc to use the smaller of the "two: screens.

Disabling the TV output with `xrandr --output TV --off` "solves" the problem.

In order to prevent external TV output to be activated at boot time, the following is necessary to /etc/X11/xorg.conf:

Section "Device"
        Driver "intel"
        Option "monitor-TV" "TV"

Section "Monitor"
        Identifier "TV"
        Option "Ignore" "true"

This hint was taken from

I'd suggest that we make that entry above the default in our xorg.conf, Alternatively, we can perhaps change the xserver-intel driver to not enable the output TV, even presence of a monitor is detected.

Revision history for this message
Reinhard Tartler (siretart) wrote :

Reassigning to ubuntu-x-swat (Is this the correct protocol? - if no, please update

Setting to Triaged, since I propsed 2 solutions how this could be solved.

Revision history for this message
Don Mullis (don.mullis) wrote :

The above change to xorg.conf caused X to fail to start up for me. One more line was necessary:

--- /etc/X11/xorg.conf.dist 2007-09-09 09:57:48.000000000 -0700
+++ /etc/X11/xorg.conf 2007-09-09 10:29:56.000000000 -0700
@@ -75,6 +75,17 @@
        BusID "PCI:0:2:0"

+Section "Device"
+ Identifier "TV"
+ Driver "intel"
+ Option "monitor-TV" "TV"
+Section "Monitor"
+ Identifier "TV"
+ Option "Ignore" "true"
 Section "Monitor"
        Identifier "Generic Monitor"
        Option "DPMS"

Revision history for this message
Henrik Nilsen Omma (henrik) wrote :

Moving milestone to beta.

Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel:
assignee: ubuntu-x-swat → bryceharrington
Revision history for this message
Bryce Harrington (bryce) wrote :

This sounds like 123170, which I believe was fixed when we added the 2.1.1 -intel driver.

Can someone re-test this with xserver-xorg-video-intel-2:2.1.1-0ubuntu3 and let us know if the issue is still there or not?

Revision history for this message
Jose Manuel Romero Ximil (jximil) wrote :

It is still there

Revision history for this message
Guido Conaldi (guido-conaldi) wrote :

It's still there for me as well.
Tested on Gutsy x86_64 with intel GM965 reconfiguring xorg.conf from scratch.

Revision history for this message
Jose Manuel Romero Ximil (jximil) wrote :

2.1.1-0ubuntu4 fixed this problem in my laptop

Revision history for this message
Erik Andrén (erik-andren) wrote :

I still have this issue with the xserver-xorg-video-intel-2.1.1-0ubuntu5

Revision history for this message
Jose Manuel Romero Ximil (jximil) wrote :


Did you reconfigured xorg?

Revision history for this message
Dave LeGendre (dblegend) wrote :

I have this same issue on a Toshiba u305-7446 using the x3100 intel graphics adapter. I'm running xserver-xorg-video-intel-2.1.1-0ubuntu9. Reconfiguring xserver did not fix the problem. I added the lines from Don's 9/9/07 update to my xorg.conf and it is working great.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.