onboard intel g33 graphics not working in feisty/gutsy

Bug #121443 reported by dean on 2007-06-20
12
Affects Status Importance Assigned to Milestone
915resolution (Ubuntu)
Undecided
Kyle McMartin
Feisty
High
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Feisty
High
Tim Gardner

Bug Description

feisty kernel 2.6.20-16-generic
deb package xserver-xorg-video-intel_2.0.0-1ubuntu2.1_i386.deb

lspci:
00:02.0 0300: 8086:29c2 (rev 02) (prog-if 00 [VGA])
 Subsystem: 1028:020d
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 5
 Region 0: Memory at fdf00000 (32-bit, non-prefetchable) [size=512K]
 Region 1: I/O ports at ff00 [size=8]
 Region 2: Memory at d0000000 (32-bit, prefetchable) [size=256M]
 Region 3: Memory at fdb00000 (32-bit, non-prefetchable) [size=1M]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [d0] Power Management version 2
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-

dean (dean-oliver) wrote :

attatched Xorg log..

dean (dean-oliver) wrote :

this has been confirmed fixed by compiling new intel driver and agpgart.
attached is 2 patches prepared by Jordan to fix this..

dean (dean-oliver) wrote :
dean (dean-oliver) wrote :

This is only 2d driver working so far, still working the 3d mesa side..

Kyle McMartin (kyle) wrote :

Hi, I've already got all this ready to upload...

dean (dean-oliver) wrote :

do you also have the mesa 3d driver ?

Kyle McMartin (kyle) wrote :

mesa has been uploaded to feisty-proposed (6.5.2 +backports) and gutsy (7.0.0 +backports from HEAD).

Roger Noriega (rnoriega) wrote :

what is the version of the new linux-backports package that contains this ?
Have not seen any changes yet on feisty-proposed repository

dean (dean-oliver) wrote :

This is to clarify that as of 07-12... the 2D driver still does not work for 530n..
We need clarification on when the 2d driver will be available, and the 3d mesa driver availability..

Kyle McMartin (kyle) on 2007-07-13
Changed in xorg:
status: New → Fix Released
status: New → Triaged
assignee: nobody → kyle
importance: Undecided → High
Kyle McMartin (kyle) on 2007-07-13
Changed in 915resolution:
assignee: nobody → kyle
status: New → Fix Released
assignee: nobody → kyle
importance: Undecided → High
status: New → In Progress
Martin Pitt (pitti) wrote :

Accepted into feisty-proposed, please go ahead with QA testing.

Changed in 915resolution:
status: In Progress → Fix Committed
Tim Gardner (timg-tpi) wrote :

G33 2-D support requires a new kernel with AGP/DRM support as well as an update xserver-xorg-intel package. Please test using the following commands:

wget http://people.ubuntu.com/~rtg/inspiron-530/kernel-package_10.065ubuntu6_all.deb
wget http://people.ubuntu.com/~rtg/inspiron-530/linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb
wget http://people.ubuntu.com/~rtg/inspiron-530/xserver-xorg-video-intel_1.9.94-1ubuntu4_i386.deb
sudo dpkg -i kernel-package_10.065ubuntu6_all.deb
sudo dpkg -i linux-image-2.6.20-16-generic_2.6.20-16.30_i386.deb
sudo dpkg -i xserver-xorg-video-intel_1.9.94-1ubuntu4_i386.deb
sudo reboot

# enable feisty-proposed
sudo echo "deb http://archive.ubuntu.com/ubuntu/ feisty-proposed main restricted universe multiverse" >> /etc/apt/sources.list
sudo apt-get update
sudo apt-get install 915resolution

Tim Gardner (timg-tpi) wrote :

Martin, Will you sponsor this upload? Kyle has checked it out and given his blessing.

dget http://people.ubuntu.com/~rtg/inspiron-530/xserver-xorg-video-intel_1.9.94-1ubuntu4.dsc

Tim Gardner (timg-tpi) wrote :

Forgot to attach the package diff.

Martin Pitt (pitti) wrote :

Add missing debdiff for feisty-proposed.

Martin Pitt (pitti) wrote :

I uploaded Tim's xserver-xorg-video-intel package and accepted it into feisty-proposed. Please test.

Can anyone please test the previous SRU in that bug for 915resolution?

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Committed
Sam Morris (yrro) wrote :

Is there an amd64 version of that kernel available anywhere? :)

Saivann Carignan (oxmosys) wrote :

I installed and tried the new intel xorg driver with a g33 Intel card and there's a serious resolution problem.

After a X restart, I'm on the welcome screen which is shadowed and at a HIGH HIGH resolution, too high for the card itself. There's no solution to force the resolution in the xorg.conf. I still can change the resolution in System / Preference, but this only works for the actual user session.

The 3d works great and it's possible to start Compiz without any problems.

Shadowtester (shadowtester) wrote :

I have to agree there are problems with the resolutions their are several resolutions which are not available for the driver which I know the chip set supports such as 1280x1024 as an example. On my system its defaulting to 1280x768 which is not supported by my monitor since its a 4x3 not widescreen. I have to manually change the resolution after each restart of reboot.

Saivann Carignan (oxmosys) wrote :

I have to notive it, the actual xorg driver had a serious resolution problem, but changing the screen did fix the problem.

Seems that it was a resolution detection problem rather than a intel driver problem.

Seems to work with Gutsy tribe-5 plus latest updates. 3D effects work.

Changed in dell:
importance: Undecided → Medium
status: New → Fix Released
Martin Pitt (pitti) wrote :

This is sitting in feisty-proposed for over three months now. Is it still an issue? If not, I'll remove the -proposed versions.

Tim Gardner (timg-tpi) wrote :

Martin - please do remove -proposed. I believe this package works.

Martin Pitt (pitti) wrote :

I removed those due to obsolescence then:

xserver-xorg-video-intel | 2:1.9.94-1ubuntu4 | feisty-proposed/universe | source, amd64, i386, ia64, powerpc
915resolution | 0.5.2-10ubuntu2 | feisty-proposed/universe | source, amd64, i386

Tim, thanks for the followup.

Changed in 915resolution:
status: Fix Committed → Won't Fix
Changed in xserver-xorg-video-intel:
status: Fix Committed → Won't Fix
Tim Gardner (timg-tpi) wrote :

Martin - oops. What I meant was that the package in -proposed is the correct one, e.g., it fixes the resolution issues.

Martin Pitt (pitti) wrote :

Tim: urgh, sorry then. I'll rescue them tomorrow (I need to run now). Can you please add a "TEST CASE:" to the description?

Martin Pitt (pitti) wrote :

I did no-change uploads of 915resolution and -intel into feisty-proposed, so that they reappear. Please give this some testing and report back here for verification.

Changed in 915resolution:
assignee: kyle → timg-tpi
status: Won't Fix → Fix Committed
Changed in xserver-xorg-video-intel:
assignee: kyle → timg-tpi
status: Won't Fix → Fix Committed
Tim Gardner (timg-tpi) on 2007-12-10
Changed in 915resolution:
assignee: timg-tpi → nobody
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Tim, these packages are only in feisty-proposed, not -updates. They need to be tested, then we move them to -updates and close the bug.

Changed in 915resolution:
status: Fix Released → Fix Committed
Changed in xserver-xorg-video-intel:
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Tim, any news wrt. testing these versions in feisty-proposed? Nobody seems to care about them in this bug, so if they are not necessary, I'll delete them from -proposed again. Thanks!

Tim Gardner (timg-tpi) wrote :

Martin, the drivers in feisty-proposed are the ones that Dell ships on their recovery CD. I have this video hardware in an Inspiron 530, but am having a hard time getting the time to restore it to Feisty in order to test it. I'll get it on my todo list...

Hi Tim,

Tim Gardner [2008-01-09 14:14 -0000]:
> Martin, the drivers in feisty-proposed are the ones that Dell ships on
> their recovery CD. I have this video hardware in an Inspiron 530, but am
> having a hard time getting the time to restore it to Feisty in order to
> test it. I'll get it on my todo list...

I see, I wasn't aware of that. I guess that qualifies as verification.
:)

Martin Pitt (pitti) wrote :

Copied to feisty-updates.

Changed in 915resolution:
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released

I have had the same too-high resolution problem for a very long time.
I stumbled upon a way to fix the problem:

1. Edit 'xorg.conf' (most probably '/etc/X11/xorg.conf').
2. Check Section "Monitor".
(If the fields 'HorizSync' and 'VertRefresh' are not present - which, by default, they are not - you can add them manually.)
Try:
- DECREASING the MAXIMUM value of HorizSync.
- INCREASING the MINIMUM value of VertRefresh.

Explanation:
- By dropping the maximum value of HorizSync, we will restrict the maximum supported resolution. Xorg will drop down to a lower resolution.
- By raising the minimum value of VertRefresh, Xorg will find that the default too-high resolution is impossible at our specified minimum refresh rate. Xorg will drop down to a lower resolution.

By tweaking both HorizSync and VertRefresh independently of each other, you should be able to get your preferred resolution and refresh rate with a little trial-and-error.

p.s.
Regarding this section:
Section "Screen"
       SubSection "Display"

Any modes (resolutions) specified here do not seem to have any effect.
Only the DefaultDepth option works - this might be useful in case you wish to use a non-default color depth (e.g. 16-bit).

p.p.s.
Hope this helps!
Any questions are most welcome.

Wout van Gelder (wout) on 2009-11-06
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → New
status: New → Fix Released
Changed in somerville:
importance: Undecided → Medium
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306190

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers