White boxes instead of shadows on Intel 945 (-intel driver)

Bug #116808 reported by Scott James Remnant (Canonical)
52
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned
Gutsy
Medium
Unassigned

Bug Description

Binary package hint: compiz

Instead of shadows around items, I see a white box.

This is on an Intel 945 graphics chip with the -intel driver (our preferred vendor!)

This regressed with the 0.5.0 packages, the previous packages in gutsy were fine.

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

(High: composite-by-default blocker)

Changed in compiz:
importance: Undecided → High
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

(after discussion, upgrading all composite-by-default problems to Critical, since these must be closed for gutsy)

Changed in compiz:
importance: High → Critical
Revision history for this message
David McBride (david-mcbride) wrote :

Also observing here, new bug as of 0.5.0 packages on Intel GMA945.

This appears like it may be a problem with gtk-window-decorator; ~/.xsession-errors is indicating the following:

***MEMORY-WARNING***: gtk-window-decorator[29262]: GSlice: g_thread_init() must be called before all other GLib functions; memory corruption due to late invocation of g_thread_init() has been detected; this program is likely to crash, leak or unexpectedly abort soon...

(Perhaps bizarrely, there are other similar warnings for other GTK-using tools, such as gnome-terminal.)

Cheers,
David

Revision history for this message
Travis Watkins (amaranth) wrote :

This is actually a bug in the driver. We can work around it again and again in compiz but it'd be best to get it fixed for real.

Revision history for this message
Juan Pablo Salazar Bertín (snifer) wrote :

I can confirm this, using Intel 945 in a Dell Inspiron 9400 laptop + Gutsy Tribe 1.

To get compiz enabled, I have to load it using compiz --replace ini (to bypass bug #119199).
After that, I see a white box around some items instead of shadows.

Changed in xserver-xorg-video-intel:
status: Unconfirmed → Confirmed
Revision history for this message
Juan Pablo Salazar Bertín (snifer) wrote :

After some recent compiz update (currently using 1:0.5.0+git20070612-0ubuntu1), it looks like it has been "worked around" in gutsy.
I think this bug should be left open until it's fixed in the driver.

Revision history for this message
Antonio Barba (thekaneb) wrote :

The same bug occurred to me with Intel GMA915 and i810 driver... white boxes instead of shadows. Because the driver isn't the same, I suppose that something went wrong with Aiglx.

Revision history for this message
Travis Watkins (amaranth) wrote :

Lowering importance since we work around it in compiz.

Changed in xserver-xorg-video-intel:
importance: Critical → Medium
Revision history for this message
ThomasGillespie (tomjamesgillespie) wrote :

Still isnt fixed with the kde-window-decorator

Revision history for this message
Daniel Ranger (dranger003) wrote :

Problem not present with gtk-window-decorator but kde-window-decorator is showing the problem...
Any ideas?

I added !dock twice to the Window Decoration plugin under the Shadows option as a workaround for now.

DELL Latitude D430
Intel 945GM

Revision history for this message
Joseph Smidt (jsmidt) wrote :

I can confirm this bug. I have the same issue during a Gnome session. Also, it still doesn't work after the latest compiz update FYI on Sept. 13.

Revision history for this message
Joseph Smidt (jsmidt) wrote :

The last set of updates seem to fix this for me. Thanks.

Revision history for this message
Anders K. Madsen (madsen-lillesvin) wrote :

Problem still remains in the current Gutsy (just dist-upgraded from Feisty a moment ago).
In Gnome I get white boxes around panels and menus instead of shadows. Shadows on windows appear to work just fine though.

I'm on a MacBook Core 2 Duo
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Tell me if there's more info I can supply to help.

Revision history for this message
brage (osoi) wrote :

I am experiencing the white boxes as well on a fully updated Gutsy. But I have a ATI graphics card.

My device section from xorg.conf (if that helps):

 Identifier "ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]"

 Boardname "ati"

 Busid "PCI:1:0:0"

 Driver "ati"

 Screen 0

 Option "MergedFB" "off"

Revision history for this message
Anders K. Madsen (madsen-lillesvin) wrote :

Hmm, turns out the white boxes disappear if I increase the shadow radius to >= 8.5. Don't know if that'll do the trick for any of you.

Revision history for this message
Anders K. Madsen (madsen-lillesvin) wrote :

Btw, that's in CCSM (CompizConfig Settings Manager) > Window Decorations > Shadow Radius.

Revision history for this message
Robert Pickle (rpickle) wrote :

increasing the shadow radius > 8.5 works for me, on both my PCs (ati, intel chipsets). strange.

Revision history for this message
Evandro Fernandes Giovanini (evandrofg) wrote :

I have this bug on a GMA950 card with compiz 0.5.2+git20070918-0ubuntu4 with the latest gutsy updates (on a fresh install from 20070921.1 daily-live). The workaround mentioned by Anders fixes it here as well.

Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
Revision history for this message
Adriaan Peeters (apeeters) wrote :

The >= 8.5 workaround fixes it for me on a Dell Latitude D505 (00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02))

Maybe as a temporary fix: use at least 8.5 as default?

Revision history for this message
Travis Watkins (amaranth) wrote :

We use 9.0 already.

Changed in compiz:
status: New → Fix Released
Bryce Harrington (bryce)
Changed in xserver-xorg-video-intel:
assignee: bryceharrington → nobody
Revision history for this message
Joachim Frieben (jfrieben) wrote :

For a fully updated Gutsy system as of 2007-10-15, I still have these artifacts [see attached screenshot]. The graphics device is an onboard "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 03)".

Revision history for this message
Travis Watkins (amaranth) wrote :

gconftool-2 --recursive-unset /apps/compiz

Revision history for this message
Bryce Harrington (bryce) wrote :

I wonder if this is at all related to bug 175774 (badly drawn window shadows on 965GM). Can you test if the fix for that applies here as well?

Test this by launching X in hardy configured to use EXA and the "greedy" migration heuristic. For example:

Section "Device"
  ....
        Driver "intel"
        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
  ....
EndSection

If this solves the issue, then we should extend the fix for bug 177492 to cover this chipset as well.

Revision history for this message
Travis Watkins (amaranth) wrote :

I doubt it, if I remember correctly Mirco said this has something to do with the shadow size being a power of two and the driver and the X server not agreeing on whether it was a power of two texture or a non power of two texture.

Revision history for this message
Bryce Harrington (bryce) wrote :

Travis, okay - do you or Mirco have a recommendation for what to do to fix this in the driver?

I would still like to see if the greedy option addresses this bug or not, because that seems to be using a very different rendering approach, and I'm considering making that the default for all Intel chips in Hardy.

Revision history for this message
Bryce Harrington (bryce) wrote :

Ran across this old bug... we ended up switching greedy on by default, and since there's been no comments since my last one, I'm guessing this no longer affects anyone. If I'm wrong and it still occurs with Intrepid, please feel free to reopen. (A fresh Xorg.0.log and lspci -vvnn output would be nice to include.)

Changed in xserver-xorg-video-intel:
status: Confirmed → Won't Fix
status: Confirmed → Fix Released
Revision history for this message
JZ (jz-45) wrote :

I'm having this issue in Oneiric. White boxes keep appearing around my popup menus. In 11.04 I used to be able to change the Shadow Radius to fix the issue, but that doesn't appear to be the case anymore.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers