visual glitch in Evolution's importance button, etc.

Bug #1157458 reported by Benjamin Drung on 2013-03-19
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
High
Canonical X.org

Bug Description

I can see visual glitches from time to time. For example, there are glitches over the importance sign in Evolution from time to time (screenshot attached). The context menu of libreoffice gets corrupted from time to time.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xserver-xorg-video-intel 2:2.21.4-0ubuntu1b1
ProcVersionSignature: Ubuntu 3.8.0-13.22-generic 3.8.3
Uname: Linux 3.8.0-13-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.9.2-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Tue Mar 19 23:27:07 2013
DistUpgraded: 2013-02-25 14:36:53,923 DEBUG enabling apt cron job
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.2.8, 3.8.0-13-generic, x86_64: installed
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-13-generic root=UUID=8f4d45c4-a452-475a-9e84-6248a0467e4f ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: Upgraded to raring on 2013-02-25 (22 days ago)
dmi.bios.date: 08/20/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3806
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P8H67-M PRO
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3806:bd08/20/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP8H67-MPRO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.9~daily13.03.08-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.42-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.3-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.3-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu2b1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1b1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.4-0ubuntu1b1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3b1
xserver.bootTime: Tue Mar 19 21:50:51 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.3-0ubuntu2b1
xserver.video_driver: intel

Benjamin Drung (bdrung) wrote :
Benjamin Drung (bdrung) wrote :

Another screenshot with a glitch.

Chris Wilson (ickle) wrote :

Those glitches look like different causes. Can you grab a few more to see if the patterns are consistent - also note if any glitch is not apparent in a screenshot.

Do you experience any GPU hangs? As they can also cause similar corruption.

Can you estimate the rough frequency of the hangs? Do they become more frequent with time? Are they a recent regression?

You can try xorg-edgers, but there will be a 2.21.5 soon with some compiler fixes that might just account for this.

b3nmore (b3nmore) wrote :

I get glitches too on a freshly installed Xubuntu 13.04beta1 (view attachment). However in my case it's somehow correlated with the compositor (xfwm4), which must be switched on to get the artifacts. I don't have gpu hangups.
kernel : 3.8.0-13.23
intel driver: 2.21.4

Benjamin Drung (bdrung) wrote :

I saw the glich in the importance sign in Evolution several times and the glitch looked similar every time, but I don't know how to trigger it. I don't see that many different gliches any more besides the mentioned ones here in the bug report. I will report back if I stumble over other ones.

The glichtes that I tried to catch in a screenshot appear in it. Does that mean that the bug lies somewhere above the driver, because it can be catched in a screenshot?

GPU hangs freeze the desktop for several second or need the X server rebooted, right? Then I don't experience GPU hangs.

Benjamin Drung (bdrung) wrote :

The menu entry that is below the cursor is not highlighted in all libreoffice applications (screenshot attached). Is this related to this bug or is this just a bug in libreoffice?

Chris Wilson (ickle) wrote :

The relevence of whether it is captured in a screenshot is that it gives a clue as to whereabout in the driver it fails - or rather it rules out several potential candidates. A GPU hang will indeed be first noticed by a stutter and be recorded in the kernel log - on your system, it should not require a reboot except in exceptional circumstances.

Not sure about the libreoffice glitch, that I would say is more likely to be a gui issue rather than driver, but you already have too many weirds things happening that one more wouldn't surprise me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Benjamin Drung (bdrung) wrote :

Now I got a GPU hang (while playing a HTML5 video on Youtube) and I had to relaunch Unity to recover from it. apport-gtk told me that this GPU hang is a duplicate of bug #1041790.

I saw the glitches over the importance sign in Evolution several times today after switching from one application to Evolution.

Adolfo Jayme (fitojb) wrote :

@bdrung: the issue of LibreOffice menus not highlighting on mouse hover is LP: #1153350.

Bryce Harrington (bryce) on 2013-04-04
summary: - visual glitch
+ visual glitch in Evolution's importance button, etc.
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Bryce Harrington (bryce) on 2013-04-08
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Canonical X.org (canonical-x)
Chris Wilson (ickle) wrote :

I have lots of very unlikely suspects. The biggest question is why is the corruption appearing on only a very small number of machines (1)?

Can you please track the latest gfx drivers from ppa:xorg-edgers and drm-intel-nightly kernel from ppa:mainline?

Benjamin Drung (bdrung) wrote :

Hm, xserver-xorg-video-intel from ppa:xorg-edgers failed to build from source.

Chris Wilson (ickle) wrote :

The package has been updated for the build failure (and I've fixed the breakage upstream).

Benjamin Drung (bdrung) wrote :

I updated the xserver-xorg-video-intel and DRM packages to their ppa:xorg-edgers versions and installed the 3.9.0-994.201304110406 kernel from drm-intel-nightly.

When booting the drm-intel-nightly kernel, the mouse does not work (cursor will not move) and the screen corrupts when switching to a tty. So this drm-intel-nightly kernel is totally unusable. When booting the raring kernel, everything seems to work so far. I will continue using the ppa:xorg-edgers packages and see if I still experience visual gliches.

Chris Wilson (ickle) wrote :

Sounds like the update to xorg-edgers triggered a fallback to vesa; something broke in the installation. I've landed a couple of patches which I think are going to be related, so if you can verify you have a working setup with ppa:xorg-edgers that would be great.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Benjamin Drung (bdrung) wrote :

I have installed all updates from ppa:xorg-edgers [1]. The mouse and everything else is working like it should.

I see no visual glitches, yet. I will continue to use the system and will report back if I experince a glich again. Assume that the gliches are gone otherwise.

[1] These updates include:
mesa 9.2.0~git20130612.adf324ad-0ubuntu0sarvatt~raring
xorg-server 2:1.13.4~git20130508+server-1.13-branch.10c42f57-0ubuntu0ricotz~raring
xserver-xorg-video-intel 2:2.21.9+git20130612.1f180b89-0ubuntu0sarvatt~raring

Benjamin Drung (bdrung) wrote :

BTW, here is a glitch I saw two weeks ago in the Firefox browser.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
Benjamin Drung (bdrung) wrote :

I haven't experince the glitch in Evolution with ppa:xorg-edgers, but I experience glitches in the slide pane in LibreOffice (screenshot attached).

Benjamin Drung (bdrung) wrote :

I installed linux-image-3.10.0-994-generic_3.10.0-994.201306140422_amd64 (+ headers) from drm-intel-nightly, but the LibreOffice glitches are still there.

Chris Wilson (ickle) wrote :

Can you explain how to trigger that libreoffice glitch? Looks like that should be quite reproducible in comparison to the ff glitches (which I haven't yet been subjected to).

Benjamin Drung (bdrung) wrote :

I open a presentation (that contains multiple slides) with Impress and scroll in the slide pane with my mouse wheel. In some cases I see glitches in the slide pane by just opening a presentation.

Benjamin Drung (bdrung) wrote :
  • test.odp Edit (12.1 KiB, application/vnd.oasis.opendocument.presentation)

Here is an example presentation that can trigger glitches by opening it.

Benjamin Drung (bdrung) wrote :

Here is one screenshot of a glitch produced by the example presentation.

Benjamin Drung (bdrung) wrote :

Here is another screenshot.

Benjamin Drung (bdrung) wrote :

I saw the visual glitch in Evolution (screenshot in comment #1) again (with the setup described in comment #16 and #19).

Chris Wilson (ickle) wrote :

commit 22fd5ca947b58901927d100d2b1aa0f1672b3435
Author: Chris Wilson <email address hidden>
Date: Fri Jun 28 16:54:08 2013 +0100

    drm/i915: Only clear write-domains after a successful wait-seqno

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Committed
Benjamin Drung (bdrung) wrote :

I grabbed the linux 3.8.0-25.37 source tarball, applied the patch mentioned in comment #26, built and installed the package. I still do see the glitch in Evolution with this patch applied.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Triaged
Benjamin Drung (bdrung) wrote :

Therefore the patch is not sufficient.

Chris Wilson (ickle) wrote :

And just to check, you have an xserver-xorg-video-intel from today?

Benjamin Drung (bdrung) wrote :

I have tested it with xserver-xorg-video-intel from raring and version 2.21.10+git20130627.60d716b5-0ubuntu0sarvatt~raring from ppa:xorg-edgers. I experience glitches with both versions.

Chris Wilson (ickle) wrote :

That package was slightly older than one patch I had in mind. I can be optimistic!

Do the errors continue to take the same form?

Benjamin Drung (bdrung) wrote :

The errors have the same form. I tested xserver-xorg-video-intel 2.21.11+git20130701.7d916398-0ubuntu0sarvatt~raring, which showed the same glitches, too.

Chris Wilson (ickle) wrote :

Hmm, could this also be:

Author: Chris Wilson <email address hidden>
Date: Wed Oct 2 14:59:11 2013 +0100

    sna: Only delete unused io buffers

    Before deleting the io buffer, we need to check that it is not active.
    Currently we check that it is not pending use in the current batch, but
    we also need to double check that it does not have outstanding use by
    the GPU. Failing to do so could mean overwriting the data prior to it
    being read by the GPU, a very small race but often hit!

    Reported-by: Vedran Rodic <email address hidden> # and many others
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=66990
    Signed-off-by: Chris Wilson <email address hidden>

Chris Wilson (ickle) on 2013-10-06
Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.904-0ubuntu1

---------------
xserver-xorg-video-intel (2:2.99.904-0ubuntu1) saucy; urgency=low

  * Merge from unreleased debian git
    - new release candidate (LP: #1218839, #1157458, #1216252, #1232546)
  * xmir.patch: refreshed.
 -- Timo Aaltonen <email address hidden> Wed, 09 Oct 2013 19:40:51 +0300

Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.