SRU: xserver-xorg-video-geode 2.11.12-1 to Lucid and Maverick

Bug #625280 reported by Martin-Éric Racine on 2010-08-27
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xserver-xorg-video-geode (Ubuntu)
High
Chris Halse Rogers
Hardy
High
Unassigned
Jaunty
High
Unassigned
Karmic
High
Unassigned
Lucid
High
shevana7
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-geode

Advanced Micro Devices recently assigned two engineers to maintain the code of xf86-video-geode and the first tangible result of this was the recent release of version 2.11.9 of the driver, which fixes several rendering issues and code base regressions. Also, as a byproduct of fixing one rendering issue, the performance of the driver was greatly enhanced.

Some of the bugs closed by this release were found via the upstream Free Desktop Bugzilla, while others were found in distribution-specific bug trackers at Debian, Fedora and Ubuntu. Other issues still were discovered and fixed in the process of fixing those aforementioned bugs. More details can be found in the upstream ChangeLog.

Thus, it would be desirable to push the Maverick 2.11.9-1 version of this package into all currently supported Ubuntu releases.

Test packages have already been built via my PPA. Building for Intrepid, Jaunty, Karmic and Lucid requires no modification.

Meanwhile, building for Hardy requires minor adjustments to Build-Depends and debian/rules. Comparing the Hardy and Lucid versions of the 2.11.9-1 package in my PPA shows how small the difference in packaging is.

Changed in xserver-xorg-video-geode (Ubuntu):
importance: Undecided → High
Changed in xserver-xorg-video-geode (Ubuntu Lucid):
importance: Undecided → High
Changed in xserver-xorg-video-geode (Ubuntu Karmic):
importance: Undecided → High
Changed in xserver-xorg-video-geode (Ubuntu Hardy):
importance: Undecided → High
Changed in xserver-xorg-video-geode (Ubuntu Jaunty):
importance: Undecided → High
Bryce Harrington (bryce) on 2010-08-27
Changed in xserver-xorg-video-geode (Ubuntu):
status: New → Confirmed
Martin-Éric Racine (q-funk) wrote :

PS: I will emphasize that this release introduces too many changes compared to the existing 2.11.8 releases and that producing such a patch would result in exactly the same as the upstream 2.11.9, minus the refreshed autoconf files.

Bryce Harrington (bryce) on 2010-08-27
tags: added: lucid
Bryce Harrington (bryce) wrote :

I've confirmed this version is merged in maverick.

Changed in xserver-xorg-video-geode (Ubuntu):
assignee: nobody → Chris Halse Rogers (raof)
status: Confirmed → Triaged
status: Triaged → Fix Released
Bryce Harrington (bryce) wrote :

Unfortunately, as you may recall from prior -geode update attempts, Ubuntu's SRU policy does not permit doing micro-version updates of packages, due to concern for regression risk. The SRU team wants each discrete change broken out separately, to be reviewed, tested, and tracked in Ubuntu. Personally I wish we could roll out point releases of X drivers, since there's a lot of drivers with fixes I'd like to be able to easily roll out.

However there are some options you can take:

1. We provide the x-updates PPA (https://edge.launchpad.net/~ubuntu-x-swat/+archive/x-updates) specifically as a semi-official solution to this need. You are a member of the ubuntu-x-swat team and should be able to upload to that PPA directly; I'd strongly encourage you to do so, and encourage any geode users or clients to install this ppa. This ppa will only contain stable releases of drivers, so it should be relatively low risk, and if there did happen to be any regression it leaves the user with the option to revert back to the stock distro versions.

2. ubuntu-backports is the most official way to request backports of new versions of packages.

3. There has been a new policy established for permitting exceptions to the SRU policy, for allowing specific packages to receive micro updates in stable releases. The requirement for this is that upstream includes a regression testsuite in the package, and that it is enabled to run in the package's build. Then, an exception must be requested and granted by the Technical Board. For more info if you want to pursue this option please see https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions or talk with Colin Watson if you have questions.

Changed in xserver-xorg-video-geode (Ubuntu Hardy):
status: New → Won't Fix
Changed in xserver-xorg-video-geode (Ubuntu Jaunty):
status: New → Won't Fix
Changed in xserver-xorg-video-geode (Ubuntu Karmic):
status: New → Won't Fix
Bryce Harrington (bryce) wrote :

I'm going to leave this bugtask open against Lucid, because I believe the LTS policy permits having package updates in Ubuntu point releases. I would +1 an update of -geode for that release, but please check with one of the release managers (robbie, kate, slangasek, pitti) for what policy you'll need to follow for that. Possibly just setting this milestone is enough to get it on the radar, but maybe it requires a team subscription as well.

Changed in xserver-xorg-video-geode (Ubuntu Lucid):
milestone: none → ubuntu-10.04.2
status: New → Triaged
Changed in xserver-xorg-video-geode (Ubuntu):
status: Fix Released → In Progress
Changed in xserver-xorg-video-geode (Ubuntu Lucid):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

> Unfortunately, as you may recall from prior -geode update attempts, Ubuntu's SRU policy does not permit doing micro-version updates of packages, due to concern for regression risk. The SRU team wants each discrete change broken out separately, to be reviewed, tested, and tracked in Ubuntu.

That's not really done in practice, though, and the SRU policy doesn't strictly require it. It is not so important from where the patch comes (upstream release, patch, etc.), but whether all of the individual changes contained in a point release, and thus this point release as a whole, are appropriate for SRUing. We quite commonly do microversion updates of GNOME components, libraries, etc.

The trouble with X drivers is always that they are very prone to regressions, and that we can't possibly do an exhaustive regression testing (as we can do with some isolated GUI component).

With -geode this might be a lot easier since it only supports a very limited set of platforms (unlike e. g. the intel driver). So if we have someone (Martin-Eric?) who can test the new release in a lucid environment on the affected hardware, I'm okay with a microrelease update. I'm still interested in seeing a changelog from 2.11.8 to 2.11.9.

Thanks!

Martin Pitt (pitti) wrote :

Martin-Eric, since you have upload rights for -geode now, would you like to upload this yourself?

Martin-Éric Racine (q-funk) wrote :

I suppose that I could do it myself, since I have access to test hardware for a variety of LX platforms.

Please note that upstream is now up to version 2.11.10, which is still a bugfix release. However, some of the fixes only apply to X servers 1.8 or newer, which means that we can skip them for Lucid.

summary: - SRU: xserver-xorg-video-geode 2.11.9-1 to Lucid and older supported
- releases
+ SRU: xserver-xorg-video-geode 2.11.10-1 to Lucid

Martin-Eric,

can you test the current version on lucid and upload it to -proposed? Thank you in advance!

The current upstream (also present in Natty) works as-is on Lucid, as can be verified via my own PPA's packages. If this is satisfactory, I could upload this. if I should instead remain stricter to the SRU policy, I'll need a bit more time to weed through the changes and only extract essential ones.

summary: - SRU: xserver-xorg-video-geode 2.11.10-1 to Lucid
+ SRU: xserver-xorg-video-geode 2.11.11-1 to Lucid

Martin-Éric Racine [2011-01-03 16:54 -0000]:
> The current upstream (also present in Natty) works as-is on Lucid, as
> can be verified via my own PPA's packages. If this is satisfactory, I
> could upload this.

That sounds fine to me. Thanks!

Martin

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

Accepted xserver-xorg-video-geode into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-geode (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed

Martin-Eric, do you have some time to test the actual .debs from lucid-proposed? To ensure that they weren't misbuilt due to toolchain changes, etc? Thank you!

NO ENTIENDO EL INGLES. (Por favor solo ESPAÑOL)

> Date: Wed, 26 Jan 2011 13:59:25 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 625280] Re: SRU: xserver-xorg-video-geode 2.11.11-1 to Lucid
>
> Martin-Eric, do you have some time to test the actual .debs from lucid-
> proposed? To ensure that they weren't misbuilt due to toolchain changes,
> etc? Thank you!
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> ubuntu-10.04.2.
> https://bugs.launchpad.net/bugs/625280
>
> Title:
> SRU: xserver-xorg-video-geode 2.11.11-1 to Lucid
>
> Status in “xserver-xorg-video-geode” package in Ubuntu:
> In Progress
> Status in “xserver-xorg-video-geode” source package in Lucid:
> Fix Committed
> Status in “xserver-xorg-video-geode” source package in Hardy:
> Won't Fix
> Status in “xserver-xorg-video-geode” source package in Jaunty:
> Won't Fix
> Status in “xserver-xorg-video-geode” source package in Karmic:
> Won't Fix
>
> Bug description:
> Binary package hint: xserver-xorg-video-geode
>
> Advanced Micro Devices recently assigned two engineers to maintain the
> code of xf86-video-geode and the first tangible result of this was the
> recent release of version 2.11.9 of the driver, which fixes several
> rendering issues and code base regressions. Also, as a byproduct of
> fixing one rendering issue, the performance of the driver was greatly
> enhanced.
>
> Some of the bugs closed by this release were found via the upstream
> Free Desktop Bugzilla, while others were found in distribution-
> specific bug trackers at Debian, Fedora and Ubuntu. Other issues still
> were discovered and fixed in the process of fixing those
> aforementioned bugs. More details can be found in the upstream
> ChangeLog.
>
> Thus, it would be desirable to push the Maverick 2.11.9-1 version of
> this package into all currently supported Ubuntu releases.
>
> Test packages have already been built via my PPA. Building for
> Intrepid, Jaunty, Karmic and Lucid requires no modification.
>
> Meanwhile, building for Hardy requires minor adjustments to Build-
> Depends and debian/rules. Comparing the Hardy and Lucid versions of
> the 2.11.9-1 package in my PPA shows how small the difference in
> packaging is.
>
>

(LTSP)root@voito:/# echo ; dpkg -l | grep geode ; echo ; cat /etc/issue

ii xserver-xorg-video-geode 2.11.11-1~lucid1 X.Org X server -- Geode GX2/LX display drive

Ubuntu 10.04.2 LTS \n \

Martin-Éric Racine (q-funk) wrote :

Verified to work using an Artec DBE61A-PXE as an LTSP client connected to a Lucid host. Packages in the LTSP chroot as above.

Thanks for testing. Marking as verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-geode - 2.11.11-1~lucid1

---------------
xserver-xorg-video-geode (2.11.11-1~lucid1) lucid-proposed; urgency=low

  * Backporting current Natty version to Lucid as-is as an SRU (LP: #625280).
 -- Martin-Eric Racine <email address hidden> Tue, 04 Jan 2011 21:54:40 +0000

Changed in xserver-xorg-video-geode (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in xserver-xorg-video-geode (Ubuntu):
status: In Progress → Fix Released
Daniel Hollocher (chogydan) wrote :

this bug breaks upgrades to maverick, please reopen

Daniel Hollocher (chogydan) wrote :

rather, the fix committed breads the upgrades

Chris Halse Rogers (raof) wrote :

Ah, yeah. Of course it does. :(.

This should be fixed by doing an additional backport to Maverick; I've added a Maverick bug nomination, but don't have the permissions to accept it.

Martin-Éric Racine (q-funk) wrote :

Pushing the same update to Maverick would indeed make sense. Let's see how the release team feels about it.

Martin-Éric Racine [2011-02-12 11:15 -0000]:
> Pushing the same update to Maverick would indeed make sense. Let's see
> how the release team feels about it.

Fine with me.

--
Martin Pitt | http://www.piware.de
Ubuntu Developer (www.ubuntu.com) | Debian Developer (www.debian.org)

summary: - SRU: xserver-xorg-video-geode 2.11.11-1 to Lucid
+ SRU: xserver-xorg-video-geode 2.11.11-1 to Lucid and Maverick

Accepted xserver-xorg-video-geode into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xserver-xorg-video-geode (Ubuntu Maverick):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed

This bug was fixed in the package xserver-xorg-video-geode - 2.11.11-1~maverick1

---------------
xserver-xorg-video-geode (2.11.11-1~maverick1) maverick-proposed; urgency=low

  * Backporting current Natty version to Maverick as-is as an SRU (LP: #625280).
 -- Martin-Eric Racine <email address hidden> Sat, 12 Feb 2011 18:14:41 +0200

Changed in xserver-xorg-video-geode (Ubuntu Maverick):
status: Fix Committed → Fix Released
shevana7 (shevana7) on 2011-06-24
Changed in xserver-xorg-video-geode (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → shevana7 (shevana7)
summary: - SRU: xserver-xorg-video-geode 2.11.11-1 to Lucid and Maverick
+ SRU: xserver-xorg-video-geode 2.11.12-1 to Lucid and Maverick
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers