Comment 12 for bug 377929

Revision history for this message
Hunk Cui (hunk-cui) wrote :

Hi, all,

As Rigo said about “unable to set rotation on AMD Geode LX800”, I used Ubuntu 9.10 which comes with generic kernel 2.6.31-17 and Xserver 1.6.4, geode-driver 2.11.6, I also able to rotate the screen just fine with the default geode driver that comes with this distribution using Xrandr. Rotation is working just fine with 'xrandr'. I used command such as:
> xrandr -o left
> xrandr -o right
> xrandr -o inverted
> xrandr -o normal

I gave a try with 1.7.1 server on rotation, Geode driver 2.11.7, In our platform, the <OUTPUT> name is "default",
(BTW: In general use $ xrandr -q to discover the appropriate output names for your configuration, the reference link:

When I tried: "xrandr --output default --rotate left". The screen turn to black.
Then tried: "xrandr --output default --rotate normal --auto". The screen return to normal.

Now we doubt it is a bug, because from 1.6.4 server to 1.7.1 server, the part of RandR have been updated and changed from source code.

Are there any other ideas?

Hunk Cui