X in 6.10 ISO Cd installer doesn't work for ATI card

Bug #68433 reported by JohnCollaros on 2006-10-26
4
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Ubuntu-X

Bug Description

This bug was also in Dapper 6.06LTS
It seems not much has been done about this problem.
My original bug number was #35934, and this was marked as a
duplicate of #28925.

This was a clean install, and my video card is ATI X700.

Firstly. I just selected the default install option.
Got the bootsplash (though it looked like the wrong colour mode was selected).
I got the bouncing status bar, then it started loading till it was 1 segment from the end.
Then it just stopped there...eventually I heard the CDRom spin down.
I couldn't switch VT's, it was just stuck on the bootsplash, but i did notice a green line accross the center of the screen that seemed to change when i hit alt-f7 or alt-78.

I tried rebooting, this time with safe graphics mode.
Same problem again!

I reboot again, this time selecting vgamode 1280x1024 32bit.
Ok, bootsplash looks right.
I get to the last segement, then my VT draws correctly, but I got the X blue screen "X failed to start".

At least I could see this now, and also change to a VT to look at log files.

I also tried the safe graphics mode using the vgamode option but got the same results.

It doesn't just work. It's a very frustrating for ATI users.

Attached are a bunch of logs I grabbed on my USB memory stick.

I really applaud the work everyone has done in Ubuntu...it has really come a long way.
Just the odd issue here and there though.

PS - I also did try changing ati to radeon in the Xorg.conf.

JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
JohnCollaros (timefantom) wrote :
description: updated
description: updated
DominikBodi (dominik-bodi) wrote :

You mix up three different problems here:
1. freeze during boot
2. X not starting in the internal display but on the external VGA output.
3. safe graphics mode not working.

1. try adding the options "irqpoll" or "noapic nolapic" to the boot line in the CDs boot menu, check for bugs that relate to that.
2. that's https://launchpad.net/products/xserver-xorg-driver-ati/+bug/22985
unless you don't have a laptop, or a gfx card with only one output port.
3. that's https://launchpad.net/distros/ubuntu/+bug/67405

I suggest marking this one as closed and add comments to the bugs already filed. For number 1. check if there's bug reports for that already. I used to have a similar problem, but that was fixed in the past.
Changing the driver in xorg.conf from ati to radeon usually doesn't help. You might want to utilise adding the "MonitorLayout" option in xorg.conf as described in the original bug report though. Alternatively, installing the non-free fglrx driver is a workaround likely to work.

Regards,
Dominik

description: updated
frankie (frankie-etsetb) wrote :

> PS - I also did try changing ati to radeon in the Xorg.conf

Have you tried also to change ati to vesa ?

Also I noticed gdm was still alive and I had to kill it before starting it again:
# killall -TERM gdm
# /etc/init.d/gdm start

DominikBodi (dominik-bodi) wrote :

Your bug original bug report contains inconsistencies and ambiguities:
1. The title of the bug report suggests that you were running the desktop CD but then you say "it was a clean install."
What do you mean with that: Did you run the desktop CD first? Did it work? Did you then use the installer and the installation on the hard disk would not work anymore?
2. 1280x1024x32: Are you sure your monitor can display that resolution? What kind of hardware to do you use? Is it a laptop/desktop? We'd need more data here.
3. Once X was started up, were you able to go back to the VTs using Ctrl+Alt+F1 ? If yes, the computer probably never froze up.
4. Try disabling the kernel boot options "quiet" and "splash". This will deactive the bootsplash and enable the output of more diagnostics.

I will mark this bug report as "rejected." Even if the report really refers a new bug, it duplicates at least to other bug reports: 59618 and 22985. The BTS cannot cope with a bug being a duplicate of more than one bug anyway.

Btw, #67405 is a dupe of #59618 , mea culpa.

If the problem with the computer freezing really/still exists, feel free to re-open the bug report and edit the bugs description.

DominikBodi (dominik-bodi) wrote :

dupe of two reports: #59618 and #22985

Changed in xorg:
status: Unconfirmed → Rejected
Rob Moore (roborative) wrote :

I am seeing a similar problem with a ATI Radeon X600 card. I cannot perform the install due to the X failure.

The failure results in two X log screens -- one contains the message "no screens found" and the other has this:

Primary Device is PCI 01:00:0
Candidate "Device" section "ATI Technologies, Inc RV370 5B62 [Radeon X600 (PCIE)]"
ATI: PCI Mach64 in slot 1:0:0 could not be detected!
ATI: PCI Mach64 in slot 1:0:1 could not be detected!

Dominik,

Yes my display hardware can support that resolution. I had no problems
seeing the splash screen.
The native resolution for my monitor is 1280x1024@60Hz.
I have a 2 x 17" LCDs.

What do you mean desktop CD?
I used the official ISO image available at the mirrors.
The "Desktop" CD contains the installer.

I never said my computer locked up.
I said that I was unable to switch to a VT due to video card problem.
I was only able to switch VT's when i had selected the resolution settings
from the boot menu as stated earlier.
When trying to switch VT's, i had a green line horizontally accross the
screen that seemed to get wider when
i switched back to VT 7.
On any occasion, X failed to start. X never started.
I never even saw the Blue screen, until I selected the vga mode from the
boot screen.

My guess is the boot splash interfered with me accessing the VT's when I did
not select
the resolution settings.

ATI Support in each Ubuntu release seems to be getting worse and worse.
After a lot of mucking around, and editing xorg.conf files i was able to get
into GDM, but only at
800x600 and run the installer from there.

After installing, I have decided to switch to the fglrx driver which i was
previously using in all other releases of ubuntu.
In this release however, I am unable to geth the fglrx xinerama mode
working.

This not meant as a criticism, but just trying to get some answers, or at
the very least, provide some data
that helps to diagnose what is happening.

On each release, I have chosen to install from the ISO images to run through
the installer.
Dapper and now Edgy have left me with a broken setup that I have to fiddle
with just to get into the installer.

What other information would you like?

John

DominikBodi (dominik-bodi) wrote :

Thanks for that reply. I'm quite sure your problem is not related to #22985, However, your system seems to be affected by https://launchpad.net/distros/ubuntu/+source/xorg/+bug/59618 , that's why "safe graphics mode won't work, either".

Ubuntu CDs/DVDs come in different flavours:
1. Desktop CD: ubuntu-6.10-desktop-i386.iso
This contains a LiveCD environment with a graphical installer run from X/Gnome
2. Alternate CD: ubuntu-6.10-alternate-i386.iso
This contains the old-fashioned text-based installer that runs from console and not from X.
3. ubuntu-6.10-server-i386.iso
Similar to 2, but won't install a desktop enviroment nor X. It's designed to install server systems that don't need X.
4. ubuntu-6.10-dvd-i386.iso
DVD iso, basically a combination of the three above. The boot menu lets you choose what to do with it.

Which version did you use to install? I guess you ran the Desktop CD and used the graphical installer, right? Are the logfiles you attached the ones created by the livecd environment? Just want to be sure before I go on with bug triage.

I'd appreciate if you could have a look at https://wiki.ubuntu.com/TriagingXBugs
and https://wiki.ubuntu.com/DebuggingXAutoconfiguration
and try some of the workarounds mentioned on these two webpages.

Regards,
Dominik

Changed in xorg:
assignee: nobody → ubuntu-x-swat
status: Rejected → Needs Info
JohnCollaros (timefantom) wrote :

Hi Dominik.

Thanks for helping with this.
Yeah I installed from the Desktop CD iso.
All the logfiles attached were generated from the livecd environment.

I was able to install once I altered my xorg.conf driver line from ati to
radeon.
Also, I had assumed /etc/init.d/gdm stop would actually stop gdm, but
someone suggested that you need to pkill gdm. This was true, and why
the radeon driver didn't work in my first attempts.

I'll try the Debugging XAutoConfig stuff in the meantime.

Let me know if you would like any other information.

John

DominikBodi (dominik-bodi) wrote :

I think this is problem is not related to #28925, changing xorg.conf to use the "radeon" driver instead of "ati" would not have helped otherwise. This seems to be related to not properly detecting the gfx chipset in the first place. The Xorg.0.log suggests that something goes wrong when detecting the gfx chipset. It might be useful to checkout bugs.freedesktop.org in order to find out whether upstream knows about this or not.

Changed in xserver-xorg-video-ati:
status: Needs Info → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

The problem _is_ exactly the samea as in #28925, it's just described there that changing to "radeon" helps. #22985 is the bug this not a duplicate of - there the problem is fixed in other ways than changing the driver name. Marking this as duplicate of 28925.

JohnCollaros (timefantom) wrote :

What about the problems with the boot splash locking up vty's?

When I run the CD out of the box, I don't even get to see the blue screen"X
failed to start" error.
And switching to other VT's does nothing.
You just get a garbled mess.

John

On 11/2/06, Timo Jyrinki <email address hidden> wrote:
>
> *** This bug is a duplicate of bug 28925 ***
>
> The problem _is_ exactly the samea as in #28925, it's just described
> there that changing to "radeon" helps. #22985 is the bug this not a
> duplicate of - there the problem is fixed in other ways than changing
> the driver name. Marking this as duplicate of 28925.
>
> ** This bug has been marked a duplicate of bug 28925
> X fails to start in dapper flight3 & 4 with ati X600, onward all the
> way through dapper 6.06 LTS
>
> --
> X in 6.10 ISO Cd installer doesn't work for ATI card
> https://launchpad.net/bugs/68433
>

DominikBodi (dominik-bodi) wrote :

Sorry, for temporarily unmarking this as a dupe. I was mixing up bug numbers. I think the core problem is a dupe of #28925 indeed. John: Have you managed to get Edgy installed using the alternate CD? It would be interesting to know if changing the driver to "radeon" would make the VT switching problems go aways, as well.

Have a look at #67487 and check if this sounds similar to you.

Regards,
Dominik

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers