Ubuntu

DVI port detection worked before but fails now

Reported by Alton Harkcom on 2009-11-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: x11-xserver-utils

Second attempt at getting this bug report stuff to work...

Under older Ubuntu and gNewSsnse by ATI radeon 7000 QY worked fine.
VGA-0 and DVI-0 were properly detected and managed.

Under Ubuntu 9.10 the DVI-0 port shows up as a VGA port and does not work at all.
Screen shows up in Display Preferences Utility but screen stays black...
Physical screen stays black as it does not detect DVI output anymore...

Degrade from older Ubuntu release...

ProblemType: Bug
Architecture: i386
CheckboxCommand: xrandr
CheckboxData: VGA-1 should be VGA-0 and VGA-0 should be DVI-0
CheckboxDescription:
 The following screens and video modes have been detected on your system:

 $output

 Is this correct?
CheckboxSubmission: 2b4c7f95d90a365aec9ab4f057b7d379
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
CheckboxTest: xrandr_detect_modes
CurrentDmesg:
 [ 57.468048] eth0: no IPv6 routers present
 [ 58.268033] eth1: no IPv6 routers present
 [ 170.349907] 0000:02:04.0: tulip_stop_rxtx() failed (CSR5 0xfc664010 CSR6 0xff972113)
 [ 170.349923] eth1: Setting full-duplex based on MII#1 link partner capability of 45e1.
Date: Thu Nov 5 16:42:07 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: ABIT 6A69SA1B
Package: x11-xserver-utils 7.4+2ubuntu3
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=6bdbdb4c-2e74-4d8c-adbc-2d220a32ef09 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: x11-xserver-utils
Tags: checkbox-bug
Uname: Linux 2.6.31-14-generic i686
dmi.bios.date: 12/04/2001
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: 6.00 PG
dmi.board.name: i850-W83627HF
dmi.board.vendor: ABIT
dmi.board.version: Rev:0.1
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvr6.00PG:bd12/04/2001:svnABIT:pn6A69SA1B:pvrBIOSRev0.1:rvnABIT:rni850-W83627HF:rvrRev0.1:cvn:ct3:cvr:
dmi.product.name: 6A69SA1B
dmi.product.version: BIOS Rev:0.1
dmi.sys.vendor: ABIT
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

Alton Harkcom (alton) wrote :
Alton Harkcom (alton) wrote :

To help clarify this bug I took a look at the log from gNewSense.
It took a while to reinstall it but I think the information it provided was worth it.
The port detection is failing in the Ubuntu driver.

The BIOS port detection in gNewSense gives the correct type for the ports:
(II) RADEON(0): Bios Connector table:
(II) RADEON(0): Port0: DDCType-0x60, DACType-1, TMDSType-1, ConnectorType-1
(II) RADEON(0): Port1: DDCType-0x64, DACType-2, TMDSType-1, ConnectorType-2
(II) RADEON(0): Port5: DDCType-0x0, DACType-2, TMDSType-0, ConnectorType-5

Notice that Port1 is ConnectorType-2 which it should be.
The new driver log from Ubuntu doesn`t give this information so there is nothing to compare it to.

Also, the gNewSense gives the correct post assignments:
(II) RADEON(0): I2C bus "VGA-0" initialized.
(II) RADEON(0): I2C bus "DVI-0" initialized.
(II) RADEON(0): Output S-video has no monitor section

And the correct port information:
(II) RADEON(0): Port0:
 Monitor -- AUTO
 Connector -- VGA
 DAC Type -- Primary
 TMDS Type -- None
 DDC Type -- 0x60
(II) RADEON(0): Port1:
 Monitor -- AUTO
 Connector -- DVI-I <----- The Ubuntu driver shows VGA even though it is a DVI connector...
 DAC Type -- TVDAC/ExtDAC
 TMDS Type -- Internal
 DDC Type -- 0x64
(II) RADEON(0): Port2:
 Monitor -- AUTO
 Connector -- STV
 DAC Type -- TVDAC/ExtDAC
 TMDS Type -- None
 DDC Type -- 0x0

It looks like Ubuntu is finding the wrong connector type and trying to use the DVI port as a VGA port.
This is why the screen shows up in the Display preferences but the actual display is blank.

mfg
Al

francoise (frapesc) wrote :

since ubuntu 9.10,
tryed a an unbuntu 9.10 upgrade
and with a fresh total installation, X11 server troubles are same.
Pb is: when i log in, desktop is all black.
only accessible are 2 lines of dashboard (tableau de bord in french) that shows generics usual commands (applications, shorts cut ...) and windows already open .

all my back ground for this document is black without any icone or background prefered picture i try to set.

bypass: ......
BUT, if i turn choice of visual appearence prefered choice visual from (default) normal to : no effect,
background is restaured (i see a marvalous oranged color background with my icones).

I would like to use visual effect enhancement as other. If my video pci card could do.
Christian PESCHOUX (mignt be my english is not good enough, please return me a request if you dont undestand)

Timo Aaltonen (tjaalton) wrote :

Please try a lucid livecd, preferably a daily one later next week when the newest kernel is included in it. Or wait for lucid beta1 which is not far away.

affects: x11-xserver-utils (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Invalid

This is a real bug. It affects me in Lucid 10.04 LTS. It did not affect me in 8.04 LTS.

Some Radeon 7000 VE cards have two VGA connectors and some have one VGA and one DVI connector. The current code assumes tow VGA.

A fix has been checked in upstream:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/475145
http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/commit/?id=37b348059b1c15d7b381cd3df3db52bd9ee6613e
This fix assumes one VGA and one DVI. Being wrong is less serious in the version.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Invalid → New
Bryce Harrington (bryce) on 2010-07-02
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
madbiologist (me-again) wrote :

Does this still occur on Ubuntu 13.10 "Saucy Salamander"?

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Incomplete
tags: added: lucid
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-ati (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers