[Intrepid] Screen artifacts on resume with Radeon Mobility X1400 on Thinkpad T60

Bug #272969 reported by Steve Dee on 2008-09-22
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Undecided
Unassigned

Bug Description

On resuming from suspend, I'll occasionally see colored lines on shadows, or else shadows replaced with solid white, or other similar screen corruptions. This is on a Thinkpad T60 with a Mobility X1400, using whichever drivers Intrepid uses out of the box.

One rather disingenuous workaround is to toggle bicubic filtering in compiz.

Steve Dee (mrdomino) wrote :

An example of the corruption; this is a screenshot of the "desktop wall" post-resume. Note that the random choppiness towards the top is just a result of switching desktops to bring up the wall; the interesting portion is just the white blocky weird crap in the center of the screen.

Steve Dee (mrdomino) wrote :

Another example.

Crackh34d (bartmacco) wrote :

I have about the same problem on a T60p with FireGL V5250 and using the standard drivers (radeon) on Intrepid. Upon resume I get bars of corruption below the upper gnome panel and above the lower gnome panel.

I can post a screenshot later, it is 100% reproducable.
Sadly, fglrx won't let me suspend at all if Compiz is enabled.

Alain Oser (alain-oser) wrote :

I have about the same problem as Steven Dee reported it (see corruption.png) on a Radeon 9600 (Inspiron 8600) and using the standard drivers.

alexg (asg1290) wrote :

Same issue here on a HP nw8440 with a Mobility FireGL v5200. Window boarders disappear or get corrupt after resume. See corruption on the leftmost terminal window in the attached picture.

alexg (asg1290) wrote :

I just added
Option "AccelMethod" "exa"
to the device section of my xorg.conf and it seems to have fixed my corruption issue. YMMV of course.

TomasHnyk (sup) wrote :

see https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-driver-ati/+bug/293395, i think it might be the same bug. The workaround definitely fixes this for me. Therefore I think this is an xserver-xorg-driver-ati bug.

Michele Mangili (mangilimic) wrote :

Hi!

Can anybody confirm that the workaround in bug #293395 solves this issue? (In this case I'd mark this report as a duplicate of #293395).

Thanks for your support.

Dominik (dominalien) wrote :

I am also seeing corruption in Jaunty, only when resuming from hibernation (very similar to this bug: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/293395 ).

Hardware is Acer Ferrari 3000 with a Mobility Radeon 9200 (r200). This happens with and without compositing effects enabled.

Screenshot attached, also:

1. The cursor quickly corrupts (even though the correct cursor is captured by the screen grabbing program) to a white/transparent square filled with garbage.
2. Opening an image in GIMP when compositing is enabled results in the opened image being one mess of garbage. With compositing off, images open OK

Logging out and back in fixes the problem.

Switching consoles (the workaround from bug 293395) makes the problem _worse_.

Also, this computer is unable to resume from sleep in Jaunty at all (bug filed by me here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/339336 ).

Dominik (dominalien) wrote :

This is still happening on resume from hibernation in Jaunty Alpha 6.

Screenshot attached shows what happens after switching to console 1 and back to 7.

J G Miller (jgmiller) wrote :

I have an ATI RV280 based ASUS 9250 AGP graphics card and I am using the radeon driver.

With the Xorg version used under Ubuntu 8.04 I had no problems and a good X11 image display.

After upgrading to 8.10, I noticed that the X display occasionally shimmers, and that there are severe worry lines
on simple cross hatch backgrounds generated with eg

xsetroot -bg color1 -fg color2 -mod 2 2

which were never seen with the Xorg in 8.04, and that the square cursor corruption problem occurs independent
of window manager, but is more evident with XFCE than FVWM, and also occurs with Metacity and openbox, but
not apparently with CTWM and Compiz.

Following the upgrade to 9.04 the problem persists and has not been fixed as I was hoping.

Is this bug ever going to be fixed?

Robert Ancell (robert-ancell) wrote :

Thanks for your bug report. The symptoms provided indicate this is a problem with your video drivers and is being reassigned to the xorg package. For more information on problems with visual effects and video drivers see http://wiki.ubuntu.com/VisualEffects.

affects: compiz (Ubuntu) → xorg (Ubuntu)
Bryce Harrington (bryce) on 2009-07-13
affects: xorg (Ubuntu) → xserver-xorg-video-ati (Ubuntu)
Bryce Harrington (bryce) wrote :

This sounds like a bug in the XAA acceleration architecture, which is resolved by specifying AccelMethod EXA in your xorg.conf. Note that in Intrepid EXA has some performance regression compared with XAA, so it may or may not be worth switching, but for Jaunty, EXA performance is much improved, and we moved to EXA by default.

If by chance you still reproduce the problem in Karmic, feel free to reopen the bug; please attach a new Xorg.0.log in this case.

Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers