Ubuntu

[radeonsi] radeonhd "southern islands" 3d hardware acceleration

Reported by Chris Gagnon on 2013-08-07
138
This bug affects 25 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Undecided
Maarten Lankhorst

Bug Description

Description:
radeon hd7850 has no 3d acceleration

steps:
1. install phoronix-test-suite
    sudo apt-get install phoronix-test-suite
2. install openarena
    phoronix-test-suite install openarena
3. run openarena
    phoronix-text-suite run openarena

expected results:
3d acceleration is used

Actual results:
no 3d acceleration

additional info:
<RAOF> robotfuel: Ah, yes. The 7850 is a southern islands card which requires glamor to do 2D acceleration and requires 2D acceleration to do 3D accel, and we don't currently build glamor.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xserver-xorg-video-ati 1:7.1.0+git20130801.g2ae6bb1-0ubuntu4
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
.tmp.unity.support.test.1:

ApportVersion: 2.12-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDmesg:
 [ 11.412407] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 15.388162] do_trap: 129 callbacks suppressed
 [ 15.388165] traps: install-default[1350] trap int3 ip:7f4182bef179 sp:7fffabc1ffc0 error:0
Date: Wed Aug 7 20:57:54 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850] [1002:6819] (prog-if 00 [VGA controller])
   Subsystem: Hightech Information System Ltd. Device [1787:2320]
InstallationDate: Installed on 2013-08-07 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130802)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.10.0-6-generic root=UUID=61893e71-ac88-4379-a8b1-5699b1f3e749 ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: xserver-xorg-video-ati
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/08/2012
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BHZ7710H.86A.0057.2012.0208.1904
dmi.board.name: DZ77BH-55K
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG39008-400
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrBHZ7710H.86A.0057.2012.0208.1904:bd02/08/2012:svn:pn:pvr:rvnIntelCorporation:rnDZ77BH-55K:rvrAAG39008-400:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.4-0ubuntu8
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.4-0ubuntu8
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2-0ubuntu9
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0+git20130801.g2ae6bb1-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.12-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.8-0ubuntu3
xserver.bootTime: Wed Aug 7 19:53:04 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Raritan D2CIM-DVUSB KEYBOARD, id 8
 input Raritan D2CIM-DVUSB MOUSE, id 9
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.14.2-0ubuntu9
xserver.video_driver: radeon

Chris Gagnon (chris.gagnon) wrote :
Chris Gagnon (chris.gagnon) wrote :
Download full text (24.8 KiB)

glxinfo
name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGI_make_current_read
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile,
    GLX_ARB_create_context_robustness, GLX_ARB_framebuffer_sRGB,
    GLX_ARB_get_proc_address, GLX_ARB_multisample,
    GLX_EXT_create_context_es2_profile, GLX_EXT_framebuffer_sRGB,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info,
    GLX_EXT_visual_rating, GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_swap_control,
    GLX_OML_swap_method, GLX_OML_sync_control, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync
GLX version: 1.4
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_MESA_multithread_makecurrent, GLX_OML_swap_method,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGI_make_current_read
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.2, 256 bits)
OpenGL version string: 2.1 Mesa 9.1.4
OpenGL shading language version string: 1.20
OpenGL extensions:
    GL_AMD_draw_buffers_blend, GL_ANGLE_texture_compression_dxt3,
    GL_ANGLE_texture_compression_dxt5, GL_APPLE_packed_pixels,
    GL_APPLE_vertex_array_object, GL_ARB_ES2_compatibility,
    GL_ARB_color_buffer_float, GL_ARB_copy_buffer, GL_ARB_debug_output,
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_draw_buffers_blend,
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_instanced,
    GL_ARB_explicit_attrib_location, GL_ARB_fragment_coord_conventions,
    GL_ARB_fragment_program, GL_ARB_fragment_program_shadow,
    GL_ARB_fragment_shader, GL_ARB_framebuffer_object,
    GL_ARB_get_program_binary, GL_ARB_half_float_pixel,
    GL_ARB_half_float_vertex, GL_ARB_instanced_arrays,
    GL_ARB_internalformat_query, GL_ARB_invalidate_subdata,
    GL_ARB_map_buffer_range, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_occlusion_query2,
    GL_ARB_pixel_buffer_object, GL_ARB_point_parameters, GL_ARB_point_sprite,
    GL_ARB_provoking_vertex, GL_ARB_robustness, GL_ARB_sampler_objects,
    GL_ARB_shader_objects, GL_ARB_shader_texture_lod,
    GL_ARB_shading_language_100, GL_ARB_shadow, GL_ARB_sync,
    GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_compression_rgtc, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_float, GL_ARB_texture_mirro...

summary: - radeon hd7850 has slow 3d acceleration
+ radeon hd7850 has no 3d acceleration
description: updated
tags: added: needed-xmir-automation
description: updated

Added mesa since it would need to build radeonsi module (and it needs to build-depend on llvm 3.3 for that)

https://blueprints.launchpad.net/ubuntu/+spec/client-s-xorg-general

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-ati (Ubuntu):
status: New → Confirmed
summary: - radeon hd7850 has no 3d acceleration
+ [radeonsi] radeonhd "southern islands" 3d hardware acceleration
Cybjit (cybjit) wrote :

> Added mesa since it would need to build radeonsi module (and it needs to build-depend on llvm 3.3 for that)
Current mesa radeonsi works fine for me with glamor.

Daniel Letzeisen (dtl131) wrote :

@cybjit, I guess mesa is building radeonsi

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
Jussi Pakkanen (jpakkane) wrote :

3D acceleration is not working for me using a Radeon HD 7750 on an up to date saucy.

Duncan Rumbold (djrumbold) wrote :

I have a Radeon HD 7750 and am also 'stuck' on "Gallium 0.4 on llvmpipe". I figured this would be the case until Mesa 9.2 is released because it looks like that's where all the exciting radeonsi development is happening. The recently released Fedora 19 has an early build of Mesa 9.2 and glxinfo on there gives me "Gallium 0.4 on AMD CAPE VERDE" and a noticeably smoother experience. Would the kernel version make any difference as well? (There seems to be a lot work gone on for Radeon SI owners in 3.10 and soon-to-be 3.11).

Cybjit (cybjit) wrote :

@djrumbold, the issue is not too old kernel/mesa/llvm, those are new enough since raring. What is missing is packaging and enablement of glamor (http://www.freedesktop.org/wiki/Software/Glamor/), since radeonsi does not support EXA.
(Of course newer kernel/mesa/llvm would certainly be good, for example s3tc will be supported)

I have had a ppa for glamor going for a few months, and have used radeonsi 3D acceleration in raring/saucy.
Glamor however seems a bit immature: occasional xorg crashes, occasional glyph corruption in firefox, flash content bleeding over other elements. And the 2D performance is not particularly good either. This is not something unique for glamor/radeonsi, I have seen the same result with glamor/intel.

Daniel Letzeisen (dtl131) wrote :

Yes, mesa is up to 9.2 (and radeonsi module is enabled) and the ddx driver is now 7.2.0, so glamor is what's missing. You can try it in PPA form: https://launchpad.net/~oibaf/+archive/graphics-drivers

Daniel Letzeisen (dtl131) wrote :

Actually, the PPA in my last comment is for raring, so disregard.

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
Nazar Mokrynskyi (nazar-pc) wrote :

Glamor just occured in Saucy repository!
Not tested yet.

Letheed (letheed) wrote :

On an up-to-date saucy I was using fglrx up until now. I just did:

# apt-get install xserver-xorg-glamoregl
# mv xorg.conf xorg.conf.removed
# apt-get remove --purge fglrx*

and rebooted but it's now using "Gallium 0.4 on llvmpipe". I am being stupid and doing something wrong or this is supposed to work and it doesn't yet ?

Daniel Letzeisen (dtl131) wrote :

Letheme, please attach the /var/log/Xorg.0.log

Letheed (letheed) wrote :

Here it is. Seems that glamoregl module doesn't exist.
I have an HD7950 and an Ivy Bridge HD4000.

Letheed (letheed) on 2013-09-20
information type: Public → Public Security
information type: Public Security → Public
information type: Public → Public Security
information type: Public Security → Public
Letheed (letheed) wrote :

xserver-xorg-glamoregl just got updated. Here is a new Xorg log after reboot.
glamoregl module seems to load now, but I still get "OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.3, 256 bits)" in glxinfo.

Chris Gagnon (chris.gagnon) wrote :

xserver-xorg-glamoregl is not in main, so xserver-xorg-video-radeon is not being built with glamor support in the ubuntu archive.

if you apt-get install xserver-xorg-glamoregl, apt-get source xserver-xorg-video-radeon, then build and install the deb locally, there will be 3d support. When xserver-xorg-glamoregl moves from universe to main the xserver-xorg-video-radeon package will include glamor

tested this on a radeon hd7850

Maarten Lankhorst (mlankhorst) wrote :

Blocked on bug #1227919 currently, glamor needs to be moved to main first.

Cybjit (cybjit) wrote :

I get 3D acceleration with my 7750 on the saucy daily live iso, so this seems fixed.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers