After a clean install the touchpad doesn't work untill rebooting xserver or pc

Bug #894486 reported by Robert Lemon on 2011-11-24
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

Here is some of my xorg log.

1527.998] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event8)
[ 1527.998] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 1527.998] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 1527.998] (II) LoadModule: "synaptics"
[ 1527.999] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 1528.000] (II) Module synaptics: vendor="X.Org Foundation"
[ 1528.000] compiled for 1.10.4, module version = 1.4.1
[ 1528.000] Module class: X.Org XInput Driver
[ 1528.000] ABI class: X.Org XInput driver, version 12.3
[ 1528.000] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[ 1528.000] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[ 1528.000] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 1528.000] (**) Option "Device" "/dev/input/event8"
[ 1528.024] (--) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
[ 1528.024] (--) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
[ 1528.024] (--) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[ 1528.024] (--) SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[ 1528.024] (--) SynPS/2 Synaptics TouchPad: buttons: left right
[ 1528.048] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 1528.048] (**) SynPS/2 Synaptics TouchPad: always reports core events
[ 1528.064] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input8/event8"
[ 1528.064] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
[ 1528.064] (**) SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[ 1528.064] (**) SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[ 1528.064] (**) SynPS/2 Synaptics TouchPad: AccelFactor is now 0.040
[ 1528.065] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[ 1528.066] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[ 1528.066] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[ 1528.066] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[ 1528.066] (II) SynPS/2 Synaptics TouchPad: failed to open grail, no gesture support
[ 1528.066] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 1528.067] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-input-synaptics 1.4.1-1ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-1.3-generic 3.2.0-rc2
Uname: Linux 3.2.0-1-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
Date: Thu Nov 24 09:59:19 2011
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111123)
MachineType: Hewlett-Packard HP Pavilion tx2500 Notebook PC
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-1-generic root=UUID=911f9d32-a267-48d4-a501-d8e7923ed180 ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-input-synaptics
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/18/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.0F
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30F1
dmi.board.vendor: Quanta
dmi.board.version: 97.22
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.0F:bd08/18/2009:svnHewlett-Packard:pnHPPaviliontx2500NotebookPC:pvrRev1:rvnQuanta:rn30F1:rvr97.22:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion tx2500 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Robert Lemon (rocksinboxes) wrote :
summary: - After a clean install the touchpad doesn't work untill rebooting
- xerserver or pc
+ After a clean install the touchpad doesn't work untill rebooting xserver
+ or pc
Bryce Harrington (bryce) wrote :

Same as bug #897623?

Bryce Harrington (bryce) wrote :

Fwiw, we've changed neither -synaptics nor xserver in precise compared with oneiric, so I'm suspecting this to be due either to a gnome-settings-daemon or kernel change.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

When this happens, can you please give us the output of

  gsettings list-recursively org.gnome.settings-daemon.peripherals.touchpad

? In particular, I'm interested in whether touchpad-enabled flips to false, which would be a gnome-settings-daemon misbehaviour.

Neither gnome-settings-daemon nor x-x-input-synaptics changed in precise, though, and this seems to be a new problem in precise. So we need to find out what's different compared to oneiric.

Thanks!

Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
status: Confirmed → Incomplete

i also encountered this problem, the last time i installed it was synaptic, so i remove synaptic and install it back again to see if it was from this package. i think the bug was from synaptic, it might be the best solution but it work for the meantime.

jhano@john:~$ gsettings list-recursively org.gnome.settings-daemon.peripherals.touchpad
org.gnome.settings-daemon.peripherals.touchpad disable-while-typing true
org.gnome.settings-daemon.peripherals.touchpad horiz-scroll-enabled false
org.gnome.settings-daemon.peripherals.touchpad left-handed 'mouse'
org.gnome.settings-daemon.peripherals.touchpad motion-acceleration -1.0
org.gnome.settings-daemon.peripherals.touchpad motion-threshold -1
org.gnome.settings-daemon.peripherals.touchpad scroll-method 'edge-scrolling'
org.gnome.settings-daemon.peripherals.touchpad tap-to-click true
org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled true
jhano@john:~$

sorry for the typo. i mean "it might not be the best solution but it work for the meantime."

I encountered this problem after an installation test: "Install (ubiquity) in Edubuntu DVD i386 for Precise Daily".

I tested installation for two times, and the same issue occurred. A reboot solved the issue.

tags: added: iso-testing

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/894486

Bryce Harrington (bryce) on 2012-02-03
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → New
Martin Pitt (pitti) on 2012-03-13
Changed in xserver-xorg-input-synaptics (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Bryce Harrington (bryce) wrote :

Are you still experiencing this problem? There've been a bunch of changes to synaptics in precise since the last comment of this bug report.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Incomplete

I personally noticed this didn't happen when I installed the Beta2 candidate on my N310 a few weeks ago. I would probably wait for a few more acks before confirming it though.

Bryce Harrington (bryce) wrote :

Thanks; anyone else want to confirm?

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → New
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since there has not been a response from the original reporter. However, the issue still exists please feel free to reopen with the requested information. If you're not the original reporter, we'd prefer you file a new bug report.

Some tips:

  * Report X.org bugs via the command: `ubuntu-bug xorg`

  * Test against the latest development Ubuntu. http://cdimage.ubuntu.com/daily-live/
    Bugs marked as affecting the development version tend to get priority attention.

  * The `xdiagnose` utility has functionality for enabling debugging and
    analyzing a few common X problems.

  * Tag your bugs with the Ubuntu versions you have reproduced the issue in.

  * See https://wiki.ubuntu.com/X/Reporting for tips on writing good bug reports.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Expired
RazTaz (qvovadis) on 2014-04-05
Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Expired → Confirmed
RazTaz (qvovadis) wrote :

I experience this bug with the following machine:
Lenovo Thinkpad Twist s230u

OS: Ubuntu 12.04.4

The driver is Synaptic TouchPad.

The problem I experience is as follows:

At computer boot (after power off) the driver is not loaded (the output of xinput --list command does not list PS/2 Synaptics TouchPad). However, if I reboot, then the driver is loaded ok. Rebooting after power-up is the only solution I have to load the driver correctly and have the touchpad working.

RazTaz (qvovadis) wrote :

Also, please note that I run on Gnome Shell.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers