PS/2 mouse freezes

Bug #633430 reported by stoupa on 2010-09-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-mouse (Ubuntu)
Undecided
Unassigned

Bug Description

mouse and keyboard freezes when using kubuntu (10.04 32bit or 10.04.1 64 bit live from CD or fresh installed whichever of them) System is stil running, only keyboard and mouse doesn't work, both connected via PS/2. My only solution is reboot. It doesn't happen with USB mouse. There is nothing in log about it.

Fedora core 13 did same, Windows XP without any problem.

hardware:
ASUS P7P55D-E, P55, 2x PCIe x16, DDR3 2200, SATA III RAID, USB3.0, FW, GLAN, 8ch audio, ATX, sc1156
INTEL Core i7-870
MSI VN210-MD512H NVIDIA GeForce 210
Leadtek WinFast DTV1800 Hybrid, PCI, analog and DVB-T TV a FM tuner
CREATIVE SOUND BLASTER VX

Bernhard (baumber) wrote :

same mainboard, the same problem;

System is running and suddenly PS/2 keyboard freezes or presses the last key pressed all the time , e.g. aaaaaaa ....
It can occur once a month or several times in one week.

I guess, it depends on what you are doing; e.g. if I play a racing game on wine, where I have to press the cursor keys all the time, the keyboard timer(?) will overload and triggers this problem. Also writing a lot in Openoffice triggers this bug.

dmesg and messages show no errors.
But Xorg.0.log (unfortunately I didn't store the log) shows messages like;
reopen Device events and "XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm"-events.

Using a USB Keyboard solves the problem totally.
Or use a PS/2 to USB Converter like I do, helps also , but sometimes keyboard is reinitialising suddenly.
But this is only sometimes and in one second and there will be no freeze.

I think that the mainboard isn't yet fully supported, so we should give the next release a try.

Leo Arias (elopio) wrote :

Please follow the instructions you will find at https://wiki.ubuntu.com/DebuggingMouseDetection#In%20case%20your%20mouse%20stops%20working%20after%20a%20while

Add to this report as separate attachments all the files requested there.

Thanks.

affects: ubuntu → xserver-xorg-input-mouse (Ubuntu)
Changed in xserver-xorg-input-mouse (Ubuntu):
status: New → Incomplete
bugbot (bugbot) on 2010-12-16
tags: added: kubuntu
Leo Arias (elopio) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Leo Arias (elopio) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Leo Arias (elopio) on 2011-03-25
Changed in xserver-xorg-input-mouse (Ubuntu):
status: Incomplete → Invalid
Bernhard (baumber) wrote :

See bugs
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/557065

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/632048

Solution: blacklist Asus sensors module asus_atk0110:

Go to the directory /etc/modprobe.d and edit the file blacklist.conf
Add the line blacklist asus_atk0110 to the file and refresh initramfs image for all kernels =>
update-initramfs -uk all

Best regards, Bernhard

Changed in xserver-xorg-input-mouse (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers