abnt2 keyboard layout missing thinkpad variant

Bug #359719 reported by Felipe Figueiredo on 2009-04-11
6
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Felipe Figueiredo
xserver-xorg-input-keyboard (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Felipe Figueiredo

Bug Description

I have a Lenovo 3000 v100 laptop, with a ABNT2 keyboard layout. It should use, as per the manufacter's instructions, use a thinkpad variant, so that all keys are available. In Hardy, there was such a variant selectable through the Gnome GUI, but now in jaunty and karmic there isn't. The slash-question key is interpreted as a right Ctrl key, which is non-existent in this variant.

A workaround is available as follows:

1- Open the gconf-editor application;
2- Search for key 'kbd', and look for /desktop/gnome/peripherals/keyboard/kbd;
3- In the key "layouts", there should be the value "br", change it to "br thinkpad".

The whitespace in step 3 is a tab, not several spaces.

Created an attachment (id=11051)
Includes ABNT2 Thinkpad variant

This patch includes the "thinkpad" variant to "br" layout.
Only one key is changed.

Sorry. I am a bit confused. How happend that RCTL is used for usual characters? Do you have a picture displaying engraving on that keyboard?

Also, would it make sense to add the rule like "if the layout is Brazillian and the model is Thinkpad, use br(thinkpad) by default"?

(In reply to comment #2)
> Sorry. I am a bit confused. How happend that RCTL is used for usual
> characters?
> Do you have a picture displaying engraving on that keyboard?

I am not with the thinkpad with me now. The engraving is "/ ?" (slash
question degree). How happened RCTL to be used for usual caracteres?
well... i think some manager at IBM/Lenovo thinks one extra key is very
expensive. Something like:

MANAGER1: "Damn! ABNT2 keyboard needs an extra-key! What i do now?"
MANAGER2: "Hey! This keyboard have two controls! Who need both?"
MANAGER1: "Great idea! We can use that second control to be the extra key"

> Also, would it make sense to add the rule like "if the layout is Brazillian
> and
> the model is Thinkpad, use br(thinkpad) by default"?

Yes. this is the correct. ABNT2+thinkpad=br(thinkpad)
More questions? -;)

Ok. Kind of strange, but that's life. Committed, thanks.

I have a Lenovo 3000 v100 laptop, with a ABNT2 keyboard layout. It should use, as per the manufacter's instructions, use a thinkpad variant, so that all keys are available. In Hardy, there was such a variant, but now in jaunty there isn't. One key that is completely dead is the slash-question .

Is there any special configuration I should be looking for in xorg.conf (question)

Felipe Figueiredo (philsf) wrote :

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xserver-xorg-input-keyboard
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@rothera) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare scanner tape video

affects: ubuntu → xserver-xorg-input-keyboard (Ubuntu)
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
Felipe Figueiredo (philsf) wrote :
tags: added: jaunty regression
summary: - (regression) (jaunty) abnt2 keyboard layout missing thinkpad variant
+ abnt2 keyboard layout missing thinkpad variant
Felipe Figueiredo (philsf) wrote :

I believe my issue is the same as is described in this debian bug: the slash-question key works as a right Ctrl key,with the normal ABNT2 layout.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=492919

Felipe Figueiredo (philsf) wrote :

AFAICT, the only key that's different in this variant is the slash/question, that in the default variant is the right Ctrl.

Although the "thinkpad" variant doesn't show in the menu, the following command activates the

setxkbmap -model abnt2 -layout br -variant thinkpad

I looked for it in System>Preferences>Keyboard> Layouts tab >Button "+ Add" > By country, select Brazil, Variant, see if "Thinkpad" exists. In Hardy it exists, in Jaunty, it doesn't. Some people in IRC #ubuntu confirmed it also doesn't exist in Intrepid.

Felipe Figueiredo (philsf) wrote :

As instructed in IRC (#ubuntu-x), I'm also adding the source package of xkb-data (xkeyboard-config).

Felipe Figueiredo (philsf) wrote :

To anyone else who might have this issue, here's a permanent work around.

Open a terminal and edit console-setup config to manually input the thinkpad variant.

gksu /etc/default/console-setup

and look for a line that reads

XKBVARIANT=""

and change it to

XKBVARIANT="thinkpad"

After that, a logout should suffice for X11, if not, restart hal.

For console,

sudo dpkg-reconfigure console-setup

would do the job, in theory, but since it's missing the variant this will either overwrite the manual change, or present a TUI menu to configure the layout, showing the same options that Gnome's (and KDE's?) GUI show.

It appears this bug is indeed about the specific information not existing in a central location (package xkb-data?), AUIU.

Timo Aaltonen (tjaalton) on 2009-10-20
Changed in xserver-xorg-input-keyboard (Ubuntu):
status: New → Invalid
Felipe Figueiredo (philsf) wrote :

The workaround in comment #18 does *not* work anymore since Karmic. Even the console config does not honor the settings in /etc/default/console-data anymore.

I've found a new permanent workaround, but this time it has to be configured per account, instead of system-wise.

1- Open the gconf-editor application;
2- Search for key 'kbd', and look for /desktop/gnome/peripherals/keyboard/kbd;
3- In the key "layouts", there should be the value "br", change it to "br thinkpad".

The whitespace in step 3 is a tab, not several spaces.

tags: added: karmic
description: updated
description: updated

Sergey, the committed patch needs the following update,

diff --git a/symbols/br b/symbols/br
index 75ec082..8e06eac 100644
--- a/symbols/br
+++ b/symbols/br
@@ -72,7 +72,7 @@ partial alphanumeric_keys
 xkb_symbols "thinkpad" {

     include "br(abnt2)" // for consistent naming
- name[Group1]="Brazil";
+ name[Group1]="Brazil - Thinkpad";

     key <RCTL> { [ slash, question, degree, questiondown ] };
 };

Without the name 'Brazil - Thinkpad', the entry does not appear in the Keyboard settings, and users end up having to configure the layout with either gconf or through xorg.conf.

See also
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-keyboard/+bug/359719

The fix is incorrect. The name in symbols/br does not affect layout configuration tools - it is base.xml.in that is used. But I do not want to have it there, I'll tell you why. If user chooses one of thinkpad xkb models, the default layout should automatically become br(thinkpad). That's the way rules should work.

setxkbmap -model thinkpad -layout br -print -option ''
xkb_keymap {
 xkb_keycodes { include "evdev+aliases(qwerty)" };
 xkb_types { include "complete" };
 xkb_compat { include "complete" };
 xkb_symbols { include "pc+br(thinkpad)+inet(evdev)" };
 xkb_geometry { include "thinkpad(intl)" };
};

Simos Xenitellis  (simosx) wrote :

Felipe, thanks for this report.

This should be fixed properly in the xkeyboard-config project so that you can select the Thinkpad variant either during installation or later through the Keyboard preferences.
I have updated the upstream bug details for this report.

Simos Xenitellis  (simosx) wrote :

Felipe, have a look at the upstream bug report at bugs.freedesktop.org.

What you need to do is, once you install Ubuntu, go to the Keyboard Preferences and select the Thinkpad keyboard model.
That's it, you get automatically the br(thinkpad) keyboard layout.
Note that currently the thinkpad keyboard layout is found under the IBM vendor (there is no Lenovo yet).

To add Lenovo as a vendor, follow the report at https://bugs.freedesktop.org/show_bug.cgi?id=28874

Felipe Figueiredo (philsf) wrote :

Thanks for the attention, Simos.

Will this fix be commited to Ubuntu as an SRU (say, in Lucid by any chance)?

Simos Xenitellis  (simosx) wrote :

Felipe, I am not speaking for Ubuntu. Here is my executive summary of the issue:

1. The existing Ubuntu 10.04 is able to work with the ABNT2 layout, without the specific problem from this report, if you simply configure the keyboard model, in the Keyboard preferences. Find in the list the vendor IBM and select one of the Thinkpad entries. That's it, and your layout will work as you see fit.

2. In the bug report at
https://bugs.freedesktop.org/show_bug.cgi?id=28874
I asked the developer to change the vendor name from 'IBM' to 'Lenovo (previously IBM)', so that it is more descriptive.
If you have a suggestion for a better name, please make it at the bug report.

3. You need to talk to the other brazilian users of thinkpad laptops about this; they need to configure the Keyboard model to Thinkpad so that all keys work.

4. When you install Ubuntu, there is no option to set the keyboard model. You need to complete the installation, then visit the Keyboard Preferences and set the keyboard model to IBM/Thinkpad.

5. There is no critical change that is needed for Ubuntu 10.04 to make the ABNT2 layout work fully. The only bug report pending is the one that simply asks to change the name of the vendor from 'IBM' to 'Lenovo (previously IBM)'.

6. You might be able to ask for changes in the Ubiquity (installer) so that when Brazil+Thinkpad is detected, the correct layout/model are configured. This is quite advanced and you need to get some help (perhaps some Linux geeks from Brazil?) to help you.

Simos Xenitellis  (simosx) wrote :

The change of the keyboard model name has been committed.

In Ubuntu 10.10 the model name will be 'Lenovo (previously IBM)' instead of the current 'IBM'.

Changed in xkeyboard-config (Ubuntu):
status: New → Fix Committed
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in xkeyboard-config:
importance: Medium → Unknown
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.1-1ubuntu1

---------------
xkeyboard-config (2.1-1ubuntu1) natty; urgency=low

  * Merge from debian of 2.1 release.
    - Fixes Ubuntu bugs:
      + Sindhi keyboard layout (locale: sd_PK, sd_IN) (LP: #588918)
      + Fix conflict between Mali and Malayalam layouts (LP: #575660)
      + Support for Philippines "National Keyboard Layout" (LP: #672881)
      + Support for Kinesis keyboard geometry (LP: #393887)
      + Support for Apple Aluminium keyboards (LP: #696232)
      + Support for abnt2 keyboard, thinkpad variant for Lenovo 3000 v100
        laptops (LP: #359719)
      + Fix CapsLock misspelling (LP: #592448)
    - Remaining Ubuntu changes:
      + xkb-data-i18n.install, xkb-data.install, rules: Split out
        xkb-data-i18n to be used by console-setup.
      + rules: Generate pot file for translations during build
      + 104_macbook_expose_and_dashboard.patch: Add keycode definitions
          required for Apples Expose & Dashboard keys (F3/F4).
      + 105_intelligent_keyboard.patch: Add support for the Intelligent
        Keyboard K04
      + 107_lao.patch: New keyboard layout for Lao, implemented as
        an alternative to the default one.
      + 108_taiwan.patch: New keyboard layouts for Taiwan.
  * Drop 102_mac_aliases.patch: This appears to have some side effects,
    and the patch was not taken by upstream because it was an incomplete
    fix. Reopens bug 327963
  * Drop patches included in the new upstream release:
      - 106_fixspell3d.patch: upstream
      - 109_mali.patch: upstream
      - 110_variants-cleanup.patch
      - 111_il-missing-symbol.patch
      - 112_zero-with-spacing.patch
      - 113_cz-dvorak-ucw.patch
      - 114_ejn_4_level.patch
      - 115_aluminium_geometries.patch
      - 116_aluminium_keycodes.patch
      - 117_aluminium_symbols.patch
      - 118_aluminium_aliases.patch
      - 119_aluminium_pc_compat.patch
      - 120_aluminium_rules.patch
      - 121_tamil_chars.patch
      - 122_olpc-azerty.patch
      - 123_fix_i18n.patch
      - 124_serbian_ru_level3.patch
      - 125_mapping_tools_launch5_menukb.patch
      - 126_swahili_arabic.patch
      - 127_restore_gb_colemak.patch
 -- Bryce Harrington <email address hidden> Tue, 01 Feb 2011 11:57:39 -0800

Changed in xkeyboard-config (Ubuntu):
status: Fix Committed → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.