middle click emulation not working

Bug #771716 reported by Adi Roiban on 2011-04-27
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xserver-xorg-input-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-input-mouse

This looks like a regression in Natty as in Maverick everything was fine :).

I have installed a fresh Natty system, but the middle click emulation on my external mouse is not working.
I am using an external mouse attached to the laptop.

The middle click emulation is working when I used the 2 buttons from the laptop touchpad.

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-input-mouse 1:1.6.0-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,staticswitcher,imgpng,mousepoll,vpswitch,place,wall,move,snap,unitymtgrabhandles,session,regex,animation,resize,grid,workarounds,expo,fade,scale,unityshell]
CompositorRunning: None
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAw5MQBAAAAAAATAQOAHRF4CtXVlllWjCcfUFQAAAABAQEBAQEBAQEBAQEBAQEBPhxWoFAAFjAwIDYAJqYQAAAbPhxWoFAAFjAwIDYAJqYQAAAbAAAA/gBNMjcxUIAxMzNXSDEKAAAAAAAAAAAAAAAAAAEBCiAgADk=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: Off
 modes: 1680x1050 1280x1024 1280x1024 1440x900 1440x900 1280x960 1152x864 1024x768 1024x768 832x624 800x600 800x600 800x600 640x480 640x480 720x400
 edid-base64: AP///////wAebTZW/LwAAAURAQNqLx146tQlpFVJmycTUFSna4CVD5UAgYCBQHFPAQEBAQEBITmQMGIaJ0BosDYA2SgRAAAcAAAA/QA4SxxTDwAKICAgICAgAAAA/ABMMjI2V0EKICAgICAgAAAA/AAKICAgICAgICAgICAgAPM=
Date: Wed Apr 27 12:32:34 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, i686: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0455]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
MachineType: Dell Inc. Inspiron N3010
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=57f7697a-1f41-45d3-b03a-cb4257e6694e ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-input-mouse
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/11/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A04
dmi.board.name: 0M54MP
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A04
dmi.modalias: dmi:bvnDellInc.:bvrA04:bd06/11/2010:svnDellInc.:pnInspironN3010:pvrA04:rvnDellInc.:rn0M54MP:rvrA04:cvnDellInc.:ct8:cvrA04:
dmi.product.name: Inspiron N3010
dmi.product.version: A04
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Adi Roiban (adiroiban) wrote :
Timo Aaltonen (tjaalton) on 2011-04-27
affects: xserver-xorg-input-mouse (Ubuntu) → xserver-xorg-input-evdev (Ubuntu)
Timo Aaltonen (tjaalton) wrote :

Plug your mouse, run 'xinput list >xinput-list.txt' and attach the file here.

Middlemouse emulation defaults off now, but we might add a quirk for your mouse to use it by default.

Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Incomplete
assignee: nobody → Timo Aaltonen (tjaalton)
Emil Styrke (emil-styrke) wrote :

This also affects me, using a Logitech Trackman Marble, attaching the output of "xinput list"

Adi Roiban (adiroiban) wrote :

Here is the requested file. (It was taken on Maverick, but I hope it is ok.)

Are there any drawback for enabling middle click emulation by default?

I have an external keyboard and mouse attached to the laptop. The touchpad from the laptop has only 2 buttons.
In Natty, pressing the 2 touchpad buttons in the same time triggers the middle click event. Pressing the 2 buttons from the external mouse does not trigger the event.

In Maverick everything works fine.

Olle Hassel (olle-ohassel) wrote :

This also affects me, just upgraded from Maverick to Natty and middle click mouse emulation stopped working. I'm using a Logitech G9 Laser Mouse.

Emil Styrke (emil-styrke) wrote :

Workaround: "xinput set-prop <device id> 257 1". Device id can be obtained with "xinput list".

Andrew Somerville (andy16666) wrote :

Same problem with a Kensington Orbit trackball.

Andrew Somerville (andy16666) wrote :
Timo Aaltonen (tjaalton) wrote :

just put

Section "InputClass"
    Identifier "middle button emulation class"
    MatchIsPointer "on"
    Option "Emulate3Buttons" "on"
EndSection

in /etc/X11/xorg.conf and you have the emulation again, permanently. It's not practical to add quirks to the driver, so I'll probably close this as "opinion".

Changed in xserver-xorg-input-evdev (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
status: Incomplete → New
Emil Styrke (emil-styrke) wrote :

This should be configurable in gnome-mouse-properties I guess - emulation is required to get usable copy/paste with a two-button mouse, so having to hack config files is not really acceptable. Can this bug be moved to that package or should a new one be created? Or are there other options to get this working in a user-friendly fashion?

Perseid (perseid) wrote :

I've thought the defaults of Ubuntu 10.04 very sensible: If you actually use the middle button, then the emulation is turned off. My mouse (Logitech M505) actually has a middle mouse button, but I find it too hard to use practically (I often accidentally scroll up or down while pressing the middle button) so I was very happy when I found out about the emulation.
If at all possible I try to avoid changing the xorg.conf, because I always had had bad experiences or at least more work when updating the system.
I would very appreciate it, if the standard settings in 11.04 were like those of 10.04.

Marcus Wanner (marcusw-cox) wrote :

Using a Kensington Orbit Trackball here and don't want to hack my xorg.conf. It's not a new user thing to do, and just because everyone here is assumed (rightly, I hope) to be competent enough to do so does not mean that everyone using ubuntu will be able to. I'm not seeing why having this enabled by default is bad...why wouldn't a user want this? It's not like one is going to continually accidentally hit both buttons at once, or even occasionally. I never have. Having a GUI to configure this (as part of gnome-mouse-properties as someone else suggested) would be acceptable.

Martin (mbr0wn) wrote :

I completely agree w/ Perseid and Marcus Wanner. I find the lack of default middle click emulation highly annoying.

Matt Mullin (matthewmullin) wrote :

I am exasperated with this change. For every release, I have to chase the behavior of my input devices all over the damn file system to restore them to their previous behaviors. I have no xorg.conf right now. I was under the impression that we have been in the process of moving away from using xorg.conf for anything over the last few years. I used to configure input devices through xorg.conf, and it worked well. I don't think it's been the recommended way to configure devices for about two years. Three releases ago, I had to switch to configure scrolling behavior through hal. That changed to udev in the next release. Then in 10.10, I managed to add middle click emulation using a new method that I think involved adding rules to /usr/share/X11/xorg.conf.d/ (but I can't even remember because every time an Ubuntu release comes out I have to learn a new method), and now that has stopped working. This is absurd. Maybe Ubuntu devs could release/contribute code to a configuration utility that actually allows people to set all of the behaviors of the input devices, instead of the random smattering of functionality like Gnome/KDE provide now?

So are we actually back to using /etc/X11/xorg.conf, or was that just an antiquated guess?
I would stop upgrading, but I usually get lured in by a new feature. I'm open to suggestions for a new distribution, which I'm guessing would not be Debian based.

Derek (bugs-m8y) wrote :

Same behaviour, touchpad on a Sony VPC-F11GGX

⎜ ↳ AlpsPS/2 ALPS GlidePoint id=11 [slave pointer (2)]

Very annoying behaviour, especially with terminal windows.

ClashTheBunny (spam-mason) wrote :

Same problem with my touchpad. It works when I plug in my external mouse. I also listed the details on the two input devices. Number 18 is my touchpad and it doesn't work. 20 is my mouse and it does work.

ClashTheBunny (spam-mason) wrote :

I'm really sorry. That last post of mine wasn't clear. "It works when I plug in my external mouse." should have been "Middle click works on my external mouse when I plug it in, but only on the external mouse". Sorry!

Shimi Chen (shimi-chen) on 2011-06-09
Changed in xserver-xorg-input-evdev (Ubuntu):
status: New → Confirmed
Adi Roiban (adiroiban) wrote :

I tried adding the following to /etc/X11/xorg.conf and log out but still not working ... and worse... my touchpad stop working.

Section "InputClass"
    Identifier "middle button emulation class"
    MatchIsPointer "on"
    Option "Emulate3Buttons" "on"
EndSection

----

note there was no /etc/X11/xorg.conf file before

----

I also tried using gpointing-device-settings with no luck.

Adi Roiban (adiroiban) wrote :

I delete the /etc/X11/xorg.conf file with 'Option "Emulate3Buttons"' and started gpointing-device-settings again, enabled middle mouse emulation and set timeout to short.
After this, the middle click emulation is working again.

No need to edit any xorg.conf files.

Cheers

Andrew Somerville (andy16666) wrote :

Are there plans to fix this bug? I notice it's appearing in newer releases too, and as experienced Linux users know, the middle click is pretty hard to live without once you're used to it.

Derek (bugs-m8y) wrote :

Comment #19 worked for me.
I had to *install* gpointing-device-settings first, but once I did, and enabled that for PS/2 mouse, I got my paste back.

Andrew Somerville (andy16666) wrote :

Yes, that worked for me as well. Fixing this should be as simple as having that option set by default.

bugbot (bugbot) on 2012-05-31
tags: added: natty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers