[hardy] Error opening config file: /etc/sensors.conf

Bug #206280 reported by Nanley Chery on 2008-03-25
56
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lm-sensors (Ubuntu)
Critical
Unassigned
Hardy
High
Unassigned
Intrepid
Undecided
Unassigned
xsensors (Debian)
Fix Released
Undecided
Unassigned
xsensors (Ubuntu)
Undecided
Siegfried Gevatter
Hardy
High
Unassigned
Intrepid
High
Siegfried Gevatter

Bug Description

Binary package hint: xsensors

I installed xsensors 0.50 from add/remove. I clicked on the icon and the program didn't start. I ran it in the terminal and it said :

nanley@nanley-desktop:~$ xsensors
Error opening config file: /etc/sensors.conf
Use -c option to specify location of lm_sensors configuration file.

Problem: xsensors is unusable after installation
Fix: See short debian bug report - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=460170

Nanley Chery (nanoman) on 2008-03-25
description: updated
Matthew Woerly (nattgew) wrote :

I guess this is on install... I upgraded from Gutsy and mine is fine.

Nanley Chery (nanoman) on 2008-03-25
description: updated
description: updated
Changed in xsensors:
status: Unknown → Fix Committed
Siegfried Gevatter (rainct) wrote :

I'm preparing a merge against the latest version in Debian.

Changed in xsensors:
status: New → In Progress
status: In Progress → New
Changed in lm-sensors:
assignee: nobody → rainct
status: New → In Progress
Siegfried Gevatter (rainct) wrote :

The latest lm-sensors Debian revision should fix this.

It can be downloaded from: http://ftp.de.debian.org/debian/pool/main/l/lm-sensors/lm-sensors_2.10.5-5.dsc
A debdiff to preserve the existing Ubuntu change is attached.

Changed in lm-sensors:
assignee: rainct → nobody
status: In Progress → Confirmed
Daniel Holbach (dholbach) wrote :

Chuck: can you take a look at it?

Nanley Chery (nanoman) wrote :

Final Freeze in four days!
<politely>Is there any chance this bug will be fixed?</politely>

randalotto (randalotto) wrote :

I have also been having this problem...

pkundtz (pkundtz) wrote :

try 'xsensors -c /etc/sensors3.conf' or copy /etc/sensors3.conf to /etc/sensors.conf

Nanley Chery (nanoman) wrote :

@pkundtz: Yes, doing that would let xsensors work; however, the problem lies far deeper than that - as shown in the debian bug report.

Changed in xsensors:
status: New → Triaged
Siegfried Gevatter (rainct) wrote :

Declining the nomination for Hardy as it is already too late for this.

I confirm this also testing intrepid-64bit

seems to be solved with the last update of tonight. Bye

tyme (4wf4fjmj09) wrote :

this hasn't been fixed. using latest packages in hardy's repository, newly installed system about 2 days old.

tyme (4wf4fjmj09) wrote :

this hasn't been fixed. using latest (64bit) package in hardy's repository, newly installed system about 2 days old.

@tyme
This bug is fixed for intrepid, not hardy. (Though I believe it
should, as the app simply doesn't function correctly.)

On Thu, Jun 26, 2008 at 4:46 PM, tyme <email address hidden> wrote:
> this hasn't been fixed. using latest packages in hardy's repository,
> newly installed system about 2 days old.
>
> --
> [hardy] Error opening config file: /etc/sensors.conf
> https://bugs.launchpad.net/bugs/206280
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Bryce Harrington (bryce) on 2008-10-21
Changed in xsensors:
status: Triaged → Fix Released
Bryce Harrington (bryce) on 2008-11-03
Changed in lm-sensors:
importance: Undecided → High
Changed in xsensors:
importance: Undecided → High
Changed in lm-sensors:
importance: Undecided → High
Scott Kitterman (kitterman) wrote :

Unsubscribing ubuntu-main-sponsors as there is currently nothing to sponsor.

wpshooter (joverstreet1) wrote :

Unsubscribing ubuntu-main-sponsors as there is currently nothing to sponsor.

What does that mean ? It would be nice to give a PLAIN/COMMON explanation instead of these type of messages.

If this is supposed to mean that this bug is fixed, then I beg to differ !!!

Thanks.

Siegfried Gevatter (rainct) wrote :

2008/11/23 wpshooter <email address hidden>:
>> Unsubscribing ubuntu-main-sponsors as there is currently nothing to
>> sponsor.
> What does that mean ?

That nobody has provided a fix, so there's no need for the
ubuntu-main-sponsors team (who reviews patches and if they are okay
uploads them to Ubuntu) to be subscribed.

Savvas Radevic (medigeek) wrote :

So is this too late to include in Hardy? ( comment #9 - https://bugs.launchpad.net/ubuntu/+source/lm-sensors/+bug/206280/comments/9 )

Shouldn't the nomination for hardy be set as "Invalid" then?

Felipe Xavier (lipe-loko94) wrote :

I suggest an upstream version update for xsensors ( xsensors_0.50-1ubuntu3 ) that fix this bug.

Felipe Xavier (lipe-loko94) wrote :

And here is the debdiff file.

Changed in xsensors:
status: Fix Released → Confirmed
wpshooter (joverstreet1) wrote :

Felipe:

What does "status" FIX RELEASED, mean in the e-mail that I received regarding this bug ?

I installed xsensors from Synaptic, then ran sensors-detect, restarted machine and still NOTHING when clicking on xsensors on the systems tools menu.

I am running Hardy. I have all available updates including backports applied.

Thanks.

Siegfried Gevatter (rainct) wrote :

Thanks for your patch. I've upload it :).

There was a bit of junk in the debdiff (namely, the automatic changes to config.{guess,sub} and accidentally touching the previous changelog entry.), though, which you should try to avoid in the future. Also, the "urgency" (in debian/changelog) should always be "low"; it isn't used in Ubuntu.

Changed in xsensors:
assignee: nobody → rainct
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xsensors - 0.50-1ubuntu3

---------------
xsensors (0.50-1ubuntu3) jaunty; urgency=low

  * Check for sensors3.conf if sensors.conf doesn't exist (LP: #206280)

 -- Felipe Xavier <email address hidden> Sun, 11 Jan 2009 22:45:55 -0200

Changed in xsensors:
status: Fix Committed → Fix Released
wpshooter (joverstreet1) wrote :

Is this problem with the Xsensors program fixed for the Hardy version of Ubuntu ?

If so, how do I get it ? I do not see any 0.50-lubuntu3 in Synaptic in Hardy. I see 0.50-lubuntu2 but not 3.

Thanks.

No, it is fixed in Jaunty. If the fix there works fine (can someone
please confirm this?) doing a Stable Release Update for Intrepid and
Hardy can be considered. See
https://wiki.ubuntu.com/StableReleaseUpdates

wpshooter (joverstreet1) wrote :

I will test it in Jaunty.

Will post results when I have finished.

Thanks.

wpshooter (joverstreet1) wrote :

Xsensors seems to install & work just fine under Jaunty daily build for me.

Now if we could get it to work for us persons that are still using Hardy and/or Intrepid.

Thanks.

dillinger417 (dillinger417) wrote :

I tested the the patch ( xsensors_0.50-1ubuntu3.diff.gz ) on my Hardy machine using pbuilder and it fixed the issue without any new problems. I would like to see this get submitted for an SRU, so I subscribed ubuntu-universe-sponsors since I cannot upload. Hopefully that was the correct next step for this.

Siegfried Gevatter (rainct) wrote :

I'm attaching the debdiff for a SRU to Hardy. I've also uploaded it for Intrepid (changing "hardy-proposed" to "intrepid-proposed", and "0.50-1ubuntu2.8.04" to "0.50-1ubuntu2.8.10" in debian/changelog).

There's some config.* noise in the patch but getting ride of it requires modifying debian/rules, so I've left it in.

Thanks

Changed in xsensors (Ubuntu Intrepid):
assignee: nobody → Siegfried Gevatter (rainct)
importance: Undecided → High
Changed in lm-sensors (Ubuntu Intrepid):
status: New → Invalid
Changed in lm-sensors (Ubuntu):
importance: High → Critical
status: Confirmed → Invalid
Changed in lm-sensors (Ubuntu Hardy):
status: New → Invalid
Martin Pitt (pitti) wrote :

I'm not sure that this is really worth an SRU, can this please be ack'ed/nack'ed by motu-sru?

Martin Pitt (pitti) wrote :

motu-sru ping?

Martin Pitt (pitti) wrote :

Accepted xsensors into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xsensors (Ubuntu Intrepid):
status: New → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted xsensors into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in xsensors (Ubuntu Hardy):
status: New → Fix Committed
Nanley Chery (nanoman) wrote :

Nice work on the fix guys, but I'm no longer using Hardy; someone else will have to give feedback on this bug :(

Martin Pitt (pitti) wrote :

Anyone else who can test this? This is lingering in -proposed for three months already. I'll remove it from -proposed soon if we can't get any feedback.

wpshooter (joverstreet1) wrote :

Xsensors works fine in both Jaunty and also under the latest version of Karmic that I tested.

Martin Pitt (pitti) wrote :

Right, but this bug is about the backported fix for Hardy and Intrepid, we need people to test these.

Thanks!

skrimpy (milkandmud) wrote :

I'm trying to test this with my Hardy install and things are not going well. I'm not familiar with testing proposed packages so maybe I'm doing something wrong.

But I've tried adding the -proposed repositories using the above FAQ on how to and I keep getting this error:

W: GPG error: http://ppa.launchpad.net hardy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 665F9AEFE1098513
W: GPG error: http://ppa.launchpad.net hardy Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9423A34CCA967634

Have I done something wrong?

Matthew Woerly (nattgew) wrote :

That error just means that you've added something from a PPA here but you haven't added the key to authenticate the packages. It will still allow you to install the packages.

skrimpy (milkandmud) wrote :

I'm feeling dense here so tell me if I'm doing something wrong:

I added the packages as specified.

Entered aptitude via this command: sudo aptitude -t hardy-proposed

did a search and located xsensors

used "+" to add it to install, then "g" and "g" to install it.

it installed, but it's still not working for me.

advice? again, am I doing something wrong?

Matthew Woerly (nattgew) wrote :

When you say it isn't working, what do you mean? Is it giving you an error?

skrimpy (milkandmud) wrote :

when I open the program this is what happens:

First it opens in an extremely small window (I have to hunt for it)

When I expand it it's just a blank white window - no information.

That is the original bug exactly as I remember it.

On Fri, Sep 11, 2009 at 9:31 AM, skrimpy <email address hidden> wrote:

> when I open the program this is what happens:
>
> First it opens in an extremely small window (I have to hunt for it)
>
> When I expand it it's just a blank white window - no information.
>
> --
> [hardy] Error opening config file: /etc/sensors.conf
> https://bugs.launchpad.net/bugs/206280
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “lm-sensors” package in Ubuntu: Invalid
> Status in “xsensors” package in Ubuntu: Fix Released
> Status in lm-sensors in Ubuntu Hardy: Invalid
> Status in xsensors in Ubuntu Hardy: Fix Committed
> Status in lm-sensors in Ubuntu Intrepid: Invalid
> Status in xsensors in Ubuntu Intrepid: Fix Committed
> Status in “xsensors” package in Debian: Fix Committed
>
> Bug description:
> Binary package hint: xsensors
>
> I installed xsensors 0.50 from add/remove. I clicked on the icon and the
> program didn't start. I ran it in the terminal and it said :
>
> nanley@nanley-desktop:~$ xsensors
> Error opening config file: /etc/sensors.conf
> Use -c option to specify location of lm_sensors configuration file.
>
> Problem: xsensors is unusable after installation
> Fix: See short debian bug report -
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=460170
>

skrimpy (milkandmud) wrote :

maybe this is an issue with my hardware... I tried launching xsensors from the command line and got error:

Sensor 'adm1025' not supported by xsensors!

wpshooter (joverstreet1) wrote :

I don't know what all that stuff you were referring to above regarding adding packages, etc. has to do with getting Xsensors to work but all things being equal, if you have a stock installation of Jaunty and you install Xsensors from Synaptic and then afterwards go to the terminal and run the following command, sudo sensors-detect and then answer all of the questions either YES or hit the ENTER key when prompted and then after the last question is answered do a restart of your computer then Xsensors SHOULD work from the applications/system tools menu.

Good luck.

skrimpy (milkandmud) wrote :

wpshooter, I am not using Jaunty - I'm on Hardy.

I tried what you suggested, including a reboot of my system and Xsensors is still not working (the same problem is occuring both from the menu and the command line)

wpshooter (joverstreet1) wrote :

Sorry, I missed that.

Then you are correct. Does not as of yet work on Hardy.

I don't think it would work on the previous version (Gutsy) either. But I believe that it did work on the version that came before Gutsy.

This is one reason why I switched to Jaunty.

I think the efforts to get it to a point so that it will work under Hardy and Gutsy and still on-going.

Why don't you consider changing to Jaunty. But I think that in order for it to work under Jaunty, you have to actually do an installation of Jaunty from scratch NOT by upgrading from Hardy.

Good luck.

dillinger417 (dillinger417) wrote :

see comment #28. I'm on Jaunty now but the fix worked fine for me on Hardy. I believe it was a one line change involving the location of the configuration file that determines which sensors should be used/polled.

skrimpy (milkandmud) wrote :

I am pretty positive I already installed that version via aptitude after following the instructions above.

I'm further led to believe I already installed it because when I downloaded the .deb you linked to I was informed by the package installer that the status was "Same version is already installed"

Nevertheless I went ahead and clicked "Reinstall Package"

And yet again, I get the same issues as I have detailed above. Very, very small window upon launch, blank when I expand it.

skrimpy (milkandmud) wrote :

Dillinger417 I've tried the /etc/sensors.conf change referenced above and it didn't work for me.

I looked at your comment #28 but I didn't really understand what steps you went through. Could you explain it?

and wpshooter - in regards to upgrading from Hardy - I've considered it but the computer I have Hardy on is my work computer. Its hardware is probably getting to be considered "legacy" and it will be several months before my business buys a new one. I also prefer to do clean installs for my systems and find it a pain to back everything up and reinstall every six months - especially since I have a LAMP server and quite a few web development tools installed. So I decided to stick with the LTS until I buy (hoping to build one, actually) a new computer.

I have Intrepid on my personal computer :)

skrimpy (milkandmud) wrote :

That should say Jaunty...

dillinger417 (dillinger417) wrote :

skrimpy-

If you run 'xsensors' and you get a tiny minimized-looking window that is blank when you expand the bug is fixed. This is NOT the bug. This simply means that you either don't have the sensors setup or they don't exist for your hardware- try sudo sensors-detect as was mentioned. The bug is that if you run xsensors it will fail to launch and say:

user@user-desktop:~$ xsensors
Error opening config file: /etc/sensors.conf
Use -c option to specify location of lm_sensors configuration file.

In my case it would be 'xsensors -c /etc/sensors3.conf' and I got the empty window even after running sudo sensors-detect. As far as my process, its been quite a few months now but I think I applied the jaunty patch after downloading it from this page, and after applying the patch, the only difference is I didn't have to use the -c option. Based on your results, it sounds like you properly patched it, you just may not have realized it since the behavior afterwards was not what was expected.

Hope that helps.

skrimpy (milkandmud) wrote :

I'm just going to assume my hardware is incompatible with xsensors and bow out of this then, because I've done everything suggested and it's still not working. I think I've been pretty extensive in what's going on in my earlier posts and I don't want to hold up a bug fix if the problem is on my end.

Artur Rona (ari-tczew) wrote :

Tags: fixed

Changed in xsensors (Debian):
importance: Unknown → Undecided
status: Fix Committed → New
status: New → Fix Released
Martin Pitt (pitti) wrote :

Did anyone test the packages in hardy or intrepid -proposed and can give some feedback here? Thanks!

Martin Pitt (pitti) wrote :

This proposed update has been in hardy-proposed for half a year without any feedback. Therefore it was removed from hardy-proposed again.

Changed in xsensors (Ubuntu Hardy):
status: Fix Committed → Won't Fix
Changed in xsensors (Ubuntu Intrepid):
status: Fix Committed → Won't Fix
Nanley Chery (nanoman) on 2010-01-10
Changed in xsensors (Debian):
importance: Undecided → Unknown
status: Fix Released → Unknown
Changed in xsensors (Debian):
status: Unknown → Fix Committed
Artur Rona (ari-tczew) wrote :

 xsensors (0.70-1) unstable; urgency=low

   * New upstream release.
     - Swap voltage limits depending on the chip wiring. (Closes: #441138)
     - Provides support for all libsensors4 supported chips. (Closes: #460170)
   * Dropped previous patches due to upstream switching to newer libsensors.
   * Switched to dpkg-source 3.0 (quilt) format.
   * Bumped to Standards-Version 3.8.4.
   * Recommend lm-sensors instead of Depend.
   * Build-Depend on debhelper (>= 7.0.50) and libsensors4-dev.
   * debian/rules: use debhelper extensively.
   * Improved manpage for user-friendliness.
   * Updated and removed trailing whitespaces from files in debian/*.

 -- Nanley Chery <email address hidden> Wed, 03 Feb 2010 00:24:53 -0500

Changed in xsensors (Debian):
importance: Unknown → Undecided
status: Fix Committed → New
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.