Lexmark multifunction printer does not work as scanner after upgrade to Natty

Bug #774475 reported by Matteo Cacciola on 2011-04-30
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
sane-backends (Ubuntu)
Medium
Unassigned
Nominated for Precise by Rolf Leggewie
xsane (Ubuntu)
Medium
Unassigned
Nominated for Precise by Rolf Leggewie

Bug Description

Binary package hint: xsane

Dear friends of the forum, after upgrading my ubuntu station to Natty, scanner of my multifunctions Lexmark X1110 stopped working. I mean that the device still operates correctly as printer, but the scanner is not found. Before upgrading, under Maverick, all functions of X1110 worked correctly

Here is the result of scanimage -L command
[CODE]
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[/CODE]But if I type sudo lsusb, here is the reply of the terminal
[CODE]
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 004: ID 046d:08af Logitech, Inc. QuickCam Easy/Cool
Bus 006 Device 002: ID 058f:9254 Alcor Micro Corp. Hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 010: ID 043d:007b Lexmark International, Inc. InkJet Color Printer
Bus 005 Device 009: ID 043d:007c Lexmark International, Inc. Lexmark X1110/X1130/X1140/X1150/X1170/X1180/X1185
Bus 005 Device 008: ID 043d:007a Lexmark International, Inc. Generic Hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[/CODE]It means that the device is found: that's why the printer works correctly, after installing the right drivers. Thus, I run on terminal sudo sane-find-scanner -p. Here is the result
[CODE]
  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x046d, product=0x08af) at libusb:006:004
found USB scanner (vendor=0x043d, product=0x007c, chip=rts8858c) at libusb:005:009
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # No Mustek parallel port scanners found. If you expected something
  # different, make sure the scanner is correctly connected to your computer
  # and you have apropriate access rights.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.
[/CODE]Please, note that sane-utils and xsane are installed, saned user is present and enabled within /etc/default/saned, and the demon is started by the command
[CODE]
sane-port stream tcp nowait saned:saned /usr/sbin/saned saned
[/CODE]included within the file /etc/inetd.conf.

After all these attempts, I completely uninstalled xsane and sane-utils, trying to make a scan by using simple-scan package, unsuccessfully. I installed again xsane and sane-utils, applying the configuration they had under maverick, but still unsuccessfully.

I verified that the driver lexmark in /etc/sane.d/dll.conf was uncommented. Any idea on how to solve this issue, please?

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xsane 0.998-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Sun May 1 00:00:49 2011
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: xsane
UpgradeStatus: Upgraded to natty on 2011-04-28 (2 days ago)

Gustavo A. Díaz (gdiaz) wrote :

Hi guys,

My brother has the same problem, upgraded to Natty (fresh install) and the scanner does not work anymore (Using Kubuntu 10.10 was working nicely with skanlite application).

Please, we need a fix...

Thanks.

Changed in xsane (Ubuntu):
status: New → Confirmed

Hi, i was having the same problem in Natty 64bit
and a Lexmark x1185.
The only thing that worked for me was
to download and compile an older version of both
Sane (1.0.19) and XSane.
You can download them from here:

Sane: http://www.sane-project.org/
XSane: http://www.xsane.org/

Hope it's useful for you.

Ashley Hooper (ash-hooper) wrote :

I've managed to make this work by installing the versions of libsane and libsane-extras from Debian Squeeze.

http://ftp.us.debian.org/debian/pool/main/s/sane-backends/libsane_1.0.21-9_i386.deb
http://ftp.us.debian.org/debian/pool/main/s/sane-backends-extras/libsane-extras_1.0.21.2_i386.deb

Install the packages from Nautilus or the Ubuntu software centre. Or use the CLI as follows:

sudo dpkg -i libsane-extras_1.0.21.2_i386.deb
sudo dpkg -i libsane_1.0.21-9_i386.deb

Finally, you'll need to pin the version of libsane to the newly-installed version:

gksudo gedit /etc/apt/preferences.d/libsane

Now paste the below contents into the file, save and exit.

Package: libsane
Pin: version 1.0.21-9
Pin-Priority: 900

Confirm it is working using the apt-cache policy command:

$ apt-cache policy libsane
libsane:
  Installed: 1.0.21-9
  Candidate: 1.0.21-9
  Package pin: 1.0.21-9
  Version table:
     1.0.22-2ubuntu1 900
        500 http://nz.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
 *** 1.0.21-9 900
        100 /var/lib/dpkg/status

The asterisks indicate the installed version from Debian Squeeze has priority over newer versions, so update manager won't upgrade you back to the broken version.

Santiago M. Mola (smola) on 2011-11-07
tags: added: oneiric
Santiago M. Mola (smola) wrote :

I can confirm the bug on Ubuntu Oneiric with Lexmark X1150. The workaround described by Ashley Hooper on #4 worked here.

kostas dimitrakakis (kdim26) wrote :

the #4 working and for me

Luigi Maselli (grigio) wrote :

I confirm this regression bug on Ubuntu 12.04 alpha 2

$ sane-find-scanner
  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x043d, product=0x007c, chip=rts8858c) at libusb:005:003
...

$ scanimage -L
WARNING: gnome-keyring:: no socket to connect to

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Luigi Maselli (grigio) wrote :

I confirm the hack works on Ubuntu 12.04 precise pangolin, I just added this command before the "dpkg" commands

sudo apt-get install libjpeg62

It was a dependency of the old libsane

Nick (soapduk) wrote :

I found on 12.04 (64 bit) that I had to remove the existing versions of libsane & libsane-extras before I could use Ashley's method. I don't recall having to remove them on 11.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sane-backends (Ubuntu):
status: New → Confirmed
LeoRochael (leorochael) wrote :

I have the same issue on Ubuntu 11.10, libsane 1.0.22-2ubuntu2

Following the instructions here:

http://lists.alioth.debian.org/pipermail/sane-devel/2009-December/025776.html

I ran:

 $ SANE_DEBUG_LEXMARK=255 SANE_DEBUG_LEXMARK_LOW=255 LD_PRELOAD=/usr/lib/sane/libsane-lexmark.so.1 scanimage 2>lexmark-1.0.22-2ubuntu2.log 1>lexmark.pnm

And got the attached logfile. The following entries are interesting:

(...)
[lexmark] attachLexmark: device `libusb:002:003' successfully opened
[lexmark] attachLexmark: testing device `libusb:002:003': 0x043d:0x007c, variant=0
(...)
[lexmark_low] sanei_lexmark_low_assign_sensor: unknown sensor 1235
[lexmark] attachLexmark: unsupported device `libusb:002:003': 0x043d:0x007c
[lexmark] sane_get_devices: device_list=0xbfd06b34, local_only=0
scanimage: no SANE devices found
[lexmark] sane_exit

On the above thread, it seems that previous versions of sane only new about one kind of sensor for these kinds of lexmark scanners, and only used it. Since then, support for more kinds of sensors was added, and the lexmark backend now gets lost.

Seems to be an upstream issue.

LeoRochael (leorochael) wrote :

Version 1.0.23 of the sane-backends package works again. It's the version bundled with Ubuntu 12.10.

It cannot be directly installed in any previous Ubuntu release, but you can build it from source from the files at:

http://packages.ubuntu.com/source/quantal/sane-backends

Rolf Leggewie (r0lf) wrote :

Ashley, I guess your comment #4 is well-meant, but please NEVER suggest this kind of stuff. It is a VERY bad idea to install binary packages meant for a different distribution. If you want that package, RECOMPILE it for your distribution. You and everyone else have been warned.

Going by what you say and what multiple others have confirmed this seems to be a regression after 1.0.21 that was present in 1.0.22 and has since been fixed in 1.0.23.

Can you guys please test if "sudo scanimage -L" correctly identifies the printer and "scanimage -L" does not?

Changed in sane-backends (Ubuntu):
assignee: nobody → Rolf Leggewie (r0lf)
Nick (soapduk) wrote :

Rolf, Raring (13.04) is finding my Printer in the System Settings but it doesn't allow me to install it. I don't know if I need certain packages installed, since I had to remove whichever ones I installed from Debian to make the scanner work before Raring would let me upgrade my distro.

I've reinstalled Simple Scan and the following, because they had the ubuntu symbol* beside them in Synaptic.
libsane libsane-dbg libsane-hpaio libsane-common libsane-dev

*I notice now that the symbol just means supported, not necessarily bundled with the distro. So I'm not sure which packages I need.

Nick (soapduk) wrote :

Rolf, "sudo scanimage -L" and "scanimage -L" both give me the same result:

device `lexmark:libusb:008:003' is a Lexmark X1100/rev. B2 flatbed scanner

sdaau (sd-imi) wrote :

Just had this with a custom Ubuntu 12.04 - I got the "unknown sensor 1235" as per #11.

So I downloaded the sources for "quantal/sane-backends" as per #12, built them on 11.04 (using the -d override switch of `dpkg-buildpackage`); copied the resulting *.debs to 12.04 machine.

After installing both libsane-common_1.0.23-0ubuntu1_i386.deb and libsane_1.0.23-0ubuntu1_i386.deb on the 12.04 machine, finally I could get "is a Lexmark X1100/rev. B2 flatbed scanner" as in #15, but only with `sudo` - and after that, I could finally call `sudo simple-scan`, and it works properly with the scanner.

Thanks to all for the useful info in this thread,
Cheers!

Rolf Leggewie (r0lf) wrote :

Hello everyone and thanks for chipping in. Sorry for the slow progress.

Apparently this was an unfortunate upstream regression and still affects precise. The good news is that Quantal and later are not affected. I'll mark this ticket as fixed accordingly. I'll also request a fix for precise but I have little hope of it actually happening. I'd advise users to upgrade to trusty soon after its release instead.

Changed in sane-backends (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
importance: Undecided → Medium
status: Confirmed → Fix Released
Changed in xsane (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers