dapper flight 7 text install loses screen during xorg.server configuration

Bug #43722 reported by Tim Jackson on 2006-05-09
16
Affects Status Importance Assigned to Milestone
debian-installer (Ubuntu)
Medium
Unassigned
xresprobe (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: debian-installer

Install get to the point configuring xorg.server and then the screen goes black during the hardware probe and does not come back to a viewable state. This hardware installs fine on dapper flight 6, ddcprobe shows Intel Brookdate-G Graphic Chip and CTX S760A monitor

Tim Jackson (tim-jackson) wrote :

I see this was changed to an xorg.server bug. I think it is really an installer issue because after the install finishes and reboots, the xserver is configured properly (in fact X has never looked crisper). The issue just seems be be that the installer video is hosed after the probe.

Colin Watson (cjwatson) wrote :

I reassigned this to xorg-server because it's X/xresprobe that probes the screen and doesn't restore it properly. I do not see how this is intrinsically an installer issue, given that the installer doesn't even call this code itself (it's buried within packages' maintainer scripts).

Tim Jackson (tim-jackson) wrote :

I see this was changed to an xorg.server bug. I think it is really an installer issue because after the install finishes and reboots, the xserver is configured properly (in fact X has never looked crisper). The issue just seems be be that the installer video is hosed after the probe.

Tim Jackson (tim-jackson) wrote :

sorry about that last repost, I hit refresh in error

Can you please attach the generated xorg.conf and log?

Fabio

Changed in xorg-server:
status: Unconfirmed → Needs Info
Tim Jackson (tim-jackson) wrote :
Download full text (4.4 KiB)

Here is the conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
 FontPath "/usr/share/X11/fonts/misc"
 FontPath "/usr/share/X11/fonts/cyrillic"
 FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
 FontPath "/usr/share/X11/fonts/Type1"
 FontPath "/usr/share/X11/fonts/100dpi"
 FontPath "/usr/share/X11/fonts/75dpi"
 # path to defoma fonts
 FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "type1"
 Load "vbe"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc104"
 Option "XkbLayout" "us"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ExplorerPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "stylus"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "stylus"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "eraser"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "eraser"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "cursor"
  Option "Device" "/dev/wacom" # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option "Type" "cursor"
  Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
 Driver "i810"
 BusID "PCI:0:2:0"
EndSection

Section "Monitor"
 Identifier "CTX S760A"
 Option "DPMS"
EndSection

Section "Scr...

Read more...

Tim Jackson (tim-jackson) wrote :
Download full text (68.3 KiB)

Here is Xorg.log

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.12 i686
Current Operating System: Linux host-172-16-1-66 2.6.15-21-386 #1 PREEMPT Fri Apr 21 16:43:33 UTC 2006 i686
Build Date: 16 March 2006
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 9 16:42:09 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "CTX S760A"
(**) | |-->Device "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "stylus"
(**) |-->Input Device "cursor"
(**) |-->Input Device "eraser"
(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
 Entry deleted from font path.
(**) FontPath set to "/usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/etc/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.2
 X.Org Video Driver: 0.8
 X.Org XInput driver : 0.5
 X.Org Server Extension : 0.2
 X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
 compiled for 7.0.0, module version = 1.0.0
 Module class: X.Org Font Renderer
 ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
 compiled for 7.0.0, module version = 1.0.0
 ABI class: X.Org Video Driver, version 0.8
(++) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,2560 card 8086,2560 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:02:0: chip 8086,2562 card 8086,2562 rev 03 class 03,00,00 hdr 00
(II) PCI: 00:1d:0: chip 8086,24c2 card 8086,24c2 rev 02 class 0c,03,00 hdr 80
(II) PCI: 00:1d:1: chip 8086,24c4 card 8086,24c2 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1d:2: chip 8086,24c7 card 8086,24c2 rev 02 class 0c,03,00 hdr 00
(II) PCI: 00:1d:7: chip 8086,24cd card 15bd,1008 rev 02 class 0c,03,20 hdr 00
(II) PCI: 00:1e:0: chip 8086,244e card 0000,0000 rev 82 class 06,04,00 hdr 01
(II) PCI: 00:1f:0: chip 8086,24c0 card 0000,0000 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:1f:1: chip 8086,24cb card 8086,24c2 rev 02 class 01,01,8a hdr 00
(II) PCI: 00:1f:3: chip 8086,24c3 card 8086,24c2 rev 02 class 0c,05,00 hdr 00
(II) PCI: 00:1f:5: chip 8086,24c5 card 15bd,1001 rev 02 class 04,01,00 ...

Tim Jackson (tim-jackson) wrote :

Just to reiterate X is working fine as configured after the reboot from the install.
The problem is that during the Text install after the xorg-server configuration probe the install screens do not come back. The install does continue however you just can't see the progress bar and messages.

When you normally start X, do you actually see an extra text displayed by the video card that gives some info from the vendor?

Thanks
Fabio

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Fabio Massimo Di Nitto wrote:
> When you normally start X, do you actually see an extra text displayed by the video card that gives some info from the vendor?
>
I believe I only see the what is teed into the Xorg.log file. If I
crash the X server by hitting ctl+alt+backspace and do startx I only see
what is in the log.

Tim J
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEY20zgLVM9zV5AaMRAo8YAJ9BYQWogqyQsiSyZhfOBDc/opBD9QCfViB/
iBeFTE3lXUFVou5KIDLaD34=
=Nmwi
-----END PGP SIGNATURE-----

Tim Jackson (tim-jackson) wrote :

What other info can I help with to get this resolved?

Note to the maintainer: xresprobe should not attempt to run X on known to be broken intel cards to detect screen resolution.

Changed in debian-installer:
status: Unconfirmed → Rejected
Rodrigo Novo (rodarvus) wrote :

It would be nice if you could try to reproduce the problem with the current Edgy livecd, since it has a new version of the i810 driver, which is supposed to fix this problem.

You can download the current livecd from here:

http://cdimage.ubuntu.com/daily-live/

Please note that the current version (20060823) is known to be broken (but unrelated to X.Org). Please wait until version 20060824 is available before attempting to download the livecd.

Thank you in advance!

Tim Jackson (tim-jackson) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Rodrigo Novo wrote:
> It would be nice if you could try to reproduce the problem with the
> current Edgy livecd, since it has a new version of the i810 driver,
> which is supposed to fix this problem.

Yes the edgy install does not blank out. Whether that is based on i810
driver or other xorg changes i.e. xresprobe, I don't know. A backport
of the edgy xorg to dapper would be a good thing for i810 users. Sorry I
took so long to reply, I was away for a couple weeks. :)

Tim J
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFE9xozgLVM9zV5AaMRArndAJ4j/MqevWN/kpxlP4+WvvXuZ3fdOACfcWWD
972Oeymiv9Uxn0dE4y3v5QY=
=Hg8c
-----END PGP SIGNATURE-----

Nanley Chery (nanoman) wrote :

Does this bug still exist?

Nanley Chery wrote:
> Does this bug still exist?
>

I believe so, as of the 6,06.1 text install the install screen still
went blank after probing the video. The issue was fixed in later
versions (edgy).

Tim

Nanley Chery (nanoman) wrote :

This bug is fixed in Edgy. Since the Dapper Final iso cannot be changed., Thank you for this submission.

Changed in xresprobe:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers