Ubuntu

Ctrl-Alt-Backspace should request confirmation before killing Xorg

Reported by Jason Spiro on 2007-03-23
2
Affects Status Importance Assigned to Milestone
X.Org X server
Won't Fix
Medium
xorg (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xserver-xorg

== Background ==

Every day, many users press Control+Alt+Backspace by accident. Here is some example evidence of how this is so are at the bottom of this bug report.

== Feature request ==

Xorg must somehow request confirmation before terminating after the user presses Ctrl+Alt+Backspace. Maybe it could show a confirmation dialog box.

== Example evidence ==

"We routinely use backspace to kill a character, C-backspace to kill a word, C-x backspace to kill a sentence, etc. And inevitably, we press C-M-backspace trying to kill an s-expression, just to find ourselves wondering why the screen suddenly turns black for a moment before the login screen appears again. Yup, we zapped the X server, because that is what C-M-backspace does." --http://www.foldr.org/~michaelw/log/programming/lisp/dontzap-emacs (Emacs's C and Java modes use the Ctrl+Alt+Backspace key combination to delete the {}-enclosed structural block to the left of the cursor.)

"How can I configure X not to shutdown when I accidentally press control-alt-backspace? This happens a lot, believe it or not, while I'm using emacs. If X were to pop up a confirmation dialog, that
would be even better." -- http://www.answers.google.com/answers/threadview?id=38992

"In the terminal programs I use, alt-backspace erases the word to the left of the cursor. This is very handy, but when my thumb slips just a small amount it also presses the ctrl key..." -- http://www.lugod.org/mailinglists/archives/vox-tech/2005-09/msg00046.html

"A word to Alt+Backspace and Shift+Alt+Backspace: I have noticed the danger of shutting down X-Windows when you accidentally hit Ctrl+Alt+Backspace instead of one of the two other keystrokes. So, this might be arguable that users might accidentally mistype a keystroke thus losing some work (as I did :-))" -- http://bugs.kde.org/63540

With sticky keys: "I crashed my system accidentally - I wanted Ctrl-Backspace, and got
Ctrl-Alt-Backspace!
Perhaps sticky keys should not stick the combinations:
Ctrl-Alt-[Del|Backspace|Esc]" -- http://lists.freedesktop.org/archives/xorg-bugzilla-noise/2004-September/003354.html

For more examples see: http://www.google.com/search?q=accidentally+hit+%7C+press+%7C+hitting+%7C+pressing+control+%7C+ctrl+alt+backspace+x%7Cxorg

== Note ==

The Cygwin X server for Microsoft Windows disables Ctrl+Alt+Bksp by default, if you re-enable it, when you press Ctrl+Alt+Bksp you get an exit confirmation dialog like the one I am requesting. There is a screenshot at: http://x.cygwin.com/screenshots/cygx-multiwindow-emacs-exitconfirm-20031224-0010.png

Jason Spiro (jasonspiro) wrote :

See also bug 95259, the equivalent bug for Xgl instead of Xorg.

Forwarded from https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/95258 (from the Ubuntu bugtracker):

== Background ==

Every day, many users press Control+Alt+Backspace by accident. Here is some example evidence of how this is so are at the bottom of this bug report.

== Feature request ==

Xorg must somehow request confirmation before terminating after the user presses Ctrl+Alt+Backspace. Maybe it could show a confirmation dialog box.

== Example evidence ==

"We routinely use backspace to kill a character, C-backspace to kill a word, C-x backspace to kill a sentence, etc. And inevitably, we press C-M-backspace trying to kill an s-expression, just to find ourselves wondering why the screen suddenly turns black for a moment before the login screen appears again. Yup, we zapped the X server, because that is what C-M-backspace does." --http://www.foldr.org/~michaelw/log/programming/lisp/dontzap-emacs (Emacs's C and Java modes use the Ctrl+Alt+Backspace key combination to delete the {}-enclosed structural block to the left of the cursor.)

"How can I configure X not to shutdown when I accidentally press control-alt-backspace? This happens a lot, believe it or not, while I'm using emacs. If X were to pop up a confirmation dialog, that
would be even better." -- http://www.answers.google.com/answers/threadview?id=38992

"In the terminal programs I use, alt-backspace erases the word to the left of the cursor. This is very handy, but when my thumb slips just a small amount it also presses the ctrl key..." -- http://www.lugod.org/mailinglists/archives/vox-tech/2005-09/msg00046.html

"A word to Alt+Backspace and Shift+Alt+Backspace: I have noticed the danger of shutting down X-Windows when you accidentally hit Ctrl+Alt+Backspace instead of one of the two other keystrokes. So, this might be arguable that users might accidentally mistype a keystroke thus losing some work (as I did :-))" -- http://bugs.kde.org/63540

With sticky keys: "I crashed my system accidentally - I wanted Ctrl-Backspace, and got
Ctrl-Alt-Backspace!
Perhaps sticky keys should not stick the combinations:
Ctrl-Alt-[Del|Backspace|Esc]" -- http://lists.freedesktop.org/archives/xorg-bugzilla-noise/2004-September/003354.html

For more examples see: http://www.google.com/search?q=accidentally+hit+%7C+press+%7C+hitting+%7C+pressing+control+%7C+ctrl+alt+backspace+x%7Cxorg

== Note ==

The Cygwin X server for Microsoft Windows disables Ctrl+Alt+Bksp by default, if you re-enable it, when you press Ctrl+Alt+Bksp you get an exit confirmation dialog like the one I am requesting. There is a screenshot at: http://x.cygwin.com/screenshots/cygx-multiwindow-emacs-exitconfirm-20031224-0010.png

If you want to disable Ctrl-Alt-Backspace, set Option "DontZap" in the ServerFlags section, I think it is. Pretty well documented. The reason it doesn't (and won't) show a dialog box, is because it's the 'the server needs to die _now_' emergency combination. Maybe it's set up the wrong mode for your laptop panel and is starting to bloom it. Maybe your mouse is dead and you have no way to kill your session otherwise (or click okay). Maybe your monitor isn't showing anything, so you can't click anything.

Either way, Ctrl-Alt-Backspace is defined as the emergency exit. If you don't want it enabled ... disable it?

Daniel, thanks your reply, and I see your point about a zap ability having useful uses. (Btw I am arguing not that you disable the option for me, but also for my fellow students and for all Xorg users. :-) ) I have just filed bug 10510 ("Xorg should use a more unlikely key combination than Control-Alt-Backspace as the server zap key") to suggest something less severe and CC'ed you. I hope you don't mind.

Jason Spiro (jasonspiro) on 2007-04-02
description: updated
Jason Spiro (jasonspiro) on 2007-04-02
description: updated
Changed in xorg-server:
status: Unknown → Rejected
Jerome S. Gotangco (jsgotangco) wrote :

This would be a good candidate for a spec for future releases. Tagging as as a wishlist for now

Changed in xorg:
importance: Undecided → Wishlist
status: Unconfirmed → Needs Info
Bryce Harrington (bryce) wrote :

From upstream:

"If you want to disable Ctrl-Alt-Backspace, set Option "DontZap" in the
ServerFlags section, I think it is. Pretty well documented. The reason it
doesn't (and won't) show a dialog box, is because it's the 'the server needs to
die _now_' emergency combination. Maybe it's set up the wrong mode for your
laptop panel and is starting to bloom it. Maybe your mouse is dead and you
have no way to kill your session otherwise (or click okay). Maybe your monitor
isn't showing anything, so you can't click anything.

Either way, Ctrl-Alt-Backspace is defined as the emergency exit. If you don't
want it enabled ... disable it?"

Changed in xorg:
status: Needs Info → Rejected
Bryce Harrington (bryce) wrote :

There's been a blueprint to disable this shortcut entirely:

https://wiki.ubuntu.com/XorgCtrlAltBackspace

Changed in xorg-server:
status: Invalid → Won't Fix
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.