Ubuntu

Ubuntu 11.04 / Unity freezing when screen is 'woken up'

Reported by errorist on 2011-05-11
202
This bug affects 45 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

When i close my laptop's top (or the screen just 'falls to sllep') and then open it again (or 'wake the screen up'), everything that i'm allowed to do is mouse cursor moving - the picture just freezes. No other interactions avaliable. My laptop is ASUS K50IJ, Ubuntu 11.04 (with Unity).

Any help would be great!

IKT (ikt) on 2011-05-12
affects: ubuntu → xorg (Ubuntu)

I have the same exact problem. I've installed Ubuntu 11.04 about 4 times, and each time I've experienced the same issue. Every time I leave my computer idle long enough for the display to go to sleep, it freezes on the screensaver when I "awaken" it. All I am able to do is move the cursor. I'm on an ASUS Essentio Series CM5570 desktop computer. I've noticed the original poster is also using an ASUS, but a different model. I am somewhat suspecting it could be an issue with the hardware, but I'm not sure.

However, I have also noticed that when I use "Blank Screen" for screensaver choice, the freezing does not occur upon awakening the display.

I hope this narrows it down a bit. I would appreciate any help on this. :)

Rytis (rytisb) wrote :

Same experience here. After waking the screen up, the desktop environment is frozen, only the mouse can be moved. Then I have to ctrl + alt + f1 and sudo reboot.
I'm using the GNOME desktop environment ("Ubuntu classic"), so this appears to be an issue for both, GNOME and Unity.
I have disabled screensaver, and set screen power management to always on, but upon returning from a while of no activity, the screen is frozen.

Rytis (rytisb) wrote :

Disabling compiz seems to have fixed the freezing.
There might be a shorter way to do this, but this is what I've done.:

In Ubuntu Software Center find and install Compiz Fusion Icon.
Run it:
Applications -> System Tools -> Compiz Fusion Icon.
Then on the blue icon that appears, right click, go to Select Window Manager, and choose Metacity.

Well I'll see if it works. When I first changed to Metacity, the complete Unity bar left and top crashed and I wasn't able to access any menus except the FF menu. I'll see how things go and report back.

Looks like that did the trick, so far so good. Thanks for posting the info.

Gabriel Alonso (gabriel-alonso) wrote :

Having the same exact problem with a Dell latitude E6400 laptop. Will try disabling compiz

Rytis (rytisb) wrote :

Want to say that it still froze a couple of times after disabling compiz, but it happens much less now, as before it was happening constantly.
Disabled the screen saver as well, just kept power management for the screen. So far it's been ok.

Washington (huoxito) wrote :

I'm dealing with the same problem, it's really annoying, I dont remember that happening in previous versions.
At first I thought it was something to do with screensaver. But I disabled it and still got the same problem.

Mine is an Intel Core 2 Duo E7500 2,93GHz.

I'll try out Rytis tip to see if that works.

Roland (roland-breedveld) wrote :

Same problem on Lenovo T61 with screensaver disabled.
It mostly happens after a lock-screen.

on the console (ctr-alt-f1) tried to reload compiz and unity, this didn't help.

reboot is not necessary, a simple pkill -9 -u <user-name> on the console will restart your X.

Patrickus (pkchancey009) wrote :

I have seen a lot of users with this problem on 11.04 Natty, I too have been having this problem since day one on my DELL Inspirion 1525. I have seen a couple threads that insit on installing "xscreensaver", it worked for a few days then my computer locked up on my last night twice. I will give the "Compiz" workaround a shot this afternoon.

PKC

Rytis (rytisb) wrote :

pkill -9 -u <user-name> works great to restart X. Thanks Roland!

Patrickus (pkchancey009) wrote :

I used "sudo apt-get install compiz compizconfig-settings-manager", once there I browsed to "Compiz Config Manager" / clicked on "OpenGL" / and UNCHECK "Sync to VBlank". These steps are what I took on my DELL Inspirion 1525 running Ubuntu 11.04 Natty to resolve the freezing problem I was getting when I would return to my laptop while the screensaver was on. If the problem arises or these steps cease to work I shall update all my info.

PKC

Lucas Hope (lucas-r-hope) wrote :

I was having the same problem with a Lenovo G560 and natty. Patrickus's solution (#12) seems to have worked for me.

The screen would go to sleep, and then X would be unresponsive - except the mouse would move. I could Ctrl-Alt-F1 into a terminal.

All programs were operative, just inaccessible.

Chris Gross (gross-cw) wrote :

I have this problem, too. Dell Inspiron 15n. Second fresh install did not help. This really needs to be fixed, or I will just have to stop using Ubuntu.

Hi all,

I too have this exact same problem after waking from Screensaver on 11.04 (Natty) on an old Dell Optiplex GX620 (P4 HT).

Until this issue is resolved a quicker and easier way of restarting X-Windows (rather than logging into the console) is to re-enable the old CTRL-ALT-Backspace keyboard combination. I discovered this by following Kerry Kobashi's instructions here:

http://www.kerryonworld.com/computers/how-to-restart-x-server-in-ubuntu

Unfortunately this will also log you off but it's better than pulling the plug and doing a cold reboot. :-/

Best of luck people.

Just followed Patrickus' instructions for unchecking "Sync to Vblank" in Compiz Config Manager (Post #12) so we'll see if that fixes things. Many thanks for the suggestion PKC.

Lucky (my-111-stuff) wrote :

I think this is a video card problem. Using nVidia geForce 8400 GS.

After suspending the computer and turning it on, the computer was working (hard drive noises and num lock led in the keyboard was on but the screen refused to response, just black screen).

No suggested keyboard combination turned the screen on.

Tried the Compiz solution suggested above and it worked sometimes.

Today I finally tried using another driver version

Selected System->Admin->Additional drivers-> selected the 173 version (not the recommended version) and it seems that the problem was solved.

You can try using other drivers for you specific video card.

*By the way, had the same problem with this video card also in WinXP (solved it in the same manner), so I don't think it's an Ubuntu problem.

Hi Lucky,

The Dell Optiplex I was experiencing this on is only has built-in Intel GMA950 graphics so if it definitely is a graphics driver issue then it might not be something limited exclusively to Nvidia drivers.

Gabriel Alonso (Post #6) mentiones having this issue with a Dell E6400. These laptops have built-in Intel graphics but can also come fitted with an Nvidia Quadro so it'd be very interesting to see what card is fitted to his laptop and whether upgrading to the 173 driver like you did will also fix his issues?

My PC seems to be behaving so far since disabling the 'Sync to Blank' although it's still early days...

Richard Wonka (richard-wonka) wrote :

I am running natty with the same issue on a Lenovo Edge with built-in Intel Graphics.

Will try solution #12 now. If you don't hear back from me, it's solved. :-D

Dražen Lučanin (kermit666) wrote :

Same problem with me - HP Compaq 6710b, Intel integrated graphics card. Started happening after I upgraded to Natty.

So, does #12 work? None of the people wrote back of it not working, so I guess that might mean it does.

Rytis (rytisb) wrote :

It didn't seemed to have worked for me.

Never had much problems with previous Ubuntu's, but with 11.04, somethings were just not right. Maybe because they are transitioning with the desktop environments. Anyhow, I got and installed Xubuntu, and it's been smooth since, this issue doesn't happen. So I'll wait this season out with Xubuntu, and then see how Ubuntu 11.10 plays out.

Babaei (babaei) wrote :

This issue didn't initially affect me, but starting maybe a week ago (perhaps related to a compiz/Xorg update?), my machine started to occasionally refuse to return from the sleeping screen (launched from the screen saver, after letting the machine set for a while, or letting the machine sit overnight). The screen remains unpowered and all key combinations (eg alt-ctrl-F1) are ignored. If I have music streaming (eg VLC), the audio continues and the network light shows traffic.

The last time it happened, I was able to SSH into the machine. top reported that Xorg was pegged at 100%. I kill -9'ed Xorg and the screen came back alive (with the login prompt, of course). I didn't see anything particularly telling in the Xorg logs (or system logs).

I'm running Ubuntu 11.04 64-bit with Unity on a Dell Vostro 1400 laptop (with the discrete Nvidia GeForce 8400M GS running the proprietary current version 270 Nvidia driver). I am going to try solution #12 to see if it helps.

szabie (karolyiszabolcs) wrote :

Hi,
just to confirm that method mentioned in post #12 works and solved the issue.

Toshiba L40, Ubuntu 11.04 with clean install.
Graphics: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller.

Anyway perhaps it helps to find the root cause:
Issue only happened when there was open window on my desktop. Either put down all windows on the sidebar or closing all windows prevents the bug.

Bryce Harrington (bryce) wrote :

Not enough information has been provided to make this a useful bug report. See http://wiki.ubuntu.com/X/Reporting for instructions on reporting X issues.

Freeze bugs in particular have very specific reporting requirements and files that must be collected.

Changed in xorg (Ubuntu):
status: New → Invalid
jems (jmonnet) wrote :

@Bryce :
You may not invalidate this bug so fast as it seems easy enough to reproduce. I got it on two HP 2510p laptops. Apparently, #12 solves it, that's a lead. I will check and provide information for the reporting.

Thanks.

kristian (m-kristian) wrote :

@Bryce
I was about to look for another distro/version/desktop since this "bug" did rendered unity to be big annoyance. so the hint of #12 did work for me and I happy that this "bug report" is in place. looking at your link with reporting X errors it took me quite some time to figure out that a "freeze" is a crash and that the missing in you are referring gets described in https://wiki.ubuntu.com/X/Troubleshooting/Freeze

hope I will find time to provide this info.

thanx.

damormino (david-amormino) wrote :

We are experiencing this bug on 3 computers. All computers are running Natty 11.04 x86_64 desktop.

After some inactivity by the user, the screen is black and the mouse pointer is visible and moves with the mouse.

We have not experience this problem when the user logs in the same computer with Ubuntu Classic (no effects), which we believe disables Unity.

The file i915_error_state contains: no error state collected

I have attached 2 other files: dmesg.txt and Xorg.0.log (the latter in a comment to follow.

Hi,

I am experiencing another version of this bug but I think it might be related. When I resume after my computer has been asleep, the system freezes up to 6 times. Each time lasts in about 30 seconds, then it comes alive in a few seconds, and then another 30 seconds freeze.

I am running Ubuntu 11.04 with Unity on LG R400.

Nicholas Ochiel (nochiel) wrote :

I have the same problem. I'm running Ubuntu 11.04 on a Toshiba Satellite P200.

loke (developer-loke) wrote :

I am facing the same issue with Intel 915. When I leave the computer for some time, and come back after half an hour or so. I find that the screen remains black with the mouse pointer visible. Seems like the password window appears as well, but does not display.

This does not happen when lock for a minute or two, but after long periods.

Harish (mgharish) wrote :

I have a fresh installation of Ubuntu 11.10, and I have the same problem. I am using HP dv6500

Rytis (rytisb) wrote :

I noticed in Ubuntu 11.10 when you return to your pc with a stuck screen, if you press CTRL + ALT + F1 and then CTRL + ALT + F7, it returns you to the normal unlock screen, where you type your password and the screen is unlocked all is well.

Ignacio Romero (elvencity) wrote :

Same problem around here. Disabling Sync to Vblank wont work for me.

The bug has appeared with 2 variants: After long time of inactivity (everything freezes, except the mouse) and after suspending the notebook by closing the lid (black screen, mouse still can be seen and moves)

I'm running an M880 RAdeon HD 6650M on ubuntu 12.04

OS still works, since CTRL+ALT+F1 works fine. However pressing CTRL+ALT+F7 return you to the stuck screen

Xen-uhhh (xen-uhhh) wrote :

Remove compiz...
sudo apt-get remove --purge compiz*
Am using ubuntu 12.04... It worked for me...

delki8 (delki8) wrote :

Same problem with AMD Radeon HD 7700M Series and 13.10 saucy

Patrick P (pztrick44) wrote :

#12 worked for me using an Asus N10J notebook and Ubuntu GNOME 14.04 alpha 1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions