On Dell Inspiron with ATI x300, xorg.conf is set up to not work and must be manually edited.

Bug #35623 reported by Ketil Wendelbo Aanensen on 2006-03-19
8
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned

Bug Description

I did a *clean* install of Dapper Flight 5 this morning, on my Dell Inspiron 9300 WUXGA (17" laptop)
The installation went fine (with no special modifications on my part), but when I was asked to reboot my computer things went wrong:
My graphics card is ATI Radeon x300 (or whatever the name is).
xorg.conf was edited automatically by the install process, and I realised that having "ati" instead of "fglrx" did not work. The screen was plain black when x was supposed to start. I tried resetting the computer three or four times, the second time the screen was white about 1/6 of the lower part of the screen, but the display didn't work.
I fixed it by booting into safe mode, apt-getting xorg-driver-fglrx and linux-restricted-modules, then using vim to edit xorg.conf to use "fglrx" as a driver instead of "ati"
There is clearly a workaround, but newbie users should not have to put up with this, and it should definately be fixed.

- Ketil

Mark Lord (launchpad-rtr) wrote :

This bug was probably due to the "dri" line in xorg.conf.

A stock install now works for me as of today, on Dell Inspiron 9300 w/ATI x300.

Cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers