Ubuntu

missing "/etc/X11/rgb.txt" file and broken link to it

Reported by draco on 2008-11-22
182
This bug affects 15 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Timo Aaltonen
Nominated for Jaunty by Cruncher
Declined for Karmic by Timo Aaltonen

Bug Description

Hi,

It seems the file /etc/X11/rgb.txt is not present after the installation of Xubuntu 8.10 x86_64.
More over, the symbolic link /usr/share/X11/rgb.txt is also broken as you can see below :

draco@draco-desktop:~$ file /usr/share/X11/rgb.txt
/usr/share/X11/rgb.txt: broken symbolic link to `/etc/X11/rgb.txt'

The link is created by the package x11-common, but the file /etc/X11/rgb.txt appears to be included in no package.

Here is my configuration :

draco@draco-desktop:~/.ZiK$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.10
Release: 8.10
Codename: intrepid

draco@draco-desktop:~/.ZiK$ dpkg -s x11-common
Package: x11-common
Status: install ok installed
Priority: optional
Section: x11
Installed-Size: 748
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: all
Source: xorg
Version: 1:7.4~5ubuntu3

Is it possible to include the file /etc/X11/rgb.txt as it lists all the avaible keyword for corresponding color in X11.
_______________________________________________________________________________________________________

The bug affect several application such as :
- xcolors (totally broken)
- giftrans (totally broken)
- gcolor2 (loosing preferences)
- git (only in gui mode)
- clusterssh
- netpbm
- xterm
- vnc4server (obsolete ?)
- x3270
- stage
- sng (Failed to build from source / FTBFS)
- old xorg.conf from Hardy or previous version (see RgbPath problems)
_______________________________________________________________________________________________________

This bugs must have a *medium* importance, not less, as explained in bug report #304567 (mark as duplicate) :
> Medium importance is defined as:
>
> Medium: most bugs are of medium importance, examples are:
>
> * A bug that has a moderate impact on a core application.
> * A bug that has a severe impact on a non-core application.
> * A problem with a non-essential hardware component (network card, camera, webcam, music player, sound card, power management feature, printer, etc.)
>
> In this case this bug falls under "A bug that has a moderate impact on a core application".
_______________________________________________________________________________________________________

Temporary solution, is to download rgb.txt file and copy it into the folder /etc/X11 by sudo.
See the comment below to give URL : https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/300935/comments/6

UPDATE :
The broken link from /usr/share/X11/rgb.txt is only an Intrepid problem.
This link wasn't created since Jaunty.
However, the missing file /etc/X11/rgb.txt is still a problem on both Intrepid and Jaunty.

Related branches

Alberto Milone (albertomilone) wrote :

I have looked at the package and it contains the file in /usr/share/X11/. Maybe try this command?
sudo apt-get install --reinstall x11-common

draco (draco31-fr) wrote :

First, thank you for your answer !

As you say, I try to reinstall the package.
But as expected, only the link is replaced and no regular file is created.

You can see below the ls command view of the /usr/share/X11 directory :

draco@draco-desktop:/usr/share/X11$ ll
total 72
drwxr-xr-x 60 root root 4096 2008-10-30 00:54 locale
lrwxrwxrwx 1 root root 16 2008-11-22 12:52 rgb.txt -> /etc/X11/rgb.txt
-rw-r--r-- 1 root root 38887 2008-10-08 16:58 XErrorDB
drwxr-xr-x 10 root root 4096 2008-10-30 00:51 xkb
-rw-r--r-- 1 root root 8450 2008-10-08 16:58 XKeysymDB
-rw-r--r-- 1 root root 8305 2008-08-28 02:47 xman.help

The file /usr/share/X11/rgb.txt is not a regular file, permission is lrwxrwxrwx.
It is a link to /etc/X11/rgb.txt that is missing, and it seems that no package avaible in the standard Xubuntu 8.10 release could install it.

Florian Diesch (diesch) wrote :

I can reproduce this bug on Ubuntu 8.10 x86_32.

According to 'apt-file search rgb.txt' no package provides /etc/X11/rgb.txt. There are a few other files named rgb.txt but none seems to be the one we need here.

I'm going to mark the bug as confirmed and let the developers handle it from here. Thanks for taking the time to make Ubuntu better! :-)

Changed in xorg:
status: New → Confirmed
draco (draco31-fr) wrote :

Thank you for confirming the bug.
After a new search on the web, I could find two other bug-reports, on the ubuntu launchpad, with the same description :
BUG #20161 : very old : version of Xorg have been changed since.
BUG #298312 : same description and on Interpid to.

Research in the Ubuntu Package Database shows the file was present on both Hardy i386 and Hardy x86_64 in the package x11-common :
See here for Hardy i386 : http://packages.ubuntu.com/hardy/i386/x11-common/filelist
and here for Hardy x86_64 : http://packages.ubuntu.com/hardy/amd64/x11-common/filelist
But the file is not present in both Interpid version.

PS : maybe one of the bugs between this one and #298312 should be marked as duplicate, but I don't know how to do it !!

Florian Diesch (diesch) wrote :

Jaunty doesn't have the file, too:
http://packages.ubuntu.com/search?searchon=contents&keywords=rgb.txt&mode=exactfilename&suite=jaunty&arch=any

To marks a bug as duplicate just click on the "Mark as duplicate" link on top of the page.

I marked BUG #298312 as a duplicate of this one as we have some more information here.
I'm not sure about BUG #20161

draco (draco31-fr) wrote :

Thank you.
I think I need to take some holliday, because I haven't seen the link yesterday !

If the missing file causes severe bugs, you can download a version of rgb.txt file here : http://cvsweb.xfree86.org/cvsweb/xc/programs/rgb/rgb.txt
the direct link to the latest version is this one : http://cvsweb.xfree86.org/cvsweb/*checkout*/xc/programs/rgb/rgb.txt?rev=HEAD&content-type=text/plain
But beware : there is no waranty with these file !!

Timo Aaltonen (tjaalton) wrote :

Fixed in jaunty.

Changed in xorg:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

sorry, was too quick. The symlink should be removed though.

Changed in xorg:
status: Fix Released → Confirmed
Timo Aaltonen (tjaalton) on 2008-12-28
Changed in xorg:
importance: Undecided → Wishlist
sirianni (eric-sirianni) wrote :

I still see this on intrepid.

sirianni@graves:~$ ll /usr/share/X11/rgb.txt
lrwxrwxrwx 1 root root 16 2008-11-03 20:03 /usr/share/X11/rgb.txt -> /etc/X11/rgb.txt
sirianni@graves:~$ ll /etc/X11/rgb.txt
ls: cannot access /etc/X11/rgb.txt: No such file or directory
sirianni@graves:~$

This is breaking vnc4server. When I try to start an xterm from a vnc session, I now get this error:

$ xterm -bg black -fg white
Warning: Color name "black" is not defined
Warning: Color name "white" is not defined

$ xcolors
/etc/X11/rgb.txt: No such file or directory

Is there a workaround for this? Where should vnc be getting the colors from?

Jeremy Cantrell (jmcantrell) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg - 1:7.4~5ubuntu11

---------------
xorg (1:7.4~5ubuntu11) jaunty; urgency=low

  [ Bryce Harrington ]
  * apport/source_xorg.py:
    - Adding system environment items recommended at
      http://intellinuxgraphics.org/how_to_report_bug.html
    - Add lshal
    - Add debug test code
    - Drop use of intel_reg_dumper since it requires root (LP: #311560)
  * scripts/vars.sparc: Drop sunbw2. It's dead jim. (LP: #314539)

  [ Timo Aaltonen ]
  * Merge with Debian experimental.
  * debian/control: xserver-xorg doesn't need to depend on mdetect
    anymore.
  * x11-common.links: Don't install the symlink to rgb.txt (LP: #300935)

 -- Bryce Harrington <email address hidden> Fri, 30 Jan 2009 13:42:37 -0800

Changed in xorg:
status: Confirmed → Fix Released
sirianni (eric-sirianni) wrote :

I don't understand... how does this fix the bug?
 * x11-common.links: Don't install the symlink to rgb.txt (LP: #300935)

If applications such as VNC are depending on rgb.txt being present in the system, simply removing the broken symlink does not fix the problem. Right?

Michael Janssen (jamuraa) wrote :

this could be two different bugs, but the bug that rgb.txt does not exist is still a bug. There are applications that don't work without an rgb.txt.

Changed in xorg:
status: Fix Released → Confirmed
Timo Aaltonen (tjaalton) wrote :

That file has no meaning with xserver 1.5, it's obsolete. Use a better vnc server, vnc4server is obsolete in itself since no one maintains it and it doesn't build anymore.

Changed in xorg:
status: Confirmed → Fix Released
Michael Janssen (jamuraa) wrote :

I'm not going to get into a fixed / unfixed launchpad war, but this doesn't just affect vncserver - many legacy programs use this file for translating colors. For example the stage program (universe package stage) uses the /etc/X11/rgb.txt.

Jeremy Cantrell (jmcantrell) wrote :

I agree. The one that affects me is NX Free Edition from NoMachine. It still uses rgb.txt (although they've told me that this was going to change with 4.0. I'm not sure if FreeNX uses it.

pbeeson (pbeeson) wrote :

I fixed this easily enough by copying the file, but since I administer something like 20 machines, it's a pain to have to make sure all my machines have an rgb.txt.

I just have one additional question (please don't read this as being a negative tone):
I don't understand why this can't simply be included back in x11-common on Intrepid and a new x11-common package be put in intrepid-updates. Adding a simple file back in that WAS in Hardy seems to take a couple of minutes and doesn't require any testing.

Seriously, I'm not trying to be a pain in the ass. I really would like to know why the package maintainers have decided that because xserver 1.5 no longer uses rgb.txt, that it needs to be taken out of the package completely. I am also using a program (not vnc4server) that requires rgb.txt to run. Simply saying that rgb.txt is no longer used by xserver 1.5 is NOT a reasonable answer, as any OS upgrade needs to be able to handle legacy code.

ejprinz (ejprinz) wrote :

On Intrepid (8.10) I've been using vnc4server and asked for a "gnome-session &" in the xstartup file. Gnome didn't start. I then tried "startfluxbox &" (a different window manager) and that one worked, but I couldn't start emacs due to rgb.txt missing. I now added rgb.txt as described above and gnome-session seems to start OK. So, I second adding rgb.txt to /etc/X11 even in Intrepid.

Timo, you mentioned "Use a better vnc server, vnc4server is obsolete in itself since no one maintains it and it doesn't build anymore.", which begs the question: Which vncserver should we be using? Thanks for any answer you can provide.

ejprinz (ejprinz) wrote :

I couldn't reproduce the link between adding rgb.txt to /etc/X11/ and gnome-session starting when it didn't start before on a second machine (see above post). I did confirm that emacs doesn't start unless rgb.txt is present in /etc/X11/.

ejprinz (ejprinz) wrote :

To clarify, the above statement is true when running a VNC server started with vnc4viewer, the fluxbox window manager, then trying to start Emacs. But, Emacs does start in a normal Gnome session (not using VNC).

H3g3m0n (h3g3m0n) wrote :

This doesn't seem fixed, I'm still missing rgb.txt as of the latest Jaunty alpha 6.

http://packages.ubuntu.com/jaunty/i386/x11-common/filelist doesn't show the rgb.txt (1:7.4~5ubuntu15).

rgb.txt is such an annoying file, I've had problem with it in just about every distro, its such a simple but fairly pointless file that can cause major problems such as xterms refusing to start because they don't know what "black" is or problems with VNC servers.

Peter Chubb (peterc-gelato) wrote :

Missing rgb.txt also affects xcolors (Bug #304567) and netpbm

draco (draco31-fr) wrote :

As it was described in bug #304567 , the missing file rgb.txt show a "medium" bug importance.
It is not a simple "whishlist" ! As shown in bug #331375 , it affects several application that are not "obsolete" like netpbm, xcolors and more.
Would it be possible to pass the bug as medium importance and really think about adding the rgb.txt on the next jaunty release ?

draco (draco31-fr) on 2009-03-30
description: updated
draco (draco31-fr) on 2009-03-30
description: updated
draco (draco31-fr) on 2009-03-30
description: updated
Cruncher (ubuntu-wkresse) wrote :

Changing this back to "Confirmed", since the main part of the problem (the file /etc/X11/rgb.txt (which is apparently required by several older tools and utilities, which are still installable in current releases) is missing on newer installs) has not been fixed. What has been fixed is merely the broken link within the package x11-common.

Even if it is decided that this file no longer belongs in xorg/x11-common (which would legitimate a "Fix Released" for that package), the file should probably be provided by some other package then, shouldn't it?

On a sidenode, it is strange that on my Xubuntu intrepid (upgraded over time since Ubuntu edgy) the file still exists, I have 1:7.4~5ubuntu3 installed (which according to launchpad does not contain the file), and both "dpkg -L x11-common" and "dpkg -S rgb.txt" do list /etc/X11/rgb.txt.

Changed in xorg:
status: Fix Released → Confirmed
Cruncher (ubuntu-wkresse) wrote :

For the same reason I petition that the "Importance" should be changed from "Wishlist" to "Medium". The missing file is not a wishlist item, since it *breaks* the usability of several utilities in several official Ubuntu packages. The correct "Importance" would be "Medium", in accordance with https://bugs.launchpad.net/ubuntu/+source/xcolors/+bug/304567/comments/6 from a duplicate bug.

Cruncher (ubuntu-wkresse) wrote :

One way to fix this would be for every package requiring rgb.txt to bundle a copy of that file, as several packages already have done (e.g., pixmap (bug #248657), emacs, and a few others). This approach, however, doesn't make a lot of sense, since every package then needs to drag this identical file around, and should there be any changes, everyone of those packages would have to be updated once again.

The only reasonable approach would be, to have *some* single package provide the file, either at /etc/X11/rgb.txt, or at a FHS conform location (in which case all packages requiring it would have to be adapted - but only once!).

It seems, in the past there must have been a similar discussion, and the file was moved(?) to the package "xrgb" https://launchpad.net/ubuntu/+source/xrgb/+publishinghistory . However, this package was deleted in Hardy, moving the file bak(?) to x11-common, and it appears the whole discussion now started once again because the file was removed from xorg.

Richard Seguin (sectech) wrote :

I corrected the importance to low as it actually satisfies the criteria for non-core applications. I didn't realise that the time how far down this issue went.

Changed in xorg:
importance: Wishlist → Low
Richard Seguin (sectech) wrote :

Cruncher:

Low: Bugs which affect functionality, but to a lesser extent than most bugs, examples are:

    * Ones that can be easily worked around
    * Ones that affect unusual configurations or uncommon hardware
    * A bug that has a moderate impact on a non-core application
    * A cosmetic/usability issue that does not limit the functionality of an application

In our case this would be a bug having a moderate impact on an non-core application.

https://wiki.ubuntu.com/Bugs/Importance

draco (draco31-fr) wrote :

Mr Richard Seguin,
First of all, thank you for the interrest you are according to this bug.
I don't really know where is the frontier between core-application and non-core application, but you said yourself in this comment https://bugs.launchpad.net/ubuntu/+source/xcolors/+bug/304567/comments/6 that the bug have a moderate impact on a core application.

I think that xcolors and xterm are part of core application.
Most of all, there is a discrepancy between the content and the dependencies of the xcolors and x11-common package.
Let me explain :

draco@23:17:51 [0] <0>:~$ apt-cache rdepends xcolors
xcolors
Reverse Depends:
  x11-common

The package xcolors is needed by x11-common, but the xcolors application is totaly broken since the file rgb.txt has been removed from x11-common.

A solution may be to include the rgb.txt file into the xcolors package (I was understanding the program is "just" interpreting those file !)

The package sng has the same problem. FTBFS because it can't find rgb.txt

draco (draco31-fr) on 2009-04-03
description: updated
Cruncher (ubuntu-wkresse) wrote :

Hm, none of these are core applications. However, the impact on them being non-core applications is pretty severe - because you can't use them anymore! So this should call for a Medium importance.
Unless you count the relatively simple workaround of downloading a rgb.txt from somewhere (or take it from another package, see below), and copy it to /etc/X11.

Other applications affected by the bug:
xcolorsel

Note that "netpbm" is not an application in itself, but a package consisting of over 200(!) utilities to convert and manipulate PNM images. Although admittedly only a few(?) of those utilities broke because of the missing rgb.txt.

Several packages have already included a (redundant) copy of rgb.txt locally, since the file seems to have been moved through the filesystem several times in the past already:
emacs
latex2html
pgplot5
pixmap
xplanet
xwatch

Cruncher (ubuntu-wkresse) wrote :

Please set importance to "Medium", on the basis of:
*A bug that has a severe impact on a non-core application.

It effectively BREAKS several current Intrepid and Jaunty packages (all non-core applications). Try for yourself:
sudo apt-get install giftrans
giftrans

Package giftrans, version 1.12.2-15ubuntu1 (current for both 8.10 and 9.04)
The program will not start. As won't the several other programs listed in this thread.

To continue the list of tools that already include a (redundant) copy of /etc/X11/rgb.txt, ImageMagick (including tools such as "convert" and "identify") has the color names incorporated into its library, libMagick.so.10, package libmagick10.

Morten Kjeldgaard (mok0) wrote :
Changed in xorg (Ubuntu):
importance: Low → Medium
Bryce Harrington (bryce) on 2009-04-23
Changed in xorg (Ubuntu):
status: Confirmed → Triaged

Another application that is affected is git. "git gui" will not start at all on a fresh Jaunty install.

Come on people, this is clearly something that needs to be fixed. I will download rgb.txt now to continue with my work, but this has eaten 20 minutes of my time. Scale this to millions of Ubuntu users ...

And if we must play the priority game, this should probably be rated "High" as it satisfies the following part of the definition.

* Has a moderate impact on a large portion of Ubuntu users (estimated)

Great ... I downloaded rgb.txt (and some variations) and put it in /etc/X11/rgb.txt, /usr/share/X11/rgb.txt, and /usr/lib/X11/rgb.txt. No luck so far.

This works around the bug for showrgb etc., but tk apps still do not see the colors. Investigating further ...

Ok, after restarting the X server (i.e., killing my long-running vnc session) the rgb.txt in /etc/X11/rgb.txt was accepted.

Still, I think the current state is unacceptable. I'd be happy to help in finding a better solution.

Hugo Heden (hugoheden) wrote :

Bug #358678 , which IMHO is a duplicate of this one, has some more information related to problems invoking emacs (and other applications, see above) under NX from NoMachine (nxserver) and FreeNX.

zorzella (zorzella) wrote :

Bug #358678 indeed seems to have the same root cause. Here's something interesting. Before the workaround I had this:

$ locate rgb.txt
/usr/lib/X11/rgb.txt
/usr/share/X11/rgb.txt
/usr/share/emacs/22.2/etc/rgb.txt
$ ls -l /usr/lib/X11/rgb.txt
lrwxrwxrwx 1 root root 16 2009-04-27 17:57 /usr/lib/X11/rgb.txt -> /etc/X11/rgb.txt

So, not only /etc/X11/rgb.txt was missing, Jaunty seems to have created a symlink to that unexisting location (someone please confirm, it could have been me, by mistake, while trying some solution).

Anyway, copying /usr/share/emacs/22.2/etc/rgb.txt to /etc/X11 solved it. Thanks!

Z

Nick B. (futurepilot) wrote :

I ran into this problem myself while trying to figure out why gcolor2 is missing all of its preset colors. While running an strace on it I noticed it's looking for this rgb.txt which doesn't exist.

16:40:24.658326 access("/usr/X11R6/lib/X11/rgb.txt", F_OK) = -1 ENOENT (No such file or directory)
16:40:24.659307 access("/usr/lib/X11/rgb.txt", F_OK) = -1 ENOENT (No such file or directory)
16:40:24.659699 access("/etc/X11/rgb.txt", F_OK) = -1 ENOENT (No such file or directory)
16:40:24.660114 access("/usr/openwin/lib/X11/rgb.txt", F_OK) = -1 ENOENT (No such file or directory)
16:40:24.660731 open("/home/nick/.rgb.txt", O_RDONLY) = -1 ENOENT (No such file or directory)

Which lead me to this bug report.

Martin Olsson (mnemo) wrote :

FWIW, the file /etc/X11/rgb.txt does exist (and gcolor2 shows the pre-defined colors properly) on my cleanly install ubuntu jaunty system (didnt check with live CD though). Also, if I run "dpkg -S /etc/X11/rgb.txt" it says that this file has been installed on my system by the "x11-common" package.

Can you repro your issue on your live CD? Also, are you using ubuntu, kubuntu or xubuntu? Maybe it's broken on some of them and not all of them? I use ubuntu myself.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Martin Olsson wrote:
> FWIW, the file /etc/X11/rgb.txt does exist (and gcolor2 shows the
> pre- defined colors properly) on my cleanly install ubuntu jaunty
> system (didnt check with live CD though). Also, if I run "dpkg -S
> /etc/X11/rgb.txt" it says that this file has been installed on my
> system by the "x11-common" package.
>
> Can you repro your issue on your live CD? Also, are you using
> ubuntu, kubuntu or xubuntu? Maybe it's broken on some of them and
> not all of them? I use ubuntu myself.
>

This is a fresh install of Ubuntu Jaunty. I've also reproduced this on
a freshly install virtual machine (Ubuntu Jaunty as well) and the live
CD. On all of them gcolor2's preset color list is empty and rgb.txt is
nowhere to be found. I found /etc/X11/rgb.txt on one of my other
systems that has been upgraded numerous times, most likely left over
from a previous release. Oddly on that system dpkg -S reports that it
is in the x11-common package yet it's clearly not in there as I
checked the file list myself.

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQEcBAEBCAAGBQJKCfq2AAoJEIltSrFpUGtenEQIAMJTV/SVJUvsPTNpsAKOpdE1
eRQ4/qq9GHG0hEhOaXF+TSx02gaMt4cxQ3MHLOakxfZ4Ptr2wKtGusiGDXNEOj2i
BQu0nuxV+IBCBrisiR4VJ3ZrXAwaL1eYPta9YqOjwuo23Z/WOQdtYhsne4JYPNXH
x8UYYCWdzhmg8QzRcIK60hWbtxpEzBIi34wzY7xOPQMW4iXc0YjdLB3pN5Ogc+rC
h3jcQxMRk0a6VQZmud0fF8UWEOoMrtpbxRoKZBHfFN3sOX5lr/6gM04CTIZlq/VO
uzqLSYP50bBmxFNDVhqGU8Z8oqJfpdLIuk57Pd9Pz318DCtHdpRTYeEaQpDHfxQ=
=6RWx
-----END PGP SIGNATURE-----

Cruncher (ubuntu-wkresse) wrote :

Same here, upgraded since Edgy, to Xubuntu Jaunty. Martin, your system really is a clean install onto new file system?

Martin Olsson (mnemo) wrote :

Sorry I wrong. I ran those commands in a ssh terminal which was logged into a machine that has been upgraded since gutsy. I checked again on my cleanly installed jaunty box and there I don't have the file anywhere in /usr and not under /etc either, despite having x11-common and gcolor2 installed. If I open gcolor2 the colors and indeed missing on this machine just as you suggested.

I also grepped the upstream xserver git tree and found this:

commit d0dd649035fc3698c5b436f9d9d248116aa106a3
Author: Jon TURNEY <email address hidden>
Date: Thu Feb 12 16:03:16 2009 +0000

    Remove references to rgb.txt from files section of Xserver and Xorg man pages

    The references to this file in the server code were removed in commit dda10c9066a660b647384179f82e1da8e063264f

    Signed-off-by: Jon TURNEY <email address hidden>

commit dda10c9066a660b647384179f82e1da8e063264f
Author: Daniel Stone <email address hidden>
Date: Mon Nov 5 16:28:35 2007 +0000

    Remove all traces of external RGB database (and Speedo)

    Remove all references to an external RGB database (which hasn't been enabled
    for a very long time). Also get rid of some references to Speedo fonts.

Martin Olsson (mnemo) wrote :

To me it sounds like gcolor2 should just ship it's own copy in a file called /usr/share/gcolor2/predefined_colors.txt or similar? The gcolor2 package hasn't been modified in ubuntu since 2006 and 0.4 is still the latest upstream release, so I think you should just prepare a debdiff that drops a patch in the debian/patches for this ubuntu package (and the CC it to debian maybe).

You can find step by step instructions on how to prepare a debdiff here:
https://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff

Once you have attached a debdiff to the bug, request sponsporship for upload by subscribing the MOTU team:
https://wiki.ubuntu.com/SponsorshipProcess

Cruncher (ubuntu-wkresse) wrote :

As I mentioned earlier, IMHO trying to "fix" every single package that requires rgb.txt by supplying each of these packages with a standalone copy of said file would be a pretty...strange solution to the problem.
rgb.txt is the *definition* of a shared file, so all that is required is a place and package where rgb.txt is distributed with. Apparently somewhere a similar discussion happened in the past at least once, as rgb.txt already shifted places between the x11-common and xrgb packages, and probably others, in addition to several shifts within the filesystem itself.

So somebody should make a decision where to include the file (once), and where to place it in the FHS (e.g., /etc/X11 "Configuration files for the X Window System, version 11", or /usr/share "Architecture-independent (shared) data"). But there's no point in demanding that every package using this exact same file should include its own copy.

Martin Olsson (mnemo) wrote :

It would be helpful if someone assembled a list of all the packages that are known to be broken by missing rgb.txt

The file is 17K so in terms of disk space the reuse is not essential imo. However, if you prefer to reuse a common file (which is clearly a more _clean_ solution), please create a package for rgb-color-data or such and make them all depend on it. If you choose this approach get the fix into Debian first and let it sync to Ubuntu.

As Timo pointed out above ( https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/300935/comments/14 ); as far as the X server goes, Ubuntu is likely to follow upstream. It's a bad idea to ship data files in the xserver-xorg-core package which is not related to the X server. The only way Ubuntu would be shipping rgb.txt in the core X server package is if upstream puts it back for some reason (you could always file an upstream bug for X to see if this is an option).

draco (draco31-fr) on 2009-05-21
description: updated
tags: added: gcolor2 giftrans sng
draco (draco31-fr) wrote :

@ Zorzella,
I mentionned the broken link directly on the bug report.

@ Martin,
For each new comment, I try to update the list of broken apps on the bug description.

So please, first read carrefully the description in the bug report. If you think something has not been mentionned or is not clear enough, leave a comment !

Thank's to all for your help in solving this bug !
I hope this very little file will find its own place inside a nice package for the happyness of all ubuntu users.

PS : I'm a french user, so maybe my english is poor and maybe I don't use the correct words for those description, so let me know if you couldn't understand me.

Shawn McMahon (smcmahon) wrote :

Also breaks clusterssh.

draco (draco31-fr) on 2009-06-04
description: updated
tags: added: clusterssh netpbm vnc4server x3270
morr (michael-orr25) wrote :

kde4 color change dialog is also broken (see attached screenshot).

Pablo Di Noto (pablo-dinoto) wrote :

Using 9.04 with all updates, on i386 and amd64.

I confirm the issue also affects tightvncserver (v1.3.9, there is a v1.3.10 but it does not seem to include its own /etc/X11/rgb.txt).

This missing file is causing a lot of cascading side effects (like lots of X apps not working when the X server cannot provide that name to color mapping). It took me several hours to find the real reason.

Downloading a rgb.txt file as suggested worked as workaround.

Timo Aaltonen (tjaalton) wrote :

This is now fixed in karmic.

Changed in xorg (Ubuntu):
status: Triaged → Fix Released
Cruncher (ubuntu-wkresse) wrote :

Thanks!
May I ask how it has been resolved?

Timo Aaltonen (tjaalton) wrote :

 xorg (1:7.4+1) unstable; urgency=low
   .
   .
   * Re-add rgb.txt, some clients still use it, even though the server doesn't.
   .
   .

 -- Julien Cristau <email address hidden> Thu, 09 Apr 2009 00:52:17 +0100

fermulator (fermulator) wrote :

Can we also please have this fix backported to Intrepid and Jaunty?

It's pretty severe (clearly affecting many applications used by many Ubuntu users).

Also causes Octave/Gnuplot under Xrdp to produce mostly black plots and multiple of the error gnuplot: unable to parse 'color'. Using black. The fix is to copy or symlink rgb.txt to /usr/share/X11/rgb.txt See: https://bugs.launchpad.net/ubuntu/+bug/420753.

Also break 'xball'
# xball
color_list::get_rgb4_names: Opening rgb.txt file: /etc/X11/rgb.txt: No such file or directory

Also breaks 'xball'
# xball
color_list::get_rgb4_names: Opening rgb.txt file: /etc/X11/rgb.txt: No such file or directory

ddouthitt (ddouthitt) wrote :

I echo the sentiment previously expressed: this should be fixed in previous versions of Ubuntu like Jaunty and Intrepid. It's not hard to do; what's the hold up?

Florian Diesch (diesch) wrote :

ddouthitt <email address hidden> writes:

> I echo the sentiment previously expressed: this should be fixed in
> previous versions of Ubuntu like Jaunty and Intrepid. It's not hard to
> do; what's the hold up?

I second this.

   Florian
--
<http://www.florian-diesch.de/software/pdfrecycle/>

Jonathan Reed (jdreed) wrote :

Although this has been fixed in Karmic (it'sin x11-common), it's still missing in Jaunty. Can we get an update to x11-common on Jaunty that includes this 17K file?

Changed in xorg (Ubuntu):
status: Fix Released → Confirmed
Bryce Harrington (bryce) on 2010-02-25
tags: added: xubuntu
Timo Aaltonen (tjaalton) wrote :

This is fixed in the , don't change the status. I'll decline this for intrepid which is obsolete soon anyway. If you want this in jaunty, create a debdiff and get a sponsor to upload it to -proposed.

Changed in xorg (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments