60x11-common_xdg_path uses $DESKTOP_SESSION which needs a sanity check

Bug #1668722 reported by Martin Nicholas on 2017-02-28
60
This bug affects 12 people
Affects Status Importance Assigned to Milestone
SDDM
Unknown
Unknown
sddm (Ubuntu)
High
Simon Quigley
Bionic
High
Simon Quigley
xorg (Ubuntu)
Wishlist
Unassigned
Bionic
Wishlist
Unassigned

Bug Description

This file:
/etc/X11/Xsession.d/60x11-common_xdg_path
contains references to $DESKTOP_SESSION variable.

On one of my Ubuntu installs this variable contains: "plasma",
on the other it contains: "/usr/share/xsessions/plasma".

I don't know where either example comes from, but the upshot is that
paths are added to XDG_DATA_DIRS and XDG_CONFIG_DIRS that don't exist.
MANDATORY_PATH is also affected I believe, maybe others.

Surely a sanity check of the generated paths is in order. Seems pointless to add non-existent ones.

$XDG_SESSION_DESKTOP looks like a replacement for $DESKTOP_SESSION, but is that true?

Cheers!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Adrien Beau (adrienbeau) wrote :

DESKTOP_SESSION is created by the display manager.

In particular, SDDM puts an absolute path in DESKTOP_SESSION, which seem to be quite distinct from what other managers are doing. I have opened https://github.com/sddm/sddm/issues/852 about that matter.

However, the 60x11-common_xdg_path could be made to produce better XDG paths. This scripts was created by Ubuntu (see https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/804734 for the context), so Ubuntu should fix it if need be.

Note that nothing says the paths in such variables have to be valid. The users of these variables should be ready for invalid path (simply switch to the next one in the list).

Simon Quigley (tsimonq2) on 2018-02-09
tags: added: rls-bb-incoming
Simon Quigley (tsimonq2) on 2018-02-09
tags: removed: rls-bb-incoming
Simon Quigley (tsimonq2) on 2018-02-09
Changed in xorg (Ubuntu):
importance: Undecided → High
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) on 2018-02-09
Changed in xorg (Ubuntu Bionic):
milestone: none → ubuntu-18.02
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1668722

tags: added: iso-testing
Simon Quigley (tsimonq2) wrote :

So it seems that the problem is not that xorg doesn't set DESKTOP_SESSION correctly, it's that SDDM uses an absolute path for this instead of just the base name like every other window manager.

I'll fix it in Ubuntu; meanwhile, a bug is filed upstream. Linked here.

Changed in xorg (Ubuntu Bionic):
status: Confirmed → Invalid
importance: High → Wishlist
assignee: Simon Quigley (tsimonq2) → nobody
Changed in sddm (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) on 2018-02-11
Changed in sddm (Ubuntu Bionic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sddm - 0.14.0-4ubuntu2

---------------
sddm (0.14.0-4ubuntu2) bionic; urgency=high

  * Don't use an absolute path when setting $DESKTOP_SESSION (LP: #1668722).

 -- Simon Quigley <email address hidden> Sat, 10 Feb 2018 18:25:09 -0600

Changed in sddm (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.