Cannot log in to kubuntu after update (Intel graphics + ksshaskpass)

Bug #1623969 reported by Alan Robertson on 2016-09-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Low
Unassigned

Bug Description

I just took some updates to a number of graphic libraries on 16.04, and now I can't login to kubuntu. The symptom is that it takes my password on the greeter screen, but never updates the screen after that.

The messages include these possibly related kernel messages:
kernel: [ 701.564034] [drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe B
kernel: [ 701.564054] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun

I'm currently running kernel 4.4.0-36.

Here are my most recent updates. The problem started after I rebooted. Of course that was the next time I logged in too...

Start-Date: 2016-09-07 08:46:04
Commandline: /usr/bin/unattended-upgrade
Remove: libcdaudio1:amd64 (0.99.12p2-14), linux-image-extra-4.2.0-36-generic:amd64 (4.2.0-36.42), linux-image-extra-4.4.0-22-generic:amd64 (4.4.0-22.40), gtk2-engines-murrine:amd64 (0.98.2-0ubuntu2.1), linux-image-extra-4.4.0-24-generic:amd64 (4.4.0-24.43), libslv2-9:amd64 (0.6.6+dfsg1-3build1), linux-image-extra-4.4.0-28-generic:amd64 (4.4.0-28.47), linux-image-extra-4.4.0-31-generic:amd64 (4.4.0-31.50), libfaac0:amd64 (1.28+cvs20151130-1)
End-Date: 2016-09-07 08:48:13

Start-Date: 2016-09-07 16:42:27
Install: libgnome-keyring-common:amd64 (3.12.0-1build1, automatic), libgnome-keyring0:amd64 (3.12.0-1build1, automatic)
Upgrade: libgles2-mesa:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libgles1-mesa:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libglapi-mesa:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libglapi-mesa:i386 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), p11-kit:amd64 (0.23.2-3, 0.23.2-5~ubuntu16.04.1), libxatracker2:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libegl1-mesa-drivers:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libegl1-mesa:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libegl1-mesa:i386 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), p11-kit-modules:amd64 (0.23.2-3, 0.23.2-5~ubuntu16.04.1), libgbm1:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libgbm1:i386 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), cups-filters:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), chromium-browser:amd64 (51.0.2704.79-0ubuntu0.16.04.1.1242, 52.0.2743.116-0ubuntu0.16.04.1.1250), libcupsfilters1:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), chromium-codecs-ffmpeg-extra:amd64 (51.0.2704.79-0ubuntu0.16.04.1.1242, 52.0.2743.116-0ubuntu0.16.04.1.1250), libwayland-egl1-mesa:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libfontembed1:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), libgl1-mesa-dri:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libgl1-mesa-dri:i386 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), cups-filters-core-drivers:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1), libgl1-mesa-glx:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libgl1-mesa-glx:i386 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), libp11-kit0:amd64 (0.23.2-3, 0.23.2-5~ubuntu16.04.1), libp11-kit0:i386 (0.23.2-3, 0.23.2-5~ubuntu16.04.1), mesa-vdpau-drivers:amd64 (11.2.0-1ubuntu2.1, 11.2.0-1ubuntu2.2), chromium-browser-l10n:amd64 (51.0.2704.79-0ubuntu0.16.04.1.1242, 52.0.2743.116-0ubuntu0.16.04.1.1250), ubuntu-mono:amd64 (14.04+16.04.20160621-0ubuntu1, 14.04+16.04.20160804-0ubuntu1), cups-browsed:amd64 (1.8.3-2ubuntu3, 1.8.3-2ubuntu3.1)
End-Date: 2016-09-07 16:44:34

Start-Date: 2016-09-12 14:31:39
Commandline: /usr/sbin/synaptic
Requested-By: alanr (1000)
Upgrade: snapd:amd64 (2.13, 2.14.2~16.04), libappstream-glib8:amd64 (0.5.13-1ubuntu2, 0.5.13-1ubuntu3), neo4j:amd64 (3.0.4, 3.0.5), accountsservice:amd64 (0.6.40-2ubuntu11.1, 0.6.40-2ubuntu11.2), libaccountsservice0:amd64 (0.6.40-2ubuntu11.1, 0.6.40-2ubuntu11.2)
End-Date: 2016-09-12 14:32:17

It was after rebooting after updates that this occurred. My workaround is "rm -fr ~/.kde" - and that allows me to log in. I'm crippled, but at least I can log in...

If I try to log in again without doing this, the problem recurs. This happens even if I just log in and log back out, and try to log in again.

However, I may just found a better workaround - press ALT-CTRL-F1 then ALT-CTRL-F7, and then the next chunk of the login sequence occurs.

This makes it consistent with an issue reported in AskUbuntu http://askubuntu.com/questions/765364/kubuntu-16-04-sddm-login-screen-hangs

And it's possibly related to bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1550779 - because of the CPU underrun being apparently related to graphics.

In fact, each time I do this, I get a little further in the login sequence. It appears that the trigger for this bug is likely the prompts to provide passwords for my various ssh private keys (I have four). This also includes prompts from the KDE wallet manager for me to use the KDE wallet - and I don't use that feature.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
Uname: Linux 4.4.0-36-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Sep 15 07:53:07 2016
DistUpgraded: 2016-05-25 14:07:14,644 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1043:8534]
InstallationDate: Installed on 2014-07-12 (795 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.1)
MachineType: ASUS All Series
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-36-generic root=UUID=1b9b0c50-d4ac-471c-a09a-0ee1cad092e4 ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: Upgraded to xenial on 2016-05-25 (112 days ago)
dmi.bios.date: 01/16/2014
dmi.bios.vendor: ASUSTeK COMPUTER INC. (Licensed from AMI)
dmi.bios.version: 1707
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: P9D WS
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnASUSTeKCOMPUTERINC.(LicensedfromAMI):bvr1707:bd01/16/2014:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnP9DWS:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: All Series
dmi.product.version: System Version
dmi.sys.vendor: ASUS
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.2
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2.2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Thu Sep 15 07:51:50 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 9393
 vendor ACI
xserver.version: 2:1.18.3-1ubuntu2.3

Alan Robertson (alanr-unix) wrote :

Alan Robertson, thank you for reporting this and helping make Ubuntu better.

To clarify, if you boot into the kernel prior to the update, does this issue go away?

tags: added: bios-outdated-2202 regression-update
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Alan Robertson (alanr-unix) wrote :

Hi Christopher M. Penalver (@penalvch),

I have tons of old kernels to choose from. What one would you like for me to try?
Here are the choices:
vmlinuz-3.19.0-28-generic vmlinuz-3.19.0-41-generic vmlinuz-4.2.0-36-generic
vmlinuz-3.19.0-30-generic vmlinuz-3.19.0-42-generic vmlinuz-4.4.0-22-generic
vmlinuz-3.19.0-31-generic vmlinuz-3.19.0-43-generic vmlinuz-4.4.0-24-generic
vmlinuz-3.19.0-32-generic vmlinuz-3.19.0-47-generic vmlinuz-4.4.0-28-generic
vmlinuz-3.19.0-33-generic vmlinuz-3.19.0-49-generic vmlinuz-4.4.0-31-generic
vmlinuz-3.19.0-37-generic vmlinuz-3.19.0-51-generic vmlinuz-4.4.0-34-generic
vmlinuz-3.19.0-39-generic vmlinuz-3.19.0-56-generic vmlinuz-4.4.0-36-generic

By the way, I did try this before, and I think it worked, but I had trouble with USB devices afterwards (or so I remember). Since my mice are USB, that was a problem.

So it would be helpful to me for you to suggest which kernel you would like for me to try...

Something I forgot to say...
When I remove all the .kde stuff and it boots up correctly (but crippled due to all my config missing), then the fifo underrun does _not_ occur. It occurs only once per login.

Alan Robertson, feel free to start with the oldest, and advise to the results.

Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired
Alan Robertson (alanr-unix) wrote :

Sorry I didn't update this, but somewhere along the line, the problem went away - after another set of updates. I'm not sure which one(s). But it is definitely working again.

moontan (axel-kirch) wrote :

I'm unsure if I understand the above but I have the same problem on a fresh install of kubuntu 16.04.1 and it occurred after I did a reboot just after changing my user password via the user manager in the system settings. Having switched to the tty1 command line from the frozen kde login I noticed that ecryptfs-mount-private still only accepted my old user password to unlock my home folder. When I changed the user password back to the original one, kde login worked again. Hopefully this observation helps.

Alan Robertson (alanr-unix) wrote :

@moontan - that sounds like a completely different bug. This bug is a graphics driver bug, and yours appears to be something to do with needing to ecryptfs key management. I wasn't using ecryptfs at all.

Alan Robertson (alanr-unix) wrote :

Please delete the words "needing to" from comment #8.

Alan Robertson, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1623969/comments/6 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in xorg (Ubuntu):
status: Expired → Invalid
Curtis Gedak (gedakc) wrote :

Recently I encountered this problem and discovered a solution. I posted my solution at:

kubuntu 16.04 SDDM login screen hangs
https://askubuntu.com/questions/765364/kubuntu-16-04-sddm-login-screen-hangs/874972#874972

For completeness sake, I will also repost the solution here.

----------

Recently I encountered this problem with kubuntu 16.04 SDDM login screen hangs. The issue occurred after I installed kubuntu 16.04 on an Intel i7-7700k with Intel 630 HD graphics and then updated to the latest packages.

I was able to login using the workaround of using Ctrl+Alt+F1 to get to a text console and then Ctrl+Alt+F7 to get back to X and the logged in session.

I stumbled upon a fix to the login hang while I was working to get rid of a screen tearing problem. The fix involves changing the compositor rendering backend from XRender to OpenGL.

More specifically to address the hang on login and problem with screen
tearing I did the following:

FIX SCREEN TEARING AND LOGIN HANGING
------------------------------------

A) Start K -> Settings -> System Settings
     Under Hardware section
     Double-click Display and Monitor
       Choose Compositor on LHS
         Enable compositor on startup: Checked # was checked
         Rendering backend: OpenGL 3.1 # was XRender
         OpenGL interface: GLX
         Tearing prevention ("vsync"): Full screen repaints # was Automatic
          Ignore message "Full screen repaints" can cause performance problems.
       Click Apply

    REFERENCES:

    Bug 321589 - Automatic VSync strategy causes tearing
    https://bugs.kde.org/show_bug.cgi?id=321589

    Screen Tearing on Kubuntu 16.04 with Intel Drivers?
    https://askubuntu.com/questions/764302/screen-tearing-on-kubuntu-16-04-with-intel-drivers

B) Set KWIN variables.

    Edit /etc/environment and add the top and bottom line:

    __GL_YIELD="USLEEP"
    #KWIN_TRIPLE_BUFFER=0
    KWIN_USE_BUFFER_AGE=0

    REFERENCES:

    https://community.kde.org/KWin/Environment_Variables
    https://askubuntu.com/questions/764302/screen-tearing-on-kubuntu-16-04-with-intel-drivers/774788

    Listed as also working with NVidia.

I hope the above steps help others get rid of the login hang and screen tearing problems.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.