tty1-6 don't work in gutsy

Bug #148746 reported by Christopher Denter on 2007-10-03
2
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Hi,
I am experiencing problems with switching to tty1-6 on my laptop and desktop machine.
[I added a description of my issue to this bug: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/119585
Brian Murray, however, asked me to create a new bug-report because he thinks it's a different issue.
So here it is.]
-- c&p --
I have several machines running gutsy with latest updates.
Among others, one laptop and one desktop that is connected to a 19" LCD TFT.

*Both* of them cannot display the Command Line Interface on tty1-6. The laptop then dies with very ugly stripes until I get it back to STRG+ALT+F7. The TFT on my desk just goes blank.
The desktop expects a password (for hdd decryption) at boottime. You see this sucks since I cannot tell when it's ready to take the password.
This furthermore is a problem if you need to get some command executed on tty1-6. (Or you want to use the Recovery Console. I didn't check if that fails to, but I guess it does.)

In my opinion this definitely needs to be fixed.
(If you search the bug tracker here for the terms "gutsy" and "lcd" you get a whole bunch of bugreports. I chose this to report my bug to but I may have taken another.)
(These are the files of the desktop which I have upgraded to gutsy. The laptop had a fresh install with Tribe 5 and was upgraded to the latest available version.)
-- /c&p --

xorg.conf Desktop: http://launchpadlibrarian.net/9708368/xorg.conf
xorg.log Desktop: http://launchpadlibrarian.net/9708375/Xorg.0.log
menu.lst Desktop: http://pastebin.ca/724775

The Desktop has the following graphics-hardware:
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
Running with nvidia-glx-new.

The laptop has a ATI Radeon XPRESS 200M, running the standard-driver. (I could install fglrx or do anything you need me to do to help fixing this bug.)

I still want to help getting this fixed as soon as possible. So if you need anything, let me know.

regards

Christopher Denter (dennda) wrote :

Err.
I thought I had tried this without success.
If I remove vga=XXX from menu.lst, it works (although font size is too big).
I will check if this also works for the laptop.

But nevertheless this is strange, since I only upgraded this system from feisty.
VGA=XXX worked with feisty without any issue.

regards

Albert Damen (albrt) wrote :

dennda, this sounds much like bug 129910, although that only mentions the black screen in the consoles, not the stripes.
Could you check from gnome terminal if the tty's are active (i.e. with ps ax | grep -i tty)?
Also, you can try to login on tty1 blindly. Then ps ax would show if you are logged in.

Changed in xorg:
status: New → Incomplete
Christopher Denter (dennda) wrote :

Hi.
albert, removing the vga=xxx line works on the desktop. I can then switch between tty1-6, although the fontsize is too big.
On the laptop I logged in blindly (didn't remove that option yet, I need some work to be done with the laptop) and "who" told me it worked.
I guess the laptop cannot handle the mode and displays random pixels.

So I am quite sure this is a duplicate of the bug you mentioned.
Sorry for this. I will do my research better next time, promise.

Thanks for your help.
regards

Albert Damen (albrt) wrote :

No problem dennda, and thanks for the confirmation!

Caesarivs (caesarivs) wrote :

Same issue here

While I try to access a tty from X hitting Ctrl+Alt+F[1-6] I get a blank screen, if I remove the vga=XXX from the kernel line I can see the tty output, but here's my problem, if I'm on X, I try to go to a tty and my computer freezes, and since the first time when I rebooted my pc I got a message saying that HAL failed to initiate :S

Help me, PLEASE :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers