significant memory leak in xserver 1.2

Bug #92882 reported by Colin Watson on 2007-03-16
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
xorg-server (Ubuntu)
High
Unassigned

Bug Description

According to the linked freedesktop bug, there's a sizeable memory leak in xserver 1.2. We should investigate this for the Feisty beta.

Related branches

Colin Watson (cjwatson) on 2007-03-16
Changed in xorg-server:
importance: Undecided → High

I've attached the patch that should fix this problem; I'm applying this on my edgy version of Xorg 7.2 available at http://ubuntuforums.org/showthread.php?t=373087

I'll let you know if it works as reported by other users (first of all ones from gentoo)...

Changed in xorg-server:
status: Unknown → Confirmed
berserker (ejwahl) wrote :

Treviño's patched edgy version appears to be working. Running Xorg 7.2 for 12 hours now and memory usage is 75 Mb on a system with 2 GB RAM (unpatched version was using 400-500 MB after 12 hours).

Changed in xorg-server:
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) wrote :

fixed with this upload:

 xorg-server (2:1.2.0-3ubuntu4) feisty; urgency=low
 .
   * debian/patches/107_fedora_dont_backfill_bg_none.patch:
     - Re-enable to see if it helps with performance regressions.
   * debian/patches/127_check_for_clientgone.patch:
     - A fix from upstream. (LP: #60288)
   * debian/patches/128_fix_client_privates_leak.patch
     - Plug a memory leak. (LP: #92882)
   * debian/rules
     - Fix a typo in --with-default-font-path.

Changed in xorg-server:
status: Unconfirmed → Fix Released
Dmitry Hazin (dhazin) wrote :

are there any feisty repos available to perform upgrade?

The patch should be provided by official repos, as mentioned on Timo's changelog...

Xamusk (ronanpaixao) wrote :

well, where is the fix in the official repos?
did someone take it out again?
I'm using xorg-server-core 2:1.2.03ubuntu8 and the first line at top shows this:

 PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 8012 root 15 0 424m 91m 9656 S 1 9.2 16:30.74 Xorg

and that's even with memory-hungry-firefox closed.
I think the leak is still out there.
By the way, uptime reports 11:22h up.

jtp0142 (jtp0142) wrote :

The leak is definitely still out here - and I can confirm it in both the 32 and 64 bit versions.

Is there a package or instructions for a patch? This is a nasty little bug, requiring many x-server restarts for those of us with ~1 gig of memory.

Thanks

Timo Aaltonen (tjaalton) wrote :

jtp0142: make sure it's the same leak, and not due to firefox+flashplugin eating memory (see bug 98783)

jtp0142 (jtp0142) wrote :

It's not - neither machine has the flashplugin installed, and we are able to recreate the problem without any web browser running. We would really love to patch this and get this fixed, it is extremely annoying. I dont remember it happening in the Feisty herds either, if that helps.

Hello,

The solution proposed in https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/186354 worked for me: disable xinerama.

On ubuntu 9.04 (using an Intel GMA chipset), I added this at the bottom of my /etc/X11/xorg.conf file and then had no more problem after restarting the X server:

Section "Serverflags"
    Option "Xinerama" "false"
Endsection

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.