"sudo strace -p $(pgrep X)" hangs system after a few seconds

Bug #533622 reported by Daniel Hahler on 2010-03-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

I've tried "sudo strace -p $(pgrep X)" in a KDE konsole to see what Xorg was doing that may cause high cpu load.

After a few seconds and lot of output, the system hung and I could not switch to another VT, but music kept playing in the background.
Doing the REISUB sequence, the system restartet after Alt-SysRq-R or -E already.
This was reproducible (I've tried it twice), the restart however appeared only once: it required a hard reset the other time.

This is probably related to the generated output, since it did not happen on VT1 after reboot, where I've used "-o outputfile" though.

Using "sudo strace -p $(pgrep X) -o /tmp/1" and "tail -f /tmp/1" also does not cause the hangup.

ProblemType: Bug
Architecture: i386
Date: Sun Mar 7 04:06:46 2010
DistroRelease: Ubuntu 10.04
Lsusb:
 Bus 002 Device 004: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0
 Bus 002 Device 002: ID 1a7c:0068
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
NonfreeKernelModules: nvidia
Package: xserver-xorg-core 2:1.7.5-1ubuntu2
ProcCmdLine: root=UUID=73d091ef-8ee9-4ad2-9243-1ece878c1024 resume=/dev/fastrcvg/swaplv ro acpi_use_timer_override usbcore.autosuspend=1 splash
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: xorg-server
Uname: Linux 2.6.32-15-generic i686
dmi.bios.date: 03/08/2007
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F9c
dmi.board.name: NF-CK804
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF9c:bd03/08/2007:svn:pn:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnNF-CK804:rvrx.x:cvn:ct3:cvr:
system:
 distro: Ubuntu
 codename: lucidarchitecture: i686kernel: 2.6.32-15-generic

Daniel Hahler (blueyed) wrote :
description: updated
Daniel Hahler (blueyed) on 2010-03-07
description: updated
Bryce Harrington (bryce) on 2010-03-07
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-03-10
tags: added: kubuntu
Daniel Hahler (blueyed) wrote :

I've just tried reproducing it in a virtualbox guest on Windows, but it kept running for ~1 minute without problems.
I will retry it on my Ubuntu machine at home later.

Daniel Hahler, reproducible on a Trusty host with a Trusty guest as noted in the Bug Description. I'm aware the advised method of debugging xorg problems is via gdb -> https://wiki.ubuntu.com/X/Backtracing . However, this may not be preferred for folks who are used to utilizing strace.

Changed in xorg-server (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: amd64 trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers