Ubuntu

wine fullscreen app makes X server crash on jaunty

Reported by samuel782 on 2009-02-20
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Unassigned

Bug Description

On a Samsung Laptop running Kubuntu Jaunty (with latest package upgrades), the X server crashes when I run the Game "Age of Empires II: The Conquerors" with wine in fullscreen mode.

Apparently, the crash happens during or shortly after the app tries to change the screen resolution for the introductory video sequence (screen flickering).

I filed a bug for wine already, but it got rejected on the grounds that wine (when run as a user) can never crash the X server if it isn't for a buggy server or video card driver.

So I'm guessing that when changing screen resolution, maybe wine does some weird stuff which it shouldn't, and this causes X.org to crash which it definitely shouldn't. This bug report is supposed to address the second issue now.

For the sake of comparison, the following scenarios do NOT produce the problem:
  - Running the game with wine configured to emulate a virtual desktop inside an X window (In this case, the containing window resizes itself as needed and all pre-game videos as well as the game itself run fine)
  - running Globulation2 (a Linux SDL game which also changes the screen resolution) in fullscreen mode
  - manually changing the screen resolution with krandrtray

Hardware info:

Samsung X20 Laptop with "Intel Corporation Mobile 915GM/GMS/910GML Express" graphics card.

Package info:

wine 1.1.15
xserver-xorg 1:7.4~5ubuntu12
xserver-xorg-core 2:1.5.99.902-0ubuntu7
xserver-xorg-video-intel 2:2.6.1-1ubuntu2

Debug output:

I ran a blank "startx /usr/bin/xterm" session (just to rule out any kwin/kdm influences), then changed directory and ran "wine age2_x1.exe" in that xterm (resulting in the described X server crash), and saved the Xorg.0.log (see attachment).

Backtrace:
0: /usr/bin/X11/X(xorg_backtrace+0x3b) [0x81341bb]
1: /usr/bin/X11/X(xf86SigHandler+0x55) [0x80c76a5]
2: [0xb80dd400]
3: /usr/bin/X11/X [0x80f925b]
4: /usr/bin/X11/X [0x80f9516]
5: /usr/bin/X11/X [0x80f6fa6]
6: /usr/bin/X11/X(RRScreenSizeSet+0x69) [0x8168709]
7: /usr/bin/X11/X(ProcRRSetScreenConfig+0x4a6) [0x8168ee6]
8: /usr/bin/X11/X [0x8161065]
9: /usr/bin/X11/X(Dispatch+0x33f) [0x808d48f]
10: /usr/bin/X11/X(main+0x3bd) [0x80721fd]
11: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7ca7775]
12: /usr/bin/X11/X [0x80716b1]
Saw signal 11. Server aborting.
[ 20.288798] (II) PIXART USB OPTICAL MOUSE: Close
[ 20.288821] (II) UnloadModule: "evdev"
[ 20.288862] (II) AT Translated Set 2 keyboard: Close
[ 20.288910] (II) UnloadModule: "evdev"
[ 20.288973] (II) Macintosh mouse button emulation: Close
[ 20.288984] (II) UnloadModule: "evdev"
[ 20.289021] (II) Video Bus: Close
[ 20.289056] (II) UnloadModule: "evdev"
[ 20.289177] (II) UnloadModule: "synaptics"
[ 20.289195] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 20.952342] (II) intel(0): xf86UnbindGARTMemory: unbind key 0
[ 20.952674] (II) intel(0): xf86UnbindGARTMemory: unbind key 1
 ddxSigGiveUp: Closing log

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
            Subsystem: Samsung Electronics Co Ltd Device c01a
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
            Subsystem: Samsung Electronics Co Ltd Device c01a

samuel782 (sscharrer) wrote :
samuel782 (sscharrer) wrote :
Bryce Harrington (bryce) wrote :

Are you able to reproduce this issue on Jaunty? If so, please collect a full backtrace - see http://wiki.ubuntu.com/X/Backtracing for directions.

description: updated
Changed in xorg:
status: New → Incomplete
samuel782 (sscharrer) wrote :

I don't have access to a second computer from which I can ssh into this one, so I can't collect a backtrace using the method described in that article.

Is there a way to get the backtrace using only the affected machine? Maybe it will help that no user interaction is really needed to produce the crash - For example, "xinit -e ./start_aoe2" will start Xorg and crash ist right away (with start_aoe2 being a bash script that cd's to the right directory and runs "wine age2_x1.exe"). However, I don't know how to hook up /usr/bin/Xorg with gdb in this case.

If someone could give me a hint as to what to do, I'd be happy to try it.

Bryce Harrington (bryce) wrote :

Yeah, you can try running from a console terminal, assuming the crash doesn't screw up the vt's too.

Changed in xorg-server:
status: Incomplete → New
status: New → Incomplete
samuel782 (sscharrer) wrote :

So, how do I collect the backtrace in this case?

Bryce Harrington (bryce) wrote :

er, log into the console, fire up gdb xinit, then run e ./start_aoe2 or whatever. crash, 'bt full', attach log here, done.

Lots more docs on tips and tricks are in the X section of the wiki if you need to know more.

Changed in xorg-server (Ubuntu):
importance: Undecided → High
Pauli (paniemin) wrote :

I think I'm facing similar X crash in Jaunty. I'm trying to start civilization IV and it crashes when engine is trying to start.

system:
radeon r500 graphics card
everything upgraded to the latest in jaunty
I did try to fix crash with self compiled mesa r300 driver but no help there

Bryce Harrington (bryce) on 2009-04-07
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-04-21
description: updated
Alex F (frase) wrote :

Same problem. At first I was using the nvidia binary driver from the repository (180.44), and that crashed the X server as soon as a fullscreen game launched (Starcraft, in my case). I removed that and replaced it with the binary driver straight from nvidia (180.51) and then Starcraft started ok, but as soon as I exited, X crashed again. Setting everything to run in a virtual desktop seems to work around it for now.

Robin Sheat (eythian) wrote :

I see something similar in Jaunty, attempting to run Oni in Wine. The screen res changes to show the intro movie, when that finishes or is skipped, X crashes leaving this in the log:

(II) NVIDIA(0): Setting mode "640x480"

Backtrace:
0: /usr/X11R6/bin/X(xorg_backtrace+0x26) [0x4f1b66]
1: /usr/X11R6/bin/X(xf86SigHandler+0x41) [0x485a61]
2: /lib/libc.so.6 [0x7f69306b1040]
3: /usr/X11R6/bin/X [0x4b77f7]
4: /usr/X11R6/bin/X [0x4b7b95]
5: /usr/X11R6/bin/X [0x49faa9]
6: /usr/X11R6/bin/X [0x49fc63]
7: /usr/X11R6/bin/X(RRCrtcSet+0x159) [0x51f0a9]
8: /usr/X11R6/bin/X(ProcRRSetScreenConfig+0x4b6) [0x524ae6]
9: /usr/X11R6/bin/X(Dispatch+0x364) [0x44e304]
10: /usr/X11R6/bin/X(main+0x3bd) [0x433d8d]
11: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f693069c5a6]
12: /usr/X11R6/bin/X [0x433219]
Saw signal 11. Server aborting.

This is 64-bit Ubuntu, binary nvidia driver.

Same problem. With wine, Total Annihilation crashes when the game tries to switch resolution. I experience this strange flickering on the screen as well, and the game image is not placed correctly on the screen when in full screen mode. I saw a similar flickering, and crash with native Alpha Centauri as well.

Backtrace:
0: /usr/X11R6/bin/X(xorg_backtrace+0x3b) [0x813518b]
1: /usr/X11R6/bin/X(xf86SigHandler+0x55) [0x80c7be5]
2: [0xb7ff3400]
3: /usr/X11R6/bin/X [0x8114099]
4: /usr/X11R6/bin/X [0x8124b5b]
5: /usr/X11R6/bin/X [0x80fa366]
6: /usr/X11R6/bin/X [0x80f7dd6]
7: /usr/X11R6/bin/X(RRScreenSizeSet+0x69) [0x8169679]
8: /usr/X11R6/bin/X(ProcRRSetScreenConfig+0x4a6) [0x8169e56]
9: /usr/X11R6/bin/X [0x8161fc5]
10: /usr/X11R6/bin/X(Dispatch+0x33f) [0x808d57f]
11: /usr/X11R6/bin/X(main+0x3bd) [0x80722ed]
12: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7bc2775]
13: /usr/X11R6/bin/X [0x80717a1]
Saw signal 11. Server aborting.

lspci:

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

wine 1.0.1-0ubuntu6
xserver-xorg 1:7.4~5ubuntu18

Montblanc (montblanc) wrote :

The same happens with Tales of Monkey Island on Jaunty with latest upgrades, wine v1.1.25 and nvidia drivers v185.18.14. Wine crashes when trying to change resolution inside game and to set fullscreen on/off.
I'm forced to play with the lowest resolution. A virtual desktop just puts the game on a quarter of the screen and keeps crashing when I try to change resolution and setting fullscreen.

Geryon (nick-demandred) wrote :

TotoKid: I have the exact same set up and saw the exact same results. 1.1.26 was recently released and also yielded the same results. Additionally, I have the same exact problem when playing Team Fortress 2.

I'm not sure how many people my case affects but its not just running wine applications that is a problem. It seems that this bug might be related to a bigger one regarding changing resolutions in general. I have a "Intel Corporation 82852/855GM Integrated Graphics Device" (still using Jaunty) and I get undesired behavior when I change resolutions in two different cases.

First case: If I have no acceleration enabled (in my xorg.conf), when I change resolutions (from my native 1280x768 to something else) I just get a black screen. I know applications are still running because I can hear sounds and still use keyboard shortcuts. I read on some other posts that what I'm experiencing is X unable to "sync" or "vsync". This is also true for wine applications.

Second case: If I do have acceleration enabled (UXA), then when I change resolutions, X crashes and I'm brought back to the log in screen. Thus my crash might not have anything to do with wine applications.

Like I said, this is the behavior I experience on my computer, and I wonder how many other people experience the same behavior.

Hope I was able to shed some light on the bug. A fix for this would be much appreciated!

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Bryce Harrington (bryce) on 2009-09-09
tags: added: crash
Neil Burlock (malone) wrote :

I've found this problem is now happening in a fully updated beta version of Karmic, in this instance, playing Bejewelled in Wine fullscreen throws the user back to the X login screen when exiting. This is with the nVidia binary drivers on 64bit Karmic and it wasn't happening on Jaunty which I replaced this afternoon, by formatting the root partition and doing a complete reinstall, retaining the home partition.

I'm not sure if it's related, but the desktop live CD of Karmic picked a resolution for my BenQ 1080p monitor that could not be displayed during the install and I had to plug in an old 1280x1024 LCD monitor to even get an image. The screen, though set correctly to 1024 pixels, was stretched to twice the height of the display so I couldn't see the bottom half of the screen.

Philipp (philipp-strack-gmail) wrote :

Crash is still present in ubuntu 9.10 karmic koala. When I try to play age of empires 2 or some other game using wine the xserver crashes shortly after the resolution is changed. The game runs normally in virtual desktop mode of wine

John Leach (johnleach) on 2010-01-17
tags: added: karmic
Vetinari (vetinaria) wrote :

I've got a similar bug in Karmic on my Samsung N130.
At a random point of time xorg crashes without an obvious reason.

This is the end of my Xorg.0.log.old:

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x8133d6b]
1: /usr/bin/X(xf86SigHandler+0x55) [0x80c7d35]
2: [0x35b400]
3: /usr/lib/xorg/modules//libfb.so(fbCopyNtoN+0x24c) [0xad07cc]
4: /usr/lib/xorg/modules/drivers//intel_drv.so(uxa_copy_n_to_n+0x74a) [0x49e9fa]
5: /usr/lib/xorg/modules//libfb.so(fbCopyRegion+0x21b) [0xacf76b]
6: /usr/lib/xorg/modules//libfb.so(fbDoCopy+0x44d) [0xacfc8d]
7: /usr/lib/xorg/modules/drivers//intel_drv.so(uxa_copy_area+0x98) [0x49e258]
8: /usr/bin/X [0x8181593]
9: /usr/bin/X(ProcCopyArea+0x165) [0x808b4c5]
10: /usr/bin/X(Dispatch+0x35f) [0x808d17f]
11: /usr/bin/X(main+0x395) [0x8072515]
12: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6) [0x557b56]
13: /usr/bin/X [0x80719c1]
Saw signal 11. Server aborting.
(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) MOSART Semi. USB Composite Device: Close
(II) UnloadModule: "evdev"
(II) MOSART Semi. USB Composite Device: Close
(II) UnloadModule: "evdev"
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) WebCam SCB-0340N: Close
(II) UnloadModule: "evdev"
(II) Sleep Button: Close
(II) UnloadModule: "evdev"
(II) Video Bus: Close
(II) UnloadModule: "evdev"
(II) UnloadModule: "synaptics"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
(II) AIGLX: Suspending AIGLX clients for VT switch
 ddxSigGiveUp: Closing log

Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

Hi samuel782,

This bug was reported against an earlier version of Ubuntu, can you
test if it still occurs on Lucid?

Please note we also provide technical support for older versions of
Ubuntu, but not in the bug tracker. Instead, to raise the issue through
normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on
Lucid, please run the following command to refresh the report:

  apport-collect 332100

If you are not the original reporter, please file a new bug report, so
we can work with you as the original reporter instead (you can reference
bug 332100 in your report if you think it may be related):

  ubuntu-bug xorg

If by chance you can no longer reproduce the issue on Lucid or if you
feel it is no longer relevant, please mark the bug report 'Fix Released'
or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/332100

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) on 2010-05-21
tags: added: kubuntu
tags: added: hardy
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
Lord Panta (panta2mi) wrote :

i have the same problem at run starcraft under wine in lucyd..... xserver crash at close game.....

Changed in xorg-server (Ubuntu):
status: Expired → Confirmed
Jeremy Nickurak (nickurak) wrote :

Same problem with both an ATI X1600, and an intel gma945. Full-screen apps freeze X hard. Native linux full-screen apps are fine.

Jeremy Nickurak (nickurak) wrote :

Seen it under Jaunty through Maverick.

Bryce Harrington (bryce) wrote :

Based on the progression of the comments it sounds to us like the original issue here went away, but folks with vaguely similar (but unrelated) issues are joining this one, however unfortunately since they've not posted their backtraces this (allegedly) new crash bug can't be investigated.

@Panta and Jeremy, please review http://wiki.ubuntu.com/X/Backtracing, reproduce your bug, and file a *new* bug report. Either let apport file it automatically, or file it manually by collecting 'bt full' in gdb and then using 'ubuntu-bug xorg'.

Changed in xorg-server (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers