Ubuntu

[intrepid] mouse and keyboard stop working under gdm and gnome

Reported by marcobra (Marco Braida) on 2008-08-05
88
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xorg (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by VladNistor
xorg-server (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by VladNistor

Bug Description

[intrepid] after today upgrade and dist-upgrade

may be related to upgrade of

xserver-xorg-core 2:1.4.99.905-0ubuntu5 to xserver-xorg-core_2%3a1.4.99.906-1ubuntu1i386.deb

Mouse and keyboard stop working under Gdm and Gnome.

CTRL+ALT+F2 is still working and i can make login, i wait for updates and upgrades typing:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Same issue on 4 of 4 intrepid pc (not same hardware).

Thank you

description: updated
description: updated
Philipp Meier (meier-philipp) wrote :

I can confirm this bug, after today's dist-upgrade keyboard and mouse don't work anymore.

Daniel Holbach (dholbach) wrote :

Philipp: please don't assign bugs to ubuntu-core-dev. It will send emails to ALL core developers.

Changed in xorg:
assignee: ubuntu-core-dev → nobody
Philipp Meier (meier-philipp) wrote :

Ah ok sorry, I have just started with helping out in the bugsquad. What would be the correct package maintainer for xorg?

syscon-hh (syscon-kono) wrote :

I can confirm, too - isn't related to a specific hardware

My system-data: i386, startup without any error-messages, no keyboard-activity related to gdm-login (changing to console 1-6 possible), no mouse-movements after the login-screen appears.

Changed in xorg-server:
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

I can confirm the problem. Adding my mouse and keyboard to the ServerLayout solved the problem.

It's a bug since, as the documentation says, InputDevice entries in the ServerLayout sections are not mandatory.

"One of these entries should be given for each input device being used in a session. Normally at least two are required, one each for the core pointer and keyboard devices. If either of those is missing, suitable InputDevice entries are searched or using the method described above in the INPUTDEVICE section. "

Alberto Milone (albertomilone) wrote :
Timo Aaltonen (tjaalton) wrote :

I'm on it.

Changed in xorg:
status: Confirmed → Invalid
Changed in xorg-server:
assignee: nobody → tjaalton
importance: Undecided → High
ehcpdeveloper (ehcpdeveloper) wrote :

i tested xorg.conf (which is said as working) located at http://launchpadlibrarian.net/16549777/xorg.conf
with xserver-xorg-core_2%3a1.4.99.906-1ubuntu1i386.deb

same problem continues... did not solve my issue. i could not use my mouse/keyb with xwindows, ctrl+alt+f1 works...

i downgraded xserver-xorg-core to xserver-xorg-core 2:1.4.99.905-0ubuntu5
now, xwindows works, keyb/mouse works...

by the way, there should be a way to reverse an upgrade, which caused something to malfunction.... this may be ablueprint...

On another Intrepid pc i have updated/upgraded and apply the Alberto xorg.conf suggestion mouse and keyboard work fine.

Thank you

Tux (peter-hoogkamer) wrote :

I have this same issue, but running Intrepid alpha 3 within a vmware workstation. I did saw a message about not able to create the directory volatile
* Preparing restricted drivers... mkdir: cannot create directory `/lib/modules/2.6.26-5-generic/volatile/': Read-only file system

Maybe this has something to do with not being able to grab my mouse and keyboard.
Here only the recovery console gives me a login and options to fix this problem.

Tux

The same happens here. Hardware is Lenovo 3000 V200. However, touchpad works OK.

Timo Aaltonen (tjaalton) wrote :

input-hotplug is now enabled, so this bug should not happen unless i-h is deliberately deactivated. Lowering importance.

Changed in xorg-server:
importance: High → Medium
Tux (peter-hoogkamer) wrote :

Ok

This fixed the issue. Mouse and keyboard are useable again.

Tux

Alex Ruddick (alexrudd0) wrote :

I *think* I have everything upgraded successfully (dist-upgrade failed midway, but that's another issue). The new automatic setup does not work at all. The only way I can get my keyboard and USB mouse to work is by personally recreating Xorg.conf to explicitly define a keyboard and mouse. The relevant sections of my xorg.conf look identical to Alberto Milone's example.

Is there some way to check whether input-hotplug is active or not?

Bryce Harrington (bryce) wrote :

Philipp, to answer your question, it's unnecessary to assign X bugs to any team. Individuals take ownership of bugs if they intend to work on them.

Changed in xorg-server:
status: Confirmed → Triaged

If you have manally appllied Alberto workaround you may have this issue.

https://bugs.launchpad.net/ubuntu/+bug/255167

Hope this helps

Jordan (jordanu) wrote :

Although my keyboard is now working with the latest update my touchpad still is not ( it was working before this bug ). I have a default xorg.conf.

Testing on a standard 64-Bit system, I can confirm this bug. After updating first, neither the mouse nor the keyboard worked. Having installed all available updates, the mouse works, but the keyboard still does not. I cannot log in. What do I do?

In some forum someone advised to add the following to /ect/X11/xorg.conf:

----
Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 Inputdevice "Generic Keyboard"
 Inputdevice "Configured Mouse"
EndSection
----

From my limited knowledge, this appears to me like a functional but rough workaround, but I would rather fix the system clean. How do I do that?

Timo, how do we check if our input-hotplug is enabled?

I've just upgraded from 1+ week ago, and have hit this bug. I don't think i've deliberately turned it off.

Scratch that. I don't have it (xserver-xorg-input-evdev) installed.

A requirement for the upgrader, perhaps?

Scratch that. I don't have it (xserver-xorg-input-evdev) installed.

A requirement for the upgrader, perhaps?

Timo Aaltonen (tjaalton) wrote :

Sarah: xserver-xorg-input-all pulls in -evdev, and those should be installed on a normal system.

I confirm this bug... After the recent update, my keyboard and mouse n r not working anymore.

Javier Noval (javiernoval) wrote :

I can also confirm this bug. As I was able to use ctrl+alt+f1 to switch to a TTY, I could verify that the xorg server was not accessing any of the /dev/input/event* devices; however after issuing a "/etc/input/kdm restart" they were being accessed (and the keyboard & mouse worked OK), so the problem looks like some race condition at system startup.

Luka Renko (lure) wrote :

Javier, since you use kdm, please try workaround from bug 256261 - I suspect this is upgrade issue.

Peter Júnoš (petoju) wrote :

Hi,

I've installed new kernel 2.6.27 offered me as an update and this bug reappears to me. I tried the workaround, however, it doesn't work. Kernel 2.6.26 still works as expected.

Tell me if I should report it as a different bug.
I am using Gnome, GDM and last Ubuntu Intrepid Ibex.

Chris Jones (cmsj) wrote :

Is hald running? Xorg now gets all of its input stuff from hal, so if it starts before hal, or hal never starts at all, you will be left with no keyboard/mouse input.

Touchpad works with 8.10 Alpha since today's update. However, taking a full stroke only gets you as far as 1/10 of the screen.

External mouse works fine.

Peter Júnoš (petoju) wrote :

Chris Jones:
/etc/init.d/hal status returns, that hald is running. I tried to restart gdm, it doesn't help. I don't know, how to restart Xorg, so I tried to /etc/init.d/x11-common restart, but it doesn't work also. Killing X is not a solution, because X does not try to start again.

Only thing that work is switching to terminal (Ctrl+Alt+F1-F12).

phenest (steve-clark) wrote :

Amending the xorg.conf file works, but each Kernel update or change of Hardware Drivers changes the xorg.conf file back.

Peter Júnoš (petoju) wrote :

phenest: changing works only in old kernel, new 2.6.27 kernel (also 2.6.27-2) does ignore it.

benjym (benjymarks1) wrote :

I can confirm the bug. Running an HP TX2500 under latest Ibex distro. Both kdm and gdm will not recognise the mouse or keyboard. Amending the xorg.conf file did not help. After using sudo dpkg-reconfigure -phigh xserver-xorg to reset the xorg.conf file, neither kdm or gdm will load at all.

Richard Corner (rcorner) wrote :

I also experienced this bug. Alberto Milone's solution worked for me, although his Italian keyboard layout had me guessing at the login prompt for a while.

Peter Júnoš (petoju) wrote :

I've found the problem: I placed that workaround only in xorg.conf, but my PC hadn't nvidia drivers for 2.6.27, so xorg.conf.failsafe was used.

Placing workaround in xorg.conf.failsafe doesn't work, because that file is probably replaced on each boot and shutdown.

Michele Bini (michele-bini) wrote :

So how do we make sure that input-hotplug is enabled? I'm still having problems with my USB mouse.

Michele Bini (michele-bini) wrote :

Update: mine was actually an hardware problem, and had to replace the USB mouse.

Just upgrade from 8.0.4.1 to 8.10 Beta
And my laptop keyboard and touchpad not working

Then go recovery mode, regenerate new xorg.conf
Still not working until now

To make working, i hv to CTRL+ALT+F1 and restart GDM

# lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

M Pietila (pietila-meghan) wrote :

Fresh install of Beta from 2 days ago... USB keyboard works fine, USB mouse does not. In /var/log/messages I see my USB wheel mouse being detected and set to /class/input/input6. Restarting Gnome (/etc/init.d/gdm restart) did not resolve the problem, and I did a full apt-get update/upgrade/dist-upgrade set and rebooted the entire system just to check.

Have not tried the xorg.conf fix yet, I also have an nvidia card without the restricted drivers installed yet so I'm not sure whether I'll run into the same xorg.conf.failsafe problem as Peter describes above. hald is running, I don't know how to check whether gnome is using any of the /dev/event/input* devices as someone mentioned above - I'll see if I can learn that.

Any ideas are appreciated!

M Pietila (pietila-meghan) wrote :

The xorg file fix worked for me - but even better news, I ran all the updates today and with a clean xorg file (i.e. no entries for any input devices), my mouse and keyboard now work perfectly! I love seeing bugs disappear so quickly...

Sander Jonkers (jonkers) wrote :

After today's 100 MB update, my mouse is intermittently not working (Ubuntu 8.10 intrepid ibex): I can move the mouse for about 20 - 30 seconds, and then it won't move for a few minutes, after which I can move the mouse for about 20-30 seconds, etc.

This happens to both my USB mouse and my touchpad.

Timo Aaltonen (tjaalton) wrote :

sander: that sounds more like a kernel bug to me. This bug has been fixed some time ago. If restarting the xserver makes the mouse & keyboard to work it means that HAL was not ready when the xserver started first time. There should be another bug about that.

Changed in xorg-server:
status: Triaged → Fix Released

Timo,

I tried booting the older kernels in the GRUB list, with the same effect.

Do you know the other bug number?

Thanks,
Sander

On Tue, Oct 7, 2008 at 10:39 PM, Timo Aaltonen <email address hidden>wrote:

> sander: that sounds more like a kernel bug to me. This bug has been
> fixed some time ago. If restarting the xserver makes the mouse &
> keyboard to work it means that HAL was not ready when the xserver
> started first time. There should be another bug about that.
>
> ** Changed in: xorg-server (Ubuntu)
> Status: Triaged => Fix Released
>
> --
> [intrepid] mouse and keyboard stop working under gdm and gnome
> https://bugs.launchpad.net/bugs/254840
> You received this bug notification because you are a direct subscriber
> of the bug.
>

On Wed, Oct 8, 2008 at 4:07 AM, Sander Jonkers <email address hidden> wrote:
> Timo,
>
> I tried booting the older kernels in the GRUB list, with the same
> effect.
>
> Do you know the other bug number?
>
> Thanks,
> Sander
>
> On Tue, Oct 7, 2008 at 10:39 PM, Timo Aaltonen
> <email address hidden>wrote:
>
>> sander: that sounds more like a kernel bug to me. This bug has been
>> fixed some time ago. If restarting the xserver makes the mouse &
>> keyboard to work it means that HAL was not ready when the xserver
>> started first time. There should be another bug about that.
>>
>> ** Changed in: xorg-server (Ubuntu)
>> Status: Triaged => Fix Released
>>
>> --
>> [intrepid] mouse and keyboard stop working under gdm and gnome
>> https://bugs.launchpad.net/bugs/254840
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>
> --
> [intrepid] mouse and keyboard stop working under gdm and gnome
> https://bugs.launchpad.net/bugs/254840
> You received this bug notification because you are a direct subscriber
> of the bug.
>

my mouse n keyboard still can not use until know (at the 1st show gdm)
after restart gdm can use

so?

Sander Jonkers (jonkers) wrote :

As my machine had become unusable and did not see an update coming in, I've installed a fresh copy of 8.10 beta, and the mouse is fine now.

Cay Horstmann (cay) wrote :

This bug bites me hard. I tried upgrading to the latest kernel (2.6.27-7), and it makes no difference (on a Thinkpad X60). X starts up, no keyboard or mouse.

sirkubador (sirkubador) wrote :

Instalation of xserver-xorg-input-all worked for me.

I was having the same problem and sirkubador's solution (installing xserver-xorg-input-all) worked for me.

On Sat, Oct 11, 2008 at 5:05 AM, sirkubador <email address hidden> wrote:
> Instalation of xserver-xorg-input-all worked for me.
>
> --
> [intrepid] mouse and keyboard stop working under gdm and gnome
> https://bugs.launchpad.net/bugs/254840
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Instalation of xserver-xorg-input-all not worked for me :-(

Cay Horstmann (cay) wrote :

sudo apt-get install xserver-xorg-input-all fixed it for me as well.

Shwan (shwan-ciyako) wrote :

xserver-xorg-input-all fixed it for me as well, I noticed that The last upgrade before this problem did remove three xorg-input packages , I can't find the log(didn't try so hard to) so can't say which ones.

auquicu (aebsbkrs) wrote :

Bug confirmed: After upgrading a working Hardy to Intrepid, keyboard and mouse no longer work under X. The problem was easy to fix: replace /etc/X11/xorg.conf by the pre-upgrade version. The cause is clear: essential parts of xorg.conf were commented out:

"commented out by update-manager, HAL is now used".

Starting X gave the error message in /var/log/Xorg.0.log:

"EE config/hal: couldn't initialise context: (null) ((null))"

also suggesting a hal problem. (But hal is not needed, so with the old config file all is ok.)

Oreolek (oreolek) wrote :

I confirm the bug.
Upgrading from Hardy to Intrepid is painful.
However,a clean installation runs perfectly.

On Thu, Nov 13, 2008 at 10:20 PM, Oreolek <email address hidden> wrote:
> I confirm the bug.
> Upgrading from Hardy to Intrepid is painful.
> However,a clean installation runs perfectly.
>
> --
> [intrepid] mouse and keyboard stop working under gdm and gnome
> https://bugs.launchpad.net/bugs/254840
> You received this bug notification because you are a direct subscriber
> of the bug.
>

So? Any solution? My notebook still have this problem

Bryce Harrington (bryce) wrote :

If you see the following:

    "EE config/hal: couldn't initialise context: (null) ((null))"

it means hal was either not running or not installed.

frank (fhsmith) wrote :

I have the same bug after a clean install of Intrepid Server and then trying to add Ubuntu-Desktop. By running ssh into the server and watching what happens on top I can add that Xorg seems to start OK but once the cursor changes from the default X it just eats processor 99.3% etc.

At a guess one screen update every 5-10 seconds, eventually even ssh fails.

frank (fhsmith) wrote :

Further investigation by running startx in the ssh connection I get the following error:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type “ONE_LEVEL” has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

Then everything goes dead………….

I have checked /etc/default/console-setup as suggested in known issues and although not an expert it seems OK and I have run sudo dpkg-reconfigure console-setup and that made no changes to the file. There is no mouse entry in the file but I guess that is not surprising as I think a standard mouse is now be detected by the kernel.

My guess is its not X at fault but gdm.

frank (fhsmith) wrote :

I can now confirm the full desk top installation get into a similar problem. After a long slow period it stops with the background image and an almost empty install window. There are no active controls or anything like that but the window colour is not quite flat.

Again the only way out is to switch the machine off. The machine was happily running Suse 9.3 until I started this and Knoppix 5.3.1 runs happily so it should be possible.

JPHein (jp-jphein) wrote :

I can confirm this bug. I am running a totally updated 8.10. 64-bit.
I have both KDM and GDM installed. GDM is the default.
Ctrl-Alt-F1 does not work and gives me a blinking cursor.
If I restart GDM through ssh then it works. It seems like GDM is started before hal or dbus.

frank (fhsmith) wrote :

Yet another install and this time I can confirm the same bug with kdm and as previously stated X works fine until kdm or gdm get started whereupon both the mouse and the keyboard lockup and something grinds to a virtual halt.

If somebody wants to lead me through some debugging I will do my best but soon as I need the machine working!

frank (fhsmith) wrote :

If I restart gdm at the right point it seems I leave two copies of the following in memory, the younger one seems to be connected to a tty.

/usr/lib/gdm/gdmopen –l /bin/sh –c /usr/bin/whiptail

I wonder if this is the process that is hanging?

I do hope somebody is looking at this.

JPHein (jp-jphein) wrote :

This happens because GDM is started before Hal. They fixed it for KDM by making it 99th. So, I just did the same with GDM.
This is the how:
sudo update-rc.d -f gdm remove
sudo update-rc.d gdm defaults 99 01

frank (fhsmith) wrote :

Thanks but sadly, moving gdm or kdm to be in the last wave of daemons launched does not solve my problem. Even running them manually after everything has settled does not improve matters.

Every method I have tried results in the same situation, screen locked, processor at very high utilisation, ssh logins die, etc. Something just eats the processor time, presumably some form of loop, I believe a small amount of other processing is happening because if I launch from inside a ssh I can mostly kill the process but not easily.

:{

frank (fhsmith) wrote :

I have finally solved my problem I was suffering from the openchrome driver bug. So if you think you have the same bug I had try the following link https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-openchrome/+bug/274340.
Thank you and Good Luck

Orionn (getthistoneale) wrote :

Problem still happening. I just upgraded from Hardy to Intrepid. Keyboard works fine (luckily), but mouse doesn't (tried PS2 and USB).

I have tried multiple variations of xorg.conf, including adding the mouse driver & deleting the mouse section entirely.
When I run dpkg-reconfigure xserver-xorg, it kills my video output (ATI X1250=garbage, it just goes to black screen when gdm loads), so I can't tell if that fixes my mouse or not, although I don't think so, as I defaulted xorg.conf, copied the ATI section, and the mouse still didn't work.

I tried setting GDM to 99.
xserver-xorg-input-all was already installed, so I reinstalled it.

Any ideas or updates to this bug? Or failing that, can someone tell me how to rollback to Hardy?

Orionn (getthistoneale) wrote :

Here's my Xorg.0.log

Orionn (getthistoneale) wrote :

Here's my xorg.conf (ignore the filename, this is the only one that loads gnome and doesn't just give me a black screen).

Damien Freeze (dizzylizard04) wrote :

I updated this morning (actually, I rebooted this morning when I woke up and the update manager said it had downloaded an important security update and needed to be restarted), and now I have no keyboard or mouse. I'm on an Acer Aspire 3680 Laptop, 1.66 gHz Intel Celeron M, 2 Gb RAM. Currently, I'm forced to run on the live CD to be able to post this, but that's not an acceptable option for long term. I've tried several different fixes mentioned in the forums, but nothing seems to work. I've tried using apt to update/upgrade/dist-upgrade and autoremove, to no avail...I've tried the xserver-xorg-input-all tip, and nothing...of course, since I'm doing it all through the Live CD, I don't know if any of it is actually getting to my hard drive. I'm reaching the end of my rope here...thinking about chucking this paperweight out the window and going to get an abacus...snail-mail, I'm coming home!

Any suggestions are greatly appreciated!

ubuntu@ubuntu:/media/disk$ sudo apt-get install xserver-xorg-input-all
Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-input-all is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Sorry, I can't help you. What did work for me was simply to unplug and
re-plug the keyboard. It turns out I had two faulty mice, so that's why my
mouse didn't work. Basically, it just started working again by itself.

Good luck.
N.

On Tue, Apr 21, 2009 at 9:45 AM, Damien Freeze <email address hidden>wrote:

> I updated this morning (actually, I rebooted this morning when I woke up
> and the update manager said it had downloaded an important security
> update and needed to be restarted), and now I have no keyboard or mouse.
> I'm on an Acer Aspire 3680 Laptop, 1.66 gHz Intel Celeron M, 2 Gb RAM.
> Currently, I'm forced to run on the live CD to be able to post this, but
> that's not an acceptable option for long term. I've tried several
> different fixes mentioned in the forums, but nothing seems to work.
> I've tried using apt to update/upgrade/dist-upgrade and autoremove, to
> no avail...I've tried the xserver-xorg-input-all tip, and nothing...of
> course, since I'm doing it all through the Live CD, I don't know if any
> of it is actually getting to my hard drive. I'm reaching the end of my
> rope here...thinking about chucking this paperweight out the window and
> going to get an abacus...snail-mail, I'm coming home!
>
> Any suggestions are greatly appreciated!
>
>
> ubuntu@ubuntu:/media/disk$ sudo apt-get install xserver-xorg-input-all
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> xserver-xorg-input-all is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
>
>
> ** Attachment added: "xorg.conf"
> http://launchpadlibrarian.net/25802985/xorg.conf
>
> --
> [intrepid] mouse and keyboard stop working under gdm and gnome
> https://bugs.launchpad.net/bugs/254840
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “xorg” source package in Ubuntu: Invalid
> Status in “xorg-server” source package in Ubuntu: Fix Released
>
> Bug description:
> [intrepid] after today upgrade and dist-upgrade
>
> may be related to upgrade of
>
> xserver-xorg-core 2:1.4.99.905-0ubuntu5 to
> xserver-xorg-core_2%3a1.4.99.906-1ubuntu1i386.deb
>
> Mouse and keyboard stop working under Gdm and Gnome.
>
> CTRL+ALT+F2 is still working and i can make login, i wait for updates and
> upgrades typing:
>
> sudo apt-get update
> sudo apt-get upgrade
> sudo apt-get dist-upgrade
>
> Same issue on 4 of 4 intrepid pc (not same hardware).
>
> Thank you
>

J. Antonio Romero (nsdragon) wrote :

Oh man, this is going to be so fun.

I'm on an Aspire 8930G (8.10 amd-64). Rebooted yesterday morning, then found the same problem described here -- my keyboard and touchpad stopped working on both the gdm and kdm login screen. (Doubly annoying since apparently the monitor just turns itself off and I end up typing in the dark when I switch TTYs with the nvidia driver, but that's another issue). Same for my USB mouse, except that it did work after unplugging it and plugging it back. It seemed strange at the time since everything worked as expected in the LiveCD environment, and I hadn't touched xorg.conf at all, then started to get really annoying until I just decided to reinstall and the problem went away.

Figures that I decided to update everything again, so I might be facing this same problem tomorrow morning. I did check my apt logs before reinstalling though, and noticed that, other than a few xfce4.6 updates that seemed irrelevant (stuff like orage and such) I also got an upgrade for udev 144 from a PPA. But for some reason I didn't copy the log file to check later (or the info from the PPA, argh I'm stupid), and now that I've been reading through all this I doubt it's udev's fault at all.

Either way I'm going to keep an eye out on this. The update-rc.d workaround looks promising, so I hope I can apply it somehow from the LiveCD if it does go south later on.

J. Antonio Romero (nsdragon) wrote :

Aha! It was udev-144 the culprit (not from the official repositories though). Managed to download the 126 package in intrepid-updates, booted in recovery mode to install it, and now everything works fine again. I'm gonna steer clear of 144 for the time being, or at least until Jaunty comes out.

Damien Freeze (dizzylizard04) wrote :

Ok...here's an update from my futile efforts...I've tried to replace the xorg.conf file, but the backups are all void, too...I've tried booting an older kernel, with the same result. I've switched to a tty, done a killall on hald and gdm, and restarted them in the proper order, which brings up a grey screen with a black X for a cursor and does nothing else. I've tried the update-rc fix, and still no mouse or keyboard...switching to tty1 from the hung boot window, I see an error message that says "FATAL; Module -r not found", which is obviously the end of an output from something, but it doesn't say WHAT it's the output from. Nothing works so far...I'm not a complete n00b, but I don't know how to interpret the logfiles, so I'm posting the ones I think may be pertinent...If I miss any that need to be looked at, or post any extra ones that aren't needed, I apologize. I greatly appreciate any help anyone can offer...

Damien Freeze (dizzylizard04) wrote :
Damien Freeze (dizzylizard04) wrote :
Damien Freeze (dizzylizard04) wrote :
Damien Freeze (dizzylizard04) wrote :
Damien Freeze (dizzylizard04) wrote :
Damien Freeze (dizzylizard04) wrote :

Again, I apologize for the glut of info, but I'm not sure which will be pertinent...MODS, please remove any which won't help diagnose this problem...Thank you all for your help!

jcusick (jcusick) wrote :

I, too, have the same problem on a IBM T30 laptop. I decided to upgrade from Hardy and all seemed fine until it rebooted. Since last night I've been searching the 'net looking for solutions, and so far nothing has worked. I've reconfigured and reloaded about every appropriate package I can think of including all the suggestions I found here and on the 'net and No Go.

Clearly, to me anyway, it was a hal/dbus issue and so, after running a reconfigure on both of these packages with no luck, ultimately here is what I have to do every time I start the system:

CTRL-ALT-F1
sudo /etc/init.d/dbus restart

One line was obviously noticeable:

  Stopping System Tools Backends system-tools-backends
    start-stop-daemon: warning: failed to kill 1234: no such process

  Starting System Tools Backends system-tools-backends

Then Alt-F7 and back to the GDM login prompt and all is fine. The mouse and keyboard work as they are supposed to work.

An Ah-Ha moment, a system-tools-backends problem? I checked the man pages and no configuration available. Bummer.

After that,I rebooted and tried to just restart system-tools-backends and got the same error message but no mouse or keyboard at the GDM prompt, as usual. So I restarted dbus, system-tools-backends stopped normally, all restarted fine and the keyboard and mouse again worked with no problems in X.

I noticed that in /etc/rc5.d system-tools-backends was started at S30 while dbus was started at S51. Maybe that was it? I ran chkconfig system-tools-backends off and then back on and it moved to S51. Still no go. Although I don't get the initial dbus (system-tools-backends) restart error I mentioned at the top of this post anymore it did not fix the keyboard/mouse issue.

I then tried moving gdm from S30 to S52 (just after hal and dbus start) - no dice.

So I then tried adding "/etc/init.d/dbus restart" to the rc.local script - no dice.

Finally I then tried adding "/etc/init.d/gdm reload" to the rc.local script and that worked, but it's a hack. I have to wait while gdm loads, flashes off and then reloads before I can log in.

So now I'm stuck. Every time I start the system I have to go to a terminal, restart dbus and all is fine or add /etc/init.d/gdm reload to the /etc/rc.local file which seems a little silly to me.

Has anyone come up with a solution to this yet?

John C.

Timo Aaltonen (tjaalton) on 2009-08-05
Changed in xorg-server (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers