[regression] GLX is missing. gnome-shell visible latency is very high with Xorg 2:1.20.4-1ubuntu1

Bug #1818972 reported by Daniel van Vugt on 2019-03-07
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
High
Timo Aaltonen

Bug Description

[Impact]

GLX is missing. gnome-shell visible latency is very high with Xorg 2:1.20.4-1ubuntu1. And reinstalling the previous version (2:1.20.3-1ubuntu1) seems to fix it.

[Test Case]

$ glxinfo

Expected: Lots of information
Observed: An error

- or -

1. Log into a gnome-shell Xorg session ("Ubuntu").
2. Drag a window around in circles by its titlebar.

Expected: The mouse pointer to be somewhere near the titlebar
Observed: The mouse pointer is a long way away.

[Other Info]

Crucially, my patches to mutter's clutter-stage-cogl.c no longer have any effect when this Xorg regression is present. So I can tell the problem is related to some missing/broken X11 feature that is causing the mutter master clock to fall back to its secondary vsync method (no sync at all, just swapbuffers till they're all full, so typically quad-buffering).

[Workarounds]

* Install Xorg 2:1.20.3-1ubuntu1 instead; or

* Use Wayland sessions only.

[Original description]

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: xserver-xorg-core 2:1.20.4-1ubuntu1
ProcVersionSignature: Ubuntu 5.0.0-7.8-generic 5.0.0
Uname: Linux 5.0.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu23
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Mar 7 16:24:50 2019
DistUpgraded: Fresh install
DistroCodename: disco
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation HD Graphics 630 [8086:5912] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: Lenovo HD Graphics 630 [17aa:3102]
InstallationDate: Installed on 2018-12-04 (93 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Alpha amd64 (20181203)
MachineType: LENOVO 10M7CTO1WW
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.0.0-7-generic root=UUID=052b7096-9b82-4712-b596-7629d5f6498c ro quiet splash vt.handoff=1
SourcePackage: xorg-server
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/06/2018
dmi.bios.vendor: LENOVO
dmi.bios.version: M16KT47A
dmi.board.name: 3102
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40709 WIN 3259627060530
dmi.chassis.type: 3
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrM16KT47A:bd02/06/2018:svnLENOVO:pn10M7CTO1WW:pvrThinkCentreM710s:rvnLENOVO:rn3102:rvrSDK0J40709WIN3259627060530:cvnLENOVO:ct3:cvrNone:
dmi.product.family: ThinkCentre M710s
dmi.product.name: 10M7CTO1WW
dmi.product.sku: LENOVO_MT_10M7_BU_Think_FM_ThinkCentre M710s
dmi.product.version: ThinkCentre M710s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.14.0+19.04.20190223.1-0ubuntu1
version.libdrm2: libdrm2 2.4.97-1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.3.4-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.3.4-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.4-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.1.99+git20190207-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20180925-2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Daniel van Vugt (vanvugt) wrote :
description: updated
tags: added: rls-dd-incoming
Daniel van Vugt (vanvugt) wrote :

Found the problem in mutter:
CLUTTER_FEATURE_SWAP_EVENTS is missing because
COGL_WINSYS_FEATURE_SWAP_BUFFERS_EVENT is missing because
cogl-winsys-glx isn't being used because
xorg 2:1.20.4-1ubuntu1 is missing/has broken GLX support...

$ glxinfo
name of display: :4
Error: couldn't find RGB GLX visual or fbconfig

Timo Aaltonen (tjaalton) on 2019-03-07
tags: added: block-proposed
Daniel van Vugt (vanvugt) wrote :

And as Timo just pointed out:

[ 46.827] (EE) AIGLX error: dlopen of /usr//usr/lib/x86_64-linux-gnu/dri/i965_dri.so failed (/usr//usr/lib/x86_64-linux-gnu/dri/i965_dri.so: cannot open shared object file: No such file or directory)
[ 46.827] (EE) AIGLX error: unable to load driver i965
[ 46.827] (EE) AIGLX error: dlopen of /usr//usr/lib/x86_64-linux-gnu/dri/swrast_dri.so failed (/usr//usr/lib/x86_64-linux-gnu/dri/swrast_dri.so: cannot open shared object file: No such file or directory)
[ 46.827] (EE) AIGLX error: unable to load driver swrast
[ 46.827] (EE) GLX: could not load software renderer
[ 46.828] (II) GLX: no usable GL providers found for screen 0

summary: - [regression] gnome-shell visible latency is very high with Xorg
- 2:1.20.4-1ubuntu1
+ [regression] GLX is missing. gnome-shell visible latency is very high
+ with Xorg 2:1.20.4-1ubuntu1
description: updated
description: updated
description: updated
Changed in xorg-server (Ubuntu):
status: New → In Progress
assignee: nobody → Timo Aaltonen (tjaalton)
Daniel van Vugt (vanvugt) wrote :

xorg-server (2:1.20.4-1ubuntu2) disco; urgency=medium

  * Rebuild against fixed dri.pc. (LP: #1818972)

 -- Timo Aaltonen <email address hidden> Fri, 08 Mar 2019 10:31:56 +0200

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Committed
Changed in xorg-server (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers