After a while touchpad doesn't work

Bug #1784998 reported by fokedFromTheLife on 2018-08-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

By default, touchpad doesn't work, but USB mouse works.

WORKAROUND: Install the NVIDIA proprietary drivers, and use non-default kernel parameters:
nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=Linux i915.preliminary_hw_support=1 idle=nomwait

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Thu Aug 2 10:23:53 2018
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation Device [8086:591b] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:15e0]
   Subsystem: ASUSTeK Computer Inc. GP107M [GeForce GTX 1050 Mobile] [1043:15e0]
InstallationDate: Installed on 2018-04-29 (94 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 0bda:57f5 Realtek Semiconductor Corp.
 Bus 001 Device 004: ID 0b05:1854 ASUSTek Computer, Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. GL553VD
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-29-generic root=UUID=48228a8f-bbca-4be4-a07a-96a383809e68 ro quiet splash nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=Linux i915.preliminary_hw_support=1 idle=nomwait vt.handoff=1
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/02/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: GL553VD.306
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: GL553VD
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrGL553VD.306:bd01/02/2018:svnASUSTeKCOMPUTERINC.:pnGL553VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnGL553VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: GL
dmi.product.name: GL553VD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.91-2
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~18.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~18.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

fokedFromTheLife (fmalll) wrote :
summary: - mouse don't work
+ After a while touchpad doesn't work
affects: xorg (Ubuntu) → xorg-server (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

fokedFromTheLife, thank you for reporting this and helping make Ubuntu better. Please answer all of the following:

1) Regarding your Bug Description comment:
>"after a while..."

1a) Could you please define specifically how long a while is? Seconds, minutes, hours, etc.?
1b) Could you please advise to after a while from when? Boot up, login, opening a program, etc.?

2) Is this issue something that started to happen after an update? If so, which and when precisely?

3) Regarding the non-default kernel parameters:
nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=Linux i915.preliminary_hw_support=1 idle=nomwait

If you remove these, is the issue still reproducible?

tags: added: bios-outdated-307
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
fokedFromTheLife (fmalll) wrote :

so
when i install ubuntu
the touchpad don't work

i go to http://pclub.in/2017/01/06/Linux-on-Asus-ROG.html
and that' worked

after an update my touchpad stopped again

after deleting that kernel parameters that's not okay
thanks

fokedFromTheLife:

1)
>"so when i install ubuntu the touchpad don't work i go to http://pclub.in/2017/01/06/Linux-on-Asus-ROG.html and that' worked"

To clarify, you are stating that by default, the touchpad doesn't work at all. However, after using the non-default kernel parameters, and installing the NVIDIA proprietary drivers, the touchpad then begins to work?

2)
>"after an update my touchpad stopped again"

Which update precisely, and what date was the update applied?

3) To confirm this is resolved in Ubuntu, could you please test http://cdimage.ubuntu.com/daily-live/current/ and advise to the results?

fokedFromTheLife (fmalll) wrote :

1)yes

2)I don't know

3)didn't work

tags: added: cosmic

fokedFromTheLife:

1) Regarding the following non-default kernel parameters in use, could you please advise to each individually on why it was put in place, and if it is necessary for the touchpad to work:
nouveau.modeset=0
tpm_tis.interrupts=0
acpi_osi=Linux
i915.preliminary_hw_support=1
idle=nomwait

description: updated
Kai-Heng Feng (kaihengfeng) wrote :

Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v4.19-rc1 kernel[0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as
"Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19-rc1/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers