Xephyr does not have GLX

Bug #1079096 reported by Xavier Claessens on 2012-11-15
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
X.Org X server
In Progress
Medium
xorg-server (Ubuntu)
Low
Unassigned

Bug Description

Steps:

$ Xephyr :2

$ DISPLAY=:2 glxinfo
Error: couldn't find RGB GLX visual or fbconfig

On fedora/debian it seems to work.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xephyr 2:1.13.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Thu Nov 15 10:58:25 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.18, 3.5.0-18-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21fa]
InstallationDate: Installed on 2012-09-29 (46 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120929)
MachineType: LENOVO 23252EG
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-18-generic root=UUID=c4842ed7-a8fc-40fd-8c31-909f1a5ce55a ro quiet splash vt.handoff=7
SourcePackage: xorg-server
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/24/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G2ET31WW (1.11 )
dmi.board.asset.tag: Not Available
dmi.board.name: 23252EG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG2ET31WW(1.11):bd05/24/2012:svnLENOVO:pn23252EG:pvrThinkPadX230:rvnLENOVO:rn23252EG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 23252EG
dmi.product.version: ThinkPad X230
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.8.4+bzr3407-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Related branches

Xavier Claessens (zdra) wrote :
Xavier Claessens (zdra) wrote :

I've installed precise package[1] and it works fine on Quantal. So this is really a regression.

[1] http://launchpadlibrarian.net/113881100/xserver-xephyr_1.11.4-0ubuntu10.8_amd64.deb

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed
David Barth (dbarth) wrote :

Confirmed to regress on i386 as well, if ever there was a doubt. The precise package does restore GLX compatibility on quantal.

Roman Yepishev (rye) wrote :

Newer Xephyr versions don't add any external extensions. The version shipped in Precise had GLX extension activated unconditionally but now it looks like Xephyr does not have any code to run external extension initialization. Specifying +extension GLX won't help because the code that actually loads external extensions never runs.

The bug has been reported on https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1079096

"$ Xephyr :2

$ DISPLAY=:2 glxinfo
Error: couldn't find RGB GLX visual or fbconfig"

The issue happens on Ubuntu quantal or raring with xserver-xephyr 1.13, installing the precise binary (1.12) makes it work

Created attachment 76536
That patch fixes the issue for me (on 1.13.2)

similar to the commit previously pointed, it does the job it seems ;-)

Changed in xorg-server (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
status: Triaged → In Progress
Sebastien Bacher (seb128) wrote :

Confirmed, jcristau pointed to http://cgit.freedesktop.org/xorg/xserver/commit/?id=ac1a60e7b6f06fd075cc5bf55d6bc67206a01d29 and mentioned it might be a similar issue.

I've tried that an indeed that fixes it, that patch applies to raring and fixes the bug for me

tags: added: patch
Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Confirmed
Maarten Lankhorst (mlankhorst) wrote :

I'll apply it, but can you post it to <email address hidden> too so upstream will get it?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xorg-server - 2:1.13.3-0ubuntu4

---------------
xorg-server (2:1.13.3-0ubuntu4) raring; urgency=low

  * Do not bother registering xv/xvmc on gpu screens.
    - xfree86-no-xv-for-gpuscreens.patch
  * Re-enable GLX on Xephyr. (LP: #1079096)
    - xephyr-glx-register.patch
 -- Maarten Lankhorst <email address hidden> Tue, 26 Mar 2013 16:16:14 +0100

Changed in xorg-server (Ubuntu):
status: In Progress → Fix Released

Could you provide that patch in git-format-patch form with an appropriate signed-off-by line?

Created attachment 84537
updated patch, in git format, for the current trunk

> Could you provide that patch in git-format-patch form with an appropriate signed-off-by line?

sure, I guess the signed-off should have your name?

There you go!

It would hopefully have your name, assuming you're the author of the patch, indicating that you agree with the developer's certificate of origin (https://www.kernel.org/doc/Documentation/SubmittingPatches)

Created attachment 84552
updated patch with the right signed-off

oh, ok, thanks!

Thanks! It's on the list with a fixed up commit message, though it ended up at the *end* of a giant patch series I sent out. If that all gets stalled I'll try to make sure it makes it in anyway.

Changed in xorg-server:
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.