[regression] X11 screen blanking after 10 minutes with no UI to change it

Bug #1072531 reported by Tristan Schmelcher on 2012-10-29
120
This bug affects 26 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Undecided
Unassigned

Bug Description

After updating from Ubuntu 12.04 Precise to Ubuntu 12.10 Quantal, X11 has started automatically blanking the screen after 10 minutes of inactivity even though I have set "Turn off screen when inactive" in "Brightness and Lock" to 1 hour.

If I change "Turn off screen when inactive" to 1 minute, then the screen turns off after 1 minute as it should, but if I set it back to 1 hour then the screen goes back to blanking after 10 minutes, not turning off after 1 hour as it should. So it seems that there are two independent timers and the GUI has no effect on the 10 minute one.

Looking in xset, there is indeed a 10-minute screen blanking timeout.

$ xset q
Keyboard Control:
  auto repeat: on key click percent: 0 LED mask: 00002000
  XKB indicators:
    00: Caps Lock: off 01: Num Lock: off 02: Scroll Lock: off
    03: Compose: off 04: Kana: off 05: Sleep: off
    06: Suspend: off 07: Mute: off 08: Misc: off
    09: Mail: off 10: Charging: off 11: Shift Lock: off
    12: Group 2: off 13: Mouse Keys: on
  auto repeat delay: 500 repeat rate: 33
  auto repeating keys: 00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
  acceleration: 2/1 threshold: 4
Screen Saver:
  prefer blanking: yes allow exposures: yes
  timeout: 600 cycle: 600
Colors:
  default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,built-ins
DPMS (Energy Star):
  Standby: 0 Suspend: 0 Off: 0
  DPMS is Enabled
  Monitor is On
$

Note that I am using a dual head configuration so I have an xorg0.conf and an xorg1.conf, but there is nothing in either related to screen blanking. Both heads experience the same problem. My other machine that I upgraded from 12.04 to 12.10 does not.

Running "xset s 0 0" avoids the problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: xserver-xorg-core 2:1.13.0-0ubuntu6
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.gpus.1: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/1'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 304.43 Sun Aug 19 20:14:03 PDT 2012
 GCC version: gcc version 4.7.2 (Ubuntu/Linaro 4.7.2-2ubuntu1)
.tmp.unity.support.test.0:

.tmp.unity.support.test.1:

ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,grid,imgpng,gnomecompat,move,place,regex,resize,snap,animation,vpswitch,session,mousepoll,unitymtgrabhandles,compiztoolbox,wall,expo,workarounds,ezoom,fade,scale,unityshell]
CompositorRunning: compiz
Date: Sun Oct 28 19:41:51 2012
DistUpgraded: 2012-10-28 10:39:13,985 DEBUG enabling apt cron job
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 304.43, 3.2.0-32-generic, x86_64: installed
 nvidia-current, 304.43, 3.5.0-18-generic, x86_64: installed
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 NVIDIA Corporation GF110 [GeForce GTX 570] [10de:1081] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:1570]
 NVIDIA Corporation GF110 [GeForce GTX 570] [10de:1081] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: eVga.com. Corp. Device [3842:1570]
JockeyStatus:
 kmod:nvidia_experimental_304 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
 kmod:nvidia_experimental_310 - Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (Free, Disabled, Not in use)
 kmod:nvidia_current - nvidia_current (Proprietary, Enabled, Not in use)
 kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Proprietary, Disabled, Not in use)
MachineType: System76, Inc. The Leopard Extreme
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=UUID=e7728359-15b1-4eb6-a7c9-db1b40e7c807 ro quiet splash
SourcePackage: xorg-server
UpgradeStatus: Upgraded to quantal on 2012-10-28 (0 days ago)
dmi.bios.date: 12/14/2010
dmi.bios.vendor: Intel Corp.
dmi.bios.version: SOX5810J.86A.5529.2010.1214.2317
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DX58SO
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE29331-503
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrSOX5810J.86A.5529.2010.1214.2317:bd12/14/2010:svnSystem76,Inc.:pnTheLeopardExtreme:pvrleo1:rvnIntelCorporation:rnDX58SO:rvrAAE29331-503:cvn:ct2:cvr:
dmi.product.name: The Leopard Extreme
dmi.product.version: leo1
dmi.sys.vendor: System76, Inc.
version.compiz: compiz 1:0.9.8.4+bzr3407-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.39-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

Workaround: add this to xorg.conf (in my case, to both of them):

Section "ServerFlags"
        Option "BlankTime" "0"
EndSection

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg-server (Ubuntu):
status: New → Confirmed

I think the default value of 10 minutes is coming from DEFAULT_SCREEN_SAVER_TIME in include/site.h. I don't understand why it only affects one of my computers though ...

This is a duplicate of this bug report filed at launchpad:
https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1072531

When the computer is idle, the screen blanks automatically after ten minutes. It seems to be a screensaver because it returns to the normal state when I move the mouse or press a key.
As suggested on launchpad, the following command temporarily fixes the problem until the next reboot:
xset s 0 0
Please refer to the launchpad link above for more details.

Sorry, this is my first bug report. Please feel free to change the component and other details. I wasn't sure what I should enter because I don't understand the options offered.

I have now upgraded two other computers to 12.10 and neither of them experience this issue ...

To the other people experiencing this bug: are you also using multi-head/multi-seat? (If you've never heard those terms before, the answer is probably no.)

Andrew Wharton (mmyhib) wrote :

Yes, I have the same problem after upgrading, I'm running dual monitors from a Acer TravelMate 5530, one on the HDMI port and one on the VGA port. I've tried both answers on http://askubuntu.com/questions/207131/screensaver-blanking-problem/207240, neither of which work, the screen still goes black after 10 mins or so.

Andrew Wharton (mmyhib) wrote :

also running "xset s 0 0" fixed the problem for me as well, thanks.

If you are a developer, please fix this bug! No one on Launchpad wants to fix it.

I am also available by email if you need more information. I'll be happy to provide any log/ config file/ other info you need. I will try to make the fixing process as easy as possible for you. Please help!

(In reply to comment #1)
> If you are a developer, please fix this bug! No one on Launchpad wants to
> fix it.
>
> I am also available by email if you need more information. I'll be happy to
> provide any log/ config file/ other info you need. I will try to make the
> fixing process as easy as possible for you. Please help!

Here is my email address:
marion (döt) zepf (ät) gmail (döt) com
I'm not sure whether it is publicly visible next to my post, so I though I'd give it explicitly.

I don't see any X bug described here or in the Ubuntu report - the X server
has always defaulted to screen blanking after a timeout.

If you previously had UI to control it, and that's not working after an
upgrade, then that's a bug in GNOME, KDE, or whatever provides that UI.

Changed in xorg-server:
importance: Unknown → Medium
status: Unknown → Won't Fix

Thanks Alan. To my knowledge, Ubuntu actually has _never_ had a UI to control this--screen blanking has always been disabled before. The UI only allows the user to configure the time period for powering off the display. Now it seems that screen blanking is mysteriously enabled on some machines in 12.10.

Other than with xorg.conf or xset, how might the distro be disabling this? I wasn't able to find any override anywhere. I am guessing that the override is not working in some corner case.

Jeremy Bicha (jbicha) wrote :

I believe this is actually a duplicate of bug 1046118 but I thought that required at least gdm to be running. Do you know for sure whether you are using gdm or lightdm for your logon screen?

I am using only lightdm and Unity. My lightdm.conf is attached above.

Also, in my case the screen does _not_ power down after 10 minutes, it just displays black. i.e., the HDMI display connected to it shows that it is still receiving a signal. By comparison, the "Turn off screen when inactive" setting truly turns off the display and the display reports no signal. But possibly the reporter of bug 1046118 used the term "power down" loosely.

I have this problem, have never heard of multi-head/multi-seat but the problem arose a while after upgrading to 12.10. Most of this discussion is way over my head, but I would very much like to resolve this issue without having to clean-install again. Can somebody please publish step-by step instructions for the aged?

Florent Delayen (tnedel) wrote :

Clean install will not change anything, because I installed ubuntu 12.10 (not upgraded), and still have this bug.

Seems to be a bug in Ubuntu (config).

To permanently correct this, add this line at the top of /home/YOU/.profile :

xset s 0 0

The file should look just like this :

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

xset s 0 0

(and some other lines)

Doug Coleman (doug-coleman) wrote :

This is a real usability issue. I have a Mac Pro running two Ubuntu VMs and I never want them to activate screensavers/sleep mode/locked screen--the Mac Pro has its own power-saving features. The 12.04 VM works correctly, but the 12.10 has no easy option to stop the screen from turning black.

I found a fix here: http://askubuntu.com/questions/207131/screensaver-blanking-problem

The accepted answer worked for me -- setting idle-dim-time to 0 is my guess at what fixes things, but I also have the screensaver disabled thanks to an answer below it.

Ideally the setting for this would be configurable through the "System Settings" application so that people don't have to know about dconf.

Thanks!

Tristan Schmelcher, thank you for reporting this bug to Ubuntu. Quantal reached EOL on May 16, 2014.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

If this is reproducible in a supported release, please file a new report.

no longer affects: xorg-server (Ubuntu)
affects: xorg-server → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
importance: Medium → Undecided
status: Won't Fix → New
status: New → Invalid
To post a comment you must log in.