Ubuntu

Using the touchscreen breaks normal device left clicking

Reported by Charlie Murder on 2012-05-22
90
This bug affects 18 people
Affects Status Importance Assigned to Milestone
xorg-server (Ubuntu)
Low
Canonical X.org

Bug Description

Shortly after reboot, the problem starts occurring.

Haven't been able to find a trigger for the issue.

When opening the home folder, using the left Unity menu, we are unable to open files or folders by left clicking on them.
When right clicking, the menu contains no open option

Same problem with files on the desktop.

We have installed the 'open in terminal' right click menu addon from repos.

Description: Ubuntu 12.04 LTS
Release: 12.04

nautilus:
  Installed: 1:3.4.1-0ubuntu1
  Candidate: 1:3.4.1-0ubuntu1
  Version table:
 *** 1:3.4.1-0ubuntu1 0
        500 http://za.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

nautilus-open-terminal:
  Installed: 0.19-2build1
  Candidate: 0.19-2build1
  Version table:
 *** 0.19-2build1 0
        500 http://za.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

We would appreciate your help.

Kind regards,
Charles & Tresor

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: wl fglrx
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Tue May 22 12:07:42 2012
GsettingsChanges: org.gnome.nautilus.window-state geometry '800x550+1076+157'
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 LANGUAGE=en_ZA:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Charlie Murder (charlesmurder) wrote :
Charlie Murder (charlesmurder) wrote :

I've figured out what triggers the behaviour, it happens whenever we use the touchscreen.

Best short term solution is to disable the touchscreen. To do this on Ubuntu 12.04 do the following:

1. To determine the device name look at instructions here http://ubuntuforums.org/showthread.php?p=9999160
2. Create a file in your home directory called .xsessionrc
3. Add the following line to the file: xinput set-prop 'Quanta OpticalTouchScreen' 'Device Enabled' 0
    Be aware that 'Quanta OpticalTouchScreen' is specific to my machine. You will need to enter your device name, acquired by

4. save, close and restart

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
debb1046 (debb1046) wrote :

I experience the same problem with 12.04 on exopc (eGalax TouchController USB 0xeef:0x72a1). I do not have the nautilus-open-terminal package installed. Since this is a tablet, disabling the touchscreen is not feasible.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
summary: - Unable to access file or folder when clicking
+ Using touchscreen break normal device left clicking
summary: - Using touchscreen break normal device left clicking
+ Using the touchscreen breaks normal device left clicking
Sebastien Bacher (seb128) wrote :

is the issue specific to nautilus or does it happen in other GTK softwares?

debb1046 (debb1046) wrote :

It is very prominent with Nautilus and I haven't noticed this problem in other programs (GTK and other).

That said, the touchscreen in 12.04 is in general less reliable than in the previous version of Ubuntu. Symptoms are:
- it stops working in unity-3d after a couple of clicks (Bug #949791)
- unity-panel-service crashes sometimes when indicators are clicked with touchscreen
- click helpers in onboard are not working when used with touchscreen
- right click emulation with mousetweaks is not working with touchscreen

No idea whether these problems are in any way related.

Sebastien Bacher (seb128) wrote :

did you use apport to report bugs about the unity-panel-services issues? not sure, but the description looks like the bug is rather on the xorg input side or utouch than nautilus

debb1046 (debb1046) wrote :

I can't use apport on this device because it triggers a GPU hang which launches another apport instance which triggers a GPU hang etc until the tablet is completely unresponsive.

The unity-panel-services crash is probably due to Bug #863720 and as far as I can guess unrelated.

BTW, I've discovered that things are OK when I switch to list view in Nautilus, so that's a workaround for now. Icon view and compact view are not working.

Sivabalan (siva886) wrote :

I am trying out Ubuntu 12.04 on an Exo-PC tablet and I face this issue as well. Left clicking an item in nautilus does not work in Icon/Compact view. Selection can still be done by dragging a box around though.

Ar-Paramir (arparamir) wrote :

I can confirm this bug, BUT for Fedora 17 x64. So it's not a distro-specific issue, the bug might be somewhere in GTK3. For me it's exactly the same as has been described here. With one important notice. NOT only Nautilus! In System Settings window, when you click on System Info and move the mouse (just move without any clicking) above the information, it's selected. And also in Torcs Car Simulator the menu items are selected with hovering (I mean I don't need to make a click at all, just to put the mouse over and that's it, the menu item opens, and it isn't a normal behaviour). It seems like the left button of the mouse is always pressed or like that. This issue is not a rule, when I restart, it's OK for a while, and I still don't know the reason of the bug's activation. First I thought because of plugging in a USB-HDD, but I'm not sure now.
One more important notice. My machine is a monoblock (MSI All-In-One PC) with multitouch screen.
Unfortunately I don't know how to trace the bug to see the technical details and post a reasonable bug-report.

Linus Seelinger (s-linus) wrote :

Just another confirmation, using an Acer T230H on 12.04. Practically makes the touchscreen unusable

ID 0eef:480d D-WAV Scientific Co., Ltd, eGalax touchscreen in asus t101mt.
Nautilus don't work, Firefox (touchscreen+touchpad) don't work.
how can i get debug codes?.
The tablet now is only a Eeepc.

Thomas (tom-rosary) wrote :

same problem with the Lenovo Ideacentre A720
workaround from debb1046 with list view works for me to!

Benjamin Tissoires (tissoire) wrote :

This bug is related to xserver and not only nautilus.
It has been fixed upstream in commit 3e6358ee6c33979329b78fe2097a1fdf76fb69cd "Xi: Don't check for TOUCH_END, it's never set" but as you are experiencing, it's not included in neither ubuntu 12.04 nor F17 (though F18 is fixed).

I would recommend changing the priority of this bug as it affects all multitouch screens and also changing the component to xserver.

Cheers,
Benjamin

BeeWhy (thedeeps-await) wrote :

Another Confirmation of the same bug, Using a Gateway One ZX6810. Exact same problem, Nautilus only functions well when I disable touchscreen (obviously a less than optimal fix).

The importance is LOW, but two months ago I do not use Ubuntu, and I use Android x86 because I can't use it as Tablet.
In Android my Asus TM-101MT is working, for my is a IMPORTANT bug.

kathleenhenri (kathleenhenri) wrote :

Ah yes, this bug has been driving me crazy! I have an Exopc running 12.10 and the same problem for me.
If I have to disable the touchscreen in order to use the left click, it turns the touchscreen tablet just another monitor.
Hope someone is able to work this out.
I can move open windows around, but cannot click (or tap for that matter) and open or move ANYTHING on the desktop.

Sebastien Bacher (seb128) wrote :
affects: nautilus (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
assignee: nobody → Canonical X.org (canonical-x)
debb1046 (debb1046) wrote :

I rebuilt xserver-xorg-core and xserver-common with the patch from comment #19. It does help insofar as my touchscreen stays usable after double-tapping something in nautilus in icon view. This machine (exo-pc) does not have a touch pad so I can't test that. Bluetooth mouse works fine. However, double tapping the touchscreen still does not trigger any actions (open folder, open file etc.) in icon view (https://bugs.launchpad.net/ubuntu-nexus7/+bug/1071922). It only works as expected in list view.

Thomas (tom-rosary) wrote :

found this http://askubuntu.com/questions/143015/mouse-selects-everything-on-its-own maybe it's a hind or it could help some people to fix it
Can't test it if the change in /usr/share/X11/xorg.conf.d/10-evdev.conf works cause of another issues at the moment.

Bratmaxe (marcel-456) wrote :

I have sovlved it by installing all updates from this PPA: ppa:xorg-edgers/ppa

debb1046 (debb1046) wrote :

Installed xorg-xedgers. Behaviour of nautilus in icon view is still erratic. Double tapping to open folders works a couple of times and then stops working. I cannot trigger file actions by double tapping. Again, list view works fine. After switching back from list view to icon view, it will once again register a few double taps then stop working again.

An upstream bug is here: https://bugzilla.gnome.org/show_bug.cgi?id=688281

Templaer (temrez) wrote :

After installing xorg-edgers and trying fix from comment 21, i have the same behavior of nautilus as described in comment 23.
Try on Acer Iconia W500

Thomas (tom-rosary) on 2013-01-26
tags: added: kernel-bug-exists-upstream-v3.8
Thomas (tom-rosary) wrote :

#22 didn't work for me in 12.04

$ Xorg -version

X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.42-34-generic x86_64 Ubuntu
Current Operating System: Linux Tommy-AIO 3.2.0-37-generic #58-Ubuntu SMP Thu Jan 24 15:28:10 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-37-generic root=UUID=ea1671bb-6d90-4e88-8808-5a5fc1bff71c ro nopat crashkernel=384M-2G:64M,2G-:128M resume=UUID=e4918e2d-1704-43a6-93c0-93235d39768e
Build Date: 17 January 2013 06:14:10AM
xorg-server 2:1.11.4-0ubuntu10.11 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.28.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.

Confirmed on ASUS VivoBook X202E. In fact updating ppa:xorg-edgers/ppa worked for me. :)

Kevin Nielson (kevin-nielson) wrote :

Confirmed under 12.10

$ Xorg -version

X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-32-xen x86_64 Ubuntu
Current Operating System: Linux ProblemBox 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-3.5.0-26-generic root=/dev/mapper/ubuntu-root ro quiet splash vt.handoff=7
Build Date: 05 November 2012 10:00:21AM
xorg-server 3:1.12.4+git20121105-makson1~ppa2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.26.0
 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.

debb1046 (debb1046) wrote :

Try updating nautilus. I believe that at least part of the problem was:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1071922
which has been fixed recently in 12.04 and in Raring but not in 12.10. This was a bug in nautilus rather than in Xorg. If it works in nautilus "list view" but not in "icon view" then it is probably the nautilus bug.

Bryce Harrington (bryce) wrote :

Agreed, this does sound like the recently fixed nautilus bug. Can you re-test with current raring?

Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
John Faulkner (johnnyuk) wrote :

I'm using an up-to-date Raring install. I have this problem still, which appears to be tied in some way to operations which tax the hardware in some way, but I'll get back to that later. What is interesting in that when the bug occurs, rendering the unity dash and GTK apps unusable with the touch screen, nautilus is now the one application which continues to work flawlessly.

I've tried using the xorg-edgers PPA to fix the issue but because it's an all-or-nothing approach (you have to update every package in the ppa), it renders Unity completely unstable - appears to be an intel graphics regression causing massive slowdown whenever transparency or blurring is used (Unity dash search, logout dialog etc) so I had to ppa-purge and I can't tell if it fixed the issue.

With regards to the hardware taxing, it appears that the touch screen is usable on boot up until any operation which seems to take a little longer than usual. For instance, I have a custom built GTK application which utilises a GtkToolPalette (https://developer.gnome.org/gtk3/3.4/GtkToolPalette.html) which has a nice smooth animation for opening the category. Whenever I tap one of these headers with the touch screen, without fail, I can reproduce this exact bug. It still happens occasionally with other tasks, but this happens every time.

I wonder, with it possibly being performance-related, whether or not this makes it harder for devs to reproduce the error? Either way, I'm happy to provide any help I can with this bug, just let me know.

John Faulkner (johnnyuk) wrote :

I should probably also point out that a standard mouse continues to work fine, in nautilus or otherwise.

Szilard Novaki (novaki) wrote :

I have the same problem with ASUS Vivobook S400. Touchscreen is Atmel Atmel maXTouch Digitizer.

I tried the xorg-edgers ppa, but it did not help. It worked after reboot, but stopped recognizing clicks after ~5mins of use.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.