segmentation fault when using cnee

Bug #378648 reported by xylo on 2009-05-20
68
This bug affects 14 people
Affects Status Importance Assigned to Milestone
xnee (Debian)
Fix Released
Unknown
xnee (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cnee

When I try to execute
  cnee --record --events-to-record 1000 --mouse --keyboard -o /tmp/xnee.xns -e /tmp/xnee.log -v
as mentioned as an example in the man pages of cnee I get a segmentation fault. Here is the entire output:
% cnee --record --events-to-record 1000 --mouse --keyboard -o /tmp/xnee.xns -e /tmp/xnee.log -v
--> xnee_prepare
---> xnee_open_files
--- xnee_open_files: handling err
--- xnee_open_files: opening err: /tmp/xnee.log
zsh: segmentation fault (core dumped) cnee --record --events-to-record 1000 --mouse --keyboard -o /tmp/xnee.xns -e

BTW, other cnee commands also fail, but with an other error. For example, when I run
  cnee --record --keyboard --events-to-record 2
it tries to start recording but ends with the following output:
error-range 0-0
Error received:
        error type 0 (0x0)
        error code 156 (0x9c)
        error code major 136 (0x88)
        error code minor 5 (0x5)
        display 29128224 (0x1bc7620)
 XRecordBadContext
This error can be ignored
Error number: 35
  Error: Record memory failure
  Solution: Xnee failed due to bad data received from RECORD extension

I just thought these bugs could be related. Therefore I have mentioned it here.

ProblemType: Crash
Architecture: amd64
DistroReleases: Ubuntu 9.04, Ubuntu 10.04

Related branches

xylo (stefan-endrullis) wrote :

I forgot to mention that I'm using Ubuntu Jaunty.

xylo (stefan-endrullis) wrote :

64 bit

xylo (stefan-endrullis) on 2009-05-27
description: updated
xylo (stefan-endrullis) on 2009-05-27
description: updated
xylo (stefan-endrullis) wrote :

The shortest command to produce a segmentation fault is:
  cnee -e

xylo (stefan-endrullis) wrote :

Also tested with Ubuntu Karmic i686: same behavior. :(

I still have to work with hardy since any further Ubuntu release has this bug. :(

xylo (stefan-endrullis) wrote :

There is a similar issue (bug #315456) about the broken RECORD extension of the xserver. Maybe this bug depends on that issue.

xylo (stefan-endrullis) wrote :

No news about this issue? :-(

userdce (userdce) wrote :

same with karmic 64bit

Zurd (zurd3) wrote :

This is definitely broken everywhere, no fix yet, might be a problem with xorg and not cnee :
http://www.sandklef.com/hesa/index.php/2009/05/06/gnu-xnee-303-released/

Note that it might be the same problem with xmacro, but at least with xmacro you can still make it work :
https://bugs.launchpad.net/ubuntu/+source/xmacro/+bug/367685

xylo (stefan-endrullis) wrote :

Yes, the segmentation fault might be caused by the broken Record extension of the X server. I still cannot believe how the developers of xorg could break such an important extension which is used by dozens of applications. On the other hand I'm very disappointed to see this broken X server version in several releases of ubuntu (intrepid, jaunty, karmic, and lucid). IMO it should have been rejected until this bug has been fixed. I already tried to install the xserver from hardy in jaunty, but I had several problem with the keyboard layout afterwards and did not know how to fix them. Therefore I'll stay with hardy on most of my systems.

BTW, there seems to be a progress on this issue: https://bugs.freedesktop.org/show_bug.cgi?id=20500

I hope it will be fixed at least in lucid, because I don't want to stay with hardy forever. (I'm already mixing hardy packages with karmic packages and waiting for the big crash.)

xylo (stefan-endrullis) wrote :

The xserver related bug #315456 has been fixed but cnee is still producing this segmentation fault.

Changed in xnee (Ubuntu):
status: New → Confirmed
xylo (stefan-endrullis) on 2010-03-16
description: updated
xylo (stefan-endrullis) wrote :

added corresponding Debian bug report

Changed in xnee (Debian):
importance: Undecided → Unknown
status: New → Unknown
hesa (hesa) wrote :

Can you please test with a slightly older Xnee;

   ftp://ftp.gnu.org/gnu/xnee/xnee-3.02.tar.gz

Some code was added to Xnee to check for newer versions of X.org (with faulty RECORD extension). This code is still there so the new X.org may (actually I am quite sure) not work.

xylo (stefan-endrullis) wrote :

This xnee version does not compile anymore on Ubuntu lucid.
./pnee_impl.h:32:19: error: gnome.h: No such file or directory

I suppose the compiler tries to locate the file under /usr/include/gnome-1.0/gnome.h where it was located under hardy (package libgnome-dev). But this package does not exist anymore.

If you need the full output of make, just tell me and I will provide it.

Hernando Torque (htorque) wrote :

I just copied over the debian folder from Ubuntu's sources and compiling worked fine. Xnee on the other hand didn't:

Error received:
 error type 0 (0x0)
 error code 144 (0x90)
 error code major 135 (0x87)
 error code minor 5 (0x5)
 display 142529520 (0x87ed3f0)
 XRecordBadContext
This error can be ignored
Error number: 35
  Error: Record memory failure
  Solution: Xnee failed due to bad data received from RECORD extension

Changed in xnee (Debian):
status: Unknown → New
Changed in xnee (Debian):
status: New → Fix Released
giannisfs (giannisfs) wrote :

It doesn't work in Lucid either ...
either cnee (new name for xnee ) either gnee they all crash in ubuntu 10.04

i have compiled version 3.06 of xnee on lucid. I can record and replay.

Vibhav Pant (vibhavp) on 2012-04-22
Changed in xnee (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.