xmacro quit-key no longer recognized

Bug #367685 reported by Sky on 2009-04-27
104
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xmacro (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xmacro

Using Ubuntu 9.04 - the Jaunty Jackalope.

When using xmacrorec2 to record a new keyboard macro, the escape key sequence is no longer recognized. I can start xmacrorec2 just fine, as follows:

$ xmacrorec2
Server VendorRelease: 10600000
XRecord for server ":0.0" is version 1.13.
Press the key you want to use to end the application. This key can be any key,
as long as you don't need it while working with the remote display.
A good choice is Escape.

Upon pressing escape, I receive the following message, showing that the key has been recognized:

The chosen quit-key has the keycode: 9
XQueryPointer returned: 1
Got Start Of Data
Skipping...

But then, after recording my mouse clicks, I press the escape key, and nothing happens. The only way out of the program is to ^C it, at which point the sequence is not saved. This is occurring with various different keystrokes, not just the escape key.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: xmacro 0.3pre-20000911-4.1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: xmacro
Uname: Linux 2.6.28-11-generic i686

Sky (omgee) wrote :
Michael Gefen (gefenm11) wrote :

i have the same issue.

when i tried to use xmacrorec (instead of xmacrorec2) any event i make starts repeating itself numerous times.

ouch (ouch67) wrote :

yep, I can confirm it doing the same thing on my ubuntu jaunty machine.

seems like xmacrorec2 forgets how to grab keystrokes once the quit-key is pushed.

spiral0ut83 (spiral0ut83) wrote :

any workarounds for this? - I got to this point as well - very disheartening

Kangarooo Jānis (kangarooo) wrote :

Today i also for long time again needed Xmacro it was working last time on Xubuntu 8.10 Ubuntu 8.10 and Linuxmint but just 2min ago i put it on Xubuntu 9.04 and Any Escape key is not recognized..
I quote from http://xmacro.sourceforge.net/ :"The programs are heavily based on the xremote utility of Jan Ekholm (chakie at infa.abo.fi)."
So maybe bug is in xremote? Im hoping to get some attention to this bug from this great programm makers. :)

Kangarooo Jānis (kangarooo) wrote :

Any Esc Key is not only problem.. I tryd recording and opening file and it was empty.. On 8.10 ubuntu i think any movement and key press was immidiatlly written in output file. No?

evilakos (akyros1) wrote :

Guys in my opinion the xmacro is just broken on recording after 8.04.
And what I hate is that noone is trying to fix this.
At least on the ubuntu side.Thats at least what I see.I know its not an important package on the core system but :/.
Probably on Debian latest this bug does not exist?(Debian cycle about 18-21 months but you can go latest(packages) with a repo right now but I don't remember name(definitely not experimental)(sid?).)
And so noone from them bothers his self to fix the package.
The xmacro project is dead for a long time too..
I myself is sticking on 8.04 LTS to have the xmacro rec thing right and I am thinking on changing to Debian (at last) with some configurations I wanna find and make.(I have no desktop-pc atm.(bad luck)).

Michael Gefen (gefenm11) wrote :

while it seems that xmacrorec2 works (at least on my debian 5 machine in vitualbox), xmacrorec does not.

PGScooter (pgscooter) wrote :

Another "me too". Jaunty 64-bit. Wish I knew enough to get my hands dirty and fix it.

ikester8 (ihall) wrote :

Same here. macrorec2 is not recognizing keystrokes in Ubuntu 9.04. We are going to have to find someone with the skills to work on this.

Wayne Cat (exchange) wrote :

the problem still exists in Karmic Alpha 3

Confirmed that issue exists in Jaunty.

Changed in xmacro (Ubuntu):
status: New → Confirmed
Rohan Kapoor (rohankapoor) wrote :

I also agree this is a problem. It would be appreciated if fixed!

Rick (rckbrgr) wrote :

Just came across xmacro and see it as a very useful tool. I am disappointed it's not working and that there is very little good documentation for the beginner. I would hope that people would realize that this can be a very valuable tool for people with disabilities affecting their hand dexterity. Is there any way of escalating interest in fixing xmacro as an accessibility issue?

ascle (eric-ruest) wrote :

Any updates on this issue?

ikester8 (ihall) wrote :

@Rick: I have no idea how to get Canonical to get interested. Sounds like I need to get full support and demand someone look at this.

Sky (omgee) wrote :

@Rich: that's exactly my issue. I'm still using 8.10, and it is entirely because of this that I have not been able to update. It looks like Karmic will also not be an option for me, since this issue has apparently not been fixed in that release either. Very frustrating.

I don't have the technical knowledge to work on this, but how do we hunt down someone who does? Can we at least isolate the issue? It seems that the xmacro programs are written in C++. Does anyone have enough of knowledge of that language that they could take a brief look at this and see if it's an easy fix? Perhaps it's something incredibly simple... if it is, I'd hate for this issue to continue to sit here unfixed. I filed this bug report in April, and as far as I can see, nothing's been done with it since that time. What is the procedure to get this escalated? Is there anything that I can do to assist with that process?

ikester8 (ihall) wrote :

Rick pointed out in an email to me that a similar program, xnee, is doing the same thing. There seems to be a call to the X-window system that's causing the problem in both programs.

I'm willing to pay for a solution. But I have no idea how I'd find someone who'd be willing to work on it!

Sky (omgee) wrote :

Can anyone confirm that this is still an issue in Karmic? Given the lack of response here, I'm assuming the bug has not been fixed, but before I continue to use an operating system version that is now over a year old, I figured I'd double check.

Also, if there is a workaround or any alternate tool that accomplishes the same thing as the xmacro package, I'd be grateful to hear about it.

theLured (thelured) wrote :

@Sky
I can confirm that this problem is still in Karmic.

xmacroplay seems to work fine, but xmacrorecord repeats every keypress about 100 times. xmacrorec2 doesn't do anything past choosing an exit key.

xnee/cnee/gnee don't work for recording either. I haven't tried playback, as I don't know how to make a playback file.

running "cnee -demo" seems to show this
---start output---
Xnee will now start recording your mouse and keyboard in 3 seconds
xnee: delayed start, time left: 3 seconds left
## 10 blank lines ##
xnee: delayed start, time left: 3 seconds left
## 10 blank lines ##
xnee: delayed start, time left: 3 seconds left
## 10 blank lines ##
---end output---

It will also break your ability to hold down a key and have it repeat. To get key repeat back, you have to go into system > preferences > keyboard and move the "delay" slider a little.

If you press anything, you are spammed out like with xmacrorec. If the key presses continue after the program has crashed, press any key.
After it has crashed and you cant repeat any keys, running it again gets this output.
---start output---
Xnee will now start recording your mouse and keyboard in 3 seconds
## countdown ##
Error received:
 error type 0 (0x0)
 error code 156 (0x9c)
 error code major 136 (0x88)
 error code minor 5 (0x5)
 display 167679392 (0x9fe95a0)
 XRecordBadContext
This error can be ignored
xnee failed to start
   Error number: 35
   Error string: 'Record memory failure'
   Solution string: 'Xnee failed due to bad data received from RECORD extension'
---end output---

Zurd (zurd3) wrote :

Last comment from theLured explains very well the situation we are facing. But I've found a workaround to make xmacro works. The only problem with it is to record, but it can play a script file. So just open up your favorite text editor and create a script file! It's not user-friendly but it's very simple. Here's a few tips to get you starting :

- All the commands that can be entered in a script file can be found at http://xmacro.sourceforge.net/
- To play a macro : xmacroplay $DISPLAY < your_script_file.txt
- To know what command is used for a key or a mouse button, call xmacrorec $DISPLAY and type the key or press the mouse button, it will show up many times but quit it and you'll have the command to insert into your script file.
- To know the position of your mouse install xdotool : sudo apt-get install xdotool
and use it like so in a console : xdotool getmouselocation
With the position you can call the MotionNotify command of xmacro to position your mouse where you want it to be.
For example in a script file :
MotionNotify 57 10
ButtonPress 1
ButtonRelease 1
This will open up your Applications menu of Ubuntu at the top left.
- To make a return key both pressed and released use "KeyStr Return"
- Use the Delay commands if your actions are too fast for the computer to handle or the computer is waiting for an input (like a network connection).

This is just a work-around that I've used and it's working and in my opinion the only way to automate stuff on linux right now.
I found xmacro to be even better than xnee, less complicated. And don't try the same work-around with xnee, the script file is way too complicated.

nice - i have been watching this issue since july of this year - this is the
first useful tip
 thank you - does creating the script on an older, supported dist a good
course of action
 if you happen to have such a box around?

hesa (hesa) wrote :

Think the problem is solved in GNU Xnee (some problem remain when recording a program in Xephyr).

If anyone can help me test the latest (unreleased) version, I'd be happy

/hesa - GNU Xnee maintainer

hesa (hesa) wrote :

hi,

 just got some test report from two Ubuntu volunteers[1]. cnee now works fine in:

  ubuntu jaunty (9.04)
  karmic koala

/hesa

[1] http://lists.gnu.org/archive/html/bug-xnee/2009-12/msg00000.html

Rohan Kapoor (rohankapoor) wrote :

Does this xnee do the same thing as xmacro?

ikester8 (ihall) wrote :

hesa,

That's great news. I'd be happy to help test the new version.

ikester8

Still not working in Ubuntu 9.10

Any news about this bug?

What about cnee? I'm getting a segmentation fault using:

cnee --record --events-to-record 1000 --mouse --keyboard -o testmacro -v

--snip--
feedback-xosd
Segmentation fault
--snip--

xmacrorec not working in ubuntu 9.10 (x86-64). the description at comment #20 describe it well.

cnee is really segfaulting.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers