Danish Dvorak keyboard layout missing tilde

Bug #989626 reported by Anders Bruun Olsen on 2012-04-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Medium
Unassigned
Precise
Low
Unassigned

Bug Description

[Impact]
Danish Dvorak keyboard layout is just a copy of Norwegian Dvorak created by including the xkb definition for Norwegian Dvorak in the Danish Dvorak section. Apparently Norwegian Dvorak was changed in 12.04 to no longer have the tilde key in the same place. It was correctly placed in 11.10. This is easily fixed by adding the AD12-key from Norwegian Dvorak in 11.10 to the right section in Danish Dvorak in 12.04. This change goes into /usr/share/X11/xkb/symbols/dk. I have attached a patch.

[Test Case]
1. Set the Danish Dvorak keyboard layout
2. Hit the tilde key (between the ' key and the return key on danish keyboards, or the ] key on us keyboards)
3. Hit the tilde key + shift
Broken Behavior: <nothing printed>
Fixed Behavior: ~ ^

[Regression Potential]
The patch only changes the Danish Dvorak keyboard layout for the AC12, so the scope of regression risk is limited to that key for those users.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xkb-data 2.5-1ubuntu1 [modified: usr/share/X11/xkb/symbols/dk]
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
Date: Fri Apr 27 13:12:20 2012
Dependencies:

DistUpgraded: 2012-04-27 11:37:07,541 ERROR SystemError from cache.commit(): installArchives() failed
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
MachineType: Gigabyte Technology Co., Ltd. G31M-S2L
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-24-generic root=UUID=25b20c49-4476-4a39-95a7-649599511430 ro quiet splash vt.handoff=7
SourcePackage: xkeyboard-config
UpgradeStatus: Upgraded to precise on 2012-04-27 (0 days ago)
dmi.bios.date: 06/01/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F10f
dmi.board.name: G31M-S2L
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF10f:bd06/01/2009:svnGigabyteTechnologyCo.,Ltd.:pnG31M-S2L:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnG31M-S2L:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: G31M-S2L
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Anders Bruun Olsen (abo-dsl.dk) wrote :
Anders Bruun Olsen (abo-dsl.dk) wrote :

It should also be noted that when you choose to view the keyboard layout through the system settings, the tilde key for Danish Dvorak is shown as being where it has always been.

The attachment "Patch to fix DK Dvorak in 12.04" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

Created attachment 60806
dk-dvorak-fix

Forwarding this patch from Ubuntu reporter Anders Bruun Olsen:

  https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/989626

"Danish Dvorak keyboard layout is just a copy of Norwegian Dvorak created by including the xkb definition for Norwegian Dvorak in the Danish Dvorak section. Apparently Norwegian Dvorak was changed in 12.04 to no longer have the tilde key in the same place. It was correctly placed in 11.10. This is easily fixed by adding the AD12-key from Norwegian Dvorak in 11.10 to the right section in Danish Dvorak in 12.04. This change goes into /usr/share/X11/xkb/symbols/dk. I have attached a patch.

It should also be noted that when you choose to view the keyboard layout through the system settings, the tilde key for Danish Dvorak is shown as being where it has always been."

[locale]
LANG=en_DK.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=en_US.UTF-8
LC_NUMERIC="en_DK.UTF-8"
LC_TIME="en_DK.UTF-8"
LC_COLLATE=en_US.UTF-8
LC_MONETARY="en_DK.UTF-8"
LC_MESSAGES=C
LC_PAPER="en_DK.UTF-8"
LC_NAME="en_DK.UTF-8"
LC_ADDRESS="en_DK.UTF-8"
LC_TELEPHONE="en_DK.UTF-8"
LC_MEASUREMENT="en_DK.UTF-8"
LC_IDENTIFICATION="en_DK.UTF-8"
LC_ALL=

[setxkbmap]
xkb_keymap {
 xkb_keycodes { include "evdev+aliases(qwerty)" };
 xkb_types { include "complete" };
 xkb_compat { include "complete" };
 xkb_symbols { include "pc+dk(dvorak)+dk:2+inet(evdev)+level3(ralt_switch_for_alts_toggle):1+level3(ralt_switch_for_alts_toggle):2+group(alts_toggle)" };
 xkb_geometry { include "pc(pc105)" };
};

[xkbcomp]
https://launchpadlibrarian.net/103251827/xkbcomp.txt

Bryce Harrington (bryce) wrote :

Anders Bruun Olsen - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=49312 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

The patch looks pretty safe, but I don't want to do an SRU for this until it's accepted upstream.

Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Great! thanks, committed.

Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.5-1ubuntu3

---------------
xkeyboard-config (2.5-1ubuntu3) quantal; urgency=low

  * Add 111_cz_ssharp.patch: Fix mapping of 4th level of the AC11 key to
    ssharp rather than quotedbl for the Czech layout. Cherrypick of
    patch from upstream.
    (LP: #953477)
  * Add 112_dk_dvorak_tilde.patch: Fix tilde key in the Danish Dvorak
    layout. It's not the same as Norwegian as has been assumed previously.
    (LP: #989626)
 -- Bryce Harrington <email address hidden> Mon, 04 Jun 2012 18:11:53 -0700

Changed in xkeyboard-config (Ubuntu):
status: Triaged → Fix Released
Bryce Harrington (bryce) on 2012-06-05
description: updated

Hello Anders, or anyone else affected,

Accepted xkeyboard-config into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in xkeyboard-config (Ubuntu Precise):
importance: Undecided → Low
status: New → Fix Committed
Chris Halse Rogers (raof) wrote :

Hello Anders, or anyone else affected,

Accepted xkeyboard-config into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xkeyboard-config/2.5-1ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.5-1ubuntu1.3

---------------
xkeyboard-config (2.5-1ubuntu1.3) precise-proposed; urgency=low

  * Add 113_ossmath_is_five_levels.patch: Some keymaps like fr(oss) fail to
    load because they include ossmath (via keypad(oss)) which
    misconfigures the keypad as 4-level when it should be 5-level. This
    patch from upstream bugzilla fixes this by adding the 5th level to the
    ossmath definition.
    (LP: #985065)
  * Drop 109_fr_oss_space_char.patch change; the fix causes behavioral
    changes for right control which a fr(oss) user did not like.
    (LP: #1013881)

xkeyboard-config (2.5-1ubuntu1.2) precise-proposed; urgency=low

  * Add 111_cz_ssharp.patch: Fix mapping of 4th level of the AC11 key to
    ssharp rather than quotedbl for the Czech layout. Cherrypick of
    patch from upstream.
    (LP: #953477)
  * Add 112_dk_dvorak_tilde.patch: Fix tilde key in the Danish Dvorak
    layout. It's not the same as Norwegian as has been assumed previously.
    (LP: #989626)

xkeyboard-config (2.5-1ubuntu1.1) precise-proposed; urgency=low

  * Add 109_fr_oss_space_char.patch: Fix problems using space bar in various
    applications when using the fr(oss) keymap.
    (was for LP bug 221112)
  * Add 110_dead_hook_horn.patch: Add two deadkeys on level 3 and 4 of the
    j key for the latin keymap.
    (LP: #825624)
 -- Bryce Harrington <email address hidden> Mon, 25 Jun 2012 17:32:15 -0700

Changed in xkeyboard-config (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.