patch: added dead_hook and dead_horn to latin keyboard layout

Bug #825624 reported by jeremy-list on 2011-08-13
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

[Impact]
The latin keyboard map lacks functionality to do dead_hook and dead_horn characters, which makes it inconvenient to type Vietnamese characters.

[Development Fix]
Patch from reporter was accepted upstream, and included in precise as a cherrypick of what went up.

[Stable Fix]
We're carrying the same xkeyboard-config in both quantal and precise currently, so can carry the same patch both places.

[Test Case]
1. In System Settings, go to Keyboard Layout
2. Select Layouts
3. Press the '+' to add a layout
4. Type 'Maori' (or other layout that imports Latin)
5. In Options, make sure you have 'Key to choose 3rd level' selected (e.g. set to Right Windows key)
6. Hold your configured 3rd level key (e.g. Right Windows key)
7. Press j

Broken Behavior: No character printed
Fixed Behavior: 3rd level places a hook under characters, 4th puts a horn on top.

[Regression Potential]
None expected, this adds functionality to previously unused keys.

Possibly some people have locally mapped j to other key behaviors, but seems unlikely, and they can just as easily locally re-map it again if they prefer.

[Original Report]
Because I occasionally type in Vietnamese, but not with sufficient frequency to learn a completely different keyboard layout, I find it most useful to add dead_hook and dead_horn to the latin keyboard layout (as imported from the Maori layout). I had thought this a minor enough issue to just leave the patch on my own system but it got overwritten last time I did a distribution upgrade.
The added deadkeys are on level 3 and 4 of the J key, which were previously unused.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xkb-data 2.1-1ubuntu3 [modified: usr/share/X11/xkb/symbols/latin]
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Sat Aug 13 14:23:23 2011
Dependencies:

DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3676]
   Subsystem: Hewlett-Packard Company Device [103c:3676]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: Hewlett-Packard Presario CQ57 Notebook PC
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_NZ:en
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=UUID=ed5ad4cb-8918-4323-b338-945d113867cb ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xkeyboard-config
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/10/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.02
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3676
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 29.15
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.02:bd03/10/2011:svnHewlett-Packard:pnPresarioCQ57NotebookPC:pvr0595100000204910002020100:rvnHewlett-Packard:rn3676:rvr29.15:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: Presario CQ57 Notebook PC
dmi.product.version: 0595100000204910002020100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

jeremy-list (quick-dudley) wrote :
jeremy-list (quick-dudley) wrote :

I just had to patch the file again after upgrading to oneric. I wouldn't even bother to report this as a bug if it weren't for the fact apt *#_-@ always overwrites my customization!

Bryce Harrington (bryce) wrote :

Hey quick-dudley,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xkeyboard-config (Ubuntu):
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Expired
jeremy-list (quick-dudley) wrote :

Bug is still present in Oneric. Please note that I included a patch in the original bug report, no effort is required from the official maintainers except testing and incorporating my patch.

jeremy-list (quick-dudley) wrote :

The only other person to make a comment on this report didn't seem notice that it's a patch. IT'S A PATCH! THERE IS ALREADY A PATCH!
Yes, the issue the patch is for is present in every version of Ubuntu and there is little point even testing for it until this report has at least been commented on by someone who has noticed that it includes a patch.

Changed in xkeyboard-config (Ubuntu):
status: Expired → New

Created attachment 60810
0001-latin-Add-dead_hook-and-dead_horn-to-J-key-level-3-4.patch

Forwarding patch from Ubuntu report:
  https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/825624

[Problem]
dead_hook and dead_horn needed for latin keymap.

[Original Report]
Because I occasionally type in Vietnamese, but not with sufficient frequency to learn a completely different keyboard layout, I find it most useful to add dead_hook and dead_horn to the latin keyboard layout (as imported from the Maori layout). I had thought this a minor enough issue to just leave the patch on my own system but it got overwritten last time I did a distribution upgrade.
The added deadkeys are on level 3 and 4 of the J key, which were previously unused.

[Discussion]
I've refreshed the patch to apply to the upstream xkeyboard-config tree.

Bryce Harrington (bryce) wrote :

jeremy-list - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=49315 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Confirmed

ok, committed. Actually latin is used quite widely - so if people complain, I'll have to revert.

Changed in xkeyboard-config:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.5-1ubuntu2

---------------
xkeyboard-config (2.5-1ubuntu2) quantal; urgency=low

  * Add 109_fr_oss_space_char.patch: Fix problems using space bar in various
    applications when using the fr(oss) keymap.
    (LP: #221112)
  * Add 110_dead_hook_horn.patch: Add two deadkeys on level 3 and 4 of the
    j key for the latin keymap.
    (LP: #825624)
 -- Bryce Harrington <email address hidden> Wed, 16 May 2012 18:46:24 -0700

Changed in xkeyboard-config (Ubuntu):
status: Triaged → Fix Released
Bryce Harrington (bryce) on 2012-05-17
description: updated
Changed in xkeyboard-config (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → Low
Martin Pitt (pitti) wrote :

The uploaded SRU removes rules/base.lst and rules/evdev.lst entirely and also patches rules/evdev.xml.in, which is not described in the changelog and does not look related. It also removes the two files from po/POTFILES. See http://launchpadlibrarian.net/105269828/xkeyboard-config_2.5-1ubuntu1_2.5-1ubuntu1.1.diff.gz . Please check if this is intended, and if not, reupload. Thanks!

Bryce Harrington (bryce) wrote :

I checked with Timo Aaltonen about this. It seems there was some cruft remaining in his tree when he built the original package which caused these differences. The git tree (from which I built the SRU package) was clean.

However, the cruft causes no harm, so I will upload a new package built from the shipped package that leaves the cruft bits alone.

Hello jeremy-list, or anyone else affected,

Accepted xkeyboard-config into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Bryce Harrington (bryce) on 2012-06-06
description: updated
C de-Avillez (hggdh2) wrote :

xkb-data:
  Installed: 2.5-1ubuntu1.1
  Candidate: 2.5-1ubuntu1.1
  Version table:
 *** 2.5-1ubuntu1.1 0
        500 http://archive.ubuntu.com/ubuntu/ precise-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     2.5-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

I tried, installing Maori, and setting Right-Alt as my third-level key. This is what I get:

ả (alt-j + a)

This does not seem to be the horn I expected.

C de-Avillez (hggdh2) on 2012-06-06
tags: added: verification-failed
removed: verification-needed
C de-Avillez (hggdh2) wrote :

I do not think it is a good idea for me to check on this -- I do not speak/read Vietnamese, and a (say) 'a' with a horn is as visible as an 'a' with a tail.

Resetting to verification-needed.

tags: added: verification-needed
removed: verification-failed
Chris Halse Rogers (raof) wrote :

Hello jeremy-list, or anyone else affected,

Accepted xkeyboard-config into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xkeyboard-config/2.5-1ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Stéphane Graber (stgraber) wrote :

Followed the test case and the fix indeed works.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.5-1ubuntu1.3

---------------
xkeyboard-config (2.5-1ubuntu1.3) precise-proposed; urgency=low

  * Add 113_ossmath_is_five_levels.patch: Some keymaps like fr(oss) fail to
    load because they include ossmath (via keypad(oss)) which
    misconfigures the keypad as 4-level when it should be 5-level. This
    patch from upstream bugzilla fixes this by adding the 5th level to the
    ossmath definition.
    (LP: #985065)
  * Drop 109_fr_oss_space_char.patch change; the fix causes behavioral
    changes for right control which a fr(oss) user did not like.
    (LP: #1013881)

xkeyboard-config (2.5-1ubuntu1.2) precise-proposed; urgency=low

  * Add 111_cz_ssharp.patch: Fix mapping of 4th level of the AC11 key to
    ssharp rather than quotedbl for the Czech layout. Cherrypick of
    patch from upstream.
    (LP: #953477)
  * Add 112_dk_dvorak_tilde.patch: Fix tilde key in the Danish Dvorak
    layout. It's not the same as Norwegian as has been assumed previously.
    (LP: #989626)

xkeyboard-config (2.5-1ubuntu1.1) precise-proposed; urgency=low

  * Add 109_fr_oss_space_char.patch: Fix problems using space bar in various
    applications when using the fr(oss) keymap.
    (was for LP bug 221112)
  * Add 110_dead_hook_horn.patch: Add two deadkeys on level 3 and 4 of the
    j key for the latin keymap.
    (LP: #825624)
 -- Bryce Harrington <email address hidden> Mon, 25 Jun 2012 17:32:15 -0700

Changed in xkeyboard-config (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.