[Needs SRU to Lucid] Keyboard layout for Sindhi

Bug #588918 reported by Abdul-Rahim Nizamani on 2010-06-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
High
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: xkeyboard-config

I was advised to report the keyboard layout for Sindhi language here. The new file for keyboard layouts of Pakistan (pk) is attached here. The new keyboard layout is called "MBSindhi", though you can name it "Sindhi" as well. It starts at line 203 in the attached file.

This layout is for Sindhi language (locale: sd_PK, sd_IN), though the locale sd_PK is yet to be included. This is is the default keyboard layout widely used for Sindhi in Windows and Linux, but is not included in the Ubuntu's packages. So I am submitting it here to be included in the system.

It is not used by the locale sd_IN@devanagari, which uses a different writing script whereas this keyboard layout is for the Arabic-based script of Sindhi which is the default and official script both in Pakistan and India.

Abdul-Rahim Nizamani (ghaffari) wrote :
  • pk Edit (20.4 KiB, text/plain)

Created an attachment (id=36663)
Sindhi keyboard layout

Forwarding from upstream,
https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/588918
for the addition of the Sindhi keyboard layout, in the 'pk' file.

(I am not related to the keyboard layout; I created this partial patch).

Could you provide the full patch, including bits for base.xml.in? I am asking because I am not sure about languages involved.

Created an attachment (id=36667)
Patch for base.xml.in

Patch for base.xml.in.

Created an attachment (id=36669)
Patch for symbols/pk (Sindhi layout)

Thanks Abdul-Rahim.
I made a patch and I created a bug report for the xkeyboard-config project at
https://bugs.freedesktop.org/show_bug.cgi?id=28875

Please follow this bug report in case any requests are needed for the layout.

Changed in xkeyboard-config (Ubuntu):
status: New → In Progress

Thanks! I added it as pk(snd). Hope it is ok

The layout has been accepted upstream in the xkeyboard-config project.

You will have the Sindhi keyboard layout available in Ubuntu 10.10 :-).

Changed in xkeyboard-config (Ubuntu):
status: In Progress → Fix Committed
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in xkeyboard-config:
importance: Medium → Unknown
Abdul-Rahim Nizamani (ghaffari) wrote :

The status is shown as "Fix released" but I am still unable to use it in Ubuntu 10.04 after reinstalling the xkb-data package. I also downloaded the iso of Ubuntu 10.10 and mounted it to see if the keyboard layout is included in it. But it isn't there too. So what is the current status?

By the way, the Sindhi locale sd_PK is now included in the Ubuntu 10.10. So this keyboard should have been there!

Bryce Harrington (bryce) on 2011-02-02
summary: - Keyboard layout for Sindhi
+ [Needs SRU to Lucid] Keyboard layout for Sindhi
Bryce Harrington (bryce) wrote :

If I understand correctly, the bug was fixed upstream but xkeyboard-config was not updated during Maverick so the fix is still outstanding in Ubuntu.

I've pulled in the new xkeyboard-config package for Natty which I've confirmed does in fact include this change.

I've opened two SRU tasks to backport the fix to maverick and lucid, in case someone has time to file them.

Changed in xkeyboard-config (Ubuntu Natty):
importance: Undecided → High
bugbot (bugbot) on 2011-02-03
tags: added: lucid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.1-1ubuntu1

---------------
xkeyboard-config (2.1-1ubuntu1) natty; urgency=low

  * Merge from debian of 2.1 release.
    - Fixes Ubuntu bugs:
      + Sindhi keyboard layout (locale: sd_PK, sd_IN) (LP: #588918)
      + Fix conflict between Mali and Malayalam layouts (LP: #575660)
      + Support for Philippines "National Keyboard Layout" (LP: #672881)
      + Support for Kinesis keyboard geometry (LP: #393887)
      + Support for Apple Aluminium keyboards (LP: #696232)
      + Support for abnt2 keyboard, thinkpad variant for Lenovo 3000 v100
        laptops (LP: #359719)
      + Fix CapsLock misspelling (LP: #592448)
    - Remaining Ubuntu changes:
      + xkb-data-i18n.install, xkb-data.install, rules: Split out
        xkb-data-i18n to be used by console-setup.
      + rules: Generate pot file for translations during build
      + 104_macbook_expose_and_dashboard.patch: Add keycode definitions
          required for Apples Expose & Dashboard keys (F3/F4).
      + 105_intelligent_keyboard.patch: Add support for the Intelligent
        Keyboard K04
      + 107_lao.patch: New keyboard layout for Lao, implemented as
        an alternative to the default one.
      + 108_taiwan.patch: New keyboard layouts for Taiwan.
  * Drop 102_mac_aliases.patch: This appears to have some side effects,
    and the patch was not taken by upstream because it was an incomplete
    fix. Reopens bug 327963
  * Drop patches included in the new upstream release:
      - 106_fixspell3d.patch: upstream
      - 109_mali.patch: upstream
      - 110_variants-cleanup.patch
      - 111_il-missing-symbol.patch
      - 112_zero-with-spacing.patch
      - 113_cz-dvorak-ucw.patch
      - 114_ejn_4_level.patch
      - 115_aluminium_geometries.patch
      - 116_aluminium_keycodes.patch
      - 117_aluminium_symbols.patch
      - 118_aluminium_aliases.patch
      - 119_aluminium_pc_compat.patch
      - 120_aluminium_rules.patch
      - 121_tamil_chars.patch
      - 122_olpc-azerty.patch
      - 123_fix_i18n.patch
      - 124_serbian_ru_level3.patch
      - 125_mapping_tools_launch5_menukb.patch
      - 126_swahili_arabic.patch
      - 127_restore_gb_colemak.patch
 -- Bryce Harrington <email address hidden> Tue, 01 Feb 2011 11:57:39 -0800

Changed in xkeyboard-config (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in xkeyboard-config:
importance: Unknown → Medium
Changed in xkeyboard-config (Ubuntu Lucid):
status: New → Triaged
Changed in xkeyboard-config (Ubuntu Maverick):
status: New → Triaged
Adolfo Jayme (fitojb) on 2013-05-17
Changed in xkeyboard-config (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in xkeyboard-config (Ubuntu Maverick):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.