Ubuntu

Mali layout selects Malayalam layout

Reported by reg on 2010-05-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Medium
xkeyboard-config (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: xkeyboard-config

In lucid, Mali keyboard layout has been added.
Unfortunately, choosing it selects the Malayalam layout:

Mali has country-code ML
Malayalam has language-code ML

This is an Ubuntu-specific bug (see https://bugs.freedesktop.org/show_bug.cgi?id=25760)

(In reply to comment #0)
> Please note that while I've set name to 'mali', it should be 'ml' but there
> seem to be a bug somewhere (either freedesktop or gnome keyboard properties)
> which makes it conflicts with the Malayalam layout: ML is Mali ISO 3166-1
> country code and ML is also Malayalam ISO 639-1 language code.

My bad, I just realize I missed the <countryList><iso3166Id> tags.
Will update the report in a bit.

Created an attachment (id=32248)
Fixed Mali Layout

Well,

All my apologies for talking about a bug which doesn't exist ; I should have
read the DTD more carefully.

Attached is the fixed layout and bellow the fixed base extract

--
    <layout>
      <configItem>
        <name>mali</name>
        <shortDescription>Mali</shortDescription>
        <description>Mali</description>
        <countryList><iso3166Id>ML</iso3166Id></countryList>
        <languageList><iso639Id>BAM</iso639Id></languageList>
      </configItem>
      <variantList>
        <variant>
          <configItem>
            <name>fr</name>
            <description>Français (France)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>fross</name>
            <description>Français (France - Alternative)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>usmac</name>
            <description>English (USA - Macintosh)</description>
          </configItem>
        </variant>
        <variant>
          <configItem>
            <name>usintl</name>
            <description>English (USA - International)</description>
          </configItem>
        </variant>
      </variantList>
    </layout>
--

Are you sure the group names are correct???

Also, about base.xml.in - the default layout should not be listed among variants.

Please have a look at http://www.freedesktop.org/wiki/Software/XKeyboardConfig/Rules

Created an attachment (id=32381)
Mali Layout - Fixed Group Names

Created an attachment (id=32382)
base.xml.in Mali Layout

Thanks Sergey for the Rules URI. I haven't found those.

> Are you sure the group names are correct???

There were wrong according to the rules. Now fixed.

> Also, about base.xml.in - the default layout should not be listed among
variants.

Right, also fixed.

I also fixed some cosmetics in the layout file according to the rules.

Thank you for your comments,

--

Please note that the name of the layout (and thus <name> value in base.xml.in) should be "ml" because that's the iso3166 code of Mali. I decided not to follow the rules because if I do then gnome-keyboard-properties (haven't tested lower levels) confuses the layout with Malayalam language.

I committed your code. But the filename would be still ml, because that's what ISO tells us. I checked with my version of gnome - it recognizes Mali properly.

Thanks for your code!

reg (rgaudin) wrote :

Binary package hint: xkeyboard-config

In lucid, Mali keyboard layout has been added.
Unfortunately, choosing it selects the Malayalam layout:

Mali has country-code ML
Malayalam has language-code ML

This is an Ubuntu-specific bug (see https://bugs.freedesktop.org/show_bug.cgi?id=25760)

A user reported that if you select Mali and any of the variants, you actually get Malayalam,
https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/575660

I tried and I can replicate that instead of Mali, you get Malayalam.

gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
says
 layouts = [us,ml]
 options = [Compose key compose:menu,grp grp:shifts_toggle]
 model =

The keyboard display in GNOME shows the Mali variants but the keyboard itself shows Malayalam characters.

(btw, all this xkc traffic is due to https://wiki.ubuntu.com/UbuntuBugDay/20100701 ;-)

I managed to reproduce, but that issue was caused by the bug in the Indian layout. Please try from git

(In reply to comment #10)
> I managed to reproduce, but that issue was caused by the bug in the Indian
> layout. Please try from git

Which bug from the Indian layout are you referring to? Is it a known bug?

Kamus (kamus) wrote :

According to upstream developers this was fixed few months ago. Any way, I have checked this under Ubuntu Lucid and now
Malayan layout is under India layout as "in", instead Mali now is using "ml" prefix. Please could you check if is possible of course under Lucid if is still affecting you? Thanks!

Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Simos Xenitellis (simosx) wrote :

I verify that if you select Mali in the keyboard settings, you end up getting Malayalam.
For example, കരിദൈഗാരിദൈഗരൈൈ. Mali is similar to french.

I linked to the upstream report and let's see what the xkc developer has to say on this.

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Confirmed
Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xkeyboard-config - 2.1-1ubuntu1

---------------
xkeyboard-config (2.1-1ubuntu1) natty; urgency=low

  * Merge from debian of 2.1 release.
    - Fixes Ubuntu bugs:
      + Sindhi keyboard layout (locale: sd_PK, sd_IN) (LP: #588918)
      + Fix conflict between Mali and Malayalam layouts (LP: #575660)
      + Support for Philippines "National Keyboard Layout" (LP: #672881)
      + Support for Kinesis keyboard geometry (LP: #393887)
      + Support for Apple Aluminium keyboards (LP: #696232)
      + Support for abnt2 keyboard, thinkpad variant for Lenovo 3000 v100
        laptops (LP: #359719)
      + Fix CapsLock misspelling (LP: #592448)
    - Remaining Ubuntu changes:
      + xkb-data-i18n.install, xkb-data.install, rules: Split out
        xkb-data-i18n to be used by console-setup.
      + rules: Generate pot file for translations during build
      + 104_macbook_expose_and_dashboard.patch: Add keycode definitions
          required for Apples Expose & Dashboard keys (F3/F4).
      + 105_intelligent_keyboard.patch: Add support for the Intelligent
        Keyboard K04
      + 107_lao.patch: New keyboard layout for Lao, implemented as
        an alternative to the default one.
      + 108_taiwan.patch: New keyboard layouts for Taiwan.
  * Drop 102_mac_aliases.patch: This appears to have some side effects,
    and the patch was not taken by upstream because it was an incomplete
    fix. Reopens bug 327963
  * Drop patches included in the new upstream release:
      - 106_fixspell3d.patch: upstream
      - 109_mali.patch: upstream
      - 110_variants-cleanup.patch
      - 111_il-missing-symbol.patch
      - 112_zero-with-spacing.patch
      - 113_cz-dvorak-ucw.patch
      - 114_ejn_4_level.patch
      - 115_aluminium_geometries.patch
      - 116_aluminium_keycodes.patch
      - 117_aluminium_symbols.patch
      - 118_aluminium_aliases.patch
      - 119_aluminium_pc_compat.patch
      - 120_aluminium_rules.patch
      - 121_tamil_chars.patch
      - 122_olpc-azerty.patch
      - 123_fix_i18n.patch
      - 124_serbian_ru_level3.patch
      - 125_mapping_tools_launch5_menukb.patch
      - 126_swahili_arabic.patch
      - 127_restore_gb_colemak.patch
 -- Bryce Harrington <email address hidden> Tue, 01 Feb 2011 11:57:39 -0800

Changed in xkeyboard-config (Ubuntu):
status: Confirmed → Fix Released
reg (rgaudin) wrote :

Can someone reopen this bug as it is a regression since 11.04.
The bug was fixed for 10.10 but came back in 11.04 and is still present in 11.10

The fix is easy: change Malayalam file name as it should be tied to country code (India) instead of Language code.

Changed in xkeyboard-config (Ubuntu):
status: Fix Released → New
Bryce Harrington (bryce) wrote :

reg, can you explain further what the issue is that you see?

I checked our source regarding the mali codes and we're not patching it differently than upstream in that respect.

Changed in xkeyboard-config (Ubuntu):
status: New → Incomplete
reg (rgaudin) wrote :

Bryce,

The issue is not on Mali, the issue is on Malayalam which breaks Mali.

From a user's standpoint, after installing oneiric, if you choose any Mali (country) or Bambara (language) layout, you will get Malayalam (language). It is easy to distinguish as Malayalam uses a non-latin script.

The causes I've identified in the past were a conflict of codes and filenames:
Mali (country) has an ISO3166-1 code of ML
XKB convention is that layouts are stored in per-country files named after the ISO3166-1 code (thus ml)
Malayalam (language) has an ISO 639-1 code of ML

According to upstream the problem is not with the ml layout (to fix the problem locally, I rename ml to mali and change its name in evdev.xml)

Looking at evdev.xml in oneiric, I am not sure how to resolve the problem as Malayalam no longer makes reference to ML but only to MAL. I imagine the problem still lies in code conversion but I can't check as freedesktop website is down for me at the moment.

--
Mali country codes:
ISO 3166-1 Alpha-3 MLI
ISO 3166-1 Alpha-2 ML
Malayalam language codes:
ISO 639-1 ml
ISO 639-2 mal
ISO 639-3 mal
Bambara language codes:
ISO 639-1 bm
ISO 639-2 bam
ISO 639-3 bam

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.