"Make CapsLock an additional Ctrl" should be under "CapsLock key behavior," not "Ctrl key position."

Bug #488532 reported by aheinz1 on 2009-11-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Unknown
Wishlist
xkeyboard-config (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: udev

If you open Keyboard Preferences, then go to the Layouts tab, then select the "layout options..." button, the setting "Make CapsLock an additional Ctrl" should be under "CapsLock key behavior," not "Ctrl key position," as it is a much more logical place for it, as well as being mutually exclusive with the other options in the CapsLock heading.

ProblemType: Bug
Architecture: i386
Date: Wed Nov 25 16:53:15 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Apple Inc. MacBookPro3,1
NonfreeKernelModules: nvidia
Package: udev 147~-6.1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=e0f1421a-6887-4c44-9b3f-e7b92971f3a4 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: udev
Uname: Linux 2.6.31-14-generic i686
dmi.bios.date: 06/18/07
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP31.88Z.0070.B02.0706181323
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F4238BC8
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F4238BC8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP31.88Z.0070.B02.0706181323:bd06/18/07:svnAppleInc.:pnMacBookPro3,1:pvr1.0:rvnAppleInc.:rnMac-F4238BC8:rvrPVT:cvnAppleInc.:ct2:cvrMac-F4238BC8:
dmi.product.name: MacBookPro3,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

aheinz1 (aheinz1) wrote :
jtniehof (jtniehof) on 2009-11-26
affects: udev (Ubuntu) → gnome-control-center (Ubuntu)
jtniehof (jtniehof) on 2009-11-26
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
jtniehof (jtniehof) wrote :

Per comments on Gnome bug 602991.

affects: gnome-control-center (Ubuntu) → xkeyboard-config (Ubuntu)

This really is a duplicate of bug 382301 but this has seen more activity so I don't know if it should be marked the other way around.

jtniehof (jtniehof) wrote :

Thanks Thomas; I should have caught that. Since this is triaged I'm marking bug 382301 as the duplicate, even though it came earlier (per https://wiki.ubuntu.com/Bugs/HowToTriage#Marking%20duplicate)

Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
Changed in gnome-control-center:
importance: Unknown → Wishlist
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in xkeyboard-config (Ubuntu):
status: Triaged → New
status: New → Incomplete
tags: added: oneric
Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.