xkbcomp error: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols

Bug #433926 reported by Brezhonneg on 2009-09-21
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Confirmed
Medium
xkeyboard-config (Ubuntu)
Undecided
Sergey V. Udaltsov

Bug Description

I can confirm that the bug reported upstream is also present in Karmic alpha 6:
https://bugs.freedesktop.org/show_bug.cgi?id=21761

This bug was also reported in gentoo
http://bugs.gentoo.org/show_bug.cgi?id=269931

and in debian
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=291853

Apparently a fix was released upstream, it would be nice to have it in Karmic as well.

Many thanks!

This is just a warning, can be ignored. But I will make it TWO_LEVEL after the release (due in 10 days).

Fixed. Committed. Thanks!

I can confirm that the bug reported upstream is also present in Karmic alpha 6:
https://bugs.freedesktop.org/show_bug.cgi?id=21761

This bug was also reported in gentoo
http://bugs.gentoo.org/show_bug.cgi?id=269931

and in debian
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=291853

Apparently a fix was released upstream, it would be nice to have it in Karmic as well.

Many thanks!

I too experience this bug with xkb-data 1.6-1ubuntu2 on an up-to-date Karmic.

Applying the patch from upstream helps:

$ diff -ruN /usr/share/X11/xkb/symbols/level3.old /usr/share/X11/xkb/symbols/level3

--- /usr/share/X11/xkb/symbols/level3.old 2009-10-05 13:12:07.839025962 +0200
+++ /usr/share/X11/xkb/symbols/level3 2009-10-05 13:04:32.416525774 +0200
@@ -11,7 +11,7 @@
 default partial modifier_keys
 xkb_symbols "ralt_switch" {
   key <RALT> {
- type[Group1]="ONE_LEVEL",
+ type[Group1]="TWO_LEVEL",
     symbols[Group1] = [ ISO_Level3_Shift ]
     };
   modifier_map Mod5 { ISO_Level3_Shift };

ilf (ilf) wrote :

Euh, hold on. This patch disabled the right Alt_Gr for me. Not good.

Reopening for ilf

Since the patch sounds like it has a regression, I'm skipping it for now. ilf post a new patch if you find one that is regression free for you.

Changed in xkeyboard-config (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic

Actually, that fix got lost somehow! It is still ONE_LEVEL. But I have to get to the bottom of the issue. TWO_LEVELS still sound logical to me. Anyway, let's continue in launchpad - when we resolve it there, I'll update this bug.

ilf, could you please post output of

xkbcomp :0 -xkb out.xkb

with that patch - and without that patch?

Thanks

ilf (ilf) wrote :

I can post the complete output, but I think you just need the diff:

- type= "ONE_LEVEL",
- symbols[Group1]= [ ISO_Level3_Shift ]
+ type= "TWO_LEVEL",
+ symbols[Group1]= [ ISO_Level3_Shift, Meta_R ]
+ modifier_map Mod1 { <RALT> };

Bryce Harrington (bryce) wrote :

[Resetting to incomplete since we need a response from the original reporter on this].

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xkeyboard-config (Ubuntu):
status: Incomplete → Invalid
ilf (ilf) wrote :

Euh, this bug is still present in my up-to-date Karmic.
And my /usr/share/X11/xkb/symbols/level3 still has the same timestamp as reported above.
It also seems it's not fixed upstream yet.

I can't run a Lucid Beta right now.

But I am wondering: should bugs really be closed because of "no response"?
That feels kind of rude. What should I have responded?

Btw, I have neither xkeyboard-config nor xkbcomp installed.

Changed in xkeyboard-config (Ubuntu):
status: Invalid → New
ilf (ilf) wrote :

This is still present in Lucid Release :(

Moncef (mob-ajm) wrote :

I don't know if it's the right way to do it, but the following worked for me.
I opened the xkb/symbols/altwin file, and replaced the line:
key <RALT> { type[Group1] = "TWO_LEVEL";
             symbols[Group1] = [ Alt_R, Meta_R ] };
by:
key <RALT> { type[Group1] = "ONE_LEVEL";
             symbols[Group1] = [ Alt_R ] };

PS : Commenting the line works, too.

summary: - [karmic] xkbcomp error message
+ xkbcomp error: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Sergey V. Udaltsov (svu)
status: New → Confirmed

What about the following:

  key <RALT> {
    type[Group1]="TWO_LEVEL",
    symbols[Group1] = [ ISO_Level3_Shift, ISO_Level3_Shift ]
    };

Would that work for everybody?

Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in xkeyboard-config:
importance: Medium → Unknown
Changed in xkeyboard-config:
importance: Unknown → Medium

This issue is fixed in another way in xkbcomp
by attachment #86805 to bug #57242.

Still in xenial
affected: xkb-data 2.16-1ubuntu1

│Jan 8 11:49:55 user.warning /usr/lib/gdm3/gdm-x-session[3463 > Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 │

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2018-01-09 18:45, H.-Dirk Schmitt wrote:
> Still in xenial
> affected: xkb-data 2.16-1ubuntu1
>
> │Jan 8 11:49:55 user.warning /usr/lib/gdm3/gdm-x-session[3463 >
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 │

This seems to be an old one. If I understand it correctly, Sergey posted a suggestion in comment #17, but got no feedback. Can someone who is affected provide some feedback to that suggestion?

Please note that this is not important enough to update 16.04 or any other stable release. However, if the change would be committed upstream, it might make it into Ubuntu 18.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.