Misleading Label in Keyboard Layout Options

Bug #374699 reported by Egan McComb on 2009-05-11
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)
Undecided
Ubuntu Desktop

Bug Description

Binary package hint: gnome-control-center

1) Ubuntu 9.04 Jaunty Jackalope
2) gnome-control-center 1:2.26.0-0ubuntu3
3) Enabling "Make CapsLock an additional ESC" should make CapsLock and Escape mapped to ^[.
4) Only CapsLock is mapped, and Escape appears unused.

The keyboard layout I am using is Generic 105-key (Intl) PC with some modifications.

When I go into "Keyboard Layout Options>CapsLock key Behavior" I see the entry "Make CapsLock an additional ESC".
Yet when I enabled this feature, the normal escape key stopped working. I am unsure whether this is a software or naming issue.

affects: gnome-control-center (Ubuntu) → xkeyboard-config (Ubuntu)
Liehann Loots (liehannl) wrote :

I believe the problem is in the xkb-data package. Specifically in the file /usr/share/X11/xkb/symbols/capslock, the configuration for 'xkb_symbols "escape"' includes a definition for ESC for None - that should be removed.

I'm going to submit a patch (once I figure out how). I believe the affected project is actually xkb-data.

In the meanwhile you can manually edit the file, remove the appropriate line, and reconfigure the setting.

partial hidden modifier_keys
xkb_symbols "escape" {
    key <CAPS> { [ Escape ] };
// Remove the following line
    key <ESC> { [ None ] };
};

Wow, thanks! That was an easy fix.

Liehann Loots (liehannl) wrote :

Looks like this has already been fixed in the xkeyboard-config development branch at freedesktop.org. The launchpad project imports from the old cvs repository though, so I have no idea how to get this issue fixed in Ubuntu. Would appreciate some help from someone who understands the Ubuntu system better.

Btw - the file is in the xkb-data package. The project is correct as xkeyboard-config.

sibidiba (sibidiba) wrote :

Can confirm this.

$ apt-file update
$ apt-file find capslock|grep X11
xkb-data: /usr/share/X11/xkb/symbols/capslock

Launchpad says: 'xkb-data' is a binary package. This bug has been assigned to its source package 'xkeyboard-config' instead.

Patch is below:

$ diff capslock.old capslock
--- capslock.old 2009-07-09 22:55:42.000000000 +0200
+++ capslock 2009-07-09 23:51:11.000000000 +0200
@@ -34,7 +34,6 @@ xkb_symbols "groupshift" {
 partial hidden modifier_keys
 xkb_symbols "escape" {
     key <CAPS> { [ Escape ] };
- key <ESC> { [ None ] };
 };

 partial hidden modifier_keys

Changed in xkeyboard-config (Ubuntu):
status: New → Confirmed
sibidiba (sibidiba) on 2009-07-09
Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
Bryce Harrington (bryce) on 2009-09-02
tags: added: jaunty
Simos Xenitellis  (simosx) wrote :

This appears to have been applied already on xkeyboard-config (git),

partial hidden modifier_keys
xkb_symbols "escape" {
    key <CAPS> { [ Escape ] };
};

There should be a relevant bug report on bugs.freedesktop.org solving this.
I am closing the report, thanks for reporting.

Changed in xkeyboard-config (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers