MS Windows numpad keys missing cut, copy, paste

Bug #32768 reported by Jeffry Johnston on 2006-02-24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xkeyboard-config (Ubuntu)

Bug Description

This bug is found when in the Keyboard Properties application (gnome-keyboard-properties), or: System > Preferences > Keyboard > Layout Options > Miscellaneous compatibility options, then enabling "Shift with numpad keys works as in MS Windows."

This is a really cool feature, because it allows me to select text using Shift + keypad, yet still use NumLock to get numeric input from the numpad when I want it. However, there is a vital feature still missing: cut, copy, and paste using the numpad:

cut = Shift + Del
copy = Ctrl + Ins
paste = Shift + Ins

Note that these combos work when used with the separate Insert and Delete keys, but NOT with the numpad Ins and Del keys. These clipboard combos are very handy, as the right hand is already on the numpad to move around while selecting text. Additionally, they are supported by MS Windows.

I have an .xmodmap file I've been using to get the numpad clipboard and selection to work, however it prevents NumLock from working (so it's also only a partial solution). If you'd be interested in checking it out anyway, let me know.

Thanks a lot!

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That capplet gets the option from xorg and does apply xorg configuration. I don't know the details about how the keyboard configuration works but that seems to be a feature request and an xorg issue, updating the settings and reassigning. Note that's not a distro specific issue and should probably be taken upstream

Henrik Nilsen Omma (henrik) wrote :

Just re-assigning the bug to xkeyboard-config.

Changed in xorg:
assignee: nobody → tfheen
Tollef Fog Heen (tfheen) wrote :

Just confirming this as I'm able to see it. No solution yet, though.

Changed in xkeyboard-config:
status: Unconfirmed → Confirmed
Tollef Fog Heen (tfheen) on 2007-03-30
Changed in xkeyboard-config:
assignee: tfheen → nobody
Bryce Harrington (bryce) wrote :

This has been open a long while. I agree it should go upstream; before I do so, could someone please re-confirm this is still an issue on Jaunty?

Changed in xkeyboard-config:
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xkeyboard-config (Ubuntu):
status: Triaged → Invalid
Max Vlasov (max-vlasov) wrote :

I recently reported a similar bug (802028), not knowing about this one, I reopened this one and marked 802028 as duplicate

Changed in xkeyboard-config (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers